kernel-5.8.0-1
* Mon Aug 03 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-1] - v5.8 rebase - Updated changelog for the release based on ac3a0c847296 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
b303d37046
commit
4403d9295a
@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 6bcfd5635a72..a7b784c0fade 100644
|
||||
index 37cfb39d77af..c65a263990ae 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -496,7 +496,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||
|
@ -0,0 +1,32 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Sun, 12 Jul 2020 13:39:32 +0100
|
||||
Subject: [PATCH] Revert "dt-bindings: Add doc for Pine64 Pinebook Pro"
|
||||
|
||||
This reverts commit ec0f66d2bc5ffd2a06eaf254ad314153e557cb7c.
|
||||
|
||||
This is already upstream and not sure why it still applies but we
|
||||
don't need it any more.
|
||||
---
|
||||
Documentation/devicetree/bindings/arm/rockchip.yaml | 5 -----
|
||||
1 file changed, 5 deletions(-)
|
||||
|
||||
diff --git a/Documentation/devicetree/bindings/arm/rockchip.yaml b/Documentation/devicetree/bindings/arm/rockchip.yaml
|
||||
index ed808148b6a7..d4a4045092df 100644
|
||||
--- a/Documentation/devicetree/bindings/arm/rockchip.yaml
|
||||
+++ b/Documentation/devicetree/bindings/arm/rockchip.yaml
|
||||
@@ -425,11 +425,6 @@ properties:
|
||||
- const: pine64,rockpro64
|
||||
- const: rockchip,rk3399
|
||||
|
||||
- - description: Pine64 PinebookPro
|
||||
- items:
|
||||
- - const: pine64,pinebook-pro
|
||||
- - const: rockchip,rk3399
|
||||
-
|
||||
- description: Radxa Rock
|
||||
items:
|
||||
- const: radxa,rock
|
||||
--
|
||||
2.26.2
|
||||
|
@ -36,10 +36,10 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
||||
1 file changed, 24 insertions(+)
|
||||
|
||||
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
|
||||
index 812bfc32ecb8..e09fec76c320 100644
|
||||
index 2ea61abd5830..abb314891f5b 100644
|
||||
--- a/drivers/pci/quirks.c
|
||||
+++ b/drivers/pci/quirks.c
|
||||
@@ -4183,6 +4183,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
||||
@@ -4196,6 +4196,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9084,
|
||||
quirk_bridge_cavm_thrx2_pcie_root);
|
||||
|
||||
|
@ -15,10 +15,10 @@ Signed-off-by: Aaron Ma <aaron.ma@canonical.com>
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/ethernet/intel/e1000e/ich8lan.c b/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
||||
index f999cca37a8a..9cbd2d6c7da4 100644
|
||||
index 489bb5b59475..26bb39b62956 100644
|
||||
--- a/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
||||
+++ b/drivers/net/ethernet/intel/e1000e/ich8lan.c
|
||||
@@ -1247,9 +1247,9 @@ static s32 e1000_disable_ulp_lpt_lp(struct e1000_hw *hw, bool force)
|
||||
@@ -1245,9 +1245,9 @@ static s32 e1000_disable_ulp_lpt_lp(struct e1000_hw *hw, bool force)
|
||||
ew32(H2ME, mac_reg);
|
||||
}
|
||||
|
||||
|
@ -114,7 +114,7 @@ index aa183c9ac0a2..dc323b3f5838 100644
|
||||
&modinfo_coresize,
|
||||
&modinfo_initsize,
|
||||
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
|
||||
index 45f2ab2ec2d4..3bf849a0c6ab 100644
|
||||
index 69341b36f271..dbc63328187c 100644
|
||||
--- a/scripts/mod/modpost.c
|
||||
+++ b/scripts/mod/modpost.c
|
||||
@@ -21,6 +21,7 @@
|
||||
@ -125,7 +125,7 @@ index 45f2ab2ec2d4..3bf849a0c6ab 100644
|
||||
|
||||
/* Are we using CONFIG_MODVERSIONS? */
|
||||
static int modversions = 0;
|
||||
@@ -2392,6 +2393,12 @@ static void write_buf(struct buffer *b, const char *fname)
|
||||
@@ -2393,6 +2394,12 @@ static void write_buf(struct buffer *b, const char *fname)
|
||||
}
|
||||
}
|
||||
|
||||
@ -138,7 +138,7 @@ index 45f2ab2ec2d4..3bf849a0c6ab 100644
|
||||
static void write_if_changed(struct buffer *b, const char *fname)
|
||||
{
|
||||
char *tmp;
|
||||
@@ -2644,6 +2651,7 @@ int main(int argc, char **argv)
|
||||
@@ -2645,6 +2652,7 @@ int main(int argc, char **argv)
|
||||
add_depends(&buf, mod);
|
||||
add_moddevtable(&buf, mod);
|
||||
add_srcversion(&buf, mod);
|
||||
|
@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 229e67f2ff75..6bcfd5635a72 100644
|
||||
index 24a4c1b97bb0..37cfb39d77af 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1217,7 +1217,13 @@ endef
|
||||
|
@ -76,6 +76,7 @@
|
||||
0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
0001-Revert-dt-bindings-Add-doc-for-Pine64-Pinebook-Pro.patch
|
||||
0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
|
@ -3272,7 +3272,7 @@ CONFIG_LEDS_PCA9532=m
|
||||
CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
# CONFIG_LEDS_TCA6507 is not set
|
||||
|
@ -3254,7 +3254,7 @@ CONFIG_LEDS_PCA9532=m
|
||||
CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
# CONFIG_LEDS_TCA6507 is not set
|
||||
|
@ -3317,7 +3317,7 @@ CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PM8058=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
CONFIG_LEDS_TCA6507=m
|
||||
|
@ -3300,7 +3300,7 @@ CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PM8058=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
CONFIG_LEDS_TCA6507=m
|
||||
|
@ -3245,7 +3245,7 @@ CONFIG_LEDS_PCA9532=m
|
||||
CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
# CONFIG_LEDS_TCA6507 is not set
|
||||
|
@ -3228,7 +3228,7 @@ CONFIG_LEDS_PCA9532=m
|
||||
CONFIG_LEDS_PCA963X=m
|
||||
CONFIG_LEDS_PWM=m
|
||||
CONFIG_LEDS_REGULATOR=m
|
||||
# CONFIG_LEDS_SGM3140 is not set
|
||||
CONFIG_LEDS_SGM3140=m
|
||||
# CONFIG_LEDS_SPI_BYTE is not set
|
||||
CONFIG_LEDS_SYSCON=y
|
||||
# CONFIG_LEDS_TCA6507 is not set
|
||||
|
82
kernel.spec
82
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc7.1
|
||||
%global distro_build 1
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.8.0
|
||||
%define pkgrelease 0.rc7.1
|
||||
%define pkgrelease 1
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 8
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc7.1%{?buildid}%{?dist}
|
||||
%define specrelease 1%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -567,7 +567,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.8-rc7.tar.xz
|
||||
Source0: linux-5.8.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -794,26 +794,27 @@ Patch76: 0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
Patch77: 0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
Patch78: 0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
Patch79: 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
Patch80: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
Patch81: 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
Patch82: 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
Patch83: 0001-Revert-drm-panel-add-Xingbangda-XBD599-panel.patch
|
||||
Patch84: 0001-Revert-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timin.patch
|
||||
Patch85: 0001-Revert-arm64-allwinner-dts-a64-add-LCD-related-devic.patch
|
||||
Patch86: 0001-dt-bindings-vendor-prefixes-Add-Xingbangda.patch
|
||||
Patch87: 0001-dt-bindings-panel-Convert-rocktech-jh057n00900-to-ya.patch
|
||||
Patch88: 0001-dt-bindings-panel-Add-compatible-for-Xingbangda-XBD5.patch
|
||||
Patch89: 0001-drm-panel-rocktech-jh057n00900-Rename-the-driver-to-.patch
|
||||
Patch90: 0001-drm-panel-st7703-Rename-functions-from-jh057n-prefix.patch
|
||||
Patch91: 0001-drm-panel-st7703-Prepare-for-supporting-multiple-pan.patch
|
||||
Patch92: 0001-drm-panel-st7703-Move-code-specific-to-jh057n-closer.patch
|
||||
Patch93: 0001-drm-panel-st7703-Move-generic-part-of-init-sequence-.patch
|
||||
Patch94: 0001-drm-panel-st7703-Add-support-for-Xingbangda-XBD599.patch
|
||||
Patch95: 0001-drm-panel-st7703-Enter-sleep-after-display-off.patch
|
||||
Patch96: 0001-drm-panel-st7703-Assert-reset-prior-to-powering-down.patch
|
||||
Patch97: 0001-arm64-dts-sun50i-a64-pinephone-Enable-LCD-support-on.patch
|
||||
Patch98: 0001-arm64-dts-sun50i-a64-pinephone-Add-touchscreen-suppo.patch
|
||||
Patch99: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||
Patch80: 0001-Revert-dt-bindings-Add-doc-for-Pine64-Pinebook-Pro.patch
|
||||
Patch81: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
Patch82: 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
Patch83: 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
Patch84: 0001-Revert-drm-panel-add-Xingbangda-XBD599-panel.patch
|
||||
Patch85: 0001-Revert-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timin.patch
|
||||
Patch86: 0001-Revert-arm64-allwinner-dts-a64-add-LCD-related-devic.patch
|
||||
Patch87: 0001-dt-bindings-vendor-prefixes-Add-Xingbangda.patch
|
||||
Patch88: 0001-dt-bindings-panel-Convert-rocktech-jh057n00900-to-ya.patch
|
||||
Patch89: 0001-dt-bindings-panel-Add-compatible-for-Xingbangda-XBD5.patch
|
||||
Patch90: 0001-drm-panel-rocktech-jh057n00900-Rename-the-driver-to-.patch
|
||||
Patch91: 0001-drm-panel-st7703-Rename-functions-from-jh057n-prefix.patch
|
||||
Patch92: 0001-drm-panel-st7703-Prepare-for-supporting-multiple-pan.patch
|
||||
Patch93: 0001-drm-panel-st7703-Move-code-specific-to-jh057n-closer.patch
|
||||
Patch94: 0001-drm-panel-st7703-Move-generic-part-of-init-sequence-.patch
|
||||
Patch95: 0001-drm-panel-st7703-Add-support-for-Xingbangda-XBD599.patch
|
||||
Patch96: 0001-drm-panel-st7703-Enter-sleep-after-display-off.patch
|
||||
Patch97: 0001-drm-panel-st7703-Assert-reset-prior-to-powering-down.patch
|
||||
Patch98: 0001-arm64-dts-sun50i-a64-pinephone-Enable-LCD-support-on.patch
|
||||
Patch99: 0001-arm64-dts-sun50i-a64-pinephone-Add-touchscreen-suppo.patch
|
||||
Patch100: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -1309,8 +1310,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.8-rc7 -c
|
||||
mv linux-5.8-rc7 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.8 -c
|
||||
mv linux-5.8 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1395,6 +1396,7 @@ ApplyOptionalPatch 0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
ApplyOptionalPatch 0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
ApplyOptionalPatch 0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
ApplyOptionalPatch 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
ApplyOptionalPatch 0001-Revert-dt-bindings-Add-doc-for-Pine64-Pinebook-Pro.patch
|
||||
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
ApplyOptionalPatch 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
ApplyOptionalPatch 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
@ -2848,6 +2850,34 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Aug 03 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-1]
|
||||
- v5.8 rebase
|
||||
- Updated changelog for the release based on ac3a0c847296 (Fedora Kernel Team)
|
||||
|
||||
* Sun Aug 02 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.20200802gitac3a0c847296.1]
|
||||
- ac3a0c847296 rebase
|
||||
- Updated changelog for the release based on 7dc6fd0f3b84 (Fedora Kernel Team)
|
||||
|
||||
* Sat Aug 01 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.20200801git7dc6fd0f3b84.1]
|
||||
- 7dc6fd0f3b84 rebase
|
||||
- Updated changelog for the release based on 417385c47ef7 (Fedora Kernel Team)
|
||||
|
||||
* Fri Jul 31 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.20200731git417385c47ef7.1]
|
||||
- 417385c47ef7 rebase
|
||||
- Add new certs for dual signing with boothole ("Justin M. Forbes")
|
||||
- Update secureboot signing for dual keys ("Justin M. Forbes")
|
||||
- Updated changelog for the release based on d3590ebf6f91 (Fedora Kernel Team)
|
||||
|
||||
* Thu Jul 30 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.20200730gitd3590ebf6f91.1]
|
||||
- d3590ebf6f91 rebase
|
||||
- Updated changelog for the release based on 6ba1b005ffc3 (Fedora Kernel Team)
|
||||
|
||||
* Wed Jul 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.20200729git6ba1b005ffc3.1]
|
||||
- 6ba1b005ffc3 rebase
|
||||
- Revert "dt-bindings: Add doc for Pine64 Pinebook Pro" (Peter Robinson)
|
||||
- fedora: enable LEDS_SGM3140 for arm configs (Peter Robinson)
|
||||
- Updated changelog for the release based on v5.8-rc7 (Fedora Kernel Team)
|
||||
|
||||
* Mon Jul 27 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.1]
|
||||
- v5.8-rc7 rebase
|
||||
- Updated changelog for the release based on 04300d66f0a0 (Fedora Kernel Team)
|
||||
|
Binary file not shown.
Binary file not shown.
Binary file not shown.
Binary file not shown.
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.8-rc7.tar.xz) = 0b1c515d46f0db3589b51764ed66f7fe4054c603d716243d9963c4cdc80b628ee7f0ca6d4a06c5db3e0d00c5cc2f816e6f3eacb368e3a303316558762384e815
|
||||
SHA512 (kernel-abi-whitelists-5.8.0-0.rc7.1.tar.bz2) = fee25944fc67fab7f088572315a7da8d98c2bc41c41fe2a93fd2d804acafdca88ecf57d0cb5bc1c00a5c4c3b5ece72613f9276cab9d3af4140960043831627d4
|
||||
SHA512 (kernel-kabi-dw-5.8.0-0.rc7.1.tar.bz2) = 1fc3ed21f101ddf8915b52993469886416290a0ac9b055f478ecfd55303a50c3e2ba5b062c5a7af38725274a09f83c63a05ff7a0d6c41087526cbb5eb323beca
|
||||
SHA512 (linux-5.8.tar.xz) = 19c8694bda4533464877e2d976aca95f48c2c40c11efcc1dce0ca91cc5f9826110e277c7de2a49ff99af8ae1c76e275b7c463abf71fbf410956d63066dc4ee53
|
||||
SHA512 (kernel-abi-whitelists-5.8.0-1.tar.bz2) = 972027688be571d3e6dcc130ef76aceda4bd224cca73eec8e1b13c3909946d9cd4d6af5e4b98610e80fb9a1a2ed3291b369e7e94190511e6dbef7f24feac2bdb
|
||||
SHA512 (kernel-kabi-dw-5.8.0-1.tar.bz2) = eccfdba2a487a35c1594928cae65f976ca705d0eb3bff5cc2766b9363495f76e58f74d9cfcef0e3e4a4e113707af358fc31eb380b15cd4fb07ee4a207e7fca9f
|
||||
|
Loading…
Reference in New Issue
Block a user