sched: Revert nohz_ratelimit() which causes a lot of extra wakeups burning CPU, and my legs.
This commit is contained in:
parent
4d5b945030
commit
4326aa56d8
10
kernel.spec
10
kernel.spec
@ -48,7 +48,7 @@ Summary: The Linux kernel
|
||||
# reset this by hand to 1 (or to 0 and then use rpmdev-bumpspec).
|
||||
# scripts/rebase.sh should be made to do that for you, actually.
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -597,6 +597,8 @@ Patch09: linux-2.6-upstream-reverts.patch
|
||||
# Standalone patches
|
||||
Patch20: linux-2.6-hotfixes.patch
|
||||
|
||||
Patch21: linux-2.6-tip.git-396e894d289d69bacf5acd983c97cd6e21a14c08.patch
|
||||
|
||||
Patch30: git-utrace.patch
|
||||
Patch31: utrace-ptrace-fix-build.patch
|
||||
Patch32: utrace-remove-use-of-kref_set.patch
|
||||
@ -1118,6 +1120,8 @@ ApplyOptionalPatch linux-2.6-upstream-reverts.patch -R
|
||||
|
||||
ApplyPatch linux-2.6-hotfixes.patch
|
||||
|
||||
ApplyPatch linux-2.6-tip.git-396e894d289d69bacf5acd983c97cd6e21a14c08.patch
|
||||
|
||||
# Roland's utrace ptrace replacement.
|
||||
ApplyPatch git-utrace.patch
|
||||
ApplyPatch utrace-ptrace-fix-build.patch
|
||||
@ -1877,6 +1881,10 @@ fi
|
||||
# || ||
|
||||
|
||||
%changelog
|
||||
* Wed Aug 04 2010 Dave Jones <davej@redhat.com>
|
||||
- sched: Revert nohz_ratelimit() which causes a lot of
|
||||
extra wakeups burning CPU, and my legs.
|
||||
|
||||
* Sun Aug 01 2010 Dave Jones <davej@redhat.com>
|
||||
- Linux 2.6.35
|
||||
|
||||
|
@ -0,0 +1,75 @@
|
||||
From: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
||||
Date: Fri, 9 Jul 2010 13:12:27 +0000 (+0200)
|
||||
Subject: sched: Revert nohz_ratelimit() for now
|
||||
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fx86%2Flinux-2.6-tip.git;a=commitdiff_plain;h=396e894d289d69bacf5acd983c97cd6e21a14c08
|
||||
|
||||
sched: Revert nohz_ratelimit() for now
|
||||
|
||||
Norbert reported that nohz_ratelimit() causes his laptop to burn about
|
||||
4W (40%) extra. For now back out the change and see if we can adjust
|
||||
the power management code to make better decisions.
|
||||
|
||||
Reported-by: Norbert Preining <preining@logic.at>
|
||||
Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
||||
Acked-by: Mike Galbraith <efault@gmx.de>
|
||||
Cc: Arjan van de Ven <arjan@infradead.org>
|
||||
LKML-Reference: <new-submission>
|
||||
Signed-off-by: Ingo Molnar <mingo@elte.hu>
|
||||
---
|
||||
|
||||
diff --git a/include/linux/sched.h b/include/linux/sched.h
|
||||
index 747fcae..6e0bb86 100644
|
||||
--- a/include/linux/sched.h
|
||||
+++ b/include/linux/sched.h
|
||||
@@ -273,17 +273,11 @@ extern cpumask_var_t nohz_cpu_mask;
|
||||
#if defined(CONFIG_SMP) && defined(CONFIG_NO_HZ)
|
||||
extern int select_nohz_load_balancer(int cpu);
|
||||
extern int get_nohz_load_balancer(void);
|
||||
-extern int nohz_ratelimit(int cpu);
|
||||
#else
|
||||
static inline int select_nohz_load_balancer(int cpu)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
-
|
||||
-static inline int nohz_ratelimit(int cpu)
|
||||
-{
|
||||
- return 0;
|
||||
-}
|
||||
#endif
|
||||
|
||||
/*
|
||||
diff --git a/kernel/sched.c b/kernel/sched.c
|
||||
index f52a880..63b4a14 100644
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -1232,16 +1232,6 @@ void wake_up_idle_cpu(int cpu)
|
||||
smp_send_reschedule(cpu);
|
||||
}
|
||||
|
||||
-int nohz_ratelimit(int cpu)
|
||||
-{
|
||||
- struct rq *rq = cpu_rq(cpu);
|
||||
- u64 diff = rq->clock - rq->nohz_stamp;
|
||||
-
|
||||
- rq->nohz_stamp = rq->clock;
|
||||
-
|
||||
- return diff < (NSEC_PER_SEC / HZ) >> 1;
|
||||
-}
|
||||
-
|
||||
#endif /* CONFIG_NO_HZ */
|
||||
|
||||
static u64 sched_avg_period(void)
|
||||
diff --git a/kernel/time/tick-sched.c b/kernel/time/tick-sched.c
|
||||
index 813993b..f898af6 100644
|
||||
--- a/kernel/time/tick-sched.c
|
||||
+++ b/kernel/time/tick-sched.c
|
||||
@@ -325,7 +325,7 @@ void tick_nohz_stop_sched_tick(int inidle)
|
||||
} while (read_seqretry(&xtime_lock, seq));
|
||||
|
||||
if (rcu_needs_cpu(cpu) || printk_needs_cpu(cpu) ||
|
||||
- arch_needs_cpu(cpu) || nohz_ratelimit(cpu)) {
|
||||
+ arch_needs_cpu(cpu)) {
|
||||
next_jiffies = last_jiffies + 1;
|
||||
delta_jiffies = 1;
|
||||
} else {
|
Loading…
Reference in New Issue
Block a user