kernel-6.8.5-301

* Wed Apr 10 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-0]
- Set configs for SPECTRE_BHI (Justin M. Forbes)
- Add AMD PMF bug (Justin M. Forbes)
- redhat/configs: Enable CONFIG_AMDTEE for x86 (David Arcari)
- Add CVE fix for 6.8.5 (Justin M. Forbes)
- Linux v6.8.5
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2024-04-11 12:57:01 -05:00
parent 100029c3e4
commit 3de7b4f3f0
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 75 additions and 5 deletions

View File

@ -1,3 +1,9 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/e56840b5f971b4d0f4032f6f5ab95c0c5ba40f8e
e56840b5f971b4d0f4032f6f5ab95c0c5ba40f8e nouveau: fix devinit paths to only handle display on GSP.
"https://gitlab.com/cki-project/kernel-ark/-/commit"/252ea3336f8ee7551675d82e1899125aa6e730b6
252ea3336f8ee7551675d82e1899125aa6e730b6 Bluetooth: l2cap: Don't double set the HCI_CONN_MGMT_CONNECTED bit
"https://gitlab.com/cki-project/kernel-ark/-/commit"/9ba38d5f5c49d3f4a9e429d05aa73cb397db5071
9ba38d5f5c49d3f4a9e429d05aa73cb397db5071 Revert "Bluetooth: hci_qca: Set BDA quirk bit if fwnode exists in DT"

View File

@ -163,13 +163,13 @@ Summary: The Linux kernel
%define specrpmversion 6.8.5
%define specversion 6.8.5
%define patchversion 6.8
%define pkgrelease 300
%define pkgrelease 301
%define kversion 6
%define tarfile_release 6.8.5
# This is needed to do merge window version magic
%define patchlevel 8
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}%{?dist}
%define specrelease 301%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.8.5
@ -3959,6 +3959,11 @@ fi\
#
#
%changelog
* Thu Apr 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-301]
- nouveau: fix devinit paths to only handle display on GSP. (Dave Airlie)
- Add bluetooth bug to Bugsfixed for 6.8.6 (Justin M. Forbes)
- Bluetooth: l2cap: Don't double set the HCI_CONN_MGMT_CONNECTED bit (Archie Pusaka)
* Wed Apr 10 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-0]
- Set configs for SPECTRE_BHI (Justin M. Forbes)
- Add AMD PMF bug (Justin M. Forbes)

View File

@ -13,6 +13,8 @@
drivers/firmware/efi/efi.c | 124 +++++++++++----
drivers/firmware/efi/secureboot.c | 38 +++++
drivers/firmware/sysfb.c | 18 ++-
.../gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c | 12 +-
drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c | 1 +
drivers/hid/hid-rmi.c | 66 --------
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 +++
drivers/input/rmi4/rmi_driver.c | 124 +++++++++------
@ -29,13 +31,14 @@
include/linux/security.h | 5 +
kernel/module/main.c | 2 +
kernel/module/signing.c | 9 +-
net/bluetooth/l2cap_core.c | 3 +-
scripts/mod/modpost.c | 8 +
scripts/tags.sh | 2 +
security/integrity/platform_certs/load_uefi.c | 6 +-
security/lockdown/Kconfig | 13 ++
security/lockdown/lockdown.c | 1 +
security/security.c | 12 ++
37 files changed, 671 insertions(+), 177 deletions(-)
40 files changed, 681 insertions(+), 183 deletions(-)
diff --git a/Makefile b/Makefile
index f29a75b75861..90586379d1e8 100644
@ -578,6 +581,48 @@ index 3c197db42c9d..16e4a2e90fae 100644
pd = sysfb_create_simplefb(si, &mode);
if (!IS_ERR(pd))
goto unlock_mutex;
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
index 7bcbc4895ec2..271bfa038f5b 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
@@ -25,6 +25,7 @@
#include <subdev/bios.h>
#include <subdev/bios/init.h>
+#include <subdev/gsp.h>
void
gm107_devinit_disable(struct nvkm_devinit *init)
@@ -33,10 +34,13 @@ gm107_devinit_disable(struct nvkm_devinit *init)
u32 r021c00 = nvkm_rd32(device, 0x021c00);
u32 r021c04 = nvkm_rd32(device, 0x021c04);
- if (r021c00 & 0x00000001)
- nvkm_subdev_disable(device, NVKM_ENGINE_CE, 0);
- if (r021c00 & 0x00000004)
- nvkm_subdev_disable(device, NVKM_ENGINE_CE, 2);
+ /* gsp only wants to enable/disable display */
+ if (!nvkm_gsp_rm(device->gsp)) {
+ if (r021c00 & 0x00000001)
+ nvkm_subdev_disable(device, NVKM_ENGINE_CE, 0);
+ if (r021c00 & 0x00000004)
+ nvkm_subdev_disable(device, NVKM_ENGINE_CE, 2);
+ }
if (r021c04 & 0x00000001)
nvkm_subdev_disable(device, NVKM_ENGINE_DISP, 0);
}
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
index 11b4c9c274a1..666eb93b1742 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
@@ -41,6 +41,7 @@ r535_devinit_new(const struct nvkm_devinit_func *hw,
rm->dtor = r535_devinit_dtor;
rm->post = hw->post;
+ rm->disable = hw->disable;
ret = nv50_devinit_new_(rm, device, type, inst, pdevinit);
if (ret)
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
index d4af17fdba46..154f0403cbf4 100644
--- a/drivers/hid/hid-rmi.c
@ -1415,6 +1460,20 @@ index a2ff4242e623..f0d2be1ee4f1 100644
}
int module_sig_check(struct load_info *info, int flags)
diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c
index ab5a9d42fae7..706d2478ddb3 100644
--- a/net/bluetooth/l2cap_core.c
+++ b/net/bluetooth/l2cap_core.c
@@ -4054,8 +4054,7 @@ static int l2cap_connect_req(struct l2cap_conn *conn,
return -EPROTO;
hci_dev_lock(hdev);
- if (hci_dev_test_flag(hdev, HCI_MGMT) &&
- !test_and_set_bit(HCI_CONN_MGMT_CONNECTED, &hcon->flags))
+ if (hci_dev_test_flag(hdev, HCI_MGMT))
mgmt_device_connected(hdev, hcon, NULL, 0);
hci_dev_unlock(hdev);
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
index 6568f8177e39..14d8237af366 100644
--- a/scripts/mod/modpost.c

View File

@ -1,5 +1,5 @@
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
SHA512 (linux-6.8.5.tar.xz) = f956b83e80183f46fc9dc85d8735d27c6c1cc9eef7f93d5b7dfe297acafdb33e83cdc184689c2a12afac87c1c495c217ffba843ccaded7f88b35637db3b2d434
SHA512 (kernel-abi-stablelists-6.8.5.tar.xz) = 305df0406f1e8516207fe77e8f77b0af116b2b97fdf87426068bb17405b3b9ad2f66d8c8042a5f94b050a980b8f7d752cd9e94b7f42aa74f3fe4594f40634388
SHA512 (kernel-kabi-dw-6.8.5.tar.xz) = c3df1e59427f2612f0962471ec14469072968616eba69489d6a07bcbf1ee50ff47fd7184cfa42a6e328a038970bec94e4c9231cfafadd61d15a25846807dae51
SHA512 (kernel-abi-stablelists-6.8.5.tar.xz) = 3f4a1776809941118d796908ee93df1732550220f1498b579c80db64384bc81dea3c4a6b4ad3c8b15dc83caddb74c591ff335a7cc9e846274f4c314a3a733123
SHA512 (kernel-kabi-dw-6.8.5.tar.xz) = e38a0e3756b109a96dbe30e5956d2611420cbb0d7b46308cf78df0317ddd1163f92d8296bb79938a420740a3168eba967baa03b4e06a21eaa47830f3d7ec45ef