kernel-5.19.0-0.rc5.39

* Sat Jul 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.19.0-0.rc4.089866061428.36]
- fedora: arm: enable a couple of QCom drivers (Peter Robinson)
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-07-04 09:34:00 -05:00
parent c021f4b86c
commit 3dd8c97939
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
6 changed files with 22 additions and 17 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 36
RHEL_RELEASE = 39
#
# ZSTREAM

View File

@ -3112,6 +3112,7 @@ CONFIG_INTERCONNECT_IMX8MM=m
CONFIG_INTERCONNECT_IMX8MN=m
CONFIG_INTERCONNECT_IMX8MQ=m
CONFIG_INTERCONNECT_IMX=m
CONFIG_INTERCONNECT_QCOM_BCM_VOTER=y
CONFIG_INTERCONNECT_QCOM_MSM8916=m
# CONFIG_INTERCONNECT_QCOM_MSM8939 is not set
# CONFIG_INTERCONNECT_QCOM_MSM8974 is not set
@ -5283,7 +5284,7 @@ CONFIG_PHY_QCOM_QUSB2=m
CONFIG_PHY_QCOM_USB_HS_28NM=m
CONFIG_PHY_QCOM_USB_HSIC=m
CONFIG_PHY_QCOM_USB_HS=m
# CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2 is not set
CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2=m
CONFIG_PHY_QCOM_USB_SS=m
CONFIG_PHY_ROCKCHIP_DPHY_RX0=m
CONFIG_PHY_ROCKCHIP_DP=m

View File

@ -3096,6 +3096,7 @@ CONFIG_INTERCONNECT_IMX8MM=m
CONFIG_INTERCONNECT_IMX8MN=m
CONFIG_INTERCONNECT_IMX8MQ=m
CONFIG_INTERCONNECT_IMX=m
CONFIG_INTERCONNECT_QCOM_BCM_VOTER=y
CONFIG_INTERCONNECT_QCOM_MSM8916=m
# CONFIG_INTERCONNECT_QCOM_MSM8939 is not set
# CONFIG_INTERCONNECT_QCOM_MSM8974 is not set
@ -5262,7 +5263,7 @@ CONFIG_PHY_QCOM_QUSB2=m
CONFIG_PHY_QCOM_USB_HS_28NM=m
CONFIG_PHY_QCOM_USB_HSIC=m
CONFIG_PHY_QCOM_USB_HS=m
# CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2 is not set
CONFIG_PHY_QCOM_USB_SNPS_FEMTO_V2=m
CONFIG_PHY_QCOM_USB_SS=m
CONFIG_PHY_ROCKCHIP_DPHY_RX0=m
CONFIG_PHY_ROCKCHIP_DP=m

View File

@ -120,17 +120,17 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# define buildid .local
%define specversion 5.19.0
%define patchversion 5.19
%define pkgrelease 0.rc4.20220701gita175eca0f3d7.36
%define pkgrelease 0.rc5.39
%define kversion 5
%define tarfile_release 5.19-rc4-125-ga175eca0f3d7
%define tarfile_release 5.19-rc5
# This is needed to do merge window version magic
%define patchlevel 19
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc4.20220701gita175eca0f3d7.36%{?buildid}%{?dist}
%define specrelease 0.rc5.39%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 5.19.0
@ -3100,6 +3100,9 @@ fi
#
#
%changelog
* Sat Jul 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.19.0-0.rc4.089866061428.36]
- fedora: arm: enable a couple of QCom drivers (Peter Robinson)
* Thu Jun 30 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.19.0-0.rc4.d9b2ba67917c.34]
- redhat/Makefile: Deprecate BUILD_SCRATCH_TARGET (Prarit Bhargava)
- redhat: enable CONFIG_DEVTMPFS_SAFE (Mark Langsdorf)

View File

@ -120,7 +120,7 @@ index 000000000000..effb81d04bfd
+
+endmenu
diff --git a/Makefile b/Makefile
index 8973b285ce6c..ba893f692d55 100644
index 990d2ee79186..77bce7a7dc7c 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -228,7 +228,7 @@ index 1cc85b8ff42e..b7ee128c67ce 100644
+ return !!ipl_secure_flag;
+}
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
index 8d91eccc0963..d5a41405b466 100644
index 0a37f5de2863..e2644fc7a172 100644
--- a/arch/s390/kernel/setup.c
+++ b/arch/s390/kernel/setup.c
@@ -49,6 +49,7 @@
@ -239,7 +239,7 @@ index 8d91eccc0963..d5a41405b466 100644
#include <linux/hugetlb.h>
#include <linux/kmemleak.h>
@@ -965,6 +966,9 @@ void __init setup_arch(char **cmdline_p)
@@ -970,6 +971,9 @@ void __init setup_arch(char **cmdline_p)
log_component_list();
@ -1226,7 +1226,7 @@ index ee4da9ab8013..d395d11eadc4 100644
if (ret < 0)
goto err_allowedips;
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index b3d9c29aba1e..e295e4c27a5a 100644
index ec6ac298d8de..ddce2807c680 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -240,6 +240,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
@ -1340,10 +1340,10 @@ index d3e2440d8abb..da01ce9c9542 100644
if (!ctrl->max_namespaces ||
diff --git a/drivers/nvme/host/nvme.h b/drivers/nvme/host/nvme.h
index 0da94b233fed..f3616ab87759 100644
index 5558f8812157..dc8fd8da85da 100644
--- a/drivers/nvme/host/nvme.h
+++ b/drivers/nvme/host/nvme.h
@@ -834,6 +834,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
@@ -835,6 +835,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_start_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_default_iopolicy(struct nvme_subsystem *subsys);
void nvme_failover_req(struct request *req);
@ -1351,7 +1351,7 @@ index 0da94b233fed..f3616ab87759 100644
void nvme_kick_requeue_lists(struct nvme_ctrl *ctrl);
int nvme_mpath_alloc_disk(struct nvme_ctrl *ctrl,struct nvme_ns_head *head);
void nvme_mpath_add_disk(struct nvme_ns *ns, struct nvme_id_ns *id);
@@ -870,6 +871,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
@@ -871,6 +872,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
static inline void nvme_failover_req(struct request *req)
{
}

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.19-rc4-125-ga175eca0f3d7.tar.xz) = d895c5db40b055320543ebf7596c7ffdb0311e2ed5830e85d258d8f226315dc3b01f80a5020b46646bc323b499bc88819f4c25c0148236e514db4ccccf4c2071
SHA512 (kernel-abi-stablelists-5.19.0.tar.bz2) = 08fe683004a9ef826962c6b6c55cda5573987b63f52f3321a2545a0529b324cd04a3fc2e64ff3c1d14f96f862b98ffdcc3ace0358f80996786f5a45445a54eeb
SHA512 (kernel-kabi-dw-5.19.0.tar.bz2) = a98934ae738dddccf53ac9545c59d753366d5fa32ff6b516465e73a7b6d5c6958ec9bba554f9ca07c4f3d1ec5c1737093c11de34684f5e5127c71cb09ad1778c
SHA512 (linux-5.19-rc5.tar.xz) = 1a08c56e4fd4b01e26569d904db707ce8762e5b940491c2f918f74be12735b23f6957892d15438646943ec368192ce471dc61d601f241e31b29f882711d1a085
SHA512 (kernel-abi-stablelists-5.19.0.tar.bz2) = f259cfbb475075093cbb0bd0da824546394aa6fc922fdac7ab51bcee0ae289bbb44637c7b7b880da1b5d7e7f6454028bfc611929295fd92eace9a6ab0e882afd
SHA512 (kernel-kabi-dw-5.19.0.tar.bz2) = 7507d52b7df39f1c160204a9eeac97829c285dc44ea00dde88ede1505469bad78ac0012593290dfaa8f4b56b71ae813f43af9e60a004a46cc144c74f3fc24f74