Linux 2.6.38-rc7-git4
Revert upstream commit e3e89cc535223433a619d0969db3fa05cdd946b8 for now to fix utrace build.
This commit is contained in:
parent
3c4ea9ad7f
commit
3d285d4290
12
kernel.spec
12
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 3
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 7
|
||||
# The git snapshot level
|
||||
%define gitrev 2
|
||||
%define gitrev 4
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 2.6.%{upstream_sublevel}
|
||||
%endif
|
||||
@ -614,7 +614,7 @@ Patch09: linux-2.6-upstream-reverts.patch
|
||||
# Standalone patches
|
||||
Patch20: linux-2.6-hotfixes.patch
|
||||
|
||||
|
||||
Patch29: linux-2.6-utrace-revert-make-ptrace-functions-static.patch
|
||||
Patch30: linux-2.6-tracehook.patch
|
||||
Patch31: linux-2.6-utrace.patch
|
||||
Patch32: linux-2.6-utrace-ptrace.patch
|
||||
@ -1172,6 +1172,7 @@ ApplyOptionalPatch linux-2.6-upstream-reverts.patch -R
|
||||
ApplyPatch linux-2.6-hotfixes.patch
|
||||
|
||||
# Roland's utrace ptrace replacement.
|
||||
ApplyPatch linux-2.6-utrace-revert-make-ptrace-functions-static.patch
|
||||
ApplyPatch linux-2.6-tracehook.patch
|
||||
ApplyPatch linux-2.6-utrace.patch
|
||||
ApplyPatch linux-2.6-utrace-ptrace.patch
|
||||
@ -1969,6 +1970,11 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Sat Mar 05 2011 Chuck Ebbert <cebbert@redhat.com> 2.6.38-0.rc7.git4.1
|
||||
- Linux 2.6.38-rc7-git4
|
||||
- Revert upstream commit e3e89cc535223433a619d0969db3fa05cdd946b8
|
||||
for now to fix utrace build.
|
||||
|
||||
* Fri Mar 04 2011 Roland McGrath <roland@redhat.com> - 2.6.38-0.rc7.git2.3
|
||||
- Split out perf-debuginfo subpackage.
|
||||
|
||||
|
47
linux-2.6-utrace-revert-make-ptrace-functions-static.patch
Normal file
47
linux-2.6-utrace-revert-make-ptrace-functions-static.patch
Normal file
@ -0,0 +1,47 @@
|
||||
Revert:
|
||||
commit e3e89cc535223433a619d0969db3fa05cdd946b8
|
||||
("Mark ptrace_{traceme,attach,detach} static")
|
||||
|
||||
--- b/include/linux/ptrace.h
|
||||
+++ a/include/linux/ptrace.h
|
||||
@@ -102,8 +102,11 @@
|
||||
|
||||
extern long arch_ptrace(struct task_struct *child, long request,
|
||||
unsigned long addr, unsigned long data);
|
||||
+extern int ptrace_traceme(void);
|
||||
extern int ptrace_readdata(struct task_struct *tsk, unsigned long src, char __user *dst, int len);
|
||||
extern int ptrace_writedata(struct task_struct *tsk, char __user *src, unsigned long dst, int len);
|
||||
+extern int ptrace_attach(struct task_struct *tsk);
|
||||
+extern int ptrace_detach(struct task_struct *, unsigned int);
|
||||
extern void ptrace_disable(struct task_struct *);
|
||||
extern int ptrace_check_attach(struct task_struct *task, int kill);
|
||||
extern int ptrace_request(struct task_struct *child, long request,
|
||||
--- b/kernel/ptrace.c
|
||||
+++ a/kernel/ptrace.c
|
||||
@@ -163,7 +163,7 @@
|
||||
return !err;
|
||||
}
|
||||
|
||||
+int ptrace_attach(struct task_struct *task)
|
||||
-static int ptrace_attach(struct task_struct *task)
|
||||
{
|
||||
int retval;
|
||||
|
||||
@@ -219,7 +219,7 @@
|
||||
* Performs checks and sets PT_PTRACED.
|
||||
* Should be used by all ptrace implementations for PTRACE_TRACEME.
|
||||
*/
|
||||
+int ptrace_traceme(void)
|
||||
-static int ptrace_traceme(void)
|
||||
{
|
||||
int ret = -EPERM;
|
||||
|
||||
@@ -293,7 +293,7 @@
|
||||
return false;
|
||||
}
|
||||
|
||||
+int ptrace_detach(struct task_struct *child, unsigned int data)
|
||||
-static int ptrace_detach(struct task_struct *child, unsigned int data)
|
||||
{
|
||||
bool dead = false;
|
||||
|
Loading…
Reference in New Issue
Block a user