kernel-5.8.0-0.rc7.1

* Mon Jul 27 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.1]
- v5.8-rc7 rebase
- Updated changelog for the release based on 04300d66f0a0 (Fedora Kernel Team)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2020-07-27 09:57:23 -05:00
parent e7f8b3f4a6
commit 38ae8ad573
21 changed files with 51 additions and 34 deletions

View File

@ -15,7 +15,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
2 files changed, 96 insertions(+), 31 deletions(-)
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
index 5114cae4ec97..93dcc37a9820 100644
index fdd1db025dbf..8ef7d1df09dd 100644
--- a/drivers/firmware/efi/efi.c
+++ b/drivers/firmware/efi/efi.c
@@ -31,6 +31,7 @@
@ -26,7 +26,7 @@ index 5114cae4ec97..93dcc37a9820 100644
#include <asm/early_ioremap.h>
@@ -827,40 +828,101 @@ int efi_mem_type(unsigned long phys_addr)
@@ -831,40 +832,101 @@ int efi_mem_type(unsigned long phys_addr)
}
#endif
@ -160,7 +160,7 @@ index 5114cae4ec97..93dcc37a9820 100644
static DEFINE_SPINLOCK(efi_mem_reserve_persistent_lock);
diff --git a/include/linux/efi.h b/include/linux/efi.h
index bb35f3305e55..1d77c218b67e 100644
index 05c47f857383..2e2f9f608f68 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -43,6 +43,8 @@

View File

@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 542284743304..18036f3c183f 100644
index 6bcfd5635a72..a7b784c0fade 100644
--- a/Makefile
+++ b/Makefile
@@ -496,7 +496,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE

View File

@ -107,7 +107,7 @@ index 000000000000..de0a3714a5d4
+ }
+}
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 1d77c218b67e..f5fe3e01bc0e 100644
index 2e2f9f608f68..6f5b3b019d3e 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -781,6 +781,14 @@ extern int __init efi_setup_pcdp_console(char *);
@ -143,7 +143,7 @@ index 1d77c218b67e..f5fe3e01bc0e 100644
static inline bool efi_soft_reserve_enabled(void)
{
return false;
@@ -1089,12 +1101,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
@@ -1090,12 +1102,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
extern void efi_call_virt_check_flags(unsigned long flags, const char *call);
extern unsigned long efi_call_virt_save_flags(void);

View File

@ -114,7 +114,7 @@ index aa183c9ac0a2..dc323b3f5838 100644
&modinfo_coresize,
&modinfo_initsize,
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
index 6aea65c65745..ed3c4d8a1c7f 100644
index 45f2ab2ec2d4..3bf849a0c6ab 100644
--- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c
@@ -21,6 +21,7 @@
@ -125,7 +125,7 @@ index 6aea65c65745..ed3c4d8a1c7f 100644
/* Are we using CONFIG_MODVERSIONS? */
static int modversions = 0;
@@ -2384,6 +2385,12 @@ static void write_buf(struct buffer *b, const char *fname)
@@ -2392,6 +2393,12 @@ static void write_buf(struct buffer *b, const char *fname)
}
}
@ -138,7 +138,7 @@ index 6aea65c65745..ed3c4d8a1c7f 100644
static void write_if_changed(struct buffer *b, const char *fname)
{
char *tmp;
@@ -2636,6 +2643,7 @@ int main(int argc, char **argv)
@@ -2644,6 +2651,7 @@ int main(int argc, char **argv)
add_depends(&buf, mod);
add_moddevtable(&buf, mod);
add_srcversion(&buf, mod);

View File

@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 249a51d25c63..542284743304 100644
index 229e67f2ff75..6bcfd5635a72 100644
--- a/Makefile
+++ b/Makefile
@@ -1217,7 +1217,13 @@ endef

View File

@ -1523,7 +1523,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1515,7 +1515,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1526,7 +1526,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1519,7 +1519,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1494,7 +1494,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1487,7 +1487,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1276,7 +1276,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1267,7 +1267,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1182,7 +1182,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1173,7 +1173,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1189,7 +1189,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1180,7 +1180,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1312,7 +1312,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -1303,7 +1303,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_UNSTRIPED=m
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_VERITY=m
# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG is not set
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
CONFIG_DM_WRITECACHE=m
CONFIG_DM_ZERO=y
CONFIG_DM_ZONED=m

View File

@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
%global distro_build 0.rc6.20200723gitd15be546031c.1
%global distro_build 0.rc7.1
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -69,13 +69,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.8.0
%define pkgrelease 0.rc6.20200723gitd15be546031c.1
%define pkgrelease 0.rc7.1
# This is needed to do merge window version magic
%define patchlevel 8
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc6.20200723gitd15be546031c.1%{?buildid}%{?dist}
%define specrelease 0.rc7.1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -166,7 +166,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
%define debugbuildsenabled 0
%define debugbuildsenabled 1
# The kernel tarball/base version
%define kversion 5.8
@ -567,7 +567,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-20200723gitd15be546031c.tar.xz
Source0: linux-5.8-rc7.tar.xz
Source1: Makefile.rhelver
@ -1308,8 +1308,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-20200723gitd15be546031c -c
mv linux-20200723gitd15be546031c linux-%{KVERREL}
%setup -q -n kernel-5.8-rc7 -c
mv linux-5.8-rc7 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2846,6 +2846,23 @@ fi
#
#
%changelog
* Mon Jul 27 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc7.1]
- v5.8-rc7 rebase
- Updated changelog for the release based on 04300d66f0a0 (Fedora Kernel Team)
* Sun Jul 26 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc6.20200726git04300d66f0a0.1]
- 04300d66f0a0 rebase
- Updated changelog for the release based on 23ee3e4e5bd2 (Fedora Kernel Team)
* Sat Jul 25 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc6.20200725git23ee3e4e5bd2.1]
- 23ee3e4e5bd2 rebase
- Enable CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG ("Justin M. Forbes")
- Updated changelog for the release based on f37e99aca03f (Fedora Kernel Team)
* Fri Jul 24 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc6.20200724gitf37e99aca03f.1]
- f37e99aca03f rebase
- Updated changelog for the release based on d15be546031c (Fedora Kernel Team)
* Thu Jul 23 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc6.20200723gitd15be546031c.1]
- d15be546031c rebase
- fedora: arm: Update some meson config options (Peter Robinson)

View File

@ -1,3 +1,3 @@
SHA512 (linux-20200723gitd15be546031c.tar.xz) = 1a77b4d21347bcb6c5f615a7c450b159fb6b965e186eadc721a88ca456a834bbe36d014cc8ace89a13a7349eb7d8a79910c168be3f141acb4b1869a5eca52c2a
SHA512 (kernel-abi-whitelists-5.8.0-0.rc6.20200723gitd15be546031c.1.tar.bz2) = 7c9829a0839a19b36f40365131f1ada54fa89e2e156e9420fe47ecf93a575bdcfc8e65d2cde0e8410b5d3d7b30489993a3ed138d7b941a95b6e0e100a48bd54c
SHA512 (kernel-kabi-dw-5.8.0-0.rc6.20200723gitd15be546031c.1.tar.bz2) = 7832bbe80f073e91e5478248d9cf121060451b7fa4331d2efc7f0e714023d0201cc6c72f54f6af41cb18bef05905a0d9a8fb1446138e0022e89b093b22a1c5ab
SHA512 (linux-5.8-rc7.tar.xz) = 0b1c515d46f0db3589b51764ed66f7fe4054c603d716243d9963c4cdc80b628ee7f0ca6d4a06c5db3e0d00c5cc2f816e6f3eacb368e3a303316558762384e815
SHA512 (kernel-abi-whitelists-5.8.0-0.rc7.1.tar.bz2) = fee25944fc67fab7f088572315a7da8d98c2bc41c41fe2a93fd2d804acafdca88ecf57d0cb5bc1c00a5c4c3b5ece72613f9276cab9d3af4140960043831627d4
SHA512 (kernel-kabi-dw-5.8.0-0.rc7.1.tar.bz2) = 1fc3ed21f101ddf8915b52993469886416290a0ac9b055f478ecfd55303a50c3e2ba5b062c5a7af38725274a09f83c63a05ff7a0d6c41087526cbb5eb323beca