kernel-6.11.9-300
* Sun Nov 17 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.9-0] - Linux v6.11.9 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
7e3478eb8c
commit
3762921732
@ -1,3 +1,7 @@
|
||||
* Sun Nov 17 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.9-0]
|
||||
- Linux v6.11.9
|
||||
Resolves:
|
||||
|
||||
* Thu Nov 14 2024 Augusto Caringi <acaringi@redhat.com> [6.11.8-0]
|
||||
- Linux v6.11.8
|
||||
Resolves:
|
||||
|
11
kernel.spec
11
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.11.8
|
||||
%define specversion 6.11.8
|
||||
%define specrpmversion 6.11.9
|
||||
%define specversion 6.11.9
|
||||
%define patchversion 6.11
|
||||
%define pkgrelease 300
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.11.8
|
||||
%define tarfile_release 6.11.9
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 11
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 300%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.11.8
|
||||
%define kabiversion 6.11.9
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -4128,6 +4128,9 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Sun Nov 17 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.11.9-0]
|
||||
- Linux v6.11.9
|
||||
|
||||
* Thu Nov 14 2024 Augusto Caringi <acaringi@redhat.com> [6.11.8-0]
|
||||
- Linux v6.11.8
|
||||
|
||||
|
@ -24,7 +24,6 @@
|
||||
drivers/firmware/efi/Makefile | 1 +
|
||||
drivers/firmware/efi/efi.c | 124 ++++++---
|
||||
drivers/firmware/efi/secureboot.c | 38 +++
|
||||
drivers/hid/hid-lenovo.c | 8 +
|
||||
drivers/hid/hid-rmi.c | 66 -----
|
||||
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 ++
|
||||
drivers/input/rmi4/rmi_driver.c | 124 +++++----
|
||||
@ -44,10 +43,10 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 +
|
||||
46 files changed, 979 insertions(+), 233 deletions(-)
|
||||
45 files changed, 971 insertions(+), 233 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index b8641dde171ff..0f03b97ae87f2 100644
|
||||
index 3e48c8d84540..973bfa6438ed 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -112,7 +111,7 @@ index b8641dde171ff..0f03b97ae87f2 100644
|
||||
@:
|
||||
|
||||
diff --git a/arch/arm/boot/dts/broadcom/bcm2837.dtsi b/arch/arm/boot/dts/broadcom/bcm2837.dtsi
|
||||
index 84c08b46519da..c281697142b1a 100644
|
||||
index 84c08b46519d..c281697142b1 100644
|
||||
--- a/arch/arm/boot/dts/broadcom/bcm2837.dtsi
|
||||
+++ b/arch/arm/boot/dts/broadcom/bcm2837.dtsi
|
||||
@@ -9,7 +9,7 @@ soc {
|
||||
@ -125,7 +124,7 @@ index 84c08b46519da..c281697142b1a 100644
|
||||
reg = <0x40000000 0x100>;
|
||||
interrupt-controller;
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index 402ae0297993c..bdfabc559adc6 100644
|
||||
index 402ae0297993..bdfabc559adc 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -1366,7 +1366,7 @@ endchoice
|
||||
@ -138,7 +137,7 @@ index 402ae0297993c..bdfabc559adc6 100644
|
||||
For systems with 52-bit userspace VAs enabled, the kernel will attempt
|
||||
to maintain compatibility with older software by providing 48-bit VAs
|
||||
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
||||
index e868ca5ae753a..a5c3920e0f048 100644
|
||||
index e868ca5ae753..a5c3920e0f04 100644
|
||||
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
||||
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
|
||||
@@ -263,6 +263,14 @@ gpu0_thermal: gpu0-thermal {
|
||||
@ -172,7 +171,7 @@ index e868ca5ae753a..a5c3920e0f048 100644
|
||||
};
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
|
||||
index 8b4591ddd27cc..92565e9781ad3 100644
|
||||
index 8b4591ddd27c..92565e9781ad 100644
|
||||
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
||||
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
||||
@@ -6,6 +6,7 @@ DTC_FLAGS := -@
|
||||
@ -185,7 +184,7 @@ index 8b4591ddd27cc..92565e9781ad3 100644
|
||||
bcm2837-rpi-3-b-plus.dtb \
|
||||
diff --git a/arch/arm64/boot/dts/broadcom/bcm2712-rpi-5-b.dts b/arch/arm64/boot/dts/broadcom/bcm2712-rpi-5-b.dts
|
||||
new file mode 100644
|
||||
index 0000000000000..2bdbb6780242a
|
||||
index 000000000000..2bdbb6780242
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/broadcom/bcm2712-rpi-5-b.dts
|
||||
@@ -0,0 +1,64 @@
|
||||
@ -255,7 +254,7 @@ index 0000000000000..2bdbb6780242a
|
||||
+};
|
||||
diff --git a/arch/arm64/boot/dts/broadcom/bcm2712.dtsi b/arch/arm64/boot/dts/broadcom/bcm2712.dtsi
|
||||
new file mode 100644
|
||||
index 0000000000000..6e5a984c1d4ea
|
||||
index 000000000000..6e5a984c1d4e
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/broadcom/bcm2712.dtsi
|
||||
@@ -0,0 +1,283 @@
|
||||
@ -543,7 +542,7 @@ index 0000000000000..6e5a984c1d4ea
|
||||
+ };
|
||||
+};
|
||||
diff --git a/arch/arm64/boot/dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts b/arch/arm64/boot/dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts
|
||||
index b27143f81867a..320706c88cdd6 100644
|
||||
index b27143f81867..320706c88cdd 100644
|
||||
--- a/arch/arm64/boot/dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts
|
||||
+++ b/arch/arm64/boot/dts/qcom/sc8280xp-lenovo-thinkpad-x13s.dts
|
||||
@@ -592,6 +592,57 @@ vreg_l10d: ldo10 {
|
||||
@ -628,7 +627,7 @@ index b27143f81867a..320706c88cdd6 100644
|
||||
pins = "gpio25";
|
||||
function = "gpio";
|
||||
diff --git a/arch/s390/include/asm/ipl.h b/arch/s390/include/asm/ipl.h
|
||||
index b0d00032479d6..afb9544fb0074 100644
|
||||
index b0d00032479d..afb9544fb007 100644
|
||||
--- a/arch/s390/include/asm/ipl.h
|
||||
+++ b/arch/s390/include/asm/ipl.h
|
||||
@@ -139,6 +139,7 @@ int ipl_report_add_component(struct ipl_report *report, struct kexec_buf *kbuf,
|
||||
@ -640,7 +639,7 @@ index b0d00032479d6..afb9544fb0074 100644
|
||||
/*
|
||||
* DIAG 308 support
|
||||
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
||||
index f17bb7bf93924..66e530380ee30 100644
|
||||
index f17bb7bf9392..66e530380ee3 100644
|
||||
--- a/arch/s390/kernel/ipl.c
|
||||
+++ b/arch/s390/kernel/ipl.c
|
||||
@@ -2479,3 +2479,8 @@ int ipl_report_free(struct ipl_report *report)
|
||||
@ -653,7 +652,7 @@ index f17bb7bf93924..66e530380ee30 100644
|
||||
+ return !!ipl_secure_flag;
|
||||
+}
|
||||
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
|
||||
index a3fea683b2270..a3162d93f437d 100644
|
||||
index a3fea683b227..a3162d93f437 100644
|
||||
--- a/arch/s390/kernel/setup.c
|
||||
+++ b/arch/s390/kernel/setup.c
|
||||
@@ -49,6 +49,7 @@
|
||||
@ -675,7 +674,7 @@ index a3fea683b2270..a3162d93f437d 100644
|
||||
/* boot_command_line has been already set up in early.c */
|
||||
*cmdline_p = boot_command_line;
|
||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||
index 6129dc2ba784c..feaf5fd3f37d5 100644
|
||||
index 6129dc2ba784..feaf5fd3f37d 100644
|
||||
--- a/arch/x86/kernel/setup.c
|
||||
+++ b/arch/x86/kernel/setup.c
|
||||
@@ -21,6 +21,7 @@
|
||||
@ -722,7 +721,7 @@ index 6129dc2ba784c..feaf5fd3f37d5 100644
|
||||
reserve_initrd();
|
||||
|
||||
diff --git a/certs/extract-cert.c b/certs/extract-cert.c
|
||||
index 70e9ec89d87d3..f5fb74916cee4 100644
|
||||
index 70e9ec89d87d..f5fb74916cee 100644
|
||||
--- a/certs/extract-cert.c
|
||||
+++ b/certs/extract-cert.c
|
||||
@@ -21,7 +21,6 @@
|
||||
@ -765,7 +764,7 @@ index 70e9ec89d87d3..f5fb74916cee4 100644
|
||||
BIO *b;
|
||||
X509 *x509;
|
||||
diff --git a/crypto/akcipher.c b/crypto/akcipher.c
|
||||
index e0ff5f4dda6d6..098a52ded759c 100644
|
||||
index e0ff5f4dda6d..098a52ded759 100644
|
||||
--- a/crypto/akcipher.c
|
||||
+++ b/crypto/akcipher.c
|
||||
@@ -126,14 +126,12 @@ int crypto_register_akcipher(struct akcipher_alg *alg)
|
||||
@ -786,7 +785,7 @@ index e0ff5f4dda6d6..098a52ded759c 100644
|
||||
alg->set_priv_key = akcipher_default_set_key;
|
||||
|
||||
diff --git a/crypto/dh.c b/crypto/dh.c
|
||||
index 68d11d66c0b54..6e3e515b24526 100644
|
||||
index 68d11d66c0b5..6e3e515b2452 100644
|
||||
--- a/crypto/dh.c
|
||||
+++ b/crypto/dh.c
|
||||
@@ -227,10 +227,35 @@ static int dh_compute_value(struct kpp_request *req)
|
||||
@ -826,7 +825,7 @@ index 68d11d66c0b54..6e3e515b24526 100644
|
||||
}
|
||||
|
||||
diff --git a/crypto/seqiv.c b/crypto/seqiv.c
|
||||
index 17e11d51ddc36..9c136a3b62679 100644
|
||||
index 17e11d51ddc3..9c136a3b6267 100644
|
||||
--- a/crypto/seqiv.c
|
||||
+++ b/crypto/seqiv.c
|
||||
@@ -132,6 +132,19 @@ static int seqiv_aead_decrypt(struct aead_request *req)
|
||||
@ -859,7 +858,7 @@ index 17e11d51ddc36..9c136a3b62679 100644
|
||||
|
||||
inst->alg.base.cra_ctxsize = sizeof(struct aead_geniv_ctx);
|
||||
diff --git a/crypto/testmgr.c b/crypto/testmgr.c
|
||||
index f02cb075bd681..669e306f1cb22 100644
|
||||
index f02cb075bd68..669e306f1cb2 100644
|
||||
--- a/crypto/testmgr.c
|
||||
+++ b/crypto/testmgr.c
|
||||
@@ -4216,7 +4216,7 @@ static int test_akcipher_one(struct crypto_akcipher *tfm,
|
||||
@ -887,7 +886,7 @@ index f02cb075bd681..669e306f1cb22 100644
|
||||
.kpp = __VECS(ecdh_p384_tv_template)
|
||||
}
|
||||
diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
|
||||
index 20d757687e3d9..90a13f20f052b 100644
|
||||
index 20d757687e3d..90a13f20f052 100644
|
||||
--- a/drivers/acpi/apei/hest.c
|
||||
+++ b/drivers/acpi/apei/hest.c
|
||||
@@ -142,6 +142,14 @@ static int apei_hest_parse(apei_hest_func_t func, void *data)
|
||||
@ -906,7 +905,7 @@ index 20d757687e3d9..90a13f20f052b 100644
|
||||
for (i = 0; i < hest_tab->error_source_count; i++) {
|
||||
len = hest_esrc_len(hest_hdr);
|
||||
diff --git a/drivers/acpi/irq.c b/drivers/acpi/irq.c
|
||||
index 1687483ff319e..390b67f19181a 100644
|
||||
index 1687483ff319..390b67f19181 100644
|
||||
--- a/drivers/acpi/irq.c
|
||||
+++ b/drivers/acpi/irq.c
|
||||
@@ -143,6 +143,7 @@ struct acpi_irq_parse_one_ctx {
|
||||
@ -949,7 +948,7 @@ index 1687483ff319e..390b67f19181a 100644
|
||||
return ctx.rc;
|
||||
}
|
||||
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
||||
index 22ae7829a9155..1329032ed09b6 100644
|
||||
index 22ae7829a915..1329032ed09b 100644
|
||||
--- a/drivers/acpi/scan.c
|
||||
+++ b/drivers/acpi/scan.c
|
||||
@@ -1802,6 +1802,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
||||
@ -969,7 +968,7 @@ index 22ae7829a9155..1329032ed09b6 100644
|
||||
acpi_dev_get_resources(device, &resource_list,
|
||||
acpi_check_serial_bus_slave,
|
||||
diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
|
||||
index fdfa7b2662180..f5f8ba457c93f 100644
|
||||
index fdfa7b266218..f5f8ba457c93 100644
|
||||
--- a/drivers/ata/libahci.c
|
||||
+++ b/drivers/ata/libahci.c
|
||||
@@ -729,6 +729,24 @@ int ahci_stop_engine(struct ata_port *ap)
|
||||
@ -998,7 +997,7 @@ index fdfa7b2662180..f5f8ba457c93f 100644
|
||||
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
|
||||
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
|
||||
diff --git a/drivers/char/ipmi/ipmi_dmi.c b/drivers/char/ipmi/ipmi_dmi.c
|
||||
index bbf7029e224be..cf7faa970dd65 100644
|
||||
index bbf7029e224b..cf7faa970dd6 100644
|
||||
--- a/drivers/char/ipmi/ipmi_dmi.c
|
||||
+++ b/drivers/char/ipmi/ipmi_dmi.c
|
||||
@@ -215,6 +215,21 @@ static int __init scan_for_dmi_ipmi(void)
|
||||
@ -1024,7 +1023,7 @@ index bbf7029e224be..cf7faa970dd65 100644
|
||||
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
|
||||
|
||||
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
|
||||
index e12b531f5c2f3..082707f8dff8c 100644
|
||||
index e12b531f5c2f..082707f8dff8 100644
|
||||
--- a/drivers/char/ipmi/ipmi_msghandler.c
|
||||
+++ b/drivers/char/ipmi/ipmi_msghandler.c
|
||||
@@ -35,6 +35,7 @@
|
||||
@ -1059,7 +1058,7 @@ index e12b531f5c2f3..082707f8dff8c 100644
|
||||
rv = ipmi_register_driver();
|
||||
mutex_unlock(&ipmi_interfaces_mutex);
|
||||
diff --git a/drivers/firmware/efi/Makefile b/drivers/firmware/efi/Makefile
|
||||
index a2d0009560d0f..4f3486e6a84b2 100644
|
||||
index a2d0009560d0..4f3486e6a84b 100644
|
||||
--- a/drivers/firmware/efi/Makefile
|
||||
+++ b/drivers/firmware/efi/Makefile
|
||||
@@ -25,6 +25,7 @@ subdir-$(CONFIG_EFI_STUB) += libstub
|
||||
@ -1071,7 +1070,7 @@ index a2d0009560d0f..4f3486e6a84b2 100644
|
||||
obj-$(CONFIG_EFI_RCI2_TABLE) += rci2-table.o
|
||||
obj-$(CONFIG_EFI_EMBEDDED_FIRMWARE) += embedded-firmware.o
|
||||
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
||||
index fdf07dd6f4591..cfd2b58a34940 100644
|
||||
index fdf07dd6f459..cfd2b58a3494 100644
|
||||
--- a/drivers/firmware/efi/efi.c
|
||||
+++ b/drivers/firmware/efi/efi.c
|
||||
@@ -33,6 +33,7 @@
|
||||
@ -1217,7 +1216,7 @@ index fdf07dd6f4591..cfd2b58a34940 100644
|
||||
|
||||
diff --git a/drivers/firmware/efi/secureboot.c b/drivers/firmware/efi/secureboot.c
|
||||
new file mode 100644
|
||||
index 0000000000000..de0a3714a5d44
|
||||
index 000000000000..de0a3714a5d4
|
||||
--- /dev/null
|
||||
+++ b/drivers/firmware/efi/secureboot.c
|
||||
@@ -0,0 +1,38 @@
|
||||
@ -1259,69 +1258,8 @@ index 0000000000000..de0a3714a5d44
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
diff --git a/drivers/hid/hid-lenovo.c b/drivers/hid/hid-lenovo.c
|
||||
index e5e72aa5260a9..24654c7ecb04e 100644
|
||||
--- a/drivers/hid/hid-lenovo.c
|
||||
+++ b/drivers/hid/hid-lenovo.c
|
||||
@@ -473,6 +473,7 @@ static int lenovo_input_mapping(struct hid_device *hdev,
|
||||
return lenovo_input_mapping_tp10_ultrabook_kbd(hdev, hi, field,
|
||||
usage, bit, max);
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
return lenovo_input_mapping_x1_tab_kbd(hdev, hi, field, usage, bit, max);
|
||||
default:
|
||||
return 0;
|
||||
@@ -583,6 +584,7 @@ static ssize_t attr_fn_lock_store(struct device *dev,
|
||||
break;
|
||||
case USB_DEVICE_ID_LENOVO_TP10UBKBD:
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
ret = lenovo_led_set_tp10ubkbd(hdev, TP10UBKBD_FN_LOCK_LED, value);
|
||||
if (ret)
|
||||
return ret;
|
||||
@@ -776,6 +778,7 @@ static int lenovo_event(struct hid_device *hdev, struct hid_field *field,
|
||||
return lenovo_event_cptkbd(hdev, field, usage, value);
|
||||
case USB_DEVICE_ID_LENOVO_TP10UBKBD:
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
return lenovo_event_tp10ubkbd(hdev, field, usage, value);
|
||||
default:
|
||||
return 0;
|
||||
@@ -1056,6 +1059,7 @@ static int lenovo_led_brightness_set(struct led_classdev *led_cdev,
|
||||
break;
|
||||
case USB_DEVICE_ID_LENOVO_TP10UBKBD:
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
ret = lenovo_led_set_tp10ubkbd(hdev, tp10ubkbd_led[led_nr], value);
|
||||
break;
|
||||
}
|
||||
@@ -1286,6 +1290,7 @@ static int lenovo_probe(struct hid_device *hdev,
|
||||
break;
|
||||
case USB_DEVICE_ID_LENOVO_TP10UBKBD:
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
ret = lenovo_probe_tp10ubkbd(hdev);
|
||||
break;
|
||||
default:
|
||||
@@ -1372,6 +1377,7 @@ static void lenovo_remove(struct hid_device *hdev)
|
||||
break;
|
||||
case USB_DEVICE_ID_LENOVO_TP10UBKBD:
|
||||
case USB_DEVICE_ID_LENOVO_X1_TAB:
|
||||
+ case USB_DEVICE_ID_LENOVO_X1_TAB3:
|
||||
lenovo_remove_tp10ubkbd(hdev);
|
||||
break;
|
||||
}
|
||||
@@ -1421,6 +1427,8 @@ static const struct hid_device_id lenovo_devices[] = {
|
||||
*/
|
||||
{ HID_DEVICE(BUS_USB, HID_GROUP_GENERIC,
|
||||
USB_VENDOR_ID_LENOVO, USB_DEVICE_ID_LENOVO_X1_TAB) },
|
||||
+ { HID_DEVICE(BUS_USB, HID_GROUP_GENERIC,
|
||||
+ USB_VENDOR_ID_LENOVO, USB_DEVICE_ID_LENOVO_X1_TAB3) },
|
||||
{ }
|
||||
};
|
||||
|
||||
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
|
||||
index d4af17fdba467..154f0403cbf4c 100644
|
||||
index d4af17fdba46..154f0403cbf4 100644
|
||||
--- a/drivers/hid/hid-rmi.c
|
||||
+++ b/drivers/hid/hid-rmi.c
|
||||
@@ -321,21 +321,12 @@ static int rmi_input_event(struct hid_device *hdev, u8 *data, int size)
|
||||
@ -1423,7 +1361,7 @@ index d4af17fdba467..154f0403cbf4c 100644
|
||||
data->xport.ops = &hid_rmi_ops;
|
||||
|
||||
diff --git a/drivers/hwtracing/coresight/coresight-etm4x-core.c b/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
||||
index bf01f01964cf9..703896981e8ae 100644
|
||||
index bf01f01964cf..703896981e8a 100644
|
||||
--- a/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
||||
+++ b/drivers/hwtracing/coresight/coresight-etm4x-core.c
|
||||
@@ -10,6 +10,7 @@
|
||||
@ -1474,7 +1412,7 @@ index bf01f01964cf9..703896981e8ae 100644
|
||||
platform_driver_unregister(&etm4_platform_driver);
|
||||
etm4_pm_clear();
|
||||
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
|
||||
index 2168b6cd71673..5d7cda175a0ce 100644
|
||||
index 2168b6cd7167..5d7cda175a0c 100644
|
||||
--- a/drivers/input/rmi4/rmi_driver.c
|
||||
+++ b/drivers/input/rmi4/rmi_driver.c
|
||||
@@ -182,34 +182,47 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
|
||||
@ -1666,7 +1604,7 @@ index 2168b6cd71673..5d7cda175a0ce 100644
|
||||
if (data->f01_container->dev.driver) {
|
||||
/* Driver already bound, so enable ATTN now. */
|
||||
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
|
||||
index ed6c5cb60c5ae..70cb770b78bb3 100644
|
||||
index ed6c5cb60c5a..70cb770b78bb 100644
|
||||
--- a/drivers/iommu/iommu.c
|
||||
+++ b/drivers/iommu/iommu.c
|
||||
@@ -8,6 +8,7 @@
|
||||
@ -1706,7 +1644,7 @@ index ed6c5cb60c5ae..70cb770b78bb3 100644
|
||||
* iommu_setup_default_domain - Set the default_domain for the group
|
||||
* @group: Group to change
|
||||
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
|
||||
index dccb60c1d9cc3..c7ec62f076c31 100644
|
||||
index dccb60c1d9cc..c7ec62f076c3 100644
|
||||
--- a/drivers/pci/quirks.c
|
||||
+++ b/drivers/pci/quirks.c
|
||||
@@ -4452,6 +4452,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
|
||||
@ -1741,7 +1679,7 @@ index dccb60c1d9cc3..c7ec62f076c31 100644
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
|
||||
index 53896df7ec2bf..98e08f10f60ec 100644
|
||||
index 53896df7ec2b..98e08f10f60e 100644
|
||||
--- a/drivers/scsi/sd.c
|
||||
+++ b/drivers/scsi/sd.c
|
||||
@@ -122,6 +122,14 @@ static const char *sd_cache_types[] = {
|
||||
@ -1769,7 +1707,7 @@ index 53896df7ec2bf..98e08f10f60ec 100644
|
||||
if (err)
|
||||
goto err_out_driver;
|
||||
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
|
||||
index 4b93c0bd1d4bc..b98906237306d 100644
|
||||
index 4b93c0bd1d4b..b98906237306 100644
|
||||
--- a/drivers/usb/core/hub.c
|
||||
+++ b/drivers/usb/core/hub.c
|
||||
@@ -5844,6 +5844,13 @@ static void hub_event(struct work_struct *work)
|
||||
@ -1787,7 +1725,7 @@ index 4b93c0bd1d4bc..b98906237306d 100644
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/include/linux/crypto.h b/include/linux/crypto.h
|
||||
index b164da5e129e8..72bfb79b491da 100644
|
||||
index b164da5e129e..72bfb79b491d 100644
|
||||
--- a/include/linux/crypto.h
|
||||
+++ b/include/linux/crypto.h
|
||||
@@ -134,6 +134,8 @@
|
||||
@ -1800,7 +1738,7 @@ index b164da5e129e8..72bfb79b491da 100644
|
||||
* Miscellaneous stuff.
|
||||
*/
|
||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||
index 6bf3c4fe85117..67e5400f76444 100644
|
||||
index 6bf3c4fe8511..67e5400f7644 100644
|
||||
--- a/include/linux/efi.h
|
||||
+++ b/include/linux/efi.h
|
||||
@@ -45,6 +45,8 @@ struct screen_info;
|
||||
@ -1868,7 +1806,7 @@ index 6bf3c4fe85117..67e5400f76444 100644
|
||||
enum efi_secureboot_mode efi_get_secureboot_mode(efi_get_variable_t *get_var)
|
||||
{
|
||||
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
||||
index 19c333fafe113..db33ee7f55d54 100644
|
||||
index 19c333fafe11..db33ee7f55d5 100644
|
||||
--- a/include/linux/lsm_hook_defs.h
|
||||
+++ b/include/linux/lsm_hook_defs.h
|
||||
@@ -439,6 +439,8 @@ LSM_HOOK(int, 0, bpf_token_capable, const struct bpf_token *token, int cap)
|
||||
@ -1881,7 +1819,7 @@ index 19c333fafe113..db33ee7f55d54 100644
|
||||
#ifdef CONFIG_PERF_EVENTS
|
||||
LSM_HOOK(int, 0, perf_event_open, struct perf_event_attr *attr, int type)
|
||||
diff --git a/include/linux/rmi.h b/include/linux/rmi.h
|
||||
index ab7eea01ab427..fff7c5f737fc8 100644
|
||||
index ab7eea01ab42..fff7c5f737fc 100644
|
||||
--- a/include/linux/rmi.h
|
||||
+++ b/include/linux/rmi.h
|
||||
@@ -364,6 +364,7 @@ struct rmi_driver_data {
|
||||
@ -1893,7 +1831,7 @@ index ab7eea01ab427..fff7c5f737fc8 100644
|
||||
|
||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||
diff --git a/include/linux/security.h b/include/linux/security.h
|
||||
index 1390f1efb4f07..b9a8ccb1dbdcc 100644
|
||||
index 1390f1efb4f0..b9a8ccb1dbdc 100644
|
||||
--- a/include/linux/security.h
|
||||
+++ b/include/linux/security.h
|
||||
@@ -507,6 +507,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
|
||||
@ -1916,7 +1854,7 @@ index 1390f1efb4f07..b9a8ccb1dbdcc 100644
|
||||
u32 *uctx_len, void *val, size_t val_len,
|
||||
u64 id, u64 flags)
|
||||
diff --git a/kernel/module/signing.c b/kernel/module/signing.c
|
||||
index a2ff4242e623d..f0d2be1ee4f1c 100644
|
||||
index a2ff4242e623..f0d2be1ee4f1 100644
|
||||
--- a/kernel/module/signing.c
|
||||
+++ b/kernel/module/signing.c
|
||||
@@ -61,10 +61,17 @@ int mod_verify_sig(const void *mod, struct load_info *info)
|
||||
@ -1939,7 +1877,7 @@ index a2ff4242e623d..f0d2be1ee4f1c 100644
|
||||
|
||||
int module_sig_check(struct load_info *info, int flags)
|
||||
diff --git a/scripts/sign-file.c b/scripts/sign-file.c
|
||||
index 3edb156ae52c3..0114ae1dbf7ff 100644
|
||||
index 3edb156ae52c..0114ae1dbf7f 100644
|
||||
--- a/scripts/sign-file.c
|
||||
+++ b/scripts/sign-file.c
|
||||
@@ -27,7 +27,6 @@
|
||||
@ -1993,7 +1931,7 @@ index 3edb156ae52c3..0114ae1dbf7ff 100644
|
||||
BIO *b;
|
||||
|
||||
diff --git a/scripts/tags.sh b/scripts/tags.sh
|
||||
index 191e0461d6d5b..e6f418b3e948b 100755
|
||||
index 191e0461d6d5..e6f418b3e948 100755
|
||||
--- a/scripts/tags.sh
|
||||
+++ b/scripts/tags.sh
|
||||
@@ -16,6 +16,8 @@ fi
|
||||
@ -2006,7 +1944,7 @@ index 191e0461d6d5b..e6f418b3e948b 100755
|
||||
# ignore arbitrary directories
|
||||
if [ -n "${IGNORE_DIRS}" ]; then
|
||||
diff --git a/security/integrity/platform_certs/load_uefi.c b/security/integrity/platform_certs/load_uefi.c
|
||||
index d1fdd113450a6..182e8090cfe85 100644
|
||||
index d1fdd113450a..182e8090cfe8 100644
|
||||
--- a/security/integrity/platform_certs/load_uefi.c
|
||||
+++ b/security/integrity/platform_certs/load_uefi.c
|
||||
@@ -74,7 +74,8 @@ static __init void *get_cert_list(efi_char16_t *name, efi_guid_t *guid,
|
||||
@ -2030,7 +1968,7 @@ index d1fdd113450a6..182e8090cfe85 100644
|
||||
}
|
||||
|
||||
diff --git a/security/lockdown/Kconfig b/security/lockdown/Kconfig
|
||||
index e84ddf4840101..d0501353a4b95 100644
|
||||
index e84ddf484010..d0501353a4b9 100644
|
||||
--- a/security/lockdown/Kconfig
|
||||
+++ b/security/lockdown/Kconfig
|
||||
@@ -16,6 +16,19 @@ config SECURITY_LOCKDOWN_LSM_EARLY
|
||||
@ -2054,7 +1992,7 @@ index e84ddf4840101..d0501353a4b95 100644
|
||||
prompt "Kernel default lockdown mode"
|
||||
default LOCK_DOWN_KERNEL_FORCE_NONE
|
||||
diff --git a/security/lockdown/lockdown.c b/security/lockdown/lockdown.c
|
||||
index cd84d8ea1dfbf..e4c70a0312bc8 100644
|
||||
index cd84d8ea1dfb..e4c70a0312bc 100644
|
||||
--- a/security/lockdown/lockdown.c
|
||||
+++ b/security/lockdown/lockdown.c
|
||||
@@ -74,6 +74,7 @@ static int lockdown_is_locked_down(enum lockdown_reason what)
|
||||
@ -2066,7 +2004,7 @@ index cd84d8ea1dfbf..e4c70a0312bc8 100644
|
||||
|
||||
const struct lsm_id lockdown_lsmid = {
|
||||
diff --git a/security/security.c b/security/security.c
|
||||
index 43166e341526c..b8cf110aeb589 100644
|
||||
index 43166e341526..b8cf110aeb58 100644
|
||||
--- a/security/security.c
|
||||
+++ b/security/security.c
|
||||
@@ -5630,6 +5630,18 @@ int security_locked_down(enum lockdown_reason what)
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.11.8.tar.xz) = 5760c5970b7e29a16fff9e19b6dc71d157cb372b51fc935b21fbfc0c4d52305a8d54c30d3c1be1c7c4442319ebaec9fbf2e277b490fff40dbac90a843669f249
|
||||
SHA512 (kernel-abi-stablelists-6.11.8.tar.xz) = d2137c0d1d2674e76dd831f860c307c78281f0682da1aa131229d08f153e7e5efc70ba703fd417f289cabb11ad5b96950acd1f3b2b9521598ea566bbfca55903
|
||||
SHA512 (kernel-kabi-dw-6.11.8.tar.xz) = 0852a975738b78abf992651684ecf49f187bc91ee71e34f308053289ae845e19560135cfe114c077af6c422f60bc438042725523b21c30fad2e1086dd40693a4
|
||||
SHA512 (linux-6.11.9.tar.xz) = e5400b7f755fa7ce213b1b395a5a548014da524c4d31188d44181ac7fe0db178d2d5bb0d8a34d84e44712f20053428ec163f80d880a32dbab82f8592b3b257e7
|
||||
SHA512 (kernel-abi-stablelists-6.11.9.tar.xz) = ac8826b21224b128bd96d04c49adaa751f0bb5b3b17fad0bb8e2285c75a91634019974ab45c5f48af3e5fcb0918e3b5e1f10b76b026a55711f1381ad1183eee9
|
||||
SHA512 (kernel-kabi-dw-6.11.9.tar.xz) = 4675f6e36cbd701ea77d3ec51e79279f10b75d24bf8a4da751064e52cd0e5c269f112478e5c432caf30f9f9fdc8ac13e826ae8011cf61e82626d552d7b783caa
|
||||
|
Loading…
Reference in New Issue
Block a user