kernel-6.8.6-300

* Sat Apr 13 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.6-0]
- nouveau: fix devinit paths to only handle display on GSP. (Dave Airlie)
- Add bluetooth bug to Bugsfixed for 6.8.6 (Justin M. Forbes)
- Bluetooth: l2cap: Don't double set the HCI_CONN_MGMT_CONNECTED bit (Archie Pusaka)
- Linux v6.8.6
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2024-04-13 09:34:24 -05:00
parent 3de7b4f3f0
commit 3757f8eb14
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 25 additions and 61 deletions

View File

@ -1,3 +1,10 @@
* Sat Apr 13 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.6-0]
- nouveau: fix devinit paths to only handle display on GSP. (Dave Airlie)
- Add bluetooth bug to Bugsfixed for 6.8.6 (Justin M. Forbes)
- Bluetooth: l2cap: Don't double set the HCI_CONN_MGMT_CONNECTED bit (Archie Pusaka)
- Linux v6.8.6
Resolves:
* Wed Apr 10 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-0]
- Set configs for SPECTRE_BHI (Justin M. Forbes)
- Add AMD PMF bug (Justin M. Forbes)

View File

@ -160,18 +160,18 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specrpmversion 6.8.5
%define specversion 6.8.5
%define specrpmversion 6.8.6
%define specversion 6.8.6
%define patchversion 6.8
%define pkgrelease 301
%define pkgrelease 300
%define kversion 6
%define tarfile_release 6.8.5
%define tarfile_release 6.8.6
# This is needed to do merge window version magic
%define patchlevel 8
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 301%{?buildid}%{?dist}
%define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.8.5
%define kabiversion 6.8.6
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3959,10 +3959,11 @@ fi\
#
#
%changelog
* Thu Apr 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-301]
* Sat Apr 13 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.6-0]
- nouveau: fix devinit paths to only handle display on GSP. (Dave Airlie)
- Add bluetooth bug to Bugsfixed for 6.8.6 (Justin M. Forbes)
- Bluetooth: l2cap: Don't double set the HCI_CONN_MGMT_CONNECTED bit (Archie Pusaka)
- Linux v6.8.6
* Wed Apr 10 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.8.5-0]
- Set configs for SPECTRE_BHI (Justin M. Forbes)

View File

@ -13,8 +13,6 @@
drivers/firmware/efi/efi.c | 124 +++++++++++----
drivers/firmware/efi/secureboot.c | 38 +++++
drivers/firmware/sysfb.c | 18 ++-
.../gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c | 12 +-
drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c | 1 +
drivers/hid/hid-rmi.c | 66 --------
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 +++
drivers/input/rmi4/rmi_driver.c | 124 +++++++++------
@ -38,10 +36,10 @@
security/lockdown/Kconfig | 13 ++
security/lockdown/lockdown.c | 1 +
security/security.c | 12 ++
40 files changed, 681 insertions(+), 183 deletions(-)
38 files changed, 672 insertions(+), 179 deletions(-)
diff --git a/Makefile b/Makefile
index f29a75b75861..90586379d1e8 100644
index c426d47f4b7b..9e0540aa3691 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -581,48 +579,6 @@ index 3c197db42c9d..16e4a2e90fae 100644
pd = sysfb_create_simplefb(si, &mode);
if (!IS_ERR(pd))
goto unlock_mutex;
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
index 7bcbc4895ec2..271bfa038f5b 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/gm107.c
@@ -25,6 +25,7 @@
#include <subdev/bios.h>
#include <subdev/bios/init.h>
+#include <subdev/gsp.h>
void
gm107_devinit_disable(struct nvkm_devinit *init)
@@ -33,10 +34,13 @@ gm107_devinit_disable(struct nvkm_devinit *init)
u32 r021c00 = nvkm_rd32(device, 0x021c00);
u32 r021c04 = nvkm_rd32(device, 0x021c04);
- if (r021c00 & 0x00000001)
- nvkm_subdev_disable(device, NVKM_ENGINE_CE, 0);
- if (r021c00 & 0x00000004)
- nvkm_subdev_disable(device, NVKM_ENGINE_CE, 2);
+ /* gsp only wants to enable/disable display */
+ if (!nvkm_gsp_rm(device->gsp)) {
+ if (r021c00 & 0x00000001)
+ nvkm_subdev_disable(device, NVKM_ENGINE_CE, 0);
+ if (r021c00 & 0x00000004)
+ nvkm_subdev_disable(device, NVKM_ENGINE_CE, 2);
+ }
if (r021c04 & 0x00000001)
nvkm_subdev_disable(device, NVKM_ENGINE_DISP, 0);
}
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
index 11b4c9c274a1..666eb93b1742 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/devinit/r535.c
@@ -41,6 +41,7 @@ r535_devinit_new(const struct nvkm_devinit_func *hw,
rm->dtor = r535_devinit_dtor;
rm->post = hw->post;
+ rm->disable = hw->disable;
ret = nv50_devinit_new_(rm, device, type, inst, pdevinit);
if (ret)
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
index d4af17fdba46..154f0403cbf4 100644
--- a/drivers/hid/hid-rmi.c
@ -777,7 +733,7 @@ index 2e2cabc5f50a..8b44d990f978 100644
platform_driver_unregister(&etm4_platform_driver);
etm4_pm_clear();
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
index 42eaebb3bf5c..7a35119c3144 100644
index ef9ea295f9e0..0103334e8f32 100644
--- a/drivers/input/rmi4/rmi_driver.c
+++ b/drivers/input/rmi4/rmi_driver.c
@@ -182,34 +182,47 @@ void rmi_set_attn_data(struct rmi_device *rmi_dev, unsigned long irq_status,
@ -949,7 +905,7 @@ index 42eaebb3bf5c..7a35119c3144 100644
rmi_f34_remove_sysfs(rmi_dev);
rmi_free_function_list(rmi_dev);
@@ -1219,9 +1237,15 @@ static int rmi_driver_probe(struct device *dev)
@@ -1223,9 +1241,15 @@ static int rmi_driver_probe(struct device *dev)
}
}
@ -1475,7 +1431,7 @@ index ab5a9d42fae7..706d2478ddb3 100644
hci_dev_unlock(hdev);
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
index 6568f8177e39..14d8237af366 100644
index ce686ebf5591..0d28efddb253 100644
--- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c
@@ -22,6 +22,7 @@
@ -1486,7 +1442,7 @@ index 6568f8177e39..14d8237af366 100644
static bool module_enabled;
/* Are we using CONFIG_MODVERSIONS? */
@@ -1995,6 +1996,12 @@ static void write_buf(struct buffer *b, const char *fname)
@@ -1997,6 +1998,12 @@ static void write_buf(struct buffer *b, const char *fname)
}
}
@ -1499,7 +1455,7 @@ index 6568f8177e39..14d8237af366 100644
static void write_if_changed(struct buffer *b, const char *fname)
{
char *tmp;
@@ -2055,6 +2062,7 @@ static void write_mod_c_file(struct module *mod)
@@ -2057,6 +2064,7 @@ static void write_mod_c_file(struct module *mod)
add_depends(&buf, mod);
add_moddevtable(&buf, mod);
add_srcversion(&buf, mod);

View File

@ -1,5 +1,5 @@
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
SHA512 (linux-6.8.5.tar.xz) = f956b83e80183f46fc9dc85d8735d27c6c1cc9eef7f93d5b7dfe297acafdb33e83cdc184689c2a12afac87c1c495c217ffba843ccaded7f88b35637db3b2d434
SHA512 (kernel-abi-stablelists-6.8.5.tar.xz) = 3f4a1776809941118d796908ee93df1732550220f1498b579c80db64384bc81dea3c4a6b4ad3c8b15dc83caddb74c591ff335a7cc9e846274f4c314a3a733123
SHA512 (kernel-kabi-dw-6.8.5.tar.xz) = e38a0e3756b109a96dbe30e5956d2611420cbb0d7b46308cf78df0317ddd1163f92d8296bb79938a420740a3168eba967baa03b4e06a21eaa47830f3d7ec45ef
SHA512 (linux-6.8.6.tar.xz) = 853928d4a18138453b122bb4131c2eb260b504974c2958000fbd9932761dc0302631e2f26d5c01b9c4fdcd2a89c8887714cfe634b84cf8f7fca20f984ad944d2
SHA512 (kernel-abi-stablelists-6.8.6.tar.xz) = 5d67ad8ee96bf237d720ae4f4eaa9fa7452e81da693988c5c8e40675174814ada18948cf09790c73858a646c86c8756f8bde4cfee254370f634d381dc1c4147e
SHA512 (kernel-kabi-dw-6.8.6.tar.xz) = a12f7001bcbba4ee61d3f4779539a28728a3fe51361b21264a0625ad2e028ce6e1443cde4cd5c5402076c782e912b07c6d1fd56ea7a7cb8130c7d76e4cbd3d76