Refresh from git

This commit is contained in:
Josh Boyer 2015-05-19 08:58:55 -04:00
parent e6f28ee3c8
commit 2f08a803df
31 changed files with 65 additions and 68 deletions

View File

@ -9,10 +9,10 @@ Patch for disconnect issues with storage attached to a
1 file changed, 7 insertions(+)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index 95409aacc076..f33003e59ab3 100644
index 3b7151687776..4b19e7e5bc01 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5021,6 +5021,13 @@ static void hub_event(struct work_struct *work)
@@ -5006,6 +5006,13 @@ static void hub_event(struct work_struct *work)
(u16) hub->change_bits[0],
(u16) hub->event_bits[0]);

View File

@ -14,7 +14,7 @@ Signed-off-by: David Howells <dhowells@redhat.com>
1 file changed, 20 insertions(+)
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 16ec1c00919d..b7cb7dc5ebb4 100644
index c74cbd892032..1293d0e0bf90 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);

View File

@ -159,10 +159,10 @@ index 000000000000..424896a0b169
+ return 0;
+}
diff --git a/include/linux/efi.h b/include/linux/efi.h
index b7cb7dc5ebb4..fb972b96959a 100644
index 1293d0e0bf90..706b16fa6de8 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -923,6 +923,10 @@ extern bool efi_poweroff_required(void);
@@ -925,6 +925,10 @@ extern bool efi_poweroff_required(void);
char * __init efi_md_typeattr_format(char *buf, size_t size,
const efi_memory_desc_t *md);

View File

@ -16,10 +16,10 @@ Signed-off-by: Matthew Garrett <matthew.garrett@nebula.com>
2 files changed, 17 insertions(+)
diff --git a/include/linux/module.h b/include/linux/module.h
index b653d7c0a05a..d4b96d6c926a 100644
index b03485bcb82a..b033dab5c8bf 100644
--- a/include/linux/module.h
+++ b/include/linux/module.h
@@ -502,6 +502,8 @@ int unregister_module_notifier(struct notifier_block *nb);
@@ -506,6 +506,8 @@ int unregister_module_notifier(struct notifier_block *nb);
extern void print_modules(void);
@ -28,7 +28,7 @@ index b653d7c0a05a..d4b96d6c926a 100644
#else /* !CONFIG_MODULES... */
/* Given an address, look for it in the exception tables. */
@@ -612,6 +614,11 @@ static inline int unregister_module_notifier(struct notifier_block *nb)
@@ -616,6 +618,11 @@ static inline int unregister_module_notifier(struct notifier_block *nb)
static inline void print_modules(void)
{
}
@ -41,10 +41,10 @@ index b653d7c0a05a..d4b96d6c926a 100644
#ifdef CONFIG_SYSFS
diff --git a/kernel/module.c b/kernel/module.c
index d856e96a3cce..98c3d7955a51 100644
index ec53f594e9c9..0372c3961016 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -3895,3 +3895,13 @@ void module_layout(struct module *mod,
@@ -3908,3 +3908,13 @@ void module_layout(struct module *mod,
}
EXPORT_SYMBOL(module_layout);
#endif

View File

@ -29,10 +29,10 @@ index 72665eb80692..2c7b80d31366 100644
+
#endif /* _KEYS_SYSTEM_KEYRING_H */
diff --git a/init/Kconfig b/init/Kconfig
index 9afb971497f4..ea0dbdf29b75 100644
index f5dbc6d4261b..eca8ab59ae7f 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1742,6 +1742,15 @@ config SYSTEM_TRUSTED_KEYRING
@@ -1734,6 +1734,15 @@ config SYSTEM_TRUSTED_KEYRING
Keys in this keyring are used by module signature checking.

View File

@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index dc9f43a019d6..89b47324c032 100644
index 3d16bcc87585..8d2cb8495b41 100644
--- a/Makefile
+++ b/Makefile
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer

View File

@ -25,7 +25,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
create mode 100644 kernel/modsign_uefi.c
diff --git a/include/linux/efi.h b/include/linux/efi.h
index fb972b96959a..581878071c85 100644
index 706b16fa6de8..470e8dfcb517 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);
@ -42,10 +42,10 @@ index fb972b96959a..581878071c85 100644
efi_guid_t guid;
u64 table;
diff --git a/init/Kconfig b/init/Kconfig
index ea0dbdf29b75..dac9ed0f01f7 100644
index eca8ab59ae7f..9a782b02e4d5 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1896,6 +1896,15 @@ config MODULE_SIG_ALL
@@ -1888,6 +1888,15 @@ config MODULE_SIG_ALL
comment "Do not forget to sign required modules with scripts/sign-file"
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
@ -62,10 +62,10 @@ index ea0dbdf29b75..dac9ed0f01f7 100644
prompt "Which hash algorithm should modules be signed with?"
depends on MODULE_SIG
diff --git a/kernel/Makefile b/kernel/Makefile
index a59481a3fa6c..04b4ba9e0c9d 100644
index 1408b3353a3c..8a3be67a3a15 100644
--- a/kernel/Makefile
+++ b/kernel/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_UID16) += uid16.o
@@ -46,6 +46,7 @@ obj-$(CONFIG_UID16) += uid16.o
obj-$(CONFIG_SYSTEM_TRUSTED_KEYRING) += system_keyring.o system_certificates.o
obj-$(CONFIG_MODULES) += module.o
obj-$(CONFIG_MODULE_SIG) += module_signing.o
@ -73,7 +73,7 @@ index a59481a3fa6c..04b4ba9e0c9d 100644
obj-$(CONFIG_KALLSYMS) += kallsyms.o
obj-$(CONFIG_BSD_PROCESS_ACCT) += acct.o
obj-$(CONFIG_KEXEC) += kexec.o
@@ -98,6 +99,8 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
@@ -99,6 +100,8 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
$(obj)/configs.o: $(obj)/config_data.h

View File

@ -13,7 +13,7 @@ Signed-off-by: Matthew Garrett <matthew.garrett@nebula.com>
1 file changed, 6 insertions(+)
diff --git a/drivers/char/mem.c b/drivers/char/mem.c
index fc9637812d78..dde50e5bf527 100644
index efe38c1bc234..16b8af1188e1 100644
--- a/drivers/char/mem.c
+++ b/drivers/char/mem.c
@@ -167,6 +167,9 @@ static ssize_t write_mem(struct file *file, const char __user *buf,
@ -26,7 +26,7 @@ index fc9637812d78..dde50e5bf527 100644
if (!valid_phys_addr_range(p, count))
return -EFAULT;
@@ -505,6 +508,9 @@ static ssize_t write_kmem(struct file *file, const char __user *buf,
@@ -513,6 +516,9 @@ static ssize_t write_kmem(struct file *file, const char __user *buf,
char *kbuf; /* k-addr because vwrite() takes vmlist_lock rwlock */
int err = 0;

View File

@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
index 176d4fe4f076..bd374bd2490b 100644
index 4d68ec841304..77b2fb4125ef 100644
--- a/Documentation/kernel-parameters.txt
+++ b/Documentation/kernel-parameters.txt
@@ -3793,7 +3793,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
@@ -3824,7 +3824,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
the allocated input device; If set to 0, video driver
will only send out the event without touching backlight
brightness level.
@ -28,7 +28,7 @@ index 176d4fe4f076..bd374bd2490b 100644
virtio_mmio.device=
[VMMIO] Memory mapped virtio (platform) device.
diff --git a/drivers/acpi/video.c b/drivers/acpi/video.c
index 3647ce71154c..9dc8ba086596 100644
index 26eb70c8f518..db70d550f526 100644
--- a/drivers/acpi/video.c
+++ b/drivers/acpi/video.c
@@ -68,7 +68,7 @@ MODULE_AUTHOR("Bruno Ducrot");

View File

@ -26,7 +26,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
2 files changed, 17 insertions(+), 8 deletions(-)
diff --git a/drivers/acpi/video.c b/drivers/acpi/video.c
index 2f1f16df460c..16d744e4552f 100644
index 70ea37bea84f..d9bf8ba7d848 100644
--- a/drivers/acpi/video.c
+++ b/drivers/acpi/video.c
@@ -425,6 +425,12 @@ static int __init video_disable_native_backlight(const struct dmi_system_id *d)
@ -42,7 +42,7 @@ index 2f1f16df460c..16d744e4552f 100644
static struct dmi_system_id video_dmi_table[] __initdata = {
/*
* Broken _BQC workaround http://bugzilla.kernel.org/show_bug.cgi?id=13121
@@ -556,6 +562,17 @@ static struct dmi_system_id video_dmi_table[] __initdata = {
@@ -566,6 +572,17 @@ static struct dmi_system_id video_dmi_table[] __initdata = {
DMI_MATCH(DMI_PRODUCT_NAME, "XPS L521X"),
},
},

View File

@ -21,7 +21,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
1 file changed, 13 insertions(+), 6 deletions(-)
diff --git a/drivers/acpi/video.c b/drivers/acpi/video.c
index 497622ce5c31..2f1f16df460c 100644
index db70d550f526..70ea37bea84f 100644
--- a/drivers/acpi/video.c
+++ b/drivers/acpi/video.c
@@ -82,9 +82,15 @@ module_param(allow_duplicates, bool, 0644);

View File

@ -9,10 +9,10 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
1 file changed, 21 insertions(+)
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
index db880bf46135..c931ec7201c0 100644
index 9688dda39e7a..8e3e77f3121f 100644
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
@@ -102,6 +102,27 @@
@@ -109,6 +109,27 @@
>;
};

View File

@ -8,7 +8,7 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
1 file changed, 39 insertions(+)
diff --git a/arch/arm/boot/dts/am335x-bone-common.dtsi b/arch/arm/boot/dts/am335x-bone-common.dtsi
index 2c6248d9a9ef..ec755eeb78ee 100644
index c3255e0c90aa..1fd496fe1a68 100644
--- a/arch/arm/boot/dts/am335x-bone-common.dtsi
+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
@@ -81,6 +81,13 @@

View File

@ -9,7 +9,7 @@ Will debug upstream separately, but we need F22/21 running there. (#1139762)
1 file changed, 12 insertions(+), 9 deletions(-)
diff --git a/arch/arm/mach-highbank/highbank.c b/arch/arm/mach-highbank/highbank.c
index 07a09570175d..5db6d14fcd67 100644
index 231fba0d03e5..0de5a6ddd5eb 100644
--- a/arch/arm/mach-highbank/highbank.c
+++ b/arch/arm/mach-highbank/highbank.c
@@ -51,13 +51,11 @@ static void __init highbank_scu_map_io(void)

View File

@ -7,7 +7,7 @@ Subject: [PATCH] ath9k: rx dma stop check
1 file changed, 11 insertions(+), 1 deletion(-)
diff --git a/drivers/net/wireless/ath/ath9k/mac.c b/drivers/net/wireless/ath/ath9k/mac.c
index 3e58bfa0c1fd..406eea47256e 100644
index bba85d1a6cd1..ebbee8f17130 100644
--- a/drivers/net/wireless/ath/ath9k/mac.c
+++ b/drivers/net/wireless/ath/ath9k/mac.c
@@ -693,7 +693,7 @@ bool ath9k_hw_stopdmarecv(struct ath_hw *ah, bool *reset)

View File

@ -269,7 +269,7 @@ index 000000000000..fd4736ec99f5
+
+#endif /* _X86_CRASH_H */
diff --git a/drivers/char/Kconfig b/drivers/char/Kconfig
index efefd12a0f7b..6a318132b7ee 100644
index a4af8221751e..193f1a7c2ce5 100644
--- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig
@@ -4,6 +4,9 @@
@ -281,7 +281,7 @@ index efefd12a0f7b..6a318132b7ee 100644
+
source "drivers/tty/Kconfig"
config DEVKMEM
config DEVMEM
diff --git a/drivers/char/Makefile b/drivers/char/Makefile
index d06cde26031b..0832636fd9bc 100644
--- a/drivers/char/Makefile

View File

@ -9,10 +9,10 @@ Upstream-status: Fedora mustard
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/init/Kconfig b/init/Kconfig
index dac9ed0f01f7..31a29fe7c555 100644
index 9a782b02e4d5..d97b5032d4b0 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1128,7 +1128,7 @@ config DEBUG_BLK_CGROUP
@@ -1135,7 +1135,7 @@ config DEBUG_BLK_CGROUP
endif # CGROUPS
config CHECKPOINT_RESTORE
@ -21,7 +21,7 @@ index dac9ed0f01f7..31a29fe7c555 100644
default n
help
Enables additional kernel features in a sake of checkpoint/restore.
@@ -1139,7 +1139,7 @@ config CHECKPOINT_RESTORE
@@ -1146,7 +1146,7 @@ config CHECKPOINT_RESTORE
If unsure, say N here.
menuconfig NAMESPACES

View File

@ -14,10 +14,10 @@ Upstream-status: Fedora mustard
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/block/floppy.c b/drivers/block/floppy.c
index 56d46ffb08e1..1c8db250df88 100644
index a08cda955285..e320e1e679cf 100644
--- a/drivers/block/floppy.c
+++ b/drivers/block/floppy.c
@@ -4634,8 +4634,7 @@ static const struct pnp_device_id floppy_pnpids[] = {
@@ -4633,8 +4633,7 @@ static const struct pnp_device_id floppy_pnpids[] = {
{"PNP0700", 0},
{}
};

View File

@ -14,7 +14,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/i915_params.c b/drivers/gpu/drm/i915/i915_params.c
index db07153b693f..c049fe3fbdff 100644
index 44f2262a5553..09566acd995d 100644
--- a/drivers/gpu/drm/i915/i915_params.c
+++ b/drivers/gpu/drm/i915/i915_params.c
@@ -51,7 +51,7 @@ struct i915_params i915 __read_mostly = {
@ -23,9 +23,6 @@ index db07153b693f..c049fe3fbdff 100644
.mmio_debug = 0,
- .verbose_state_checks = 1,
+ .verbose_state_checks = 0,
.nuclear_pageflip = 0,
.nuclear_pageflip = 0,
};
--
2.1.0

View File

@ -12,10 +12,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
2 files changed, 3 insertions(+)
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 5d52d67d5097..b40d6174242f 100644
index a3d8174dedf9..26c5d54124c1 100644
--- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c
@@ -1154,7 +1154,9 @@ void __init setup_arch(char **cmdline_p)
@@ -1153,7 +1153,9 @@ void __init setup_arch(char **cmdline_p)
#ifdef CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE
if (boot_params.secure_boot) {
@ -26,10 +26,10 @@ index 5d52d67d5097..b40d6174242f 100644
#endif
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 0238d612750e..16ec1c00919d 100644
index cf7e431cbc73..c74cbd892032 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -940,6 +940,7 @@ extern int __init efi_setup_pcdp_console(char *);
@@ -942,6 +942,7 @@ extern int __init efi_setup_pcdp_console(char *);
#define EFI_64BIT 5 /* Is the firmware 64-bit? */
#define EFI_PARAVIRT 6 /* Access is via a paravirt interface */
#define EFI_ARCH_1 7 /* First arch-specific bit */

View File

@ -14,10 +14,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
1 file changed, 19 insertions(+), 1 deletion(-)
diff --git a/arch/x86/boot/compressed/eboot.c b/arch/x86/boot/compressed/eboot.c
index 2192da755e34..4b03911a502d 100644
index 105e7360d747..83fc4e9888ee 100644
--- a/arch/x86/boot/compressed/eboot.c
+++ b/arch/x86/boot/compressed/eboot.c
@@ -831,8 +831,9 @@ out:
@@ -830,8 +830,9 @@ out:
static int get_secure_boot(void)
{
@ -28,7 +28,7 @@ index 2192da755e34..4b03911a502d 100644
efi_guid_t var_guid = EFI_GLOBAL_VARIABLE_GUID;
efi_status_t status;
@@ -856,6 +857,23 @@ static int get_secure_boot(void)
@@ -855,6 +856,23 @@ static int get_secure_boot(void)
if (setup == 1)
return 0;

View File

@ -11,10 +11,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index 58273956750d..e17f88ceaeab 100644
index ab403a636357..5dac78119fa7 100644
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -1661,7 +1661,8 @@ config EFI_MIXED
@@ -1696,7 +1696,8 @@ config EFI_MIXED
If unsure, say N.
config EFI_SECURE_BOOT_SIG_ENFORCE

View File

@ -22,7 +22,7 @@ Signed-off-by: Lukas Czerner <lczerner@redhat.com>
1 file changed, 19 insertions(+), 12 deletions(-)
diff --git a/fs/ext4/extents.c b/fs/ext4/extents.c
index bed43081720f..aa522429b751 100644
index 16f6365f65e7..30dee3c0e864 100644
--- a/fs/ext4/extents.c
+++ b/fs/ext4/extents.c
@@ -4803,12 +4803,6 @@ static long ext4_zero_range(struct file *file, loff_t offset,

View File

@ -9,7 +9,7 @@ Upstream-status: Fedora mustard
1 file changed, 4 insertions(+)
diff --git a/drivers/input/keyboard/atkbd.c b/drivers/input/keyboard/atkbd.c
index e27a25892db4..9ab0a86cc03d 100644
index 387c51f4b4e4..04a1c7d47aba 100644
--- a/drivers/input/keyboard/atkbd.c
+++ b/drivers/input/keyboard/atkbd.c
@@ -436,11 +436,15 @@ static irqreturn_t atkbd_interrupt(struct serio *serio, unsigned char data,

View File

@ -90,10 +90,10 @@ index 2a8ddfd12a5b..452ca53561fe 100644
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
index 5a4affe025e8..8ff38ce94c8e 100644
index 7b9be9822724..c4c5d4ae3dad 100644
--- a/arch/x86/vdso/Makefile
+++ b/arch/x86/vdso/Makefile
@@ -171,8 +171,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \
@@ -172,8 +172,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \
quiet_cmd_vdso = VDSO $@
cmd_vdso = $(CC) -nostdlib -o $@ \
$(VDSO_LDFLAGS) $(VDSO_LDFLAGS_$(filter %.lds,$(^F))) \

View File

@ -13,7 +13,7 @@ Signed-off-by: Matthew Garrett <matthew.garrett@nebula.com>
1 file changed, 8 insertions(+)
diff --git a/kernel/kexec.c b/kernel/kexec.c
index 9a8a01abbaed..9a0ecbf14545 100644
index 38c25b1f2fd5..f2b5272156ce 100644
--- a/kernel/kexec.c
+++ b/kernel/kexec.c
@@ -36,6 +36,7 @@
@ -24,7 +24,7 @@ index 9a8a01abbaed..9a0ecbf14545 100644
#include <asm/page.h>
#include <asm/uaccess.h>
@@ -1251,6 +1252,13 @@ SYSCALL_DEFINE4(kexec_load, unsigned long, entry, unsigned long, nr_segments,
@@ -1247,6 +1248,13 @@ SYSCALL_DEFINE4(kexec_load, unsigned long, entry, unsigned long, nr_segments,
return -EPERM;
/*

View File

@ -19,10 +19,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/lib/Kconfig b/lib/Kconfig
index 54cf309a92a5..64f8bb4882fb 100644
index 87da53bb1fef..c767ba0cbab7 100644
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -382,7 +382,8 @@ config CHECK_SIGNATURE
@@ -391,7 +391,8 @@ config CHECK_SIGNATURE
bool
config CPUMASK_OFFSTACK

View File

@ -22,10 +22,10 @@ Signed-off-by: Tejun Heo <tj@kernel.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
index 00f2f740b425..eabee5ec901f 100644
index 23dac3babfe3..8cfe5eeac1e6 100644
--- a/drivers/ata/libata-core.c
+++ b/drivers/ata/libata-core.c
@@ -4243,7 +4243,7 @@ static const struct ata_blacklist_entry ata_device_blacklist [] = {
@@ -4214,7 +4214,7 @@ static const struct ata_blacklist_entry ata_device_blacklist [] = {
ATA_HORKAGE_ZERO_AFTER_TRIM, },
{ "Crucial_CT*MX100*", "MU01", ATA_HORKAGE_NO_NCQ_TRIM |
ATA_HORKAGE_ZERO_AFTER_TRIM, },

View File

@ -9,7 +9,7 @@ Upstream-status: Fedora mustard (might be worth dropping...)
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index ad35ccdb92a2..661efea89ded 100644
index 3290a3ed5b31..3c682f62925c 100644
--- a/drivers/scsi/sd.c
+++ b/drivers/scsi/sd.c
@@ -2750,13 +2750,18 @@ static int sd_try_extended_inquiry(struct scsi_device *sdp)

View File

@ -9,10 +9,10 @@ Upstream-status: Fedora mustard
1 file changed, 17 insertions(+), 7 deletions(-)
diff --git a/drivers/video/console/fbcon.c b/drivers/video/console/fbcon.c
index ea437245562e..eefa9c45d2e1 100644
index b97210671a81..2d12ad82fe75 100644
--- a/drivers/video/console/fbcon.c
+++ b/drivers/video/console/fbcon.c
@@ -637,13 +637,15 @@ static void fbcon_prepare_logo(struct vc_data *vc, struct fb_info *info,
@@ -634,13 +634,15 @@ static void fbcon_prepare_logo(struct vc_data *vc, struct fb_info *info,
kfree(save);
}
@ -35,7 +35,7 @@ index ea437245562e..eefa9c45d2e1 100644
}
}
#endif /* MODULE */
@@ -3624,6 +3626,14 @@ static int __init fb_console_init(void)
@@ -3620,6 +3622,14 @@ static int __init fb_console_init(void)
return 0;
}

View File

@ -20,7 +20,7 @@ Signed-off-by: Dave Jones <davej@redhat.com>
1 file changed, 29 insertions(+)
diff --git a/kernel/watchdog.c b/kernel/watchdog.c
index 70bf11815f84..4eeb9923472b 100644
index 3174bf8e3538..d0a8abec3df9 100644
--- a/kernel/watchdog.c
+++ b/kernel/watchdog.c
@@ -19,6 +19,7 @@