kernel-5.19.10-300

* Tue Sep 20 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.19.10-0]
- kbuild: Add skip_encoding_btf_enum64 option to pahole (Martin Rodriguez Reboredo)
- Linux v5.19.10
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-09-20 09:45:04 -05:00
parent 4a4272735f
commit 2eb6e74f23
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 29 additions and 53 deletions

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/9d5fb7eaaa7db6a9952531d029dc9c3fb16a8eee
9d5fb7eaaa7db6a9952531d029dc9c3fb16a8eee kbuild: Add skip_encoding_btf_enum64 option to pahole
"https://gitlab.com/cki-project/kernel-ark/-/commit"/81d89458f7f2d872c7de7181acb857fe041ee953
81d89458f7f2d872c7de7181acb857fe041ee953 [PATCH] drm/i915: Ensure damage clip area is within pipe area

View File

@ -122,17 +122,17 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specversion 5.19.9
%define specversion 5.19.10
%define patchversion 5.19
%define pkgrelease 300
%define kversion 5
%define tarfile_release 5.19.9
%define tarfile_release 5.19.10
# This is needed to do merge window version magic
%define patchlevel 19
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 5.19.9
%define kabiversion 5.19.10
#
# End of genspec.sh variables
@ -3138,6 +3138,10 @@ fi
#
#
%changelog
* Tue Sep 20 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.19.10-0]
- kbuild: Add skip_encoding_btf_enum64 option to pahole (Martin Rodriguez Reboredo)
- Linux v5.19.10
* Thu Sep 15 2022 Justin M. Forbes <jforbes@fedoraproject.org> [5.19.9-0]
- Add CONFIG_ARM64_ERRATUM_2457168 as new stable config option (Justin M. Forbes)
- fedora: disable IWLMEI (Peter Robinson)

View File

@ -56,12 +56,13 @@
init/Kconfig | 2 +-
kernel/module/signing.c | 9 +-
net/bluetooth/hci_event.c | 20 +
scripts/pahole-flags.sh | 4 +
scripts/tags.sh | 2 +
security/integrity/platform_certs/load_uefi.c | 6 +-
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
63 files changed, 1777 insertions(+), 349 deletions(-)
64 files changed, 1781 insertions(+), 349 deletions(-)
diff --git a/Documentation/devicetree/bindings/gpu/brcm,bcm-v3d.yaml b/Documentation/devicetree/bindings/gpu/brcm,bcm-v3d.yaml
index e6485f7b046f..217c42874f41 100644
@ -253,7 +254,7 @@ index 000000000000..733a26bd887a
+
+endmenu
diff --git a/Makefile b/Makefile
index 1f27c4bd09e6..ec5fbc9dc8ae 100644
index 33a9b6b547c4..f16045bf3888 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -3305,6 +3306,19 @@ index 2c320a8fe70d..e097bf4ce549 100644
if (i == ARRAY_SIZE(hci_cc_table)) {
/* Unknown opcode, assume byte 0 contains the status, so
diff --git a/scripts/pahole-flags.sh b/scripts/pahole-flags.sh
index 0d99ef17e4a5..d4f3d63cb434 100755
--- a/scripts/pahole-flags.sh
+++ b/scripts/pahole-flags.sh
@@ -20,4 +20,8 @@ if [ "${pahole_ver}" -ge "122" ]; then
extra_paholeopt="${extra_paholeopt} -j"
fi
+if [ "${pahole_ver}" -ge "124" ]; then
+ extra_paholeopt="${extra_paholeopt} --skip_encoding_btf_enum64"
+fi
+
echo ${extra_paholeopt}
diff --git a/scripts/tags.sh b/scripts/tags.sh
index 01fab3d4f90b..2ae5dfc904f9 100755
--- a/scripts/tags.sh
@ -3395,48 +3409,3 @@ index 8b62654ff3f9..1c03d1cff35c 100644
#ifdef CONFIG_PERF_EVENTS
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
From 9d5fb7eaaa7db6a9952531d029dc9c3fb16a8eee Mon Sep 17 00:00:00 2001
From: Martin Rodriguez Reboredo <yakoyoku@gmail.com>
Date: Tue, 6 Sep 2022 15:31:23 +0200
Subject: [PATCH] kbuild: Add skip_encoding_btf_enum64 option to pahole
New pahole (version 1.24) generates by default new BTF_KIND_ENUM64 BTF tag,
which is not supported by stable kernel.
As a result the kernel with CONFIG_DEBUG_INFO_BTF option will fail to
compile with following error:
BTFIDS vmlinux
FAILED: load BTF from vmlinux: Invalid argument
New pahole provides --skip_encoding_btf_enum64 option to skip BTF_KIND_ENUM64
generation and produce BTF supported by stable kernel.
Adding this option to scripts/pahole-flags.sh.
This change does not have equivalent commit in linus tree, because linus tree
has support for BTF_KIND_ENUM64 tag, so it does not need to be disabled.
Signed-off-by: Martin Rodriguez Reboredo <yakoyoku@gmail.com>
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
scripts/pahole-flags.sh | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/scripts/pahole-flags.sh b/scripts/pahole-flags.sh
index 0d99ef17e4a5..d4f3d63cb434 100755
--- a/scripts/pahole-flags.sh
+++ b/scripts/pahole-flags.sh
@@ -20,4 +20,8 @@ if [ "${pahole_ver}" -ge "122" ]; then
extra_paholeopt="${extra_paholeopt} -j"
fi
+if [ "${pahole_ver}" -ge "124" ]; then
+ extra_paholeopt="${extra_paholeopt} --skip_encoding_btf_enum64"
+fi
+
echo ${extra_paholeopt}
--
2.37.3

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.19.9.tar.xz) = 0a02363a7c195b6b696e4fb904f4070adbb4377029f94d20e58703a7b8fef6a903a28dbec8225ec0950ce8ebc0b51c38de6817c6ff291678ac8e19ef1a061577
SHA512 (kernel-abi-stablelists-5.19.9.tar.bz2) = e3842e44ef9dbfbf11f175484ff86f30c0820ef3fdc3877ec8740db391599461ebf0ef83a2a68e06f9e5815ed3821ad7a04edbc882d0c1558d633e488cc444c6
SHA512 (kernel-kabi-dw-5.19.9.tar.bz2) = b1c5479776478d559868efc8307981a8863d01e013e241fd4f54f4f389b45e803acd5a78da29bfbf93b51ad4937065c6eae0fdfb01c09289cbe400dd4cfa30e1
SHA512 (linux-5.19.10.tar.xz) = 13979541c993284eaf1db132a238bae26d2f6adb30fd42382f49e028e662dce57e784784a7af00cd46acc8ec1f4d9612ea542e43ebfcd8bd20267ba7800ac5b5
SHA512 (kernel-abi-stablelists-5.19.10.tar.bz2) = fc97ba591f75079dc0cfebaf46c6f000a6d7c22adf2972747626e4e7da5e95df91017b97d06fcbb08c5c9d21b3bba0cb314aa67e40a66821b2bfada59b5208e6
SHA512 (kernel-kabi-dw-5.19.10.tar.bz2) = 132bbbd4460005544a5e357895d9b6eaa50c98646dba4253feb05881dfd9f66dcf533b25b5264c7bdd3bb5d920f539a4b9180564eb3579665ab38caf88d99fb2