kernel-6.4.0-0.rc5.41

* Mon Jun 05 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.4.0-0.rc5.41]
- Add rv subpackage for kernel-tools (John Kacur) [2188441]
- redhat/configs: NXP i.MX9 family (Steve Best)
- Linux v6.4.0-0.rc5
Resolves: rhbz#2188441

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-06-05 09:31:57 -05:00
parent ea14cdfdbd
commit 2e423c0eef
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
6 changed files with 55 additions and 16 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 38
RHEL_RELEASE = 41
#
# RHEL_REBASE_NUM

View File

@ -6337,7 +6337,7 @@ CONFIG_SND_VX222=m
# CONFIG_SNET_VDPA is not set
# CONFIG_SOC_BRCMSTB is not set
CONFIG_SOC_IMX8M=y
# CONFIG_SOC_IMX9 is not set
CONFIG_SOC_IMX9=m
# CONFIG_SOCIONEXT_SYNQUACER_PREITS is not set
CONFIG_SOC_TEGRA_CBB=m
# CONFIG_SOC_TI is not set

View File

@ -6312,7 +6312,7 @@ CONFIG_SND_VX222=m
# CONFIG_SNET_VDPA is not set
# CONFIG_SOC_BRCMSTB is not set
CONFIG_SOC_IMX8M=y
# CONFIG_SOC_IMX9 is not set
CONFIG_SOC_IMX9=m
# CONFIG_SOCIONEXT_SYNQUACER_PREITS is not set
CONFIG_SOC_TEGRA_CBB=m
# CONFIG_SOC_TI is not set

View File

@ -148,13 +148,13 @@ Summary: The Linux kernel
%define specrpmversion 6.4.0
%define specversion 6.4.0
%define patchversion 6.4
%define pkgrelease 0.rc4.20230601git929ed21dfdb6.38
%define pkgrelease 0.rc5.41
%define kversion 6
%define tarfile_release 6.4-rc4-78-g929ed21dfdb6
%define tarfile_release 6.4-rc5
# This is needed to do merge window version magic
%define patchlevel 4
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc4.20230601git929ed21dfdb6.38%{?buildid}%{?dist}
%define specrelease 0.rc5.41%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.4.0
@ -1121,6 +1121,17 @@ testing Linux as a black box, rtla leverages kernel tracing
capabilities to provide precise information about the properties
and root causes of unexpected results.
%package -n rv
Summary: RV: Runtime Verification
License: GPLv2
%description -n rv
Runtime Verification (RV) is a lightweight (yet rigorous) method that
complements classical exhaustive verification techniques (such as model
checking and theorem proving) with a more practical approach for
complex systems.
The rv tool is the interface for a collection of monitors that aim
analysing the logical and timing behavior of Linux.
# with_tools
%endif
@ -2513,6 +2524,9 @@ popd
pushd tools/mm/
%{tools_make} slabinfo page_owner_sort
popd
pushd tools/verification/rv/
%{tools_make}
popd
pushd tools/tracing/rtla
%{tools_make}
popd
@ -2799,6 +2813,9 @@ pushd tools/mm/
install -m755 slabinfo %{buildroot}%{_bindir}/slabinfo
install -m755 page_owner_sort %{buildroot}%{_bindir}/page_owner_sort
popd
pushd tools/verification/rv/
%{tools_make} DESTDIR=%{buildroot} install
popd
pushd tools/tracing/rtla/
%{tools_make} DESTDIR=%{buildroot} install
rm -f %{buildroot}%{_bindir}/hwnoise
@ -3258,6 +3275,14 @@ fi
%{_mandir}/man1/rtla-timerlat.1.gz
%{_mandir}/man1/rtla.1.gz
%files -n rv
%{_bindir}/rv
%{_mandir}/man1/rv-list.1.gz
%{_mandir}/man1/rv-mon-wip.1.gz
%{_mandir}/man1/rv-mon-wwnr.1.gz
%{_mandir}/man1/rv-mon.1.gz
%{_mandir}/man1/rv.1.gz
# with_tools
%endif
@ -3415,6 +3440,20 @@ fi
#
#
%changelog
* Mon Jun 05 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.4.0-0.rc5.41]
- Add rv subpackage for kernel-tools (John Kacur) [2188441]
- redhat/configs: NXP i.MX9 family (Steve Best)
- Linux v6.4.0-0.rc5
* Sun Jun 04 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.4.0-0.rc4.e5282a7d8f6b.40]
- Linux v6.4.0-0.rc4.e5282a7d8f6b
* Sat Jun 03 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.4.0-0.rc4.9e87b63ed37e.39]
- redhat/genlog.py: add support to list/process zstream Jira tickets (Herton R. Krzesinski)
- redhat: fix duplicate jira issues in the resolves line (Herton R. Krzesinski)
- redhat: add support for Jira issues in changelog (Herton R. Krzesinski)
- Linux v6.4.0-0.rc4.9e87b63ed37e
* Thu Jun 01 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.4.0-0.rc4.929ed21dfdb6.38]
- redhat/configs: turn on IMX8ULP CCM Clock Driver (Steve Best)
- redhat: update filter-modules fsdrvs list to reference smb instead of cifs (Patrick Talbert)

View File

@ -117,7 +117,7 @@ index 000000000000..effb81d04bfd
+
+endmenu
diff --git a/Makefile b/Makefile
index 836643eaefee..91f34cafca40 100644
index 09866a85bc2a..f2a166968dbe 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1218,7 +1218,7 @@ index ee4da9ab8013..d395d11eadc4 100644
if (ret < 0)
goto err_allowedips;
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index 1f0cbb77b249..0a80d662466c 100644
index 3ec38e2b9173..58c733c6dc6a 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -251,6 +251,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
@ -1274,7 +1274,7 @@ index 1f0cbb77b249..0a80d662466c 100644
void nvme_complete_rq(struct request *req)
{
struct nvme_ctrl *ctrl = nvme_req(req)->ctrl;
@@ -410,6 +423,9 @@ void nvme_complete_rq(struct request *req)
@@ -419,6 +432,9 @@ void nvme_complete_rq(struct request *req)
case FAILOVER:
nvme_failover_req(req);
return;
@ -1332,10 +1332,10 @@ index 2bc159a318ff..d5562a97f232 100644
if (!ctrl->max_namespaces ||
diff --git a/drivers/nvme/host/nvme.h b/drivers/nvme/host/nvme.h
index a2d4f59e0535..1c5092b995e9 100644
index 8657811f8b88..feee7e1e6c8d 100644
--- a/drivers/nvme/host/nvme.h
+++ b/drivers/nvme/host/nvme.h
@@ -878,6 +878,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
@@ -879,6 +879,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_start_freeze(struct nvme_subsystem *subsys);
void nvme_mpath_default_iopolicy(struct nvme_subsystem *subsys);
void nvme_failover_req(struct request *req);
@ -1343,7 +1343,7 @@ index a2d4f59e0535..1c5092b995e9 100644
void nvme_kick_requeue_lists(struct nvme_ctrl *ctrl);
int nvme_mpath_alloc_disk(struct nvme_ctrl *ctrl,struct nvme_ns_head *head);
void nvme_mpath_add_disk(struct nvme_ns *ns, __le32 anagrpid);
@@ -916,6 +917,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
@@ -917,6 +918,9 @@ static inline bool nvme_ctrl_use_ana(struct nvme_ctrl *ctrl)
static inline void nvme_failover_req(struct request *req)
{
}
@ -1771,7 +1771,7 @@ index eae288c8d40a..8b8bf447cedc 100644
error_proc:
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 7aa62c92185f..2da17f5aeef9 100644
index 571d1a6e1b74..8f786e38de3f 100644
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@ -43,6 +43,8 @@

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.4-rc4-78-g929ed21dfdb6.tar.xz) = 85372ac5ccdf8bf51018f2ef53ddcd373b87a6f35f46783f9eada291ba698c6534025d2157db7e4fda0bc1372e3e28ac63e91b5096708d0744d23d6826e9b515
SHA512 (kernel-abi-stablelists-6.4.0.tar.bz2) = 219c72bfb64ab1e74560ebb68fa67a5c2d0f1933ef8ee33778314bc9792e8f6cd14be3f1987190cb463e3e3a20e75abd44f79714c3f82f5bc6ff841800c5cec7
SHA512 (kernel-kabi-dw-6.4.0.tar.bz2) = a10dfdf5f197713de2b177b749bd45b36c8bafd37540a4c93da90684ff508f6bdf5728159c8ed8aa5273f87b0fc3ffd99d91f60c0927ee702edc684a1e64bd88
SHA512 (linux-6.4-rc5.tar.xz) = 93cfd4f7244864cd5a1ab13231f1dbc35682b7743f860be4da6b8f1cedd03e5c78d6fa089521c5ee1df15aa0c5ba348067a46fa7040662bff237e7deb2600d9f
SHA512 (kernel-abi-stablelists-6.4.0.tar.bz2) = f0e98b00912bf9be985684f0612e8069363cb1d3fc54fdc272b901611d2288203a06ec6ceb1df6ef0491acccb0a2dacdeeb5a5f9ab2ae610c57cd33430037fcf
SHA512 (kernel-kabi-dw-6.4.0.tar.bz2) = 0036f1a55eed3fe203a663592b12edf4b9eebd610c2cf0ee778ab6d75500a0711452a0476fd02df80eccd72118bb3fe76b3334bf7387d043e238a4bd7f4f8530