Create a blacklist for pci=nocrs
Add Dell Studio 1536 to it.
This commit is contained in:
parent
4ca5087fa3
commit
2da15d9521
10
kernel.spec
10
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -826,6 +826,8 @@ Patch21220: mac80211_offchannel_rework_revert.patch
|
||||
|
||||
Patch21225: pci-Rework-ASPM-disable-code.patch
|
||||
|
||||
Patch21226: pci-crs-blacklist.patch
|
||||
|
||||
#rhbz #757839
|
||||
Patch21230: net-sky2-88e8059-fix-link-speed.patch
|
||||
|
||||
@ -1553,6 +1555,8 @@ ApplyPatch mac80211_offchannel_rework_revert.patch
|
||||
|
||||
ApplyPatch pci-Rework-ASPM-disable-code.patch
|
||||
|
||||
ApplyPatch pci-crs-blacklist.patch
|
||||
|
||||
#rhbz #757839
|
||||
ApplyPatch net-sky2-88e8059-fix-link-speed.patch
|
||||
|
||||
@ -2348,6 +2352,10 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Thu Dec 29 2011 Dave Jones <davej@redhat.com> 3.1.6-2
|
||||
- Create a blacklist for pci=nocrs
|
||||
Add Dell Studio 1536 to it.
|
||||
|
||||
* Fri Dec 23 2011 Dennis Gilmore <dennis@ausil.us>
|
||||
- build imx highbank and kirkwood kernels for arm
|
||||
|
||||
|
36
pci-crs-blacklist.patch
Normal file
36
pci-crs-blacklist.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff --git a/arch/x86/pci/acpi.c b/arch/x86/pci/acpi.c
|
||||
index 404f21a..2704a9c 100644
|
||||
--- a/arch/x86/pci/acpi.c
|
||||
+++ b/arch/x86/pci/acpi.c
|
||||
@@ -24,6 +24,12 @@ static int __init set_use_crs(const struct dmi_system_id *id)
|
||||
return 0;
|
||||
}
|
||||
|
||||
+static int __init set_nouse_crs(const struct dmi_system_id *id)
|
||||
+{
|
||||
+ pci_use_crs = false;
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
static const struct dmi_system_id pci_use_crs_table[] __initconst = {
|
||||
/* http://bugzilla.kernel.org/show_bug.cgi?id=14183 */
|
||||
{
|
||||
@@ -54,6 +60,18 @@ static const struct dmi_system_id pci_use_crs_table[] __initconst = {
|
||||
DMI_MATCH(DMI_BIOS_VENDOR, "American Megatrends Inc."),
|
||||
},
|
||||
},
|
||||
+
|
||||
+ /* Now for the blacklist.. */
|
||||
+
|
||||
+ /* https://bugzilla.redhat.com/show_bug.cgi?id=770308 */
|
||||
+ {
|
||||
+ .callback = set_nouse_crs,
|
||||
+ .ident = "Dell Studio 1536",
|
||||
+ .matches = {
|
||||
+ DMI_MATCH(DMI_BOARD_VENDOR, "Dell Inc."),
|
||||
+ DMI_MATCH(DMI_BOARD_NAME, "0M273C"),
|
||||
+ },
|
||||
+ },
|
||||
{}
|
||||
};
|
||||
|
Loading…
Reference in New Issue
Block a user