Linux 2.6.36-rc3-git4
Drop revert-drm-i915-enable-rc6-on-ironlake.patch, now merged
This commit is contained in:
parent
78100db1fe
commit
2c454f2cf7
2
.gitignore
vendored
2
.gitignore
vendored
@ -3,5 +3,3 @@ patch-*.bz2
|
||||
clog
|
||||
*.rpm
|
||||
kernel-2.6.*/
|
||||
/patch-2.6.36-rc3.bz2
|
||||
/patch-2.6.36-rc3-git1.bz2
|
||||
|
10
kernel.spec
10
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 19
|
||||
%global baserelease 20
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 4
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 2.6.%{upstream_sublevel}
|
||||
%endif
|
||||
@ -659,7 +659,6 @@ Patch1824: drm-intel-next.patch
|
||||
# make sure the lvds comes back on lid open
|
||||
Patch1825: drm-intel-make-lvds-work.patch
|
||||
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
||||
Patch1901: revert-drm-i915-enable-rc6-on-ironlake.patch
|
||||
|
||||
# linux1394 git patches
|
||||
Patch2200: linux-2.6-firewire-git-update.patch
|
||||
@ -1243,7 +1242,6 @@ ApplyPatch drm-intel-big-hammer.patch
|
||||
ApplyOptionalPatch drm-intel-next.patch
|
||||
ApplyPatch drm-intel-make-lvds-work.patch
|
||||
ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
||||
ApplyPatch revert-drm-i915-enable-rc6-on-ironlake.patch
|
||||
|
||||
# linux1394 git patches
|
||||
#ApplyPatch linux-2.6-firewire-git-update.patch
|
||||
@ -1884,6 +1882,10 @@ fi
|
||||
# || ||
|
||||
|
||||
%changelog
|
||||
* Sat Sep 11 2010 Chuck Ebbert <cebbert@redhat.com> - 2.6.36-0.20.rc3.git4
|
||||
- Linux 2.6.36-rc3-git4
|
||||
- Drop revert-drm-i915-enable-rc6-on-ironlake.patch, now merged
|
||||
|
||||
* Fri Sep 10 2010 Bastien Nocera <bnocera@redhat.com> - 2.6.36-0.19.rc3.git1
|
||||
- Update AppleIR patch to work, and support the enter key on
|
||||
newer remotes
|
||||
|
@ -1,41 +0,0 @@
|
||||
From c21a31aebb5d8f0b3ad050a8f3190b6de8210845 Mon Sep 17 00:00:00 2001
|
||||
From: Kyle McMartin <kyle@dreadnought.i.jkkm.org>
|
||||
Date: Tue, 7 Sep 2010 09:45:00 -0400
|
||||
Subject: Revert "drm/i915: Enable RC6 on Ironlake."
|
||||
|
||||
This reverts commit ce17178094f368d9e3f39b2cb4303da5ed633dd4.
|
||||
---
|
||||
drivers/gpu/drm/i915/intel_display.c | 9 +++------
|
||||
1 files changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
|
||||
index 11a3394..36952e9 100644
|
||||
--- a/drivers/gpu/drm/i915/intel_display.c
|
||||
+++ b/drivers/gpu/drm/i915/intel_display.c
|
||||
@@ -5722,8 +5722,7 @@ void intel_init_clock_gating(struct drm_device *dev)
|
||||
ILK_DPFC_DIS2 |
|
||||
ILK_CLK_FBC);
|
||||
}
|
||||
- if (IS_GEN6(dev))
|
||||
- return;
|
||||
+ return;
|
||||
} else if (IS_G4X(dev)) {
|
||||
uint32_t dspclk_gate;
|
||||
I915_WRITE(RENCLK_GATE_D1, 0);
|
||||
@@ -5784,11 +5783,9 @@ void intel_init_clock_gating(struct drm_device *dev)
|
||||
OUT_RING(MI_FLUSH);
|
||||
ADVANCE_LP_RING();
|
||||
}
|
||||
- } else {
|
||||
+ } else
|
||||
DRM_DEBUG_KMS("Failed to allocate render context."
|
||||
- "Disable RC6\n");
|
||||
- return;
|
||||
- }
|
||||
+ "Disable RC6\n");
|
||||
}
|
||||
|
||||
if (I915_HAS_RC6(dev) && drm_core_check_feature(dev, DRIVER_MODESET)) {
|
||||
--
|
||||
1.7.2.2
|
||||
|
Loading…
Reference in New Issue
Block a user