kernel-6.3.8-200

* Wed Jun 14 2023 Augusto Caringi <acaringi@redhat.com> [6.3.8-0]
- usb: typec: ucsi: Fix command cancellation (Heikki Krogerus)
- Add a CVE to BugsFixed (Justin M. Forbes)
- Linux v6.3.8
Resolves:

Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
Augusto Caringi 2023-06-14 22:13:55 -03:00
parent 47dd826d4a
commit 2c1648da11
6 changed files with 47 additions and 14 deletions

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/c707ce93be6a6f4524cf88e3f18e0437d7bd2b14
c707ce93be6a6f4524cf88e3f18e0437d7bd2b14 usb: typec: ucsi: Fix command cancellation
"https://gitlab.com/cki-project/kernel-ark/-/commit"/ac99dd89b9e59639ebec28116dd57302b0148c16
ac99dd89b9e59639ebec28116dd57302b0148c16 drivers/firmware: skip simpledrm if nvidia-drm.modeset=1 is set

View File

@ -1029,7 +1029,6 @@ CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE=y
CONFIG_CDROM_PKTCDVD_BUFFERS=8
CONFIG_CDROM_PKTCDVD=m
# CONFIG_CDROM_PKTCDVD_WCACHE is not set
CONFIG_CDX_CONTROLLER=m
CONFIG_CEC_CH7322=m
CONFIG_CEC_CROS_EC=m
CONFIG_CEC_GPIO=m

View File

@ -1029,7 +1029,6 @@ CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE=y
CONFIG_CDROM_PKTCDVD_BUFFERS=8
CONFIG_CDROM_PKTCDVD=m
# CONFIG_CDROM_PKTCDVD_WCACHE is not set
CONFIG_CDX_CONTROLLER=m
CONFIG_CEC_CH7322=m
CONFIG_CEC_CROS_EC=m
CONFIG_CEC_GPIO=m

View File

@ -142,18 +142,18 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specrpmversion 6.3.7
%define specversion 6.3.7
%define specrpmversion 6.3.8
%define specversion 6.3.8
%define patchversion 6.3
%define pkgrelease 200
%define kversion 6
%define tarfile_release 6.3.7
%define tarfile_release 6.3.8
# This is needed to do merge window version magic
%define patchlevel 3
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 200%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.3.7
%define kabiversion 6.3.8
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3406,8 +3406,10 @@ fi
#
#
%changelog
* Fri Jun 09 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.7-200]
* Wed Jun 14 2023 Augusto Caringi <acaringi@redhat.com> [6.3.8-0]
- usb: typec: ucsi: Fix command cancellation (Heikki Krogerus)
- Add a CVE to BugsFixed (Justin M. Forbes)
- Linux v6.3.8
* Fri Jun 09 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.7-0]
- redhat/configs: Enable CONFIG_SC_GPUCC_8280XP for fedora (Andrew Halaney)

View File

@ -24,6 +24,7 @@
drivers/nvme/host/nvme.h | 4 +
drivers/pci/quirks.c | 24 ++++
drivers/usb/core/hub.c | 7 ++
drivers/usb/typec/ucsi/ucsi.c | 11 +-
include/linux/efi.h | 22 ++--
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
@ -36,10 +37,10 @@
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
sound/pci/hda/patch_realtek.c | 2 +
38 files changed, 509 insertions(+), 187 deletions(-)
39 files changed, 516 insertions(+), 191 deletions(-)
diff --git a/Makefile b/Makefile
index 71c958fd5285..b4dd1352e20d 100644
index b4267d7a57b3..94fab2bcc83d 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -1167,6 +1168,35 @@ index 97a0f8faea6e..d837548d2024 100644
/* Lock the device, then check to see if we were
* disconnected while waiting for the lock to succeed. */
usb_lock_device(hdev);
diff --git a/drivers/usb/typec/ucsi/ucsi.c b/drivers/usb/typec/ucsi/ucsi.c
index 8d1baf28df55..8ada8e969f79 100644
--- a/drivers/usb/typec/ucsi/ucsi.c
+++ b/drivers/usb/typec/ucsi/ucsi.c
@@ -132,10 +132,8 @@ static int ucsi_exec_command(struct ucsi *ucsi, u64 cmd)
if (ret)
return ret;
- if (cci & UCSI_CCI_BUSY) {
- ucsi->ops->async_write(ucsi, UCSI_CANCEL, NULL, 0);
- return -EBUSY;
- }
+ if (cmd != UCSI_CANCEL && cci & UCSI_CCI_BUSY)
+ return ucsi_exec_command(ucsi, UCSI_CANCEL);
if (!(cci & UCSI_CCI_COMMAND_COMPLETE))
return -EIO;
@@ -149,6 +147,11 @@ static int ucsi_exec_command(struct ucsi *ucsi, u64 cmd)
return ucsi_read_error(ucsi);
}
+ if (cmd == UCSI_CANCEL && cci & UCSI_CCI_CANCEL_COMPLETE) {
+ ret = ucsi_acknowledge_command(ucsi);
+ return ret ? ret : -EBUSY;
+ }
+
return UCSI_CCI_LENGTH(cci);
}
diff --git a/include/linux/efi.h b/include/linux/efi.h
index 7aa62c92185f..2da17f5aeef9 100644
--- a/include/linux/efi.h
@ -1414,10 +1444,10 @@ index cf6cc576736f..3653a4f35265 100644
int security_perf_event_open(struct perf_event_attr *attr, int type)
{
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 7b5f194513c7..9adf2930ff39 100644
index 48a0e87136f1..973fe458d1be 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -9726,6 +9726,8 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
@@ -9733,6 +9733,8 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
SND_PCI_QUIRK(0x17aa, 0x2318, "Thinkpad Z13 Gen2", ALC287_FIXUP_CS35L41_I2C_2),
SND_PCI_QUIRK(0x17aa, 0x2319, "Thinkpad Z16 Gen2", ALC287_FIXUP_CS35L41_I2C_2),
SND_PCI_QUIRK(0x17aa, 0x231a, "Thinkpad Z16 Gen2", ALC287_FIXUP_CS35L41_I2C_2),

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.3.7.tar.xz) = d15bf3447c9a43a9b87d4c19a8fdb9b8afaec196bb50901da9f171c1c4e6e817fc64489134728e5c139f31c69e06ed0f78a01755392be27c6d71378fca7a9401
SHA512 (kernel-abi-stablelists-6.3.7.tar.bz2) = d9d356c803d11108d58745af8b421f284c8c5cebb37b859e528d24d5c6682bc3660212379226fa0a61f51ebd36b24d59e2f31117f864ae2ecd23eb807648d0fa
SHA512 (kernel-kabi-dw-6.3.7.tar.bz2) = b995d53e956c95451f31e3507a660e5d78cc61e80daabc2da07361184094de2f5456e84d7a8e0254c242310890e23599352f8b50d6cae906f6bddfd5a489c64c
SHA512 (linux-6.3.8.tar.xz) = 11c32ab52e6390d6d4035f19f3ebb605487ccf7e160f1f61d699baae3bf8ade7fb173f6ab7460d5b543c6be82b85c5569b64d3d5c72299ef3262a65c14d847b8
SHA512 (kernel-abi-stablelists-6.3.8.tar.bz2) = ca9fc8b759e365c7c4c767f1009ee3e82e356a00a8940464fd1530acdee555b4de18dcc58972df9d1305ddedd78b9d3449210971e96a11905d821cb6d71717e6
SHA512 (kernel-kabi-dw-6.3.8.tar.bz2) = 30f4ea5bb5194580dfa55540cdcd2d596c943572d258fbf791c6c1a1fb720a3c0aa48617aa09719c7c2514c88cde67a7205981fa28d76a8d27dc172ea8b5865f