Merge branch 'master' into rawhide/user/myoung/xendom0

Conflicts:
	kernel.spec
This commit is contained in:
Michael Young 2011-01-09 20:15:36 +00:00
commit 28fc538cef
3 changed files with 80 additions and 3 deletions

View File

@ -0,0 +1,26 @@
From 56a2432f60ea0a0c85a93b0951ae8507e5b85270 Mon Sep 17 00:00:00 2001
From: dennis <dennis@daedalus.ausil.us>
Date: Wed, 5 Jan 2011 19:43:25 +0000
Subject: [PATCH] use __devexit not __exit in n2_unregister_algs fixes build failure on fedora
thanks to kylem for helping with debugging
---
drivers/crypto/n2_core.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/crypto/n2_core.c b/drivers/crypto/n2_core.c
index 88ee015..3372491 100644
--- a/drivers/crypto/n2_core.c
+++ b/drivers/crypto/n2_core.c
@@ -1542,7 +1542,7 @@ out:
return err;
}
-static void __exit n2_unregister_algs(void)
+static void __devexit n2_unregister_algs(void)
{
mutex_lock(&spu_lock);
if (!--algs_registered)
--
1.6.6.1

View File

@ -0,0 +1,33 @@
From patchwork Tue Jan 4 18:46:49 2011
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: drm/i915: check eDP encoder correctly when setting modes
Date: Tue, 04 Jan 2011 18:46:49 -0000
From: Jesse Barnes <jbarnes@virtuousgeek.org>
X-Patchwork-Id: 451441
Message-Id: <1294166809-3316-1-git-send-email-jbarnes@virtuousgeek.org>
To: intel-gfx@lists.freedesktop.org
We were using a stale pointer in the check which caused us to use CPU
attached DP params when we should have been using PCH attached params.
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
---
drivers/gpu/drm/i915/intel_display.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
index fe56cb3..28d58ef 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
@@ -3949,7 +3949,7 @@ static int intel_crtc_mode_set(struct drm_crtc *crtc,
int lane = 0, link_bw, bpp;
/* CPU eDP doesn't require FDI link, so just set DP M/N
according to current link config */
- if (has_edp_encoder && !intel_encoder_is_pch_edp(&encoder->base)) {
+ if (has_edp_encoder && !intel_encoder_is_pch_edp(&has_edp_encoder->base)) {
target_clock = mode->clock;
intel_edp_link_config(has_edp_encoder,
&lane, &link_bw);

View File

@ -52,7 +52,7 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be prepended with "0.", so
# for example a 3 here will become 0.3
#
%global baserelease 1
%global baserelease 2
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@ -340,6 +340,10 @@ Summary: The Linux kernel
%define with_perf 0
%endif
%ifarch sparcv9
%define hdrarch sparc
%endif
%ifarch ppc
%define asmarch powerpc
%define hdrarch powerpc
@ -392,7 +396,7 @@ Summary: The Linux kernel
# Which is a BadThing(tm).
# We only build kernel-headers on the following...
%define nobuildarches i386 s390 sparc %{arm}
%define nobuildarches i386 s390 sparc sparcv9 %{arm}
%ifarch %nobuildarches
%define with_up 0
@ -480,7 +484,7 @@ Version: %{rpmversion}
Release: %{pkg_release}
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
# SET %%nobuildarches (ABOVE) INSTEAD
ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ia64 sparc sparc64 s390 s390x alpha alphaev56 %{arm}
ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ia64 %{sparc} s390 s390x alpha alphaev56 %{arm}
ExclusiveOS: Linux
%kernel_reqprovconf
@ -602,6 +606,7 @@ Patch31: linux-2.6-utrace.patch
Patch32: linux-2.6-utrace-ptrace.patch
Patch150: linux-2.6.29-sparc-IOC_TYPECHECK.patch
Patch151: 0001-use-__devexit-not-__exit-in-n2_unregister_algs-fixes.patch
Patch160: linux-2.6-32bit-mmap-exec-randomization.patch
Patch161: linux-2.6-i386-nx-emulation.patch
@ -660,6 +665,7 @@ Patch1824: drm-intel-next.patch
# make sure the lvds comes back on lid open
Patch1825: drm-intel-make-lvds-work.patch
Patch1826: drm-intel-edp-fixes.patch
Patch1827: drm_i915-check-eDP-encoder-correctly-when-setting-modes.patch
Patch1900: linux-2.6-intel-iommu-igfx.patch
@ -1168,6 +1174,7 @@ ApplyPatch linux-2.6-utrace-ptrace.patch
# SPARC64
#
ApplyPatch linux-2.6.29-sparc-IOC_TYPECHECK.patch
ApplyPatch 0001-use-__devexit-not-__exit-in-n2_unregister_algs-fixes.patch
#
# Exec shield
@ -1284,6 +1291,7 @@ ApplyPatch drm-intel-big-hammer.patch
ApplyPatch drm-intel-make-lvds-work.patch
ApplyPatch linux-2.6-intel-iommu-igfx.patch
ApplyPatch drm-intel-edp-fixes.patch
ApplyPatch drm_i915-check-eDP-encoder-correctly-when-setting-modes.patch
# linux1394 git patches
#ApplyPatch linux-2.6-firewire-git-update.patch
@ -1968,10 +1976,20 @@ fi
# || ||
%changelog
* Fri Jan 07 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.37-2
- drm_i915-check-eDP-encoder-correctly-when-setting-modes.patch reported to
fix HP/Sony eDP issues by adamw and airlied.
* Wed Jan 05 2011 Michael Young <m.a.young@durham.ac.uk>
- update xen.pcifront.fixes.patch with IRQ fixes from stable/bug-fixes branch
- skip docs - it seems to cause build failures at random points the moment.
* Wed Jan 05 2011 Dennis Gilmore <dennis@ausil.us>
- build sparc headers on sparcv9
* Tue Jan 04 2011 Dennis Gilmore <dennis@ausil.us>
- add patch for sparc build failure
* Tue Jan 04 2011 Kyle McMartin <kyle@redhat.com> 2.6.37-1
- Track release of 2.6.37