kernel-6.10.4-200
* Sun Aug 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.4-0] - wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion (Janne Grunau) - New config for 6.10.3 (Justin M. Forbes) - Linux v6.10.4 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
3bce4bc08a
commit
27e98f5c04
@ -1,3 +1,6 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/2c6b48dfc4f3aad194a99c23f8d3e604c1a5593f
|
||||
2c6b48dfc4f3aad194a99c23f8d3e604c1a5593f wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/64905c656dbdbc1a21d838d33e10699e391f185b
|
||||
64905c656dbdbc1a21d838d33e10699e391f185b Bluetooth: hci_event: Fix setting DISCOVERY_FINDING for passive scanning
|
||||
|
||||
|
@ -1,3 +1,9 @@
|
||||
* Sun Aug 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.4-0]
|
||||
- wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion (Janne Grunau)
|
||||
- New config for 6.10.3 (Justin M. Forbes)
|
||||
- Linux v6.10.4
|
||||
Resolves:
|
||||
|
||||
* Mon Aug 05 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.3-0]
|
||||
- Bluetooth: hci_event: Fix setting DISCOVERY_FINDING for passive scanning (Luiz Augusto von Dentz)
|
||||
- Linux v6.10.3
|
||||
|
12
kernel.spec
12
kernel.spec
@ -160,18 +160,18 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specrpmversion 6.10.3
|
||||
%define specversion 6.10.3
|
||||
%define specrpmversion 6.10.4
|
||||
%define specversion 6.10.4
|
||||
%define patchversion 6.10
|
||||
%define pkgrelease 200
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.10.3
|
||||
%define tarfile_release 6.10.4
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 10
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 200%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.10.3
|
||||
%define kabiversion 6.10.4
|
||||
|
||||
# If this variable is set to 1, a bpf selftests build failure will cause a
|
||||
# fatal kernel package build error
|
||||
@ -4043,8 +4043,10 @@ fi\
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Aug 05 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.3-200]
|
||||
* Sun Aug 11 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.4-0]
|
||||
- wifi: brcmfmac: cfg80211: Handle SSID based pmksa deletion (Janne Grunau)
|
||||
- New config for 6.10.3 (Justin M. Forbes)
|
||||
- Linux v6.10.4
|
||||
|
||||
* Mon Aug 05 2024 Justin M. Forbes <jforbes@fedoraproject.org> [6.10.3-0]
|
||||
- Bluetooth: hci_event: Fix setting DISCOVERY_FINDING for passive scanning (Luiz Augusto von Dentz)
|
||||
|
@ -23,6 +23,7 @@
|
||||
drivers/input/rmi4/rmi_driver.c | 124 ++++++++++-------
|
||||
drivers/iommu/iommu.c | 22 +++
|
||||
drivers/media/pci/intel/ipu-bridge.c | 40 ++++--
|
||||
.../broadcom/brcm80211/brcmfmac/cfg80211.c | 13 +-
|
||||
drivers/pci/quirks.c | 24 ++++
|
||||
drivers/scsi/sd.c | 10 ++
|
||||
drivers/usb/core/hub.c | 7 +
|
||||
@ -33,18 +34,16 @@
|
||||
include/linux/rmi.h | 1 +
|
||||
include/linux/security.h | 5 +
|
||||
kernel/module/signing.c | 9 +-
|
||||
net/bluetooth/hci_core.c | 7 -
|
||||
net/bluetooth/hci_event.c | 5 +-
|
||||
scripts/sign-file.c | 29 +---
|
||||
scripts/tags.sh | 2 +
|
||||
security/integrity/platform_certs/load_uefi.c | 6 +-
|
||||
security/lockdown/Kconfig | 13 ++
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 12 ++
|
||||
43 files changed, 782 insertions(+), 265 deletions(-)
|
||||
42 files changed, 789 insertions(+), 259 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c0af6d8aeb05..33ffe9e302df 100644
|
||||
index aec5cc0babf8..d1c4b7c6cdea 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1523,6 +1522,30 @@ index 61750cc98d70..a0e9a71580b5 100644
|
||||
};
|
||||
|
||||
static const struct ipu_property_names prop_names = {
|
||||
diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
|
||||
index 5fe0e671ecb3..826b768196e2 100644
|
||||
--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
|
||||
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
|
||||
@@ -4320,9 +4320,16 @@ brcmf_pmksa_v3_op(struct brcmf_if *ifp, struct cfg80211_pmksa *pmksa,
|
||||
/* Single PMK operation */
|
||||
pmk_op->count = cpu_to_le16(1);
|
||||
length += sizeof(struct brcmf_pmksa_v3);
|
||||
- memcpy(pmk_op->pmk[0].bssid, pmksa->bssid, ETH_ALEN);
|
||||
- memcpy(pmk_op->pmk[0].pmkid, pmksa->pmkid, WLAN_PMKID_LEN);
|
||||
- pmk_op->pmk[0].pmkid_len = WLAN_PMKID_LEN;
|
||||
+ if (pmksa->bssid)
|
||||
+ memcpy(pmk_op->pmk[0].bssid, pmksa->bssid, ETH_ALEN);
|
||||
+ if (pmksa->pmkid) {
|
||||
+ memcpy(pmk_op->pmk[0].pmkid, pmksa->pmkid, WLAN_PMKID_LEN);
|
||||
+ pmk_op->pmk[0].pmkid_len = WLAN_PMKID_LEN;
|
||||
+ }
|
||||
+ if (pmksa->ssid && pmksa->ssid_len) {
|
||||
+ memcpy(pmk_op->pmk[0].ssid.SSID, pmksa->ssid, pmksa->ssid_len);
|
||||
+ pmk_op->pmk[0].ssid.SSID_len = pmksa->ssid_len;
|
||||
+ }
|
||||
pmk_op->pmk[0].time_left = cpu_to_le32(alive ? BRCMF_PMKSA_NO_EXPIRY : 0);
|
||||
}
|
||||
|
||||
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
|
||||
index 568410e64ce6..6afbaee83950 100644
|
||||
--- a/drivers/pci/quirks.c
|
||||
@ -1783,41 +1806,6 @@ index a2ff4242e623..f0d2be1ee4f1 100644
|
||||
}
|
||||
|
||||
int module_sig_check(struct load_info *info, int flags)
|
||||
diff --git a/net/bluetooth/hci_core.c b/net/bluetooth/hci_core.c
|
||||
index 7ae118a6d947..6ecb110bf46b 100644
|
||||
--- a/net/bluetooth/hci_core.c
|
||||
+++ b/net/bluetooth/hci_core.c
|
||||
@@ -120,13 +120,6 @@ void hci_discovery_set_state(struct hci_dev *hdev, int state)
|
||||
case DISCOVERY_STARTING:
|
||||
break;
|
||||
case DISCOVERY_FINDING:
|
||||
- /* If discovery was not started then it was initiated by the
|
||||
- * MGMT interface so no MGMT event shall be generated either
|
||||
- */
|
||||
- if (old_state != DISCOVERY_STARTING) {
|
||||
- hdev->discovery.state = old_state;
|
||||
- return;
|
||||
- }
|
||||
mgmt_discovering(hdev, 1);
|
||||
break;
|
||||
case DISCOVERY_RESOLVING:
|
||||
diff --git a/net/bluetooth/hci_event.c b/net/bluetooth/hci_event.c
|
||||
index 4611a67d7dcc..a78f6d706cd4 100644
|
||||
--- a/net/bluetooth/hci_event.c
|
||||
+++ b/net/bluetooth/hci_event.c
|
||||
@@ -1722,9 +1722,10 @@ static void le_set_scan_enable_complete(struct hci_dev *hdev, u8 enable)
|
||||
switch (enable) {
|
||||
case LE_SCAN_ENABLE:
|
||||
hci_dev_set_flag(hdev, HCI_LE_SCAN);
|
||||
- if (hdev->le_scan_type == LE_SCAN_ACTIVE)
|
||||
+ if (hdev->le_scan_type == LE_SCAN_ACTIVE) {
|
||||
clear_pending_adv_report(hdev);
|
||||
- hci_discovery_set_state(hdev, DISCOVERY_FINDING);
|
||||
+ hci_discovery_set_state(hdev, DISCOVERY_FINDING);
|
||||
+ }
|
||||
break;
|
||||
|
||||
case LE_SCAN_DISABLE:
|
||||
diff --git a/scripts/sign-file.c b/scripts/sign-file.c
|
||||
index 3edb156ae52c..0114ae1dbf7f 100644
|
||||
--- a/scripts/sign-file.c
|
||||
|
6
sources
6
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (kernel-abi-stablelists-6.6.0.tar.bz2) = 4f917598056dee5e23814621ec96ff2e4a411c8c4ba9d56ecb01b23cb96431825bedbecfcbaac9338efbf5cb21694d85497fa0bf43e7c80d9cd10bc6dd144dbd
|
||||
SHA512 (kernel-kabi-dw-6.6.0.tar.bz2) = 19308cd976031d05e18ef7f5d093218acdb89446418bab0cd956ff12cf66369915b9e64bb66fa9f20939428a60e81884fec5be3529c6c7461738d6540d3cc5c6
|
||||
SHA512 (linux-6.10.3.tar.xz) = 07e729ed5c9908b62dbb246887cc22e7432b8bf938b44f1f672754123ee280133eca0ccd893d31c7926796cab6a07243a652b5d8207eb8d5603837bab6407b33
|
||||
SHA512 (kernel-abi-stablelists-6.10.3.tar.xz) = be8770101b1290e85a4f766ed378df5c1bfdee74439bead9b12829bbab74b6a9a04fc66d3d7ea841003d1d67f2b28c64bb07c549593816745a6f2e4cecf713ea
|
||||
SHA512 (kernel-kabi-dw-6.10.3.tar.xz) = 5444013896d8370729dbe807fea1aada164fcdf4e58fdd42858f94a59a568517e2d88e367d07b5951029dc00b2f1087f9fe88d614ab1d6f3402ebbc759d8158a
|
||||
SHA512 (linux-6.10.4.tar.xz) = df461b2523b280f95e67ccff9f93faa04725f13653de24588bad29cc0deac4860a9a135f4aeddd169311e7039de401d1451a547b477ff7a5ddd0cdc0d5e658dd
|
||||
SHA512 (kernel-abi-stablelists-6.10.4.tar.xz) = ef976a858c2b0ac0a6d5c5d02e5f729668fa8487b64b58505d961399fd01a3b2eb8edac675a5e0cea0516f9cbd2b38c1107099bee26ba7c3ade3429cf7812143
|
||||
SHA512 (kernel-kabi-dw-6.10.4.tar.xz) = efbd1b5618897d67deff04cb63fbff51a6d8066a56f2fe52849323547c217065d2cac286902fcb417fff6aa770647134879a177be00df7b62cf87c481cf43956
|
||||
|
Loading…
Reference in New Issue
Block a user