Linux v3.10
This commit is contained in:
parent
67c0481a3b
commit
26ffc4cdb7
@ -71,6 +71,7 @@ CONFIG_ARM_ERRATA_775420=y
|
||||
# CONFIG_PL310_ERRATA_727915 is not set
|
||||
CONFIG_PL310_ERRATA_753970=y
|
||||
CONFIG_PL310_ERRATA_769419=y
|
||||
CONFIG_PJ4B_ERRATA_4742=y
|
||||
# Cortex-A15
|
||||
# CONFIG_ARM_ERRATA_798181 is not set
|
||||
|
||||
|
@ -1234,6 +1234,7 @@ CONFIG_AMD8111_ETH=m
|
||||
CONFIG_PCMCIA_NMCLAN=m
|
||||
|
||||
CONFIG_NET_VENDOR_ATHEROS=y
|
||||
CONFIG_ALX=m
|
||||
CONFIG_ATL2=m
|
||||
CONFIG_ATL1=m
|
||||
CONFIG_ATL1C=m
|
||||
|
17
kernel.spec
17
kernel.spec
@ -6,7 +6,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
||||
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
||||
# be 0.
|
||||
%global released_kernel 0
|
||||
%global released_kernel 1
|
||||
|
||||
# Sign modules on x86. Make sure the config files match this setting if more
|
||||
# architectures are added.
|
||||
@ -62,13 +62,13 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
|
||||
# which yields a base_sublevel of 0.
|
||||
%define base_sublevel 9
|
||||
%define base_sublevel 10
|
||||
|
||||
## If this is a released kernel ##
|
||||
%if 0%{?released_kernel}
|
||||
@ -93,7 +93,7 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 7
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
@ -770,9 +770,6 @@ Patch25035: block-do-not-pass-disk-names-as-format-strings.patch
|
||||
#CVE-2013-2164 rhbz 973100 973109
|
||||
Patch25038: cdrom-use-kzalloc-for-failing-hardware.patch
|
||||
|
||||
#rhbz 950735
|
||||
Patch25045: rt2800-fix-RT5390-RT3290-TX-power-settings-regression.patch
|
||||
|
||||
#rhbz 969644
|
||||
Patch25046: KVM-x86-handle-idiv-overflow-at-kvm_write_tsc.patch
|
||||
|
||||
@ -1486,9 +1483,6 @@ ApplyPatch block-do-not-pass-disk-names-as-format-strings.patch
|
||||
#CVE-2013-2164 rhbz 973100 973109
|
||||
ApplyPatch cdrom-use-kzalloc-for-failing-hardware.patch
|
||||
|
||||
#rhbz 950735
|
||||
ApplyPatch rt2800-fix-RT5390-RT3290-TX-power-settings-regression.patch
|
||||
|
||||
#rhbz 969644
|
||||
ApplyPatch KVM-x86-handle-idiv-overflow-at-kvm_write_tsc.patch
|
||||
|
||||
@ -2300,6 +2294,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Jul 01 2013 Justin M. Forbes <jforbes@redhat.com> - 3.10-1
|
||||
- Linux v3.10
|
||||
|
||||
* Fri Jun 28 2013 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Only enable ARM A15 errata on the LPAE kernel as it breaks A8
|
||||
|
||||
|
@ -1,71 +0,0 @@
|
||||
My change:
|
||||
|
||||
commit cee2c7315f60beeff6137ee59e99acc77d636eeb
|
||||
Author: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||
Date: Fri Oct 5 13:44:09 2012 +0200
|
||||
|
||||
rt2800: use BBP_R1 for setting tx power
|
||||
|
||||
unfortunately does not work well with RT5390 and RT3290 chips as they
|
||||
require different temperature compensation TX power settings (TSSI
|
||||
tuning). Since that commit make wireless connection very unstable on
|
||||
those chips, restore previous behavior to fix regression. Once we
|
||||
implement proper TSSI tuning on 5390/3290 we can restore back setting
|
||||
TX power by BBP_R1 register for those chips.
|
||||
|
||||
Reported-and-tested-by: Mike Romberg <mike-romberg@comcast.net>
|
||||
Cc: stable@vger.kernel.org
|
||||
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||
---
|
||||
drivers/net/wireless/rt2x00/rt2800lib.c | 29 ++++++++++++++++++-----------
|
||||
1 file changed, 18 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/rt2x00/rt2800lib.c b/drivers/net/wireless/rt2x00/rt2800lib.c
|
||||
index 92849e5..8b679df 100644
|
||||
--- a/drivers/net/wireless/rt2x00/rt2800lib.c
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2800lib.c
|
||||
@@ -2634,19 +2634,26 @@ static void rt2800_config_txpower(struct rt2x00_dev *rt2x00dev,
|
||||
* TODO: we do not use +6 dBm option to do not increase power beyond
|
||||
* regulatory limit, however this could be utilized for devices with
|
||||
* CAPABILITY_POWER_LIMIT.
|
||||
+ *
|
||||
+ * TODO: add different temperature compensation code for RT3290 & RT5390
|
||||
+ * to allow to use BBP_R1 for those chips.
|
||||
*/
|
||||
- rt2800_bbp_read(rt2x00dev, 1, &r1);
|
||||
- if (delta <= -12) {
|
||||
- power_ctrl = 2;
|
||||
- delta += 12;
|
||||
- } else if (delta <= -6) {
|
||||
- power_ctrl = 1;
|
||||
- delta += 6;
|
||||
- } else {
|
||||
- power_ctrl = 0;
|
||||
+ if (!rt2x00_rt(rt2x00dev, RT3290) &&
|
||||
+ !rt2x00_rt(rt2x00dev, RT5390)) {
|
||||
+ rt2800_bbp_read(rt2x00dev, 1, &r1);
|
||||
+ if (delta <= -12) {
|
||||
+ power_ctrl = 2;
|
||||
+ delta += 12;
|
||||
+ } else if (delta <= -6) {
|
||||
+ power_ctrl = 1;
|
||||
+ delta += 6;
|
||||
+ } else {
|
||||
+ power_ctrl = 0;
|
||||
+ }
|
||||
+ rt2x00_set_field8(&r1, BBP1_TX_POWER_CTRL, power_ctrl);
|
||||
+ rt2800_bbp_write(rt2x00dev, 1, r1);
|
||||
}
|
||||
- rt2x00_set_field8(&r1, BBP1_TX_POWER_CTRL, power_ctrl);
|
||||
- rt2800_bbp_write(rt2x00dev, 1, r1);
|
||||
+
|
||||
offset = TX_PWR_CFG_0;
|
||||
|
||||
for (i = 0; i < EEPROM_TXPOWER_BYRATE_SIZE; i += 2) {
|
||||
--
|
||||
1.7.11.7
|
||||
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
Loading…
Reference in New Issue
Block a user