Linux v3.18-rc6
This commit is contained in:
parent
33fc8e2a5b
commit
223ab06d15
@ -33,7 +33,7 @@ index 199f453cb4de..ec38acf00b40 100644
|
||||
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
|
||||
2D0/A00 ALL e820_map E820 memory map table
|
||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||
index ded8a6774ac9..750d32268fb1 100644
|
||||
index 41a503c15862..7b8969db8398 100644
|
||||
--- a/arch/x86/Kconfig
|
||||
+++ b/arch/x86/Kconfig
|
||||
@@ -1611,6 +1611,16 @@ config EFI_MIXED
|
||||
|
@ -21,7 +21,7 @@ Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
||||
create mode 100644 drivers/input/touchscreen/goodix.c
|
||||
|
||||
diff --git a/MAINTAINERS b/MAINTAINERS
|
||||
index c444907ccd69..766848ecf8f5 100644
|
||||
index 0ff630de8a6d..e4b643f22336 100644
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -4154,6 +4154,12 @@ L: linux-media@vger.kernel.org
|
||||
|
@ -4186,7 +4186,7 @@ CONFIG_9P_FSCACHE=y
|
||||
CONFIG_9P_FS_POSIX_ACL=y
|
||||
CONFIG_9P_FS_SECURITY=y
|
||||
CONFIG_FUSE_FS=m
|
||||
CONFIG_OVERLAYFS_FS=m
|
||||
CONFIG_OVERLAY_FS=m
|
||||
# CONFIG_OMFS_FS is not set
|
||||
CONFIG_CUSE=m
|
||||
# CONFIG_F2FS_FS is not set
|
||||
|
@ -11,7 +11,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||
index 750d32268fb1..f560653b8c4f 100644
|
||||
index 7b8969db8398..d1f4a3d88dfc 100644
|
||||
--- a/arch/x86/Kconfig
|
||||
+++ b/arch/x86/Kconfig
|
||||
@@ -1612,7 +1612,8 @@ config EFI_MIXED
|
||||
|
@ -11507,23 +11507,6 @@ index 9ecabfa..9029d59c 100644
|
||||
static int xgene_pcie_probe_bridge(struct platform_device *pdev)
|
||||
{
|
||||
struct device_node *dn = pdev->dev.of_node;
|
||||
@@ -631,10 +798,15 @@ static int xgene_pcie_probe_bridge(struct platform_device *pdev)
|
||||
if (ret)
|
||||
return ret;
|
||||
|
||||
- bus = pci_scan_root_bus(&pdev->dev, 0, &xgene_pcie_ops, port, &res);
|
||||
+ bus = pci_create_root_bus(&pdev->dev, 0,
|
||||
+ &xgene_pcie_ops, port, &res);
|
||||
if (!bus)
|
||||
return -ENOMEM;
|
||||
|
||||
+ pci_scan_child_bus(bus);
|
||||
+ pci_assign_unassigned_bus_resources(bus);
|
||||
+ pci_bus_add_devices(bus);
|
||||
+
|
||||
platform_set_drvdata(pdev, port);
|
||||
return 0;
|
||||
}
|
||||
diff --git a/drivers/pnp/resource.c b/drivers/pnp/resource.c
|
||||
index 782e822..d952462 100644
|
||||
--- a/drivers/pnp/resource.c
|
||||
|
11
kernel.spec
11
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 3
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -67,7 +67,7 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 5
|
||||
%define rcrev 6
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
@ -609,8 +609,6 @@ Patch26059: i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
||||
|
||||
Patch26064: Input-add-driver-for-the-Goodix-touchpanel.patch
|
||||
|
||||
Patch26065: sched-Remove-lockdep-check-in-sched_move_task.patch
|
||||
|
||||
#rhbz 1135338
|
||||
Patch26070: HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
|
||||
|
||||
@ -1332,8 +1330,6 @@ ApplyPatch i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
||||
|
||||
ApplyPatch Input-add-driver-for-the-Goodix-touchpanel.patch
|
||||
|
||||
ApplyPatch sched-Remove-lockdep-check-in-sched_move_task.patch
|
||||
|
||||
#rhbz 1135338
|
||||
ApplyPatch HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
|
||||
|
||||
@ -2205,6 +2201,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Nov 24 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Linux v3.18-rc6
|
||||
|
||||
* Fri Nov 21 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Move TPM drivers to main kernel package (rhbz 1164937)
|
||||
|
||||
|
@ -1,49 +0,0 @@
|
||||
From: Kirill Tkhai <ktkhai@parallels.com>
|
||||
Date: Tue, 28 Oct 2014 08:24:34 +0300
|
||||
Subject: [PATCH] sched: Remove lockdep check in sched_move_task()
|
||||
|
||||
sched_move_task() is the only interface to change sched_task_group:
|
||||
cpu_cgrp_subsys methods and autogroup_move_group() use it.
|
||||
|
||||
Everything is synchronized by task_rq_lock(), so cpu_cgroup_attach()
|
||||
is ordered with other users of sched_move_task(). This means we do no
|
||||
need RCU here: if we've dereferenced a tg here, the .attach method
|
||||
hasn't been called for it yet.
|
||||
|
||||
Thus, we should pass "true" to task_css_check() to silence lockdep
|
||||
warnings.
|
||||
|
||||
Fixes: eeb61e53ea19 ("sched: Fix race between task_group and sched_task_group")
|
||||
Reported-by: Oleg Nesterov <oleg@redhat.com>
|
||||
Reported-by: Fengguang Wu <fengguang.wu@intel.com>
|
||||
Signed-off-by: Kirill Tkhai <ktkhai@parallels.com>
|
||||
Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
|
||||
Cc: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
Link: http://lkml.kernel.org/r/1414473874.8574.2.camel@tkhai
|
||||
Signed-off-by: Ingo Molnar <mingo@kernel.org>
|
||||
---
|
||||
kernel/sched/core.c | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/kernel/sched/core.c b/kernel/sched/core.c
|
||||
index 240157c13ddc..6841fb46eb07 100644
|
||||
--- a/kernel/sched/core.c
|
||||
+++ b/kernel/sched/core.c
|
||||
@@ -7444,8 +7444,12 @@ void sched_move_task(struct task_struct *tsk)
|
||||
if (unlikely(running))
|
||||
put_prev_task(rq, tsk);
|
||||
|
||||
- tg = container_of(task_css_check(tsk, cpu_cgrp_id,
|
||||
- lockdep_is_held(&tsk->sighand->siglock)),
|
||||
+ /*
|
||||
+ * All callers are synchronized by task_rq_lock(); we do not use RCU
|
||||
+ * which is pointless here. Thus, we pass "true" to task_css_check()
|
||||
+ * to prevent lockdep warnings.
|
||||
+ */
|
||||
+ tg = container_of(task_css_check(tsk, cpu_cgrp_id, true),
|
||||
struct task_group, css);
|
||||
tg = autogroup_task_group(tsk, tg);
|
||||
tsk->sched_task_group = tg;
|
||||
--
|
||||
1.9.3
|
||||
|
Loading…
Reference in New Issue
Block a user