Add patch to fix exynosdrm build, drop old tegra patches, minor config updates
This commit is contained in:
parent
cb16613f9f
commit
2159380bfc
@ -1,28 +0,0 @@
|
|||||||
diff --git a/drivers/clk/tegra/clk-periph.c b/drivers/clk/tegra/clk-periph.c
|
|
||||||
index 788486e..2f4d0e3 100644
|
|
||||||
--- a/drivers/clk/tegra/clk-periph.c
|
|
||||||
+++ b/drivers/clk/tegra/clk-periph.c
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
#include <linux/clk-provider.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
#include <linux/err.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
|
|
||||||
#include "clk.h"
|
|
||||||
|
|
||||||
@@ -128,6 +129,7 @@ void tegra_periph_reset_deassert(struct clk *c)
|
|
||||||
|
|
||||||
tegra_periph_reset(gate, 0);
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(tegra_periph_reset_deassert);
|
|
||||||
|
|
||||||
void tegra_periph_reset_assert(struct clk *c)
|
|
||||||
{
|
|
||||||
@@ -147,6 +149,7 @@ void tegra_periph_reset_assert(struct clk *c)
|
|
||||||
|
|
||||||
tegra_periph_reset(gate, 1);
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(tegra_periph_reset_assert);
|
|
||||||
|
|
||||||
const struct clk_ops tegra_clk_periph_ops = {
|
|
||||||
.get_parent = clk_periph_get_parent,
|
|
@ -1,11 +0,0 @@
|
|||||||
--- linux-3.10.0-0.rc0.git15.1.fc20.x86_64/drivers/mmc/host/sdhci-tegra.c.orig 2013-05-05 16:02:40.473147107 +0100
|
|
||||||
+++ linux-3.10.0-0.rc0.git15.1.fc20.x86_64/drivers/mmc/host/sdhci-tegra.c 2013-05-05 16:03:08.153399199 +0100
|
|
||||||
@@ -214,7 +214,7 @@
|
|
||||||
#endif
|
|
||||||
{}
|
|
||||||
};
|
|
||||||
-MODULE_DEVICE_TABLE(of, sdhci_dt_ids);
|
|
||||||
+MODULE_DEVICE_TABLE(of, sdhci_tegra_dt_match);
|
|
||||||
|
|
||||||
static void sdhci_tegra_parse_dt(struct device *dev,
|
|
||||||
struct sdhci_tegra *tegra_host)
|
|
@ -410,6 +410,7 @@ CONFIG_PINCTRL_ABX500=y
|
|||||||
CONFIG_PINCTRL_AB8500=y
|
CONFIG_PINCTRL_AB8500=y
|
||||||
CONFIG_I2C_NOMADIK=m
|
CONFIG_I2C_NOMADIK=m
|
||||||
CONFIG_KEYBOARD_NOMADIK=m
|
CONFIG_KEYBOARD_NOMADIK=m
|
||||||
|
# CONFIG_DB8500_CPUFREQ_COOLING is not set
|
||||||
CONFIG_DB8500_THERMAL=y
|
CONFIG_DB8500_THERMAL=y
|
||||||
CONFIG_UX500_WATCHDOG=m
|
CONFIG_UX500_WATCHDOG=m
|
||||||
CONFIG_INPUT_AB8500_PONKEY=m
|
CONFIG_INPUT_AB8500_PONKEY=m
|
||||||
|
@ -49,6 +49,8 @@ CONFIG_SOC_EXYNOS5440=y
|
|||||||
CONFIG_MACH_EXYNOS5_DT=y
|
CONFIG_MACH_EXYNOS5_DT=y
|
||||||
CONFIG_ARM_EXYNOS_CPUFREQ=y
|
CONFIG_ARM_EXYNOS_CPUFREQ=y
|
||||||
# CONFIG_GENERIC_CPUFREQ_CPU0 is not set
|
# CONFIG_GENERIC_CPUFREQ_CPU0 is not set
|
||||||
|
CONFIG_EXYNOS_THERMAL=m
|
||||||
|
|
||||||
CONFIG_SERIAL_SAMSUNG=y
|
CONFIG_SERIAL_SAMSUNG=y
|
||||||
CONFIG_I2C_S3C2410=m
|
CONFIG_I2C_S3C2410=m
|
||||||
CONFIG_PINCTRL_EXYNOS=y
|
CONFIG_PINCTRL_EXYNOS=y
|
||||||
@ -62,7 +64,7 @@ CONFIG_EXYNOS_VIDEO=y
|
|||||||
CONFIG_EXYNOS_MIPI_DSI=y
|
CONFIG_EXYNOS_MIPI_DSI=y
|
||||||
CONFIG_EXYNOS_DP=y
|
CONFIG_EXYNOS_DP=y
|
||||||
# CONFIG_EXYNOS_LCD_S6E8AX0 is not set
|
# CONFIG_EXYNOS_LCD_S6E8AX0 is not set
|
||||||
# CONFIG_DRM_EXYNOS is not set
|
CONFIG_DRM_EXYNOS=m
|
||||||
CONFIG_DRM_EXYNOS_IOMMU=y
|
CONFIG_DRM_EXYNOS_IOMMU=y
|
||||||
CONFIG_DRM_EXYNOS_DMABUF=y
|
CONFIG_DRM_EXYNOS_DMABUF=y
|
||||||
CONFIG_DRM_EXYNOS_FIMD=y
|
CONFIG_DRM_EXYNOS_FIMD=y
|
||||||
|
53
drm-exynos-fix-multiple-definition-build-error.patch
Normal file
53
drm-exynos-fix-multiple-definition-build-error.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
From patchwork Fri Apr 26 05:03:10 2013
|
||||||
|
Content-Type: text/plain; charset="utf-8"
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Transfer-Encoding: 7bit
|
||||||
|
Subject: drm/exynos: fix multiple definition build error
|
||||||
|
Date: Fri, 26 Apr 2013 05:03:10 -0000
|
||||||
|
From: Inki Dae <inki.dae@samsung.com>
|
||||||
|
X-Patchwork-Id: 2490831
|
||||||
|
Message-Id: <1366952590-11652-1-git-send-email-inki.dae@samsung.com>
|
||||||
|
To: airlied@linux.ie, dri-devel@lists.freedesktop.org
|
||||||
|
Cc: kyungmin.park@samsung.com, sw0312.kim@samsung.com
|
||||||
|
|
||||||
|
This patch fixes multiple definition error like below when building it
|
||||||
|
as moudle with device tree support.
|
||||||
|
|
||||||
|
drivers/gpu/drm/exynos/exynos_drm_g2d.o: In function `.LANCHOR1':
|
||||||
|
exynos_drm_g2d.c:(.rodata+0x6c): multiple definition of `__mod_of_device_table'
|
||||||
|
drivers/gpu/drm/exynos/exynos_drm_fimd.o:exynos_drm_fimd.c:(.rodata+0x144): first defined here
|
||||||
|
|
||||||
|
Signed-off-by: Inki Dae <inki.dae@samsung.com>
|
||||||
|
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/gpu/drm/exynos/exynos_drm_fimd.c | 2 +-
|
||||||
|
drivers/gpu/drm/exynos/exynos_drm_g2d.c | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/gpu/drm/exynos/exynos_drm_fimd.c b/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||||
|
index 746b282..1e02d13 100644
|
||||||
|
--- a/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||||
|
+++ b/drivers/gpu/drm/exynos/exynos_drm_fimd.c
|
||||||
|
@@ -117,7 +117,7 @@ static const struct of_device_id fimd_driver_dt_match[] = {
|
||||||
|
.data = &exynos5_fimd_driver_data },
|
||||||
|
{},
|
||||||
|
};
|
||||||
|
-MODULE_DEVICE_TABLE(of, fimd_driver_dt_match);
|
||||||
|
+MODULE_DEVICE_TABLE(of_fimd, fimd_driver_dt_match);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
static inline struct fimd_driver_data *drm_fimd_get_driver_data(
|
||||||
|
diff --git a/drivers/gpu/drm/exynos/exynos_drm_g2d.c b/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||||
|
index 47a493c..6a01ff1 100644
|
||||||
|
--- a/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||||
|
+++ b/drivers/gpu/drm/exynos/exynos_drm_g2d.c
|
||||||
|
@@ -1525,7 +1525,7 @@ static const struct of_device_id exynos_g2d_match[] = {
|
||||||
|
{ .compatible = "samsung,exynos5250-g2d" },
|
||||||
|
{},
|
||||||
|
};
|
||||||
|
-MODULE_DEVICE_TABLE(of, exynos_g2d_match);
|
||||||
|
+MODULE_DEVICE_TABLE(of_g2d, exynos_g2d_match);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
struct platform_driver g2d_driver = {
|
11
kernel.spec
11
kernel.spec
@ -699,13 +699,10 @@ Patch21000: arm-export-read_current_timer.patch
|
|||||||
|
|
||||||
# lpae
|
# lpae
|
||||||
Patch21002: arm-lpae-ax88796.patch
|
Patch21002: arm-lpae-ax88796.patch
|
||||||
|
Patch21003: drm-exynos-fix-multiple-definition-build-error.patch
|
||||||
# ARM omap
|
|
||||||
|
|
||||||
# ARM tegra
|
# ARM tegra
|
||||||
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
||||||
#atch21006: arm-tegra-fixclk.patch
|
|
||||||
#atch21007: arm-tegra-sdhci-module-fix.patch
|
|
||||||
|
|
||||||
#rhbz 754518
|
#rhbz 754518
|
||||||
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||||
@ -1286,9 +1283,8 @@ ApplyPatch debug-bad-pte-modules.patch
|
|||||||
#
|
#
|
||||||
ApplyPatch arm-export-read_current_timer.patch
|
ApplyPatch arm-export-read_current_timer.patch
|
||||||
ApplyPatch arm-lpae-ax88796.patch
|
ApplyPatch arm-lpae-ax88796.patch
|
||||||
|
ApplyPatch drm-exynos-fix-multiple-definition-build-error.patch
|
||||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
#pplyPatch arm-tegra-fixclk.patch
|
|
||||||
#pplyPatch arm-tegra-sdhci-module-fix.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# bugfixes to drivers and filesystems
|
# bugfixes to drivers and filesystems
|
||||||
@ -2237,6 +2233,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 10 2013 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
|
- Add patch to fix exynosdrm build, drop old tegra patches, minor config updates
|
||||||
|
|
||||||
* Fri May 10 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git26.1
|
* Fri May 10 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git26.1
|
||||||
- Linux v3.9-12555-g2dbd3ca
|
- Linux v3.9-12555-g2dbd3ca
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user