Linux v3.14.20
This commit is contained in:
parent
935fa21f28
commit
1d97dbe44d
@ -1,51 +0,0 @@
|
||||
From c54def7bd64d7c0b6993336abcffb8444795bf38 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Kosina <jkosina@suse.cz>
|
||||
Date: Wed, 27 Aug 2014 09:12:24 +0200
|
||||
Subject: [PATCH] HID: magicmouse: sanity check report size in raw_event()
|
||||
callback
|
||||
|
||||
The report passed to us from transport driver could potentially be
|
||||
arbitrarily large, therefore we better sanity-check it so that
|
||||
magicmouse_emit_touch() gets only valid values of raw_id.
|
||||
|
||||
Bugzilla: 1141179
|
||||
Upstream-status: 3.17 and CC'd stable
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Reported-by: Steven Vittitoe <scvitti@google.com>
|
||||
Signed-off-by: Jiri Kosina <jkosina@suse.cz>
|
||||
---
|
||||
drivers/hid/hid-magicmouse.c | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
diff --git a/drivers/hid/hid-magicmouse.c b/drivers/hid/hid-magicmouse.c
|
||||
index ecc2cbf300cc..29a74c1efcb8 100644
|
||||
--- a/drivers/hid/hid-magicmouse.c
|
||||
+++ b/drivers/hid/hid-magicmouse.c
|
||||
@@ -290,6 +290,11 @@ static int magicmouse_raw_event(struct hid_device *hdev,
|
||||
if (size < 4 || ((size - 4) % 9) != 0)
|
||||
return 0;
|
||||
npoints = (size - 4) / 9;
|
||||
+ if (npoints > 15) {
|
||||
+ hid_warn(hdev, "invalid size value (%d) for TRACKPAD_REPORT_ID\n",
|
||||
+ size);
|
||||
+ return 0;
|
||||
+ }
|
||||
msc->ntouches = 0;
|
||||
for (ii = 0; ii < npoints; ii++)
|
||||
magicmouse_emit_touch(msc, ii, data + ii * 9 + 4);
|
||||
@@ -307,6 +312,11 @@ static int magicmouse_raw_event(struct hid_device *hdev,
|
||||
if (size < 6 || ((size - 6) % 8) != 0)
|
||||
return 0;
|
||||
npoints = (size - 6) / 8;
|
||||
+ if (npoints > 15) {
|
||||
+ hid_warn(hdev, "invalid size value (%d) for MOUSE_REPORT_ID\n",
|
||||
+ size);
|
||||
+ return 0;
|
||||
+ }
|
||||
msc->ntouches = 0;
|
||||
for (ii = 0; ii < npoints; ii++)
|
||||
magicmouse_emit_touch(msc, ii, data + ii * 8 + 6);
|
||||
--
|
||||
2.1.0
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 844817e47eef14141cf59b8d5ac08dd11c0a9189 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Kosina <jkosina@suse.cz>
|
||||
Date: Wed, 27 Aug 2014 09:13:15 +0200
|
||||
Subject: [PATCH] HID: picolcd: sanity check report size in raw_event()
|
||||
callback
|
||||
|
||||
The report passed to us from transport driver could potentially be
|
||||
arbitrarily large, therefore we better sanity-check it so that raw_data
|
||||
that we hold in picolcd_pending structure are always kept within proper
|
||||
bounds.
|
||||
|
||||
Bugzilla: 1141410
|
||||
Upstream-status: 3.17 and CC'd to stable
|
||||
|
||||
Cc: stable@vger.kernel.org
|
||||
Reported-by: Steven Vittitoe <scvitti@google.com>
|
||||
Signed-off-by: Jiri Kosina <jkosina@suse.cz>
|
||||
---
|
||||
drivers/hid/hid-picolcd_core.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/drivers/hid/hid-picolcd_core.c b/drivers/hid/hid-picolcd_core.c
|
||||
index acbb021065ec..020df3c2e8b4 100644
|
||||
--- a/drivers/hid/hid-picolcd_core.c
|
||||
+++ b/drivers/hid/hid-picolcd_core.c
|
||||
@@ -350,6 +350,12 @@ static int picolcd_raw_event(struct hid_device *hdev,
|
||||
if (!data)
|
||||
return 1;
|
||||
|
||||
+ if (size > 64) {
|
||||
+ hid_warn(hdev, "invalid size value (%d) for picolcd raw event\n",
|
||||
+ size);
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
if (report->id == REPORT_KEY_STATE) {
|
||||
if (data->input_keys)
|
||||
ret = picolcd_raw_keypad(data, report, raw_data+1, size-1);
|
||||
--
|
||||
2.1.0
|
||||
|
17
kernel.spec
17
kernel.spec
@ -74,7 +74,7 @@ Summary: The Linux kernel
|
||||
%if 0%{?released_kernel}
|
||||
|
||||
# Do we have a -stable update to apply?
|
||||
%define stable_update 19
|
||||
%define stable_update 20
|
||||
# Is it a -stable RC?
|
||||
%define stable_rc 0
|
||||
# Set rpm version accordingly
|
||||
@ -753,12 +753,6 @@ Patch25109: revert-input-wacom-testing-result-shows-get_report-is-unnecessary.pa
|
||||
Patch25110: 0001-ideapad-laptop-Blacklist-rfkill-control-on-the-Lenov.patch
|
||||
Patch25111: 0002-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
||||
|
||||
#CVE-2014-3181 rhbz 1141179 1141173
|
||||
Patch26024: HID-magicmouse-sanity-check-report-size-in-raw_event.patch
|
||||
|
||||
#CVE-2014-3186 rhbz 1141407 1141410
|
||||
Patch26025: HID-picolcd-sanity-check-report-size-in-raw_event-ca.patch
|
||||
|
||||
#CVE-2014-6410 rhbz 1141809 1141810
|
||||
Patch26026: udf-Avoid-infinite-loop-when-processing-indirect-ICB.patch
|
||||
|
||||
@ -1457,12 +1451,6 @@ ApplyPatch revert-input-wacom-testing-result-shows-get_report-is-unnecessary.pat
|
||||
ApplyPatch 0001-ideapad-laptop-Blacklist-rfkill-control-on-the-Lenov.patch
|
||||
ApplyPatch 0002-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
||||
|
||||
#CVE-2014-3181 rhbz 1141179 1141173
|
||||
ApplyPatch HID-magicmouse-sanity-check-report-size-in-raw_event.patch
|
||||
|
||||
#CVE-2014-3186 rhbz 1141407 1141410
|
||||
ApplyPatch HID-picolcd-sanity-check-report-size-in-raw_event-ca.patch
|
||||
|
||||
#CVE-2014-6410 rhbz 1141809 1141810
|
||||
ApplyPatch udf-Avoid-infinite-loop-when-processing-indirect-ICB.patch
|
||||
|
||||
@ -2278,6 +2266,9 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Mon Oct 06 2014 Justin M. Forbes <jforbes@fedoraproject.org> - 3.14.20-100
|
||||
- Linux v3.14.20
|
||||
|
||||
* Thu Sep 17 2014 Justin M. Forbes <jforbes@fedoraproject.org> - 3.14.19-100
|
||||
- Linux v3.14.19
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user