kernel-6.3.0-0.rc7.20230420gitcb0856346a60.59

* Thu Apr 20 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc7.cb0856346a60.59]
- redhat/Makefile: Support building linux-next (Thorsten Leemhuis)
- redhat/Makefile: support building stable-rc versions (Thorsten Leemhuis)
- redhat/Makefile: Add target to print DISTRELEASETAG (Thorsten Leemhuis)
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-04-20 18:36:36 -05:00
parent 14e45b6c1f
commit 182b65b5d5
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
4 changed files with 34 additions and 11 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 56
RHEL_RELEASE = 59
#
# RHEL_REBASE_NUM

View File

@ -145,13 +145,13 @@ Summary: The Linux kernel
%define specrpmversion 6.3.0
%define specversion 6.3.0
%define patchversion 6.3
%define pkgrelease 0.rc7.56
%define pkgrelease 0.rc7.20230420gitcb0856346a60.59
%define kversion 6
%define tarfile_release 6.3-rc7
%define tarfile_release 6.3-rc7-89-gcb0856346a60
# This is needed to do merge window version magic
%define patchlevel 3
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc7.56%{?buildid}%{?dist}
%define specrelease 0.rc7.20230420gitcb0856346a60.59%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.3.0
@ -680,7 +680,12 @@ BuildConflicts: dwarves < 1.13
%undefine _unique_debug_srcs
%undefine _debugsource_packages
%undefine _debuginfo_subpackages
%if 0%{?fedora}
%global _find_debuginfo_opts -r -q
%else
%global _find_debuginfo_opts -r
%endif
%global _missing_build_ids_terminate_build 1
%global _no_recompute_build_ids 1
%endif
@ -1568,6 +1573,9 @@ ApplyOptionalPatch linux-kernel-test.patch
chmod +x scripts/checkpatch.pl
mv COPYING COPYING-%{specrpmversion}-%{release}
# on linux-next prevent scripts/setlocalversion from mucking with our version numbers
rm -f localversion-next
# Mangle /usr/bin/python shebangs to /usr/bin/python3
# Mangle all Python shebangs to be Python 3 explicitly
# -p preserves timestamps
@ -3074,10 +3082,12 @@ touch %{_localstatedir}/lib/rpm-state/%{name}/installing_core_%{KVERREL}%{?-v:+%
%define kernel_uki_virt_scripts() \
%{expand:%%posttrans %{?1:%{1}-}uki-virt}\
mkdir -p /boot/efi/EFI/Linux\
cp /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz-virt.efi /boot/efi/EFI/Linux/vmlinuz-%{KVERREL}%{?1:+%{1}}-virt.efi\
entry_token=$(kernel-install inspect | grep KERNEL_INSTALL_ENTRY_TOKEN: | cut -d ' ' -f2)\
cp /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz-virt.efi /boot/efi/EFI/Linux/${entry_token}-%{KVERREL}%{?1:+%{1}}.efi\
%{nil}\
%{expand:%%postun %{?1:%{1}-}uki-virt}\
rm -f /boot/efi/EFI/Linux/vmlinuz-%{KVERREL}%{?1:+%{1}}-virt.efi\
entry_token=$(kernel-install inspect | grep KERNEL_INSTALL_ENTRY_TOKEN: | cut -d ' ' -f2)\
rm -f /boot/efi/EFI/Linux/${entry_token}-%{KVERREL}%{?1:+%{1}}.efi\
%{nil}
#
@ -3354,7 +3364,7 @@ fi
%if %{with_efiuki}\
%{expand:%%files %{?3:%{3}-}uki-virt}\
/lib/modules/%{KVERREL}%{?3:+%{3}}/%{?-k:%{-k*}}%{!?-k:vmlinuz}-virt.efi\
%ghost /%{image_install_path}/efi/EFI/Linux/%{?-k:%{-k*}}%{!?-k:vmlinuz}-%{KVERREL}%{?3:+%{3}}-virt.efi\
%ghost /%{image_install_path}/efi/EFI/Linux/%{?-k:%{-k*}}%{!?-k:*}-%{KVERREL}%{?3:+%{3}}.efi\
%endif\
%if %{?3:1} %{!?3:0}\
%{expand:%%files %{3}}\
@ -3399,6 +3409,19 @@ fi
#
#
%changelog
* Thu Apr 20 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc7.cb0856346a60.59]
- redhat/Makefile: Support building linux-next (Thorsten Leemhuis)
- redhat/Makefile: support building stable-rc versions (Thorsten Leemhuis)
- redhat/Makefile: Add target to print DISTRELEASETAG (Thorsten Leemhuis)
* Thu Apr 20 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc7.cb0856346a60.58]
- Linux v6.3.0-0.rc7.cb0856346a60
* Wed Apr 19 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc7.af67688dca57.57]
- kernel.spec: Fix UKI naming to comply with BLS (Philipp Rudo)
- redhat/kernel.spec.template: Suppress 'extracting debug info' noise in build log (Prarit Bhargava)
- Linux v6.3.0-0.rc7.af67688dca57
* Mon Apr 17 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc7.56]
- Linux v6.3.0-0.rc7

View File

@ -66,7 +66,7 @@
65 files changed, 1544 insertions(+), 189 deletions(-)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index 6221a1d057dd..90c169923eda 100644
index 7016cb12dc4e..64bbc2312980 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -6530,6 +6530,15 @@

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.3-rc7.tar.xz) = 37a215f48d8ad2d85dc6082e8b3801a3ae31b54b322a00e9d8ced62570919f4336c2bd45378ca0a6299c72efddcbad0bcccd8ca48209e7d6ee86a92047943e65
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = faff1ad68a1e2cc01898efb876e0ca597502be6eaa419d8bd2521769a07d16638dd9f6a864303e40cb3741f88b455ac7c3d6dd9354a74868d3a69ce304c8381c
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = d1820c11feb32e6f3f5d8550e546f1f0ee8bac434ba9743aec352fb224292daecfc712fc9f3b014e2fbc81149a1680ecaf6cf9b27f47a8cfe82ab590183f0ad4
SHA512 (linux-6.3-rc7-89-gcb0856346a60.tar.xz) = b842fb77aaf66d29ef9c0a29cb79add07575ddc87968c1f6b04cd5436c6a07043000b6cba434560988e5da1660bc19f326a768c2273929ebe9b1a463a8e2acbc
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = 59b8b7d9954c2a8bd5fc259d48971e493c5c87eac81190870b586e36bb617d13cc7b85c40f4d5ba50bdc8691c9e1ab9d9aee8373f80dc3bc0ddf0531267b6aeb
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = c9fe64dc46838d4e05c9396a1dc60b95d831377b6a254d8b22839ac2b29c349a9a8112bc082ac2a11250eb73410e8859c634d6f29952b0a4630f960f541ec098