Merge branch 'master' into rawhide/user/myoung/xendom0

Conflicts:
	kernel.spec
This commit is contained in:
Michael Young 2011-01-05 18:45:40 +00:00
commit 14fd9886f2
4 changed files with 26 additions and 31 deletions

1
.gitignore vendored
View File

@ -3,4 +3,3 @@ patch-*.bz2
clog
*.rpm
kernel-2.6.*/
/patch-2.6.37-rc7.bz2

View File

@ -13,32 +13,22 @@ and recreate the battery in order to populate the fields correctly.
Signed-off-by: Matthew Garrett <mjg@redhat.com>
---
drivers/acpi/battery.c | 24 +++++++++++++++++-------
1 files changed, 17 insertions(+), 7 deletions(-)
drivers/acpi/battery.c | 21 ++++++++++++++++-----
1 files changed, 16 insertions(+), 5 deletions(-)
diff --git a/drivers/acpi/battery.c b/drivers/acpi/battery.c
index 9fb9d5a..8da9c88 100644
index 95649d3..161e43a 100644
--- a/drivers/acpi/battery.c
+++ b/drivers/acpi/battery.c
@@ -130,7 +130,7 @@ struct acpi_battery {
unsigned long flags;
};
@@ -152,6 +152,7 @@ static int acpi_battery_technology(struct acpi_battery *battery)
return POWER_SUPPLY_TECHNOLOGY_UNKNOWN;
}
-static int acpi_battery_update(struct acpi_battery *battery);
+static int acpi_battery_update(struct acpi_battery *battery, bool get_info);
static int acpi_battery_get_state(struct acpi_battery *battery);
#define to_acpi_battery(x) container_of(x, struct acpi_battery, bat);
@@ -186,7 +186,7 @@ static int acpi_battery_get_property(struct power_supply *psy,
int ret = 0;
struct acpi_battery *battery = to_acpi_battery(psy);
- if (acpi_battery_update(battery))
+ if (acpi_battery_update(battery, false))
return -ENODEV;
if (acpi_battery_present(battery)) {
@@ -610,9 +610,11 @@ static void acpi_battery_quirks2(struct acpi_battery *battery)
static int acpi_battery_is_charged(struct acpi_battery *battery)
@@ -605,9 +606,11 @@ static void acpi_battery_quirks2(struct acpi_battery *battery)
}
}
@ -51,7 +41,7 @@ index 9fb9d5a..8da9c88 100644
result = acpi_battery_get_status(battery);
if (result)
return result;
@@ -631,6 +633,14 @@ static int acpi_battery_update(struct acpi_battery *battery)
@@ -626,6 +629,14 @@ static int acpi_battery_update(struct acpi_battery *battery)
}
if (!battery->bat.dev)
sysfs_add_battery(battery);
@ -66,7 +56,7 @@ index 9fb9d5a..8da9c88 100644
result = acpi_battery_get_state(battery);
acpi_battery_quirks2(battery);
return result;
@@ -808,7 +818,7 @@ static print_func acpi_print_funcs[ACPI_BATTERY_NUMFILES] = {
@@ -803,7 +814,7 @@ static print_func acpi_print_funcs[ACPI_BATTERY_NUMFILES] = {
static int acpi_battery_read(int fid, struct seq_file *seq)
{
struct acpi_battery *battery = seq->private;
@ -75,7 +65,7 @@ index 9fb9d5a..8da9c88 100644
return acpi_print_funcs[fid](seq, result);
}
@@ -919,7 +929,7 @@ static void acpi_battery_notify(struct acpi_device *device, u32 event)
@@ -914,7 +925,7 @@ static void acpi_battery_notify(struct acpi_device *device, u32 event)
if (!battery)
return;
old = battery->bat.dev;
@ -84,7 +74,7 @@ index 9fb9d5a..8da9c88 100644
acpi_bus_generate_proc_event(device, event,
acpi_battery_present(battery));
acpi_bus_generate_netlink_event(device->pnp.device_class,
@@ -948,7 +958,7 @@ static int acpi_battery_add(struct acpi_device *device)
@@ -943,7 +954,7 @@ static int acpi_battery_add(struct acpi_device *device)
if (ACPI_SUCCESS(acpi_get_handle(battery->device->handle,
"_BIX", &handle)))
set_bit(ACPI_BATTERY_XINFO_PRESENT, &battery->flags);
@ -93,7 +83,7 @@ index 9fb9d5a..8da9c88 100644
#ifdef CONFIG_ACPI_PROCFS_POWER
result = acpi_battery_add_fs(device);
#endif
@@ -989,7 +999,7 @@ static int acpi_battery_resume(struct acpi_device *device)
@@ -984,7 +995,7 @@ static int acpi_battery_resume(struct acpi_device *device)
return -EINVAL;
battery = acpi_driver_data(device);
battery->update_time = 0;

View File

@ -6,7 +6,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1. For rawhide
# and/or a kernel built from an rc or git snapshot, released_kernel should
# be 0.
%global released_kernel 0
%global released_kernel 1
# Save original buildid for later if it's defined
%if 0%{?buildid:1}
@ -52,13 +52,13 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be prepended with "0.", so
# for example a 3 here will become 0.3
#
%global baserelease 2
%global baserelease 1
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 2.6.22-rc7-git1 starts with a 2.6.21 base,
# which yields a base_sublevel of 21.
%define base_sublevel 36
%define base_sublevel 37
## If this is a released kernel ##
%if 0%{?released_kernel}
@ -83,7 +83,7 @@ Summary: The Linux kernel
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
# The rc snapshot level
%define rcrev 7
%define rcrev 0
# The git snapshot level
%define gitrev 0
# Set rpm version accordingly
@ -1968,6 +1968,13 @@ fi
# || ||
%changelog
* Tue Jan 04 2011 Kyle McMartin <kyle@redhat.com> 2.6.37-1
- Track release of 2.6.37
* Mon Jan 03 2011 Kyle McMartin <kyle@redhat.com> 2.6.37-0.rc8.git3.1
- Linux 2.6.37-rc8-git3
- Merged acpi battery notification patch and -rc8.
* Tue Jan 01 2011 Michael Young <m.a.young@durham.ac.uk>
- update pvops to add some xenbus patches

View File

@ -1,2 +1 @@
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
c879f40313f5ee305a3e324ddde957be patch-2.6.37-rc7.bz2
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2