Merge branch 'f15/master'
This commit is contained in:
commit
133f001fc7
File diff suppressed because it is too large
Load Diff
14
kernel.spec
14
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 6
|
%define rcrev 6
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -733,9 +733,6 @@ Patch12421: fs-call-security_d_instantiate-in-d_obtain_alias.patch
|
|||||||
|
|
||||||
Patch12438: ath5k-fix-fast-channel-change.patch
|
Patch12438: ath5k-fix-fast-channel-change.patch
|
||||||
|
|
||||||
# rhbz#676860
|
|
||||||
Patch12441: usb-sierra-add-airprime-direct-ip.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||||
@ -1351,9 +1348,6 @@ ApplyPatch fs-call-security_d_instantiate-in-d_obtain_alias.patch
|
|||||||
# rhbz#672778
|
# rhbz#672778
|
||||||
ApplyPatch ath5k-fix-fast-channel-change.patch
|
ApplyPatch ath5k-fix-fast-channel-change.patch
|
||||||
|
|
||||||
# rhbz#676860
|
|
||||||
ApplyPatch usb-sierra-add-airprime-direct-ip.patch
|
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1957,6 +1951,12 @@ fi
|
|||||||
# and build.
|
# and build.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 23 2011 Chuck Ebbert <cebbert@redhat.com> 2.6.38-0.rc6.git2.1
|
||||||
|
- Linux 2.6.38-rc6-git2
|
||||||
|
|
||||||
|
* Wed Feb 23 2011 Ben Skeggs <bskeggs@redhat.com> 2.6.38-0.rc6.git0.2
|
||||||
|
- nouveau: nv4x pciegart fixes, nvc0 accel improvements
|
||||||
|
|
||||||
* Tue Feb 22 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc6.git0.1
|
* Tue Feb 22 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc6.git0.1
|
||||||
- Linux 2.6.38-rc6
|
- Linux 2.6.38-rc6
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
||||||
7f88891e35d060b8f1f436cf05125c36 patch-2.6.38-rc6.bz2
|
7f88891e35d060b8f1f436cf05125c36 patch-2.6.38-rc6.bz2
|
||||||
|
3ddbe38f2ca6ae526dd0017fafdf846a patch-2.6.38-rc6-git2.bz2
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From: Jon Thomas <jthomas@redhat.com>
|
|
||||||
Subj: Add new ID for Airprime/Sierra USB IP modem
|
|
||||||
|
|
||||||
I picked up a new Sierra usb 308 (At&t Shockwave) on 2/2011 and the vendor code
|
|
||||||
is 0x0f3d
|
|
||||||
|
|
||||||
Looking up vendor and product id's I see:
|
|
||||||
|
|
||||||
0f3d Airprime, Incorporated
|
|
||||||
0112 CDMA 1xEVDO PC Card, PC 5220
|
|
||||||
|
|
||||||
Sierra and Airprime are somehow related and I'm guessing the At&t usb 308 might
|
|
||||||
be have some common hardware with the AirPrime SL809x.
|
|
||||||
|
|
||||||
I patched sierra.c with this and it works.
|
|
||||||
|
|
||||||
Signed-off-by: Jon Thomas <jthomas@redhat.com>
|
|
||||||
|
|
||||||
--- a/drivers/usb/serial/sierra.c
|
|
||||||
+++ b/drivers/usb/serial/sierra.c
|
|
||||||
@@ -301,6 +301,9 @@ static const struct usb_device_id id_tab
|
|
||||||
{ USB_DEVICE(0x1199, 0x68A3), /* Sierra Wireless Direct IP modems */
|
|
||||||
.driver_info = (kernel_ulong_t)&direct_ip_interface_blacklist
|
|
||||||
},
|
|
||||||
+ { USB_DEVICE(0x0f3d, 0x68A3), /* Airprime/Sierra Wireless Direct IP modems */
|
|
||||||
+ .driver_info = (kernel_ulong_t)&direct_ip_interface_blacklist
|
|
||||||
+ },
|
|
||||||
{ USB_DEVICE(0x413C, 0x08133) }, /* Dell Computer Corp. Wireless 5720 VZW Mobile Broadband (EVDO Rev-A) Minicard GPS Port */
|
|
||||||
|
|
||||||
{ }
|
|
Loading…
Reference in New Issue
Block a user