Linux 2.6.37-git13
This commit is contained in:
parent
ca570fd6c9
commit
126cc8b40c
@ -4485,3 +4485,8 @@ CONFIG_EVENT_POWER_TRACING_DEPRECATED=y
|
||||
|
||||
CONFIG_NFC_DEVICES=y
|
||||
CONFIG_PN544_NFC=m
|
||||
|
||||
CONFIG_TARGET_CORE=m
|
||||
CONFIG_TCM_IBLOCK=m
|
||||
CONFIG_TCM_FILEIO=m
|
||||
CONFIG_TCM_PSCSI=m
|
||||
|
10
kernel.spec
10
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 12
|
||||
%define gitrev 13
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 2.6.%{upstream_sublevel}
|
||||
%endif
|
||||
@ -732,8 +732,6 @@ Patch12401: debug-tty-print-dev-name.patch
|
||||
|
||||
Patch12421: fs-call-security_d_instantiate-in-d_obtain_alias.patch
|
||||
|
||||
Patch12422: xen_export-arbitrary_virt_to_machine.patch
|
||||
|
||||
%endif
|
||||
|
||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||
@ -1346,8 +1344,6 @@ ApplyPatch debug-tty-print-dev-name.patch
|
||||
# rhbz#662344,600690
|
||||
ApplyPatch fs-call-security_d_instantiate-in-d_obtain_alias.patch
|
||||
|
||||
ApplyPatch xen_export-arbitrary_virt_to_machine.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -1960,6 +1956,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Sat Jan 15 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc0.git13.1
|
||||
- Linux 2.6.37-git13
|
||||
- Drop xen_export-arbitrary_virt_to_machine.patch, upstream.
|
||||
|
||||
* Fri Jan 14 2011 Kyle McMartin <kmcmartin@redhat.com>
|
||||
- xen_export-arbitrary_virt_to_machine.patch: pull patch from upstream
|
||||
to fix build error.
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
||||
2aa8806680f37b62479cead4c7034b90 patch-2.6.37-git12.bz2
|
||||
347731580c0e5cd2719c268f39100261 patch-2.6.37-git13.bz2
|
||||
|
@ -1,25 +0,0 @@
|
||||
commit de23be5f3580f7b9b52cad6633bb3a3cd13abafe
|
||||
Author: Stephen Rothwell <sfr@canb.auug.org.au>
|
||||
Date: Sat Jan 15 10:36:26 2011 +1100
|
||||
|
||||
xen: export arbitrary_virt_to_machine
|
||||
|
||||
Fixes this build error:
|
||||
|
||||
ERROR: "arbitrary_virt_to_machine" [drivers/xen/xen-gntdev.ko] undefined!
|
||||
|
||||
Signed-off-by: Stephen Rothwell <sfr@canb.auug.org.au>
|
||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
|
||||
diff --git a/arch/x86/xen/mmu.c b/arch/x86/xen/mmu.c
|
||||
index 7575e55..5e92b61 100644
|
||||
--- a/arch/x86/xen/mmu.c
|
||||
+++ b/arch/x86/xen/mmu.c
|
||||
@@ -201,6 +201,7 @@ xmaddr_t arbitrary_virt_to_machine(void *vaddr)
|
||||
offset = address & ~PAGE_MASK;
|
||||
return XMADDR(((phys_addr_t)pte_mfn(*pte) << PAGE_SHIFT) + offset);
|
||||
}
|
||||
+EXPORT_SYMBOL_GPL(arbitrary_virt_to_machine);
|
||||
|
||||
void make_lowmem_page_readonly(void *vaddr)
|
||||
{
|
Loading…
Reference in New Issue
Block a user