kernel-6.3.0-0.rc2.23

* Mon Mar 13 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc2.23]
- redhat: version two of Makefile.rhelver tweaks (Clark Williams)
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-03-13 11:18:36 -05:00
parent c16812f9dc
commit 11e7f83c92
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
5 changed files with 42 additions and 22 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 19
RHEL_RELEASE = 23
#
# ZSTREAM

View File

@ -1,3 +1,6 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/a9d4f3471daaa3ce48730242df86d87eb642b650
a9d4f3471daaa3ce48730242df86d87eb642b650 redhat: version two of Makefile.rhelver tweaks
"https://gitlab.com/cki-project/kernel-ark/-/commit"/7bfeffd1d37b3bc7d86247c53843762b4e97c62b
7bfeffd1d37b3bc7d86247c53843762b4e97c62b redhat: adapt to upstream Makefile change

View File

@ -143,13 +143,13 @@ Summary: The Linux kernel
# define buildid .local
%define specversion 6.3.0
%define patchversion 6.3
%define pkgrelease 0.rc1.20230310git44889ba56cbb.19
%define pkgrelease 0.rc2.23
%define kversion 6
%define tarfile_release 6.3-rc1-106-g44889ba56cbb
%define tarfile_release 6.3-rc2
# This is needed to do merge window version magic
%define patchlevel 3
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc1.20230310git44889ba56cbb.19%{?buildid}%{?dist}
%define specrelease 0.rc2.23%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.3.0
@ -3362,6 +3362,18 @@ fi
#
#
%changelog
* Mon Mar 13 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc2.23]
- redhat: version two of Makefile.rhelver tweaks (Clark Williams)
* Mon Mar 13 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc2.22]
- Linux v6.3.0-0.rc2
* Sun Mar 12 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc1.81ff855485a3.21]
- Linux v6.3.0-0.rc1.81ff855485a3
* Sat Mar 11 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc1.ef5f68cc1f82.20]
- Linux v6.3.0-0.rc1.ef5f68cc1f82
* Fri Mar 10 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc1.44889ba56cbb.19]
- Linux v6.3.0-0.rc1.44889ba56cbb

View File

@ -1,7 +1,7 @@
Documentation/admin-guide/kernel-parameters.txt | 9 +
Kconfig | 2 +
Kconfig.redhat | 17 +
Makefile | 11 +-
Makefile | 16 +-
arch/arm/Kconfig | 4 +-
arch/arm64/Kconfig | 3 +-
arch/arm64/kernel/acpi.c | 4 +
@ -64,7 +64,7 @@
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
66 files changed, 1539 insertions(+), 189 deletions(-)
66 files changed, 1544 insertions(+), 189 deletions(-)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index 6221a1d057dd..90c169923eda 100644
@ -120,20 +120,25 @@ index 000000000000..effb81d04bfd
+
+endmenu
diff --git a/Makefile b/Makefile
index d7bd0eb9b346..43b6f18d37d0 100644
index c933ceb4f21d..6f9a92dee6fe 100644
--- a/Makefile
+++ b/Makefile
@@ -199,6 +199,9 @@ endif
this-makefile := $(lastword $(MAKEFILE_LIST))
abs_srctree := $(realpath $(dir $(this-makefile)))
@@ -22,6 +22,14 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
PHONY := __all
__all:
+# Set RHEL variables
+include $(abs_srctree)/Makefile.rhelver
+ifneq ($(realpath source),)
+include $(realpath source)/Makefile.rhelver
+else
+ifneq ($(realpath Makefile.rhelver),)
+include Makefile.rhelver
+endif
+endif
+
ifneq ($(words $(subst :, ,$(abs_srctree))), 1)
$(error source directory cannot contain spaces or colons)
endif
@@ -1335,7 +1338,13 @@ define filechk_version.h
# We are using a recursive build, so we need to do a little thinking
# to get the ordering right.
#
@@ -1335,7 +1343,13 @@ define filechk_version.h
((c) > 255 ? 255 : (c)))'; \
echo \#define LINUX_VERSION_MAJOR $(VERSION); \
echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \
@ -1697,10 +1702,10 @@ index 8e24ebcebfe5..25aa49292397 100644
{ MPI2_MFGPAGE_VENDORID_LSI, MPI25_MFGPAGE_DEVID_SAS3004,
PCI_ANY_ID, PCI_ANY_ID },
diff --git a/drivers/scsi/qla2xxx/qla_os.c b/drivers/scsi/qla2xxx/qla_os.c
index 545167627e48..fae959498d61 100644
index 80c4ee9df2a4..7f34a0966245 100644
--- a/drivers/scsi/qla2xxx/qla_os.c
+++ b/drivers/scsi/qla2xxx/qla_os.c
@@ -8074,6 +8074,7 @@ static const struct pci_error_handlers qla2xxx_err_handler = {
@@ -8082,6 +8082,7 @@ static const struct pci_error_handlers qla2xxx_err_handler = {
};
static struct pci_device_id qla2xxx_pci_tbl[] = {
@ -1708,7 +1713,7 @@ index 545167627e48..fae959498d61 100644
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2100) },
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2200) },
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2300) },
@@ -8086,13 +8087,18 @@ static struct pci_device_id qla2xxx_pci_tbl[] = {
@@ -8094,13 +8095,18 @@ static struct pci_device_id qla2xxx_pci_tbl[] = {
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8432) },
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5422) },
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5432) },

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.3-rc1-106-g44889ba56cbb.tar.xz) = 39d754a7e5cb8e2a1bcb915e786dd8b68be146f225feb9af3c3be1c4da191d1d49ad847b646da570b87787ffeda88eb39c81d5d9bc2c84ca80fa0c274bf27afb
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = edc30effccc6ddbcf2e41a43d6731b744549ab66060cd0c3e856f210915ed9be901c7337dabdec3aa65c00cc7a194f92649b5d3d0b204704adf53bf274fa7486
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = e269aa7b7f8c9729da6f9efd1d4c32f9e8b663be2eb8a5894c72491231a9b49ad6a14d0f498e1900e58c1619da278e79d72125b9ace202c1c9d1d9adfa5163df
SHA512 (linux-6.3-rc2.tar.xz) = 253957ef494697ef12584bff9316cbae4436b918e42f1b81d9a11d7e66a5e8162036c5ee0ff4d0cfc03defed71b3a2329b32990199530125d4eedd52204ebcda
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = 28d40d3d54fa53f3926246361d3dc076e5a36892e311094e90425ade9649ece555aec6ab28c504d8795f5056d1652eea22c1ad485e4d67c470a38da6333f98c7
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = e7fc2106b02c7ea5c8d2860a0ac25d1ed420984039a2f16e8fd2df9d0238314f57360c4db5da5f2353185b66a4c4022be9c34d5abb60d0001fa140e69fb7a56e