kernel-5.13.13-100

* Thu Aug 26 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.13-100]
- kernel-5.13.13-0 (Justin M. Forbes)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-08-26 11:49:50 -05:00
parent c1ddcd83ad
commit 11aa66943d
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
3 changed files with 43 additions and 14 deletions

View File

@ -116,7 +116,7 @@ Summary: The Linux kernel
# The kernel tarball/base version
%define kversion 5.13
%define rpmversion 5.13.12
%define rpmversion 5.13.13
%define stableversion 5.13
%define pkgrelease 100
@ -646,7 +646,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.13.12.tar.xz
Source0: linux-5.13.13.tar.xz
Source1: Makefile.rhelver
@ -1315,8 +1315,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.13.12 -c
mv linux-5.13.12 linux-%{KVERREL}
%setup -q -n kernel-5.13.13 -c
mv linux-5.13.13 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2886,8 +2886,37 @@ fi
#
#
%changelog
* Wed Aug 18 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.12-100]
- kernel-5.13.12-0 (Justin M. Forbes)
* Thu Aug 26 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.13-100]
- kernel-5.13.13-0 (Justin M. Forbes)
* Wed Aug 18 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.12-0]
- kernel-5.13.11-0 (Justin M. Forbes)
- bpf: Fix integer overflow involving bucket_size (Tatsuhiko Yasumatsu)
- kernel-5.13.10-0 (Justin M. Forbes)
- Fix up backport of Dell XPS 9710 quirk (Justin M. Forbes)
- ASoC: Intel: sof_sdw_max98373: remove useless inits (Pierre-Louis Bossart)
- ASoC: Intel: update sof_pcm512x quirks (Pierre-Louis Bossart)
- ASoC: SOF: Intel: Use DMI string to search for adl_mx98373_rt5682 variant (jairaj arava)
- ASoC: Intel: sof_sdw: add quirk for Dell XPS 9710 (Pierre-Louis Bossart)
- kernel-5.13.9-0 (Justin M. Forbes)
- drm/i915/dp: Use max params for older panels (Kai-Heng Feng)
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
- kernel-5.13.8-0 (Justin M. Forbes)
- Re-enable sermouse for x86 (rhbz 1974002) (Justin M. Forbes)
- Revert CRYPTO_ECDH and CRYPTO_ECDA from builtin to module to fix fips (Justin M. Forbes)
- drm/rockchip: remove existing generic drivers to take over the device (Javier Martinez Canillas)
- powerpc/pseries: Fix regression while building external modules (Srikar Dronamraju)
- kernel-5.13.7-0 (Justin M. Forbes)
- kernel-5.13.6-0 (Justin M. Forbes)
- kernel-5.13.5-0 (Justin M. Forbes)
- iwlwifi Add support for ax201 in Samsung Galaxy Book Flex2 Alpha (Justin M. Forbes)
- Revert "usb: renesas-xhci: Fix handling of unknown ROM state" (Justin M. Forbes)
- RHEL configs need this too (Justin M. Forbes)
- kernel-5.13.4-0 (Justin M. Forbes)
- Config update for 5.13.4 (Justin M. Forbes)
- kernel-5.13.3-0 (Justin M. Forbes)
- Don't tag a release as [redhat] (Justin M. Forbes)
- platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd() (Yang Yingliang)
* Tue Aug 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.13.11-0]
- bpf: Fix integer overflow involving bucket_size (Tatsuhiko Yasumatsu)

View File

@ -97,7 +97,7 @@ index 75a9dd98e76e..3ff3291551f9 100644
Boot into System Kernel
diff --git a/Makefile b/Makefile
index 2458a4abcbcc..93ddceb5d254 100644
index ed4031db3894..feffc231bdd3 100644
--- a/Makefile
+++ b/Makefile
@@ -508,6 +508,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -1383,7 +1383,7 @@ index 258d5fe3d395..f7298e3dc8f3 100644
if (data->f01_container->dev.driver) {
/* Driver already bound, so enable ATTN now. */
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index 808ab70d5df5..2a92c1c26326 100644
index db966a7841fe..8ae7a008b06f 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -7,6 +7,7 @@
@ -1394,7 +1394,7 @@ index 808ab70d5df5..2a92c1c26326 100644
#include <linux/kernel.h>
#include <linux/bug.h>
#include <linux/types.h>
@@ -3036,6 +3037,27 @@ u32 iommu_sva_get_pasid(struct iommu_sva *handle)
@@ -3039,6 +3040,27 @@ u32 iommu_sva_get_pasid(struct iommu_sva *handle)
}
EXPORT_SYMBOL_GPL(iommu_sva_get_pasid);
@ -1505,10 +1505,10 @@ index d963f25fc7ae..66455e2261d0 100644
* Some systems use a bios work around to ask for D3 on
* platforms that support kernel managed suspend.
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
index 6d74386eadc2..2333c1e4ae05 100644
index ab3de1551b50..7bc8ebb58d35 100644
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
@@ -4230,6 +4230,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
@@ -4231,6 +4231,30 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9000,
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_BROADCOM, 0x9084,
quirk_bridge_cavm_thrx2_pcie_root);

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.13.12.tar.xz) = faf3845a0a6e3c34c6562487ac330d81a3cfc117a1efb667fd6703b8a716e92e95ee1525920d28c75d5c4d1533a72c8e3cc8a91da21ceceb47ca5167cc203466
SHA512 (kernel-abi-whitelists-5.13.12-100.tar.bz2) = d9b0c77c082f46aa391e80dc0fa1a48f8b9b35e169857f597ef4fdc39070fcfa97cbd318106765407c3cf3f3c02e7122b93224078a8c93251b6403304b140eb3
SHA512 (kernel-kabi-dw-5.13.12-100.tar.bz2) = 783a284a0f95343a11164ed3e4457a0af12ca54b2ef0b386c927b5a9b656a4a45169509f273a395e9d27dfc0ab46744e1e3e821a1deb2d69191840cc2bc7a085
SHA512 (linux-5.13.13.tar.xz) = 4f2d45feedde8010485cf44f7d6bc4346fbc7fd4a3af225f4304408e2e8188f3c60d4eef3cb1cbea4ff8f8372a573b0bb00054012d93a668bfd494b9e8f29703
SHA512 (kernel-abi-whitelists-5.13.13-100.tar.bz2) = 6b29454d9a667890c55bce2aa7c0e98feee305e5fa2d960fbf23a22450a61ceb565a1aedbdb7ca5a327c591ade529dcefa6fdcd42f916008597d5f9f5920aeb2
SHA512 (kernel-kabi-dw-5.13.13-100.tar.bz2) = 405ad608e36e10c1afc2a4f10fac651bc925d9ae05f672d6251649d6eda6662a4521b4e47e6d93b95bd275f881c48ee7e7831481d6e366fe1c98e9cebdd72610