kernel-5.18.0-0.rc0.e8b767f5e04097a.14

* Fri Apr 01 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc0.e8b767f5e04097a.14]
- redhat/kernel.spec.template: Fix intel-speed-select compile (Prarit Bhargava)
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2022-04-01 09:14:51 -05:00
parent 82f396ee1c
commit 11a9e693e1
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
17 changed files with 58 additions and 30 deletions

View File

@ -12,7 +12,7 @@ RHEL_MINOR = 99
#
# Use this spot to avoid future merge conflicts.
# Do not trim this comment.
RHEL_RELEASE = 14
RHEL_RELEASE = 15
#
# Early y+1 numbering

View File

@ -1,5 +1,5 @@
"https://gitlab.com/cki-project/kernel-ark/-/commit"/ffcd4b99fd9e12abd9f05dc2b2e10ee9a11fe86d
ffcd4b99fd9e12abd9f05dc2b2e10ee9a11fe86d mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
"https://gitlab.com/cki-project/kernel-ark/-/commit"/0355e4885dfcc26b3691fa04c0072cfabd5beb5f
0355e4885dfcc26b3691fa04c0072cfabd5beb5f mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
"https://gitlab.com/cki-project/kernel-ark/-/commit"/8e648aae90c1d739b5ead43fb84c2cae550a8344
8e648aae90c1d739b5ead43fb84c2cae550a8344 Fix up rng merge

View File

@ -8539,6 +8539,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
CONFIG_VIRTIO_IOMMU=y
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -8512,6 +8512,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
CONFIG_VIRTIO_IOMMU=y
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -8787,6 +8787,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -8761,6 +8761,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -8530,6 +8530,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -8504,6 +8504,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7315,6 +7315,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7288,6 +7288,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7270,6 +7270,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7243,6 +7243,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7710,7 +7710,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
CONFIG_VIRTIO_MEM=m
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -7684,7 +7684,7 @@ CONFIG_VIRTIO_CONSOLE=m
CONFIG_VIRTIO_FS=m
CONFIG_VIRTIO_INPUT=m
# CONFIG_VIRTIO_IOMMU is not set
CONFIG_VIRTIO_MEM=m
# CONFIG_VIRTIO_MEM is not set
CONFIG_VIRTIO_MENU=y
# CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES is not set
CONFIG_VIRTIO_MMIO=m

View File

@ -87,7 +87,7 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 0
%global distro_build 0.rc0.20220331gitb4a5ea09b293.14
%global distro_build 0.rc0.20220401gite8b767f5e04097a.15
%if 0%{?fedora}
%define secure_boot_arch x86_64
@ -132,13 +132,13 @@ Summary: The Linux kernel
%define rpmversion 5.18.0
%define patchversion 5.18
%define pkgrelease 0.rc0.20220331gitb4a5ea09b293.14
%define pkgrelease 0.rc0.20220401gite8b767f5e04097a.15
# This is needed to do merge window version magic
%define patchlevel 18
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 0.rc0.20220331gitb4a5ea09b293.14%{?buildid}%{?dist}
%define specrelease 0.rc0.20220401gite8b767f5e04097a.15%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@ -698,7 +698,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.17-13532-gb4a5ea09b293.tar.xz
Source0: linux-5.17-13673-ge8b767f5e04097a.tar.xz
Source1: Makefile.rhelver
@ -1390,8 +1390,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.17-13532-gb4a5ea09b293 -c
mv linux-5.17-13532-gb4a5ea09b293 linux-%{KVERREL}
%setup -q -n kernel-5.17-13673-ge8b767f5e04097a -c
mv linux-5.17-13673-ge8b767f5e04097a linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -3018,11 +3018,21 @@ fi
#
#
%changelog
* Thu Mar 31 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc0.b4a5ea09b293.13]
- Add clk_test and clk-gate_test to mod-internal.list (Justin M. Forbes)
* Fri Apr 01 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc0.e8b767f5e04097a.14]
- redhat/kernel.spec.template: Fix intel-speed-select compile (Prarit Bhargava)
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
* Fri Apr 01 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc0.e8b767f5e04097a.13]
- Add clk_test and clk-gate_test to mod-internal.list (Justin M. Forbes)
- redhat/self-tests: Ignore UPSTREAM (Prarit Bhargava)
- redhat/self-tests: Ignore RHGITURL (Prarit Bhargava)
- redhat/Makefile.variables: Extend git hash length to 15 (Prarit Bhargava)
- redhat/self-test: Remove changelog from spec files (Prarit Bhargava)
- redhat/genspec.sh: Rearrange genspec.sh (Prarit Bhargava)
- redhat/self-test: Add spec file data (Prarit Bhargava)
- redhat/self-test: Add better dist-dump-variables test (Prarit Bhargava)
- redhat/self-test: Add variable test data (Prarit Bhargava)
* Wed Mar 30 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc0.d888c83fcec7.10]
- redhat/config: Remove obsolete CONFIG_MFD_INTEL_PMT (David Arcari)
- redhat/configs: enable CONFIG_INTEL_ISHTP_ECLITE (David Arcari)

View File

@ -51,7 +51,7 @@
include/linux/kernel.h | 19 +
include/linux/lsm_hook_defs.h | 2 +
include/linux/lsm_hooks.h | 6 +
include/linux/mmzone.h | 4 +-
include/linux/mmzone.h | 11 +-
include/linux/module.h | 1 +
include/linux/panic.h | 19 +-
include/linux/pci.h | 16 +
@ -74,13 +74,13 @@
security/lockdown/Kconfig | 13 +
security/lockdown/lockdown.c | 1 +
security/security.c | 6 +
76 files changed, 1729 insertions(+), 191 deletions(-)
76 files changed, 1735 insertions(+), 192 deletions(-)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index b7ccaa2ea867..bc58b9348bb8 100644
index 3f1cc5e317ed..fbc0870dd787 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -6077,6 +6077,15 @@
@@ -6083,6 +6083,15 @@
unknown_nmi_panic
[X86] Cause panic on unknown NMI.
@ -657,7 +657,7 @@ index c59265146e9c..caa8458edde2 100644
rv = ipmi_register_driver();
mutex_unlock(&ipmi_interfaces_mutex);
diff --git a/drivers/char/random.c b/drivers/char/random.c
index 66ce7c03a142..e6c0d7e119c7 100644
index 1d8242969751..ce626cbe3390 100644
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -52,6 +52,7 @@
@ -690,7 +690,7 @@ index 66ce7c03a142..e6c0d7e119c7 100644
/*
* Returns whether or not the input pool has been seeded and thus guaranteed
* to supply cryptographically secure random numbers. This applies to: the
@@ -575,6 +584,63 @@ static ssize_t get_random_bytes_user(void __user *buf, size_t nbytes)
@@ -576,6 +585,63 @@ static ssize_t get_random_bytes_user(void __user *buf, size_t nbytes)
return ret;
}
@ -754,7 +754,7 @@ index 66ce7c03a142..e6c0d7e119c7 100644
/*
* Batched entropy returns random integers. The quality of the random
* number is good as /dev/urandom. In order to ensure that the randomness
@@ -1167,6 +1233,19 @@ void add_bootloader_randomness(const void *buf, size_t size)
@@ -1179,6 +1245,19 @@ void add_bootloader_randomness(const void *buf, size_t size)
}
EXPORT_SYMBOL_GPL(add_bootloader_randomness);
@ -774,7 +774,7 @@ index 66ce7c03a142..e6c0d7e119c7 100644
#if IS_ENABLED(CONFIG_VMGENID)
static BLOCKING_NOTIFIER_HEAD(vmfork_chain);
@@ -1454,6 +1533,9 @@ static void try_to_generate_entropy(void)
@@ -1466,6 +1545,9 @@ static void try_to_generate_entropy(void)
SYSCALL_DEFINE3(getrandom, char __user *, buf, size_t, count, unsigned int,
flags)
{
@ -784,7 +784,7 @@ index 66ce7c03a142..e6c0d7e119c7 100644
if (flags & ~(GRND_NONBLOCK | GRND_RANDOM | GRND_INSECURE))
return -EINVAL;
@@ -1467,6 +1549,18 @@ SYSCALL_DEFINE3(getrandom, char __user *, buf, size_t, count, unsigned int,
@@ -1479,6 +1561,18 @@ SYSCALL_DEFINE3(getrandom, char __user *, buf, size_t, count, unsigned int,
if (count > INT_MAX)
count = INT_MAX;
@ -803,7 +803,7 @@ index 66ce7c03a142..e6c0d7e119c7 100644
if (!(flags & GRND_INSECURE) && !crng_ready()) {
int ret;
@@ -1620,6 +1714,7 @@ static int random_fasync(int fd, struct file *filp, int on)
@@ -1632,6 +1726,7 @@ static int random_fasync(int fd, struct file *filp, int on)
}
const struct file_operations random_fops = {
@ -2261,22 +2261,30 @@ index 419b5febc3ca..491323dfe4e0 100644
*
* @perf_event_open:
diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
index 962b14d403e8..8a89efe47571 100644
index 962b14d403e8..46ffab808f03 100644
--- a/include/linux/mmzone.h
+++ b/include/linux/mmzone.h
@@ -1398,11 +1398,9 @@ static inline unsigned long *section_to_usemap(struct mem_section *ms)
@@ -1397,13 +1397,16 @@ static inline unsigned long *section_to_usemap(struct mem_section *ms)
static inline struct mem_section *__nr_to_section(unsigned long nr)
{
+ unsigned long root = SECTION_NR_TO_ROOT(nr);
+
+ if (unlikely(root >= NR_SECTION_ROOTS))
+ return NULL;
+
#ifdef CONFIG_SPARSEMEM_EXTREME
- if (!mem_section)
+ if (!mem_section || !mem_section[SECTION_NR_TO_ROOT(nr)])
+ if (!mem_section || !mem_section[root])
return NULL;
#endif
- if (!mem_section[SECTION_NR_TO_ROOT(nr)])
- return NULL;
return &mem_section[SECTION_NR_TO_ROOT(nr)][nr & SECTION_ROOT_MASK];
- return &mem_section[SECTION_NR_TO_ROOT(nr)][nr & SECTION_ROOT_MASK];
+ return &mem_section[root][nr & SECTION_ROOT_MASK];
}
extern size_t mem_section_usage_size(void);
diff --git a/include/linux/module.h b/include/linux/module.h
index 1e135fd5c076..6ec4d001c1e2 100644
--- a/include/linux/module.h

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.17-13532-gb4a5ea09b293.tar.xz) = d7a7bcc4504b05d917dd57369e76a66f4d6be10205ada9e1e310688c06d616c0d6eba93493c30b4fd5a06ad5525a34501c6460bc38cb08edad45286b5e3bc60a
SHA512 (kernel-abi-stablelists-5.18.0-0.rc0.20220331gitb4a5ea09b293.14.tar.bz2) = 380b854341131fa3fa13a217e23897f45d9225061e4f9e36c350416d8126fc0d0d09b34ed38f52abece9e9919fd86af66f8868ec79beffb8505a5db04356d36f
SHA512 (kernel-kabi-dw-5.18.0-0.rc0.20220331gitb4a5ea09b293.14.tar.bz2) = 67760b3032a42da3fe6e4964dc4611fdaed8df304e52520a60c070e2e7d55d7c9b1f44fc7a1f1f9150d78711b52e9901ee2c7ca79bf29100fb9abfec9a950b29
SHA512 (linux-5.17-13673-ge8b767f5e04097a.tar.xz) = f58596518cf31665cce79c81eb8bf54cd3f01990c4a4bf0a68605daa319e250eec241a459aaae68e9a6d82a81f7cdab908d7a4e841b32ac7281834e0f9c9a243
SHA512 (kernel-abi-stablelists-5.18.0-0.rc0.20220401gite8b767f5e04097a.15.tar.bz2) = 9d0ee0c38b5dcba9a468a61e25c64832548c68f2459313a9714bc85682f0078bea58274860781d683d5d9fe84c2d9b95165d6b8f1bac914839f13c933c819f2a
SHA512 (kernel-kabi-dw-5.18.0-0.rc0.20220401gite8b767f5e04097a.15.tar.bz2) = 20b26ad7ff0e16f2406dc6ac35483591a83efe350659075e247caabb69bd7b0ac6ff0a4be6525958e8275d93b5b8c5dbcf52723f36cea69347fa2130647b3c77