Linux v5.2-rc3
This commit is contained in:
parent
4bf08358b0
commit
0b354a2cfe
2
gitrev
2
gitrev
@ -1 +1 @@
|
|||||||
bec7550cca106c3ccc061e3e625516af63054fe4
|
f2c7c76c5d0a443053e94adb9f0918fa2fb85c3a
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 2
|
%global rcrev 3
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 5.%{upstream_sublevel}.0
|
%define rpmversion 5.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -576,7 +576,6 @@ Patch508: KEYS-Make-use-of-platform-keyring-for-module-signature.patch
|
|||||||
Patch524: net-vhost_net-fix-possible-infinite-loop.patch
|
Patch524: net-vhost_net-fix-possible-infinite-loop.patch
|
||||||
|
|
||||||
# build fix
|
# build fix
|
||||||
Patch526: s390-mark-__cpacf_check_opcode-and-cpacf_query_func-as-__always_inline.patch
|
|
||||||
Patch527: v2-powerpc-mm-mark-more-tlb-functions-as-__always_inline.patch
|
Patch527: v2-powerpc-mm-mark-more-tlb-functions-as-__always_inline.patch
|
||||||
|
|
||||||
Patch530: crypto-ghash-fix-unaligned-memory-access-in-ghash_setkey.patch
|
Patch530: crypto-ghash-fix-unaligned-memory-access-in-ghash_setkey.patch
|
||||||
@ -1819,6 +1818,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 03 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.2.0-0.rc3.git0.1
|
||||||
|
- Linux v5.2-rc3
|
||||||
|
|
||||||
* Mon Jun 03 2019 Justin M. Forbes <jforbes@fedoraproject.org>
|
* Mon Jun 03 2019 Justin M. Forbes <jforbes@fedoraproject.org>
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
|
||||||
|
@ -1,105 +0,0 @@
|
|||||||
From patchwork Fri May 17 06:54:24 2019
|
|
||||||
Content-Type: text/plain; charset="utf-8"
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Transfer-Encoding: 7bit
|
|
||||||
X-Patchwork-Submitter: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
||||||
X-Patchwork-Id: 1075092
|
|
||||||
Return-Path: <SRS0=M1fl=TR=vger.kernel.org=linux-kernel-owner@kernel.org>
|
|
||||||
Received: from mail.kernel.org (mail.kernel.org [198.145.29.99])
|
|
||||||
by smtp.lore.kernel.org (Postfix) with ESMTP id 5FC95C04AB4
|
|
||||||
for <linux-kernel@archiver.kernel.org>; Fri, 17 May 2019 06:55:12 +0000 (UTC)
|
|
||||||
Received: from vger.kernel.org (vger.kernel.org [209.132.180.67])
|
|
||||||
by mail.kernel.org (Postfix) with ESMTP id 3103B20848
|
|
||||||
for <linux-kernel@archiver.kernel.org>; Fri, 17 May 2019 06:55:12 +0000 (UTC)
|
|
||||||
Authentication-Results: mail.kernel.org;
|
|
||||||
dkim=pass (2048-bit key) header.d=nifty.com header.i=@nifty.com
|
|
||||||
header.b="Q2VtVae6"
|
|
||||||
Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
|
|
||||||
id S1728126AbfEQGzL (ORCPT
|
|
||||||
<rfc822;linux-kernel@archiver.kernel.org>);
|
|
||||||
Fri, 17 May 2019 02:55:11 -0400
|
|
||||||
Received: from conuserg-12.nifty.com ([210.131.2.79]:40958 "EHLO
|
|
||||||
conuserg-12.nifty.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org
|
|
||||||
with ESMTP id S1727694AbfEQGzK (ORCPT
|
|
||||||
<rfc822;linux-kernel@vger.kernel.org>);
|
|
||||||
Fri, 17 May 2019 02:55:10 -0400
|
|
||||||
Received: from localhost.localdomain (p14092-ipngnfx01kyoto.kyoto.ocn.ne.jp
|
|
||||||
[153.142.97.92]) (authenticated)
|
|
||||||
by conuserg-12.nifty.com with ESMTP id x4H6sQI1006236;
|
|
||||||
Fri, 17 May 2019 15:54:26 +0900
|
|
||||||
DKIM-Filter: OpenDKIM Filter v2.10.3 conuserg-12.nifty.com x4H6sQI1006236
|
|
||||||
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=nifty.com;
|
|
||||||
s=dec2015msa; t=1558076066;
|
|
||||||
bh=/BYTJ4zxnc9ql4xZQk+WJLrlDFM4qCpFxkd8pJzLb9c=;
|
|
||||||
h=From:To:Cc:Subject:Date:From;
|
|
||||||
b=Q2VtVae6Ee0HybhaWXSMg69y6q1arF8Sf/3u/XHMZTCPOpMB44H54BKHkbXrOYYN4
|
|
||||||
sTyqKSVgGlNw7oPey6yYOSC6lOjkiel9mhOBKa/MRcGpXQ1EeRKhiJD9ciFZUJU5lo
|
|
||||||
qG5n3KT7Slc5xaDZohnfycTLEiaOSVGvd85a6BlWsNry0dKe4AR1DBIFR3kjMMSag7
|
|
||||||
ZEesarqfo0ZgWtXj9pt5ZSerrlX1EaZCLvJ3hArzEcceGum0qQRT0+XWSGTEGlPjId
|
|
||||||
aZrU4OYTFZusbiPR43kGBDWduFx1qFAPX8BlT63J0EzHwxFepnxOG46QCvqob91ugR
|
|
||||||
QTZCX5d2BYNbA==
|
|
||||||
X-Nifty-SrcIP: [153.142.97.92]
|
|
||||||
From: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
||||||
To: Martin Schwidefsky <schwidefsky@de.ibm.com>,
|
|
||||||
Heiko Carstens <heiko.carstens@de.ibm.com>,
|
|
||||||
linux-s390@vger.kernel.org
|
|
||||||
Cc: Arnd Bergmann <arnd@arndb.de>, Laura Abbott <labbott@redhat.com>,
|
|
||||||
Masahiro Yamada <yamada.masahiro@socionext.com>,
|
|
||||||
linux-kernel@vger.kernel.org,
|
|
||||||
Andrew Morton <akpm@linux-foundation.org>
|
|
||||||
Subject: [PATCH] s390: mark __cpacf_check_opcode() and cpacf_query_func() as
|
|
||||||
__always_inline
|
|
||||||
Date: Fri, 17 May 2019 15:54:24 +0900
|
|
||||||
Message-Id: <20190517065424.24453-1-yamada.masahiro@socionext.com>
|
|
||||||
X-Mailer: git-send-email 2.17.1
|
|
||||||
Sender: linux-kernel-owner@vger.kernel.org
|
|
||||||
Precedence: bulk
|
|
||||||
List-ID: <linux-kernel.vger.kernel.org>
|
|
||||||
X-Mailing-List: linux-kernel@vger.kernel.org
|
|
||||||
|
|
||||||
Commit e60fb8bf68d4 ("s390/cpacf: mark scpacf_query() as __always_inline")
|
|
||||||
was not enough to make sure to meet the 'i' (immediate) constraint for the
|
|
||||||
asm operands.
|
|
||||||
|
|
||||||
With CONFIG_OPTIMIZE_INLINING enabled, Laura Abbott reported error
|
|
||||||
with gcc 9.1.1:
|
|
||||||
|
|
||||||
In file included from arch/s390/crypto/prng.c:29:
|
|
||||||
./arch/s390/include/asm/cpacf.h: In function 'cpacf_query_func':
|
|
||||||
./arch/s390/include/asm/cpacf.h:170:2: warning: asm operand 3 probably doesn't match constraints
|
|
||||||
170 | asm volatile(
|
|
||||||
| ^~~
|
|
||||||
./arch/s390/include/asm/cpacf.h:170:2: error: impossible constraint in 'asm'
|
|
||||||
|
|
||||||
Add more __always_inline to force inlining.
|
|
||||||
|
|
||||||
Fixes: 9012d011660e ("compiler: allow all arches to enable CONFIG_OPTIMIZE_INLINING")
|
|
||||||
Reported-by: Laura Abbott <labbott@redhat.com>
|
|
||||||
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
||||||
---
|
|
||||||
|
|
||||||
arch/s390/include/asm/cpacf.h | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/s390/include/asm/cpacf.h b/arch/s390/include/asm/cpacf.h
|
|
||||||
index f316de40e51b..19459dfb4295 100644
|
|
||||||
--- a/arch/s390/include/asm/cpacf.h
|
|
||||||
+++ b/arch/s390/include/asm/cpacf.h
|
|
||||||
@@ -177,7 +177,7 @@ static inline void __cpacf_query(unsigned int opcode, cpacf_mask_t *mask)
|
|
||||||
: "cc");
|
|
||||||
}
|
|
||||||
|
|
||||||
-static inline int __cpacf_check_opcode(unsigned int opcode)
|
|
||||||
+static __always_inline int __cpacf_check_opcode(unsigned int opcode)
|
|
||||||
{
|
|
||||||
switch (opcode) {
|
|
||||||
case CPACF_KMAC:
|
|
||||||
@@ -217,7 +217,7 @@ static inline int cpacf_test_func(cpacf_mask_t *mask, unsigned int func)
|
|
||||||
return (mask->bytes[func >> 3] & (0x80 >> (func & 7))) != 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
-static inline int cpacf_query_func(unsigned int opcode, unsigned int func)
|
|
||||||
+static __always_inline int cpacf_query_func(unsigned int opcode, unsigned int func)
|
|
||||||
{
|
|
||||||
cpacf_mask_t mask;
|
|
||||||
|
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
|||||||
SHA512 (linux-5.1.tar.xz) = ae96f347badc95f1f3acf506c52b6cc23c0bd09ce8f4ce6705d4b4058b62593059bba1bc603c8d8b00a2f19131e7e56c31ac62b45883a346fa61d655e178f236
|
SHA512 (linux-5.1.tar.xz) = ae96f347badc95f1f3acf506c52b6cc23c0bd09ce8f4ce6705d4b4058b62593059bba1bc603c8d8b00a2f19131e7e56c31ac62b45883a346fa61d655e178f236
|
||||||
SHA512 (patch-5.2-rc2.xz) = 6c79dcdb017153aaafda91eb8c978f30c1788c92405a47d5616a8053a628b74ab703e606aee857ec22e56b70bfc26bacb94dd43aa0ad23aca577d852be0f9edd
|
SHA512 (patch-5.2-rc3.xz) = 0d412178769defc6f4da5bba057a0e4f1330b2d87fd08b8554598d8cd802c1edbc68d58acf5af1c2d4777609feb25aee1963d7154572ec4b2a30ca36b9d07adc
|
||||||
SHA512 (patch-5.2-rc2-git1.xz) = a9ccb31eda71748205402cf3d3b05a25a0c53ce4cdddd9824282659402e19d6d33b40f2e60f4a8acf84b428a9117ec80f2dd2ead61db5e3d13105d6f383ab791
|
|
||||||
|
Loading…
Reference in New Issue
Block a user