Fix erroneously installed .o files in python-perf subpackage (rhbz 1312102)

This commit is contained in:
Josh Boyer 2016-02-29 08:26:54 -05:00
parent b71532b6ec
commit 09ce3a3c29
2 changed files with 77 additions and 0 deletions

View File

@ -608,6 +608,9 @@ Patch647: 0001-vsock-Fix-blocking-ops-call-in-prepare_to_wait.patch
#rhbz 1309658
Patch648: 0001-mm-CONFIG_NR_ZONES_EXTENDED.patch
#rhbz 1312102
Patch649: perf-tools-Fix-python-extension-build.patch
# END OF PATCH DEFINITIONS
%endif
@ -2127,6 +2130,9 @@ fi
#
#
%changelog
* Mon Feb 29 2016 Josh Boyer <jwboyer@fedoraproject.org>
- Fix erroneously installed .o files in python-perf subpackage (rhbz 1312102)
* Thu Feb 25 2016 Laura Abbott <labbott@fedoraproject.org>
- Re-enable ZONE_DMA (rhbz 1309658)

View File

@ -0,0 +1,71 @@
From 99b0044d511e16fb373df6d8a4e011d4804432c4 Mon Sep 17 00:00:00 2001
From: Jiri Olsa <jolsa@redhat.com>
Date: Sat, 27 Feb 2016 21:21:12 +0100
Subject: [PATCH] perf tools: Fix python extension build
On Fri, Feb 26, 2016 at 11:59:03PM +0100, Jiri Olsa wrote:
> On Fri, Feb 26, 2016 at 05:49:02PM -0500, Josh Boyer wrote:
>
> SNIP
>
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/evsel.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/trace-event.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/xyarray.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/python.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/ctype.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/cgroup.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/rblist.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/perf/util/string.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/lib
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/lib/hweight.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/lib/rbtree.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/lib/bitmap.o
> > > ./python_ext_build/tmp/home/jolsa/kernel/linux-perf/tools/lib/find_bit.o
> > >
> > > not sure we want to come up with some 'nicer' solution
> >
> > I don't think anything under python_ext_build/tmp/ actually matters in
> > any significant way. As long as this doesn't negatively impact
> > something via side-effect, it's probably good enough.
>
> right, and it's probably generic sollution too
>
> >
> > Will you write up a full patch?
>
> yep, will post it tomorrow
>
> jirka
sending full patch
jirka
---
tools/perf/util/setup.py | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tools/perf/util/setup.py b/tools/perf/util/setup.py
index 1833103768cb..c8680984d2d6 100644
--- a/tools/perf/util/setup.py
+++ b/tools/perf/util/setup.py
@@ -22,6 +22,7 @@ cflags = getenv('CFLAGS', '').split()
# switch off several checks (need to be at the end of cflags list)
cflags += ['-fno-strict-aliasing', '-Wno-write-strings', '-Wno-unused-parameter' ]
+src_perf = getenv('srctree') + '/tools/perf'
build_lib = getenv('PYTHON_EXTBUILD_LIB')
build_tmp = getenv('PYTHON_EXTBUILD_TMP')
libtraceevent = getenv('LIBTRACEEVENT')
@@ -30,6 +31,9 @@ libapikfs = getenv('LIBAPI')
ext_sources = [f.strip() for f in file('util/python-ext-sources')
if len(f.strip()) > 0 and f[0] != '#']
+# use full paths with source files
+ext_sources = map(lambda x: '%s/%s' % (src_perf, x) , ext_sources)
+
perf = Extension('perf',
sources = ext_sources,
include_dirs = ['util/include'],
--
2.5.0