kernel-6.5.3-300

* Wed Sep 13 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.5.3-0]
- Revert "misc: rtsx: judge ASPM Mode to set PETXCFG Reg" (Justin M. Forbes)
- Config updates for 6.5.3 (Justin M. Forbes)
- Fix up buildReqs for UKI (Justin M. Forbes)
- Linux v6.5.3
Resolves:

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2023-09-13 07:03:15 -05:00
parent 3013c5c192
commit 07eb7fc475
No known key found for this signature in database
GPG Key ID: B8FA7924A4B1C140
3 changed files with 143 additions and 208 deletions

View File

@ -160,18 +160,18 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
%define specrpmversion 6.5.2
%define specversion 6.5.2
%define specrpmversion 6.5.3
%define specversion 6.5.3
%define patchversion 6.5
%define pkgrelease 301
%define pkgrelease 300
%define kversion 6
%define tarfile_release 6.5.2
%define tarfile_release 6.5.3
# This is needed to do merge window version magic
%define patchlevel 5
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 301%{?buildid}%{?dist}
%define specrelease 300%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.5.2
%define kabiversion 6.5.3
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@ -3702,10 +3702,11 @@ fi\
#
#
%changelog
* Mon Sep 11 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.5.2-301]
* Wed Sep 13 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.5.3-0]
- Revert "misc: rtsx: judge ASPM Mode to set PETXCFG Reg" (Justin M. Forbes)
- Config updates for 6.5.3 (Justin M. Forbes)
- Fix up buildReqs for UKI (Justin M. Forbes)
- Linux v6.5.3
* Wed Sep 06 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.5.2-0]
- Move squashfs to kernel-modules-core (Justin M. Forbes)

View File

@ -9,12 +9,10 @@
drivers/ata/libahci.c | 18 +++
drivers/char/ipmi/ipmi_dmi.c | 15 +++
drivers/char/ipmi/ipmi_msghandler.c | 16 ++-
drivers/char/tpm/tpm_crb.c | 33 ++----
drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/efi.c | 124 +++++++++++++++------
drivers/firmware/efi/secureboot.c | 38 +++++++
drivers/firmware/sysfb.c | 18 ++-
drivers/gpu/drm/msm/adreno/adreno_device.c | 2 +-
drivers/hid/hid-rmi.c | 66 -----------
drivers/hwtracing/coresight/coresight-etm4x-core.c | 19 ++++
drivers/input/rmi4/rmi_driver.c | 124 ++++++++++++---------
@ -41,10 +39,10 @@
security/lockdown/Kconfig | 13 +++
security/lockdown/lockdown.c | 1 +
security/security.c | 12 ++
43 files changed, 581 insertions(+), 216 deletions(-)
41 files changed, 572 insertions(+), 190 deletions(-)
diff --git a/Makefile b/Makefile
index c47558bc00aa..ed7450da2c78 100644
index 901cdfa5e7d3..8ca0b56a75cc 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,18 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
@ -79,10 +77,10 @@ index b0d00032479d..afb9544fb007 100644
/*
* DIAG 308 support
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
index 85a00d97a314..bbb1c69afb62 100644
index dfcb2b563e2b..29e3f1b4bd00 100644
--- a/arch/s390/kernel/ipl.c
+++ b/arch/s390/kernel/ipl.c
@@ -2533,3 +2533,8 @@ int ipl_report_free(struct ipl_report *report)
@@ -2535,3 +2535,8 @@ int ipl_report_free(struct ipl_report *report)
}
#endif
@ -332,57 +330,6 @@ index 186f1fee7534..93e3a76596ff 100644
mutex_lock(&ipmi_interfaces_mutex);
rv = ipmi_register_driver();
mutex_unlock(&ipmi_interfaces_mutex);
diff --git a/drivers/char/tpm/tpm_crb.c b/drivers/char/tpm/tpm_crb.c
index 9eb1a1859012..a5dbebb1acfc 100644
--- a/drivers/char/tpm/tpm_crb.c
+++ b/drivers/char/tpm/tpm_crb.c
@@ -463,28 +463,6 @@ static bool crb_req_canceled(struct tpm_chip *chip, u8 status)
return (cancel & CRB_CANCEL_INVOKE) == CRB_CANCEL_INVOKE;
}
-static int crb_check_flags(struct tpm_chip *chip)
-{
- u32 val;
- int ret;
-
- ret = crb_request_locality(chip, 0);
- if (ret)
- return ret;
-
- ret = tpm2_get_tpm_pt(chip, TPM2_PT_MANUFACTURER, &val, NULL);
- if (ret)
- goto release;
-
- if (val == 0x414D4400U /* AMD */)
- chip->flags |= TPM_CHIP_FLAG_HWRNG_DISABLED;
-
-release:
- crb_relinquish_locality(chip, 0);
-
- return ret;
-}
-
static const struct tpm_class_ops tpm_crb = {
.flags = TPM_OPS_AUTO_STARTUP,
.status = crb_status,
@@ -826,9 +804,14 @@ static int crb_acpi_add(struct acpi_device *device)
if (rc)
goto out;
- rc = crb_check_flags(chip);
- if (rc)
- goto out;
+#ifdef CONFIG_X86
+ /* A quirk for https://www.amd.com/en/support/kb/faq/pa-410 */
+ if (boot_cpu_data.x86_vendor == X86_VENDOR_AMD &&
+ priv->sm != ACPI_TPM2_COMMAND_BUFFER_WITH_PLUTON) {
+ dev_info(dev, "Disabling hwrng\n");
+ chip->flags |= TPM_CHIP_FLAG_HWRNG_DISABLED;
+ }
+#endif /* CONFIG_X86 */
rc = tpm_chip_register(chip);
diff --git a/drivers/firmware/efi/Makefile b/drivers/firmware/efi/Makefile
index e489fefd23da..f2dfae764fb5 100644
--- a/drivers/firmware/efi/Makefile
@ -620,19 +567,6 @@ index 82fcfd29bc4d..17b7e096b682 100644
pd = sysfb_create_simplefb(si, &mode);
if (!IS_ERR(pd))
goto unlock_mutex;
diff --git a/drivers/gpu/drm/msm/adreno/adreno_device.c b/drivers/gpu/drm/msm/adreno/adreno_device.c
index ce8d0b2475bf..6e3c1368c5e1 100644
--- a/drivers/gpu/drm/msm/adreno/adreno_device.c
+++ b/drivers/gpu/drm/msm/adreno/adreno_device.c
@@ -371,7 +371,7 @@ static const struct adreno_info gpulist[] = {
.rev = ADRENO_REV(6, 9, 0, ANY_ID),
.fw = {
[ADRENO_FW_SQE] = "a660_sqe.fw",
- [ADRENO_FW_GMU] = "a690_gmu.bin",
+ [ADRENO_FW_GMU] = "a660_gmu.bin",
},
.gmem = SZ_4M,
.inactive_period = DRM_MSM_INACTIVE_PERIOD,
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
index 84e7ba5314d3..efc96776f761 100644
--- a/drivers/hid/hid-rmi.c
@ -979,7 +913,7 @@ index 258d5fe3d395..f7298e3dc8f3 100644
if (data->f01_container->dev.driver) {
/* Driver already bound, so enable ATTN now. */
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index caaf563d38ae..d9c4d039c4e7 100644
index cabeb5bd3e41..25ef4e9cc34a 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -8,6 +8,7 @@
@ -1386,10 +1320,10 @@ index 3c668cfb146d..95724cd9875f 100644
if (err)
goto err_out_driver;
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index a739403a9e45..191513936ce8 100644
index 26a27ff50408..e1050b7dd63d 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5749,6 +5749,13 @@ static void hub_event(struct work_struct *work)
@@ -5805,6 +5805,13 @@ static void hub_event(struct work_struct *work)
(u16) hub->change_bits[0],
(u16) hub->event_bits[0]);
@ -1472,10 +1406,10 @@ index ab088c662e88..f974f9d9a7c5 100644
enum efi_secureboot_mode efi_get_secureboot_mode(efi_get_variable_t *get_var)
{
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
index 7308a1a7599b..a3aa26339b43 100644
index af796986baee..83e1cb0ca159 100644
--- a/include/linux/lsm_hook_defs.h
+++ b/include/linux/lsm_hook_defs.h
@@ -404,6 +404,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
@@ -405,6 +405,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
#endif /* CONFIG_BPF_SYSCALL */
LSM_HOOK(int, 0, locked_down, enum lockdown_reason what)
@ -1497,10 +1431,10 @@ index ab7eea01ab42..fff7c5f737fc 100644
int rmi_register_transport_device(struct rmi_transport_dev *xport);
diff --git a/include/linux/security.h b/include/linux/security.h
index 32828502f09e..b5c27505fa16 100644
index bac98ea18f78..28abed10b583 100644
--- a/include/linux/security.h
+++ b/include/linux/security.h
@@ -482,6 +482,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
@@ -483,6 +483,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
int security_inode_setsecctx(struct dentry *dentry, void *ctx, u32 ctxlen);
int security_inode_getsecctx(struct inode *inode, void **ctx, u32 *ctxlen);
int security_locked_down(enum lockdown_reason what);
@ -1508,7 +1442,7 @@ index 32828502f09e..b5c27505fa16 100644
#else /* CONFIG_SECURITY */
static inline int call_blocking_lsm_notifier(enum lsm_event event, void *data)
@@ -1388,6 +1389,10 @@ static inline int security_locked_down(enum lockdown_reason what)
@@ -1394,6 +1395,10 @@ static inline int security_locked_down(enum lockdown_reason what)
{
return 0;
}
@ -1616,10 +1550,10 @@ index 68d19632aeb7..ef348935b6ff 100644
static int __init lockdown_lsm_init(void)
diff --git a/security/security.c b/security/security.c
index b720424ca37d..bf65c13de58f 100644
index 549104a447e3..73670798f075 100644
--- a/security/security.c
+++ b/security/security.c
@@ -5184,6 +5184,18 @@ int security_locked_down(enum lockdown_reason what)
@@ -5198,6 +5198,18 @@ int security_locked_down(enum lockdown_reason what)
}
EXPORT_SYMBOL(security_locked_down);

View File

@ -1,3 +1,3 @@
SHA512 (linux-6.5.2.tar.xz) = 9aaf88d58a27576e7ce8378480718f44f140511494bb1ef6872521c94536f798d7b2adc5070f2686872cc0ea14b5412750bfaa31fb760db68901f351fd802321
SHA512 (kernel-abi-stablelists-6.5.2.tar.bz2) = 7c328de94454d54b3e2fbe93c3b0099724ffc6c22f6c304f98ff88f72a7eb3de1d3476f4b9d5fbfaf68eb95f1f5e1d6d2a4fec32e519cfbeb4102a9d56898d37
SHA512 (kernel-kabi-dw-6.5.2.tar.bz2) = 73379173c6af0d7517af2adb440470d2d8b34151cad7b4a9511f480f0fc9092a9629fea582b095fa56f28eb9e56919191828e0e5f34b0415f831cb0278a149b8
SHA512 (linux-6.5.3.tar.xz) = aa38c189954b3721c08a25e9cd077b4e1d5eb4d51baa3438f3ff7d18c76b28a99a68213a81c4fdf9a3343f0b108e42256fa8307df3fed7b943e938ed6348ac8b
SHA512 (kernel-abi-stablelists-6.5.3.tar.bz2) = ec90c164dd2b0793f5e6310c7d585ccae1a0868f11f52ce33678f980af6777d8af2dbd7578966800ee505e6788b59b41bbb2fdf90c5ba073f3740ec28ddb254d
SHA512 (kernel-kabi-dw-6.5.3.tar.bz2) = 58a0d9aea64f12a138b1d15dc7ad9345588705bb63477714d58db42cbba834d90782687b8e28275feb87e79c6c9f7a2dc10c9c13236cad99fba7f64cfe86e64f