Linux v4.6-rc7
This commit is contained in:
parent
452fe53fe0
commit
0494a46c4e
@ -1,37 +0,0 @@
|
|||||||
From 88fd0f33c3cc5aa6a26f56902241941ac717e9f8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Wed, 27 Apr 2016 13:44:05 +0100
|
|
||||||
Subject: [PATCH] gpu: ipu-v3: Fix imx-ipuv3-crtc module autoloading
|
|
||||||
|
|
||||||
---
|
|
||||||
drivers/gpu/ipu-v3/ipu-common.c | 7 ++++++-
|
|
||||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/gpu/ipu-v3/ipu-common.c b/drivers/gpu/ipu-v3/ipu-common.c
|
|
||||||
index e00db3f..abb98c7 100644
|
|
||||||
--- a/drivers/gpu/ipu-v3/ipu-common.c
|
|
||||||
+++ b/drivers/gpu/ipu-v3/ipu-common.c
|
|
||||||
@@ -1068,7 +1068,6 @@ static int ipu_add_client_devices(struct ipu_soc *ipu, unsigned long ipu_base)
|
|
||||||
goto err_register;
|
|
||||||
}
|
|
||||||
|
|
||||||
- pdev->dev.of_node = of_node;
|
|
||||||
pdev->dev.parent = dev;
|
|
||||||
|
|
||||||
ret = platform_device_add_data(pdev, ®->pdata,
|
|
||||||
@@ -1079,6 +1078,12 @@ static int ipu_add_client_devices(struct ipu_soc *ipu, unsigned long ipu_base)
|
|
||||||
platform_device_put(pdev);
|
|
||||||
goto err_register;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ /*
|
|
||||||
+ * Set of_node only after calling platform_device_add. Otherwise
|
|
||||||
+ * the platform:imx-ipuv3-crtc modalias won't be used.
|
|
||||||
+ */
|
|
||||||
+ pdev->dev.of_node = of_node;
|
|
||||||
}
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -193,6 +193,7 @@ CONFIG_DMIID=y
|
|||||||
CONFIG_DMI_SYSFS=y
|
CONFIG_DMI_SYSFS=y
|
||||||
|
|
||||||
CONFIG_SATA_AHCI_PLATFORM=y
|
CONFIG_SATA_AHCI_PLATFORM=y
|
||||||
|
CONFIG_SATA_AHCI_SEATTLE=m
|
||||||
|
|
||||||
CONFIG_LIBNVDIMM=m
|
CONFIG_LIBNVDIMM=m
|
||||||
CONFIG_BTT=y
|
CONFIG_BTT=y
|
||||||
|
13
kernel.spec
13
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 6
|
%define rcrev 7
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -507,9 +507,6 @@ Patch422: geekbox-v4-device-tree-support.patch
|
|||||||
# http://www.spinics.net/lists/arm-kernel/msg483898.html
|
# http://www.spinics.net/lists/arm-kernel/msg483898.html
|
||||||
Patch423: Initial-AllWinner-A64-and-PINE64-support.patch
|
Patch423: Initial-AllWinner-A64-and-PINE64-support.patch
|
||||||
|
|
||||||
# rhbz 1321330 http://www.spinics.net/lists/dri-devel/msg105829.html
|
|
||||||
Patch425: 0001-gpu-ipu-v3-Fix-imx-ipuv3-crtc-module-autoloading.patch
|
|
||||||
|
|
||||||
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
||||||
Patch426: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
Patch426: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
||||||
|
|
||||||
@ -614,9 +611,6 @@ Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
|
|||||||
#rhbz 1309487
|
#rhbz 1309487
|
||||||
Patch701: antenna_select.patch
|
Patch701: antenna_select.patch
|
||||||
|
|
||||||
# Stop splashing crap about broken firmware BGRT
|
|
||||||
Patch702: x86-efi-bgrt-Switch-all-pr_err-to-pr_debug-for-inval.patch
|
|
||||||
|
|
||||||
#CVE-2016-4482 rhbz 1332931 1332932
|
#CVE-2016-4482 rhbz 1332931 1332932
|
||||||
Patch706: USB-usbfs-fix-potential-infoleak-in-devio.patch
|
Patch706: USB-usbfs-fix-potential-infoleak-in-devio.patch
|
||||||
|
|
||||||
@ -2149,6 +2143,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 09 2016 Josh Boyer <jwboyer@fedoraproject.org> - 4.6.0-0.rc7.git0.1
|
||||||
|
- Linux v4.6-rc7
|
||||||
|
|
||||||
* Fri May 06 2016 Josh Boyer <jwboyer@fedoraproject.org> - 4.6.0-0.rc6.git4.1
|
* Fri May 06 2016 Josh Boyer <jwboyer@fedoraproject.org> - 4.6.0-0.rc6.git4.1
|
||||||
- Linux v4.6-rc6-165-g9caa7e78481f
|
- Linux v4.6-rc6-165-g9caa7e78481f
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,5 +1,3 @@
|
|||||||
a60d48eee08ec0536d5efb17ca819aef linux-4.5.tar.xz
|
a60d48eee08ec0536d5efb17ca819aef linux-4.5.tar.xz
|
||||||
6f557fe90b800b615c85c2ca04da6154 perf-man-4.5.tar.gz
|
6f557fe90b800b615c85c2ca04da6154 perf-man-4.5.tar.gz
|
||||||
60d2e4b5eeb4ff2b58cf85a03d9c6a4b patch-4.6-rc6.xz
|
2089df8a0f142e2a1cdcaca0f133e47d patch-4.6-rc7.xz
|
||||||
0bb662945f45e368cdb14814e6234eb4 patch-4.6-rc6-git3.xz
|
|
||||||
38510e89f41de3ff79de791f61d472a4 patch-4.6-rc6-git4.xz
|
|
||||||
|
@ -1,96 +0,0 @@
|
|||||||
From 5b252532b1785a82b71d16e3c134f58d7c7fee3d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
Date: Wed, 27 Apr 2016 08:37:41 -0400
|
|
||||||
Subject: [PATCH] x86/efi-bgrt: Switch all pr_err() to pr_debug() for invalid
|
|
||||||
BGRT
|
|
||||||
|
|
||||||
The promise of pretty boot splashes from firmware via BGRT was at
|
|
||||||
best only that; a promise. The kernel diligently checks to make
|
|
||||||
sure the BGRT data firmware gives it is valid, and dutifully warns
|
|
||||||
the user when it isn't. However, it does so via the pr_err log
|
|
||||||
level which seems unnecessary. The user cannot do anything about
|
|
||||||
this and there really isn't an error on the part of Linux to
|
|
||||||
correct.
|
|
||||||
|
|
||||||
This lowers the log level by using pr_debug instead. Users will
|
|
||||||
no longer have their boot process uglified by the kernel reminding
|
|
||||||
us that firmware can and often is broken. Ironic, considering
|
|
||||||
BGRT is supposed to make boot pretty to begin with.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
---
|
|
||||||
arch/x86/platform/efi/efi-bgrt.c | 18 +++++++++---------
|
|
||||||
1 file changed, 9 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/x86/platform/efi/efi-bgrt.c b/arch/x86/platform/efi/efi-bgrt.c
|
|
||||||
index a2433817c987..6f70d2ac8029 100644
|
|
||||||
--- a/arch/x86/platform/efi/efi-bgrt.c
|
|
||||||
+++ b/arch/x86/platform/efi/efi-bgrt.c
|
|
||||||
@@ -43,40 +43,40 @@ void __init efi_bgrt_init(void)
|
|
||||||
return;
|
|
||||||
|
|
||||||
if (bgrt_tab->header.length < sizeof(*bgrt_tab)) {
|
|
||||||
- pr_err("Ignoring BGRT: invalid length %u (expected %zu)\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: invalid length %u (expected %zu)\n",
|
|
||||||
bgrt_tab->header.length, sizeof(*bgrt_tab));
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
if (bgrt_tab->version != 1) {
|
|
||||||
- pr_err("Ignoring BGRT: invalid version %u (expected 1)\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: invalid version %u (expected 1)\n",
|
|
||||||
bgrt_tab->version);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
if (bgrt_tab->status & 0xfe) {
|
|
||||||
- pr_err("Ignoring BGRT: reserved status bits are non-zero %u\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: reserved status bits are non-zero %u\n",
|
|
||||||
bgrt_tab->status);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
if (bgrt_tab->image_type != 0) {
|
|
||||||
- pr_err("Ignoring BGRT: invalid image type %u (expected 0)\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: invalid image type %u (expected 0)\n",
|
|
||||||
bgrt_tab->image_type);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
if (!bgrt_tab->image_address) {
|
|
||||||
- pr_err("Ignoring BGRT: null image address\n");
|
|
||||||
+ pr_debug("Ignoring BGRT: null image address\n");
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
image = memremap(bgrt_tab->image_address, sizeof(bmp_header), MEMREMAP_WB);
|
|
||||||
if (!image) {
|
|
||||||
- pr_err("Ignoring BGRT: failed to map image header memory\n");
|
|
||||||
+ pr_debug("Ignoring BGRT: failed to map image header memory\n");
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
memcpy(&bmp_header, image, sizeof(bmp_header));
|
|
||||||
memunmap(image);
|
|
||||||
if (bmp_header.id != 0x4d42) {
|
|
||||||
- pr_err("Ignoring BGRT: Incorrect BMP magic number 0x%x (expected 0x4d42)\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: Incorrect BMP magic number 0x%x (expected 0x4d42)\n",
|
|
||||||
bmp_header.id);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
@@ -84,14 +84,14 @@ void __init efi_bgrt_init(void)
|
|
||||||
|
|
||||||
bgrt_image = kmalloc(bgrt_image_size, GFP_KERNEL | __GFP_NOWARN);
|
|
||||||
if (!bgrt_image) {
|
|
||||||
- pr_err("Ignoring BGRT: failed to allocate memory for image (wanted %zu bytes)\n",
|
|
||||||
+ pr_debug("Ignoring BGRT: failed to allocate memory for image (wanted %zu bytes)\n",
|
|
||||||
bgrt_image_size);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
image = memremap(bgrt_tab->image_address, bmp_header.size, MEMREMAP_WB);
|
|
||||||
if (!image) {
|
|
||||||
- pr_err("Ignoring BGRT: failed to map image memory\n");
|
|
||||||
+ pr_debug("Ignoring BGRT: failed to map image memory\n");
|
|
||||||
kfree(bgrt_image);
|
|
||||||
bgrt_image = NULL;
|
|
||||||
return;
|
|
||||||
--
|
|
||||||
2.5.5
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user