Add patch to quiet irq remapping failures (rhbz 948262)
This commit is contained in:
parent
a63cdb706f
commit
00db28f1ca
@ -0,0 +1,25 @@
|
||||
This triggers on a MacBook Pro.
|
||||
|
||||
Signed-off-by: Andy Lutomirski <luto@amacapital.net>
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=948262
|
||||
---
|
||||
drivers/iommu/intel_irq_remapping.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/iommu/intel_irq_remapping.c b/drivers/iommu/intel_irq_remapping.c
|
||||
index f3b8f23..a7e0ad1 100644
|
||||
--- a/drivers/iommu/intel_irq_remapping.c
|
||||
+++ b/drivers/iommu/intel_irq_remapping.c
|
||||
@@ -654,8 +654,7 @@ error:
|
||||
*/
|
||||
|
||||
if (x2apic_present)
|
||||
- WARN(1, KERN_WARNING
|
||||
- "Failed to enable irq remapping. You are vulnerable to irq-injection attacks.\n");
|
||||
+ pr_warn("Failed to enable irq remapping. You are vulnerable to irq-injection attacks.\n");
|
||||
|
||||
return -1;
|
||||
}
|
||||
--
|
||||
1.8.1.4
|
||||
|
11
kernel.spec
11
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -734,6 +734,9 @@ Patch25021: radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
||||
#rhbz 964367
|
||||
Patch25023: hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
|
||||
|
||||
#rhbz 948262
|
||||
Patch25024: intel_iommu-Downgrade-the-warning-if-enabling-irq-remapping-fails.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1415,6 +1418,9 @@ ApplyPatch radeon-use-max_bus-speed-to-activate-gen2-speeds.patch
|
||||
#rhbz 964367
|
||||
ApplyPatch hp-wmi-fix-incorrect-rfkill-set-hw-state.patch
|
||||
|
||||
#rhbz 948262
|
||||
ApplyPatch intel_iommu-Downgrade-the-warning-if-enabling-irq-remapping-fails.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2220,6 +2226,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri May 24 2013 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add patch to quiet irq remapping failures (rhbz 948262)
|
||||
|
||||
* Fri May 24 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc2.git3.1
|
||||
- Linux v3.10-rc2-328-g0e255f1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user