New release 1.9.4

This commit is contained in:
Pavel Zhukov 2021-02-08 11:58:06 +01:00
parent f5d2533749
commit fc667ec093
5 changed files with 35 additions and 62 deletions

1
.gitignore vendored
View File

@ -22,3 +22,4 @@
/kea-1.9.1.tar.gz
/kea-1.9.2.tar.gz
/kea-1.9.3.tar.gz
/kea-1.9.4.tar.gz

View File

@ -1,8 +1,32 @@
diff --git a/configure b/configure
index 34e4997..79e649f 100755
--- a/configure
+++ b/configure
@@ -16895,6 +16895,7 @@ $as_echo_n "checking thread support... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <thread>
+#include <memory>
std::shared_ptr<std::thread> th;
int
main ()
diff --git a/m4macros/ax_cpp11.m4 b/m4macros/ax_cpp11.m4
index f9042fa..99457f9 100644
--- a/m4macros/ax_cpp11.m4
+++ b/m4macros/ax_cpp11.m4
@@ -182,6 +182,7 @@ for retry in "none" "--std=c++11" "--std=c++0x" "--std=c++1x" "fail"; do
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[#include <thread>
+ #include <memory>
std::shared_ptr<std::thread> th;],
[th.reset(new std::thread([[]]() { return; }));
th->join();])],
diff --git a/src/lib/database/backend_selector.cc b/src/lib/database/backend_selector.cc
index cea5a53..2c3c07d 100644
index 0f61fe8..adb95d6 100644
--- a/src/lib/database/backend_selector.cc
+++ b/src/lib/database/backend_selector.cc
@@ -7,6 +7,7 @@
@@ -9,6 +9,7 @@
#include <database/backend_selector.h>
#include <exceptions/exceptions.h>
#include <climits>
@ -23,7 +47,7 @@ index 11c9e87..b5eab53 100644
#include <cc/data.h>
#include <dhcpsrv/subnet_id.h>
diff --git a/src/lib/dhcpsrv/network_state.cc b/src/lib/dhcpsrv/network_state.cc
index a86a346..94451ca 100644
index 61199ab..ceaba8c 100644
--- a/src/lib/dhcpsrv/network_state.cc
+++ b/src/lib/dhcpsrv/network_state.cc
@@ -6,6 +6,7 @@
@ -34,27 +58,3 @@ index a86a346..94451ca 100644
#include <exceptions/exceptions.h>
#include <dhcpsrv/network_state.h>
#include <dhcpsrv/timer_mgr.h>
diff --git a/m4macros/ax_cpp11.m4 b/m4macros/ax_cpp11.m4
index 8efa2e1..9cd83f2 100644
--- a/m4macros/ax_cpp11.m4
+++ b/m4macros/ax_cpp11.m4
@@ -182,6 +182,7 @@ for retry in "none" "--std=c++11" "--std=c++0x" "--std=c++1x" "fail"; do
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[#include <thread>
+ #include <memory>
std::shared_ptr<std::thread> th;],
[th.reset(new std::thread([[]]() { return; }));
th->join();])],
diff --git a/configure b/configure
index 3f52de5..1002d60 100755
--- a/configure
+++ b/configure
@@ -16895,6 +16895,7 @@ $as_echo_n "checking thread support... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <thread>
+#include <memory>
std::shared_ptr<std::thread> th;
int
main ()

View File

@ -1,30 +0,0 @@
commit ee320d0af861b3b5ba17762a8b69563cc92a800e
Author: Andrei Pavel <andrei@isc.org>
Date: Thu Jan 7 01:29:14 2021 +0200
[#1637] remove unnecessary -Werror in Makefiles
diff --git a/src/bin/perfdhcp/Makefile.am b/src/bin/perfdhcp/Makefile.am
index d781ee6ee8..276f86b9b4 100644
--- a/src/bin/perfdhcp/Makefile.am
+++ b/src/bin/perfdhcp/Makefile.am
@@ -3,7 +3,6 @@ SUBDIRS = . tests
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += -I$(top_srcdir)/src/bin -I$(top_builddir)/src/bin
AM_CPPFLAGS += $(BOOST_INCLUDES)
-AM_CPPFLAGS += -Werror
AM_CXXFLAGS = $(KEA_CXXFLAGS)
diff --git a/src/bin/perfdhcp/tests/Makefile.am b/src/bin/perfdhcp/tests/Makefile.am
index 7e3c262077..31ec9e8508 100644
--- a/src/bin/perfdhcp/tests/Makefile.am
+++ b/src/bin/perfdhcp/tests/Makefile.am
@@ -4,7 +4,6 @@ AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib -I$(top_builddir
AM_CPPFLAGS += -I$(srcdir)/.. -I$(builddir)/..
AM_CPPFLAGS += -DTEST_DATA_DIR=\"$(abs_srcdir)/testdata\"
AM_CPPFLAGS += $(BOOST_INCLUDES)
-AM_CPPFLAGS += -Werror
AM_CXXFLAGS = $(KEA_CXXFLAGS)
if USE_STATIC_LINK

View File

@ -5,8 +5,8 @@
#%%global prever P1
Name: kea
Version: 1.9.3
Release: 5%{?dist}
Version: 1.9.4
Release: 1%{?dist}
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
License: MPLv2.0 and Boost
@ -17,9 +17,8 @@ Source2: kea-dhcp6.service
Source3: kea-dhcp-ddns.service
Source4: kea-ctrl-agent.service
Patch1: kea-gcc11.patch
Patch3: 0004-Openssl-version.patch
Patch4: kea-gcc11.patch
Patch5: kea-remove_werror.patch
# autoreconf
BuildRequires: autoconf automake libtool
@ -222,6 +221,9 @@ EOF
%changelog
* Mon Feb 08 2021 Pavel Zhukov pzhukov@redhat.com> - 1.9.4-1
- Update to 1.9.4
* Mon Feb 08 2021 Pavel Raiskup <praiskup@redhat.com> - 1.9.3-5
- rebuild for libpq ABI fix rhbz#1908268

View File

@ -1 +1 @@
SHA512 (kea-1.9.3.tar.gz) = a433f371828d622fa5c17d7fea4cfdbfc4964bbb1d5ab1dfda7dd031421ee2a19193812e4b718c91e8a7bfa557576c573fa65107e0e3e761da0a0d537e0e6718
SHA512 (kea-1.9.4.tar.gz) = 1808583194d426cf3881426a4d2c2f4134c463c6804648e2b1baa6a8ae48bca8b12ee2bc230349c785aff385a05a98a943d1c6ba09565e2204f262a2255be911