0.9.1
This commit is contained in:
parent
6eda22ae6e
commit
e31e76d6dc
@ -1,6 +1,6 @@
|
||||
From 09ff7038ea23565e923179682ba96f5aa2d0f0c7 Mon Sep 17 00:00:00 2001
|
||||
From 683028b4f5dcf7fb443c85f331e319123f0027a5 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Popelka <jpopelka@redhat.com>
|
||||
Date: Tue, 19 Aug 2014 17:16:50 +0200
|
||||
Date: Wed, 1 Apr 2015 13:14:57 +0200
|
||||
Subject: [PATCH] Systemd service unit files.
|
||||
|
||||
As of August 2014, all Linux distributions include systemd and most of
|
||||
@ -36,10 +36,10 @@ as I haven't figured out a better place.
|
||||
create mode 100644 src/bin/keactrl/kea-dhcp6.service.in
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f0dbc4f..3dc4383 100644
|
||||
index a2b0daf..aa614c0 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1344,6 +1344,18 @@ if test "x$VALGRIND" != "xno"; then
|
||||
@@ -1367,6 +1367,18 @@ if test "x$VALGRIND" != "xno"; then
|
||||
found_valgrind="found"
|
||||
fi
|
||||
|
||||
@ -59,12 +59,12 @@ index f0dbc4f..3dc4383 100644
|
||||
# used to reset the state of getopt() function. Resetting its state
|
||||
# is required if command line arguments are parsed multiple times
|
||||
diff --git a/src/bin/keactrl/Makefile.am b/src/bin/keactrl/Makefile.am
|
||||
index a2d2a82..05b1c9e 100644
|
||||
index c83a597..b494160 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -31,9 +31,36 @@ endif
|
||||
@@ -32,9 +32,36 @@ endif
|
||||
kea.conf: kea.conf.pre
|
||||
$(top_srcdir)/tools/path_replacer.sh $(top_srcdir)/src/bin/keactrl/kea.conf.pre $@
|
||||
$(top_builddir)/tools/path_replacer.sh $(top_srcdir)/src/bin/keactrl/kea.conf.pre $@
|
||||
|
||||
+INSTALL_TARGETS = install-empty
|
||||
+
|
||||
@ -85,13 +85,13 @@ index a2d2a82..05b1c9e 100644
|
||||
+endif
|
||||
+
|
||||
+kea-dhcp4.service: kea-dhcp4.service.in
|
||||
+ $(top_srcdir)/tools/path_replacer.sh $< $@
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp6.service: kea-dhcp6.service.in
|
||||
+ $(top_srcdir)/tools/path_replacer.sh $< $@
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp-ddns.service: kea-dhcp-ddns.service.in
|
||||
+ $(top_srcdir)/tools/path_replacer.sh $< $@
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+install-empty:
|
||||
+ :
|
||||
@ -100,7 +100,7 @@ index a2d2a82..05b1c9e 100644
|
||||
$(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@
|
||||
for f in $(CONFIGFILES) ; do \
|
||||
if test ! -f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f; then \
|
||||
@@ -41,4 +68,12 @@ install-data-local:
|
||||
@@ -42,4 +69,12 @@ install-data-local:
|
||||
fi ; \
|
||||
done
|
||||
|
||||
@ -189,5 +189,5 @@ index 43d7bff..82625ca 100644
|
||||
-sed -e "s+\@localstatedir\@+${localstatedir}+g; s+\@prefix@+${prefix}+g; s+\@sysconfdir@+${sysconfdir}+g" $1 > $2
|
||||
+sed -e "s+\@localstatedir\@+${localstatedir}+g; s+\@prefix\@+${prefix}+g; s+\@sysconfdir\@+${sysconfdir}+g; s+\@sbindir\@+${sbindir}+g" $1 > $2
|
||||
--
|
||||
1.9.3
|
||||
2.3.4
|
||||
|
||||
|
9
kea.spec
9
kea.spec
@ -4,13 +4,13 @@
|
||||
%global prever beta
|
||||
|
||||
#%%global VERSION %{version}-%{patchver}
|
||||
#%%global VERSION %{version}
|
||||
%global VERSION %{version}-%{prever}
|
||||
#%%global VERSION %{version}-%{prever}
|
||||
%global VERSION %{version}
|
||||
|
||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||
Name: kea
|
||||
Version: 0.9.1
|
||||
Release: 0.2.%{prever}%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: ISC and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{VERSION}/kea-%{VERSION}.tar.gz
|
||||
@ -226,6 +226,9 @@ EOF
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Wed Apr 01 2015 Jiri Popelka <jpopelka@redhat.com> - 0.9.1-1
|
||||
- 0.9.1
|
||||
|
||||
* Fri Feb 20 2015 Jiri Popelka <jpopelka@redhat.com> - 0.9.1-0.2.beta
|
||||
- /run/kea/ (for logger_lockfile)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user