Fix build with boost 1.66 (#1540331)
This commit is contained in:
parent
b774ed3bbd
commit
d02badd7cc
90
kea-boost_1.66.patch
Normal file
90
kea-boost_1.66.patch
Normal file
@ -0,0 +1,90 @@
|
||||
commit 4fd11ef050438adeb1e0ae0d9d2d8ec3a2cb659c
|
||||
Author: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
Date: Sat Dec 30 14:40:24 2017 +0100
|
||||
|
||||
asiolink: fix build with boost 1.66
|
||||
|
||||
- use native_handle() for getting native socket type
|
||||
- use io_context instead of io_service
|
||||
|
||||
diff --git a/src/lib/asiolink/io_acceptor.h b/src/lib/asiolink/io_acceptor.h
|
||||
index c493d3427..913a3280b 100644
|
||||
--- a/src/lib/asiolink/io_acceptor.h
|
||||
+++ b/src/lib/asiolink/io_acceptor.h
|
||||
@@ -47,7 +47,11 @@ public:
|
||||
|
||||
/// @brief Returns file descriptor of the underlying socket.
|
||||
virtual int getNative() const {
|
||||
+#if BOOST_VERSION < 106600
|
||||
return (acceptor_->native());
|
||||
+#else
|
||||
+ return (acceptor_->native_handle());
|
||||
+#endif
|
||||
}
|
||||
|
||||
/// @brief Opens acceptor socket given the endpoint.
|
||||
diff --git a/src/lib/asiolink/io_service.h b/src/lib/asiolink/io_service.h
|
||||
index e9e402d11..e0832b2c0 100644
|
||||
--- a/src/lib/asiolink/io_service.h
|
||||
+++ b/src/lib/asiolink/io_service.h
|
||||
@@ -11,7 +11,12 @@
|
||||
|
||||
namespace boost {
|
||||
namespace asio {
|
||||
+#if BOOST_VERSION < 106600
|
||||
class io_service;
|
||||
+#else
|
||||
+ class io_context;
|
||||
+ typedef io_context io_service;
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/src/lib/asiolink/tcp_socket.h b/src/lib/asiolink/tcp_socket.h
|
||||
index adf74d1f0..83b8264c8 100644
|
||||
--- a/src/lib/asiolink/tcp_socket.h
|
||||
+++ b/src/lib/asiolink/tcp_socket.h
|
||||
@@ -75,7 +75,11 @@ public:
|
||||
|
||||
/// \brief Return file descriptor of underlying socket
|
||||
virtual int getNative() const {
|
||||
+#if BOOST_VERSION < 106600
|
||||
return (socket_.native());
|
||||
+#else
|
||||
+ return (socket_.native_handle());
|
||||
+#endif
|
||||
}
|
||||
|
||||
/// \brief Return protocol of socket
|
||||
diff --git a/src/lib/asiolink/udp_socket.h b/src/lib/asiolink/udp_socket.h
|
||||
index 07ba44743..5b040cfe1 100644
|
||||
--- a/src/lib/asiolink/udp_socket.h
|
||||
+++ b/src/lib/asiolink/udp_socket.h
|
||||
@@ -61,7 +61,11 @@ public:
|
||||
|
||||
/// \brief Return file descriptor of underlying socket
|
||||
virtual int getNative() const {
|
||||
+#if BOOST_VERSION < 106600
|
||||
return (socket_.native());
|
||||
+#else
|
||||
+ return (socket_.native_handle());
|
||||
+#endif
|
||||
}
|
||||
|
||||
/// \brief Return protocol of socket
|
||||
diff --git a/src/lib/asiolink/unix_domain_socket.cc b/src/lib/asiolink/unix_domain_socket.cc
|
||||
index f17ec2e8f..d1ad9ec30 100644
|
||||
--- a/src/lib/asiolink/unix_domain_socket.cc
|
||||
+++ b/src/lib/asiolink/unix_domain_socket.cc
|
||||
@@ -287,7 +287,11 @@ UnixDomainSocket::UnixDomainSocket(IOService& io_service)
|
||||
|
||||
int
|
||||
UnixDomainSocket::getNative() const {
|
||||
+#if BOOST_VERSION < 106600
|
||||
return (impl_->socket_.native());
|
||||
+#else
|
||||
+ return (impl_->socket_.native_handle());
|
||||
+#endif
|
||||
}
|
||||
|
||||
int
|
7
kea.spec
7
kea.spec
@ -10,7 +10,7 @@ Name: kea
|
||||
%global LVERSION %{version}-%{prever}
|
||||
#%%global VERSION %%{LVERSION}
|
||||
Version: 1.3.0
|
||||
Release: 3%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: MPLv2.0 and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{LVERSION}/kea-%{LVERSION}.tar.gz
|
||||
@ -19,6 +19,7 @@ Source0: http://ftp.isc.org/isc/kea/%{LVERSION}/kea-%{LVERSION}.tar.gz
|
||||
Patch0: kea-systemd.patch
|
||||
Patch1: kea-1.3.0-hooksdir.patch
|
||||
Patch2: kea-openssl.patch
|
||||
Patch3: kea-boost_1.66.patch
|
||||
|
||||
# autoreconf
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -93,6 +94,7 @@ Header files and API documentation.
|
||||
%patch0 -p1 -b .systemd
|
||||
%patch1 -p1 -b .hooksdir
|
||||
%patch2 -p1 -b .openssl
|
||||
%patch3 -p1 -b .boost
|
||||
|
||||
# install leases db in /var/lib/kea/ not /var/kea/
|
||||
# http://kea.isc.org/ticket/3523
|
||||
@ -269,6 +271,9 @@ EOF
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Wed Jan 31 2018 Pavel Zhukov <landgraf@fedoraproject.org> - 1.3.0-4
|
||||
- Fix build with boost 1.66 (#1540331)
|
||||
|
||||
* Thu Nov 2 2017 Pavel Zhukov <pzhukov@redhat.com> - 1.3.0-3
|
||||
- Add openssl-devel requires
|
||||
- Do not force pkgconfig(openssl) version
|
||||
|
Loading…
x
Reference in New Issue
Block a user