1.0.0
This commit is contained in:
parent
733cf86e10
commit
a3912a3450
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/kea-0.9.2.tar.gz
|
||||
/kea-1.0.0-beta.tar.gz
|
||||
/kea-1.0.0-beta2.tar.gz
|
||||
/kea-1.0.0.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From bea489ca3fe47e96c346bd06d3926af0efe80043 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Popelka <jpopelka@redhat.com>
|
||||
Date: Wed, 23 Dec 2015 13:12:36 +0100
|
||||
Subject: [PATCH] Use unsigned long for dhcp_identifier_length
|
||||
|
||||
fixes:
|
||||
mysql_host_data_source.cc:236:33: error: invalid conversion from 'size_t* {aka unsigned int*}' to 'long unsigned int*' [-fpermissive]
|
||||
bind_[1].length = &dhcp_identifier_length_;
|
||||
^
|
||||
mysql_host_data_source.cc:243:33: error: invalid conversion from 'size_t* {aka unsigned int*}' to 'long unsigned int*' [-fpermissive]
|
||||
bind_[1].length = &dhcp_identifier_length_;
|
||||
^
|
||||
mysql_host_data_source.cc:344:25: error: invalid conversion from 'size_t* {aka unsigned int*}' to 'long unsigned int*' [-fpermissive]
|
||||
bind_[1].length = &dhcp_identifier_length_;
|
||||
---
|
||||
src/lib/dhcpsrv/mysql_host_data_source.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib/dhcpsrv/mysql_host_data_source.cc b/src/lib/dhcpsrv/mysql_host_data_source.cc
|
||||
index e5aeb71..bb46a8b 100644
|
||||
--- a/src/lib/dhcpsrv/mysql_host_data_source.cc
|
||||
+++ b/src/lib/dhcpsrv/mysql_host_data_source.cc
|
||||
@@ -515,7 +515,7 @@ private:
|
||||
std::vector<uint8_t> dhcp_identifier_; /// HW address (0) / DUID (1)
|
||||
uint8_t dhcp_identifier_buffer_[DUID::MAX_DUID_LEN];
|
||||
/// Buffer for dhcp identifier
|
||||
- size_t dhcp_identifier_length_; /// Length of dhcp identifier
|
||||
+ unsigned long dhcp_identifier_length_; /// Length of dhcp identifier
|
||||
uint8_t dhcp_identifier_type_; /// Type of dhcp_identifier
|
||||
uint32_t dhcp4_subnet_id_; /// Subnet DHCPv4 identifier
|
||||
uint32_t dhcp6_subnet_id_; /// Subnet DHCPv6 identifier
|
||||
--
|
||||
2.5.0
|
||||
|
15
kea.spec
15
kea.spec
@ -3,21 +3,20 @@
|
||||
|
||||
%global prever beta2
|
||||
|
||||
#%%global VERSION %{version}-%{patchver}
|
||||
#%%global VERSION %{version}
|
||||
%global VERSION %{version}-%{prever}
|
||||
#%%global VERSION %%{version}-%%{patchver}
|
||||
#%%global VERSION %%{version}-%%{prever}
|
||||
%global VERSION %{version}
|
||||
|
||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||
Name: kea
|
||||
Version: 1.0.0
|
||||
Release: 0.3.%{prever}%{?dist}
|
||||
License: ISC and Boost
|
||||
Release: 1%{?dist}
|
||||
License: MPLv2.0 and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{VERSION}/kea-%{VERSION}.tar.gz
|
||||
|
||||
# http://kea.isc.org/ticket/3529
|
||||
Patch0: kea-systemd.patch
|
||||
Patch1: kea-unsigned-long-length.patch
|
||||
|
||||
# autoreconf
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -73,7 +72,6 @@ Header files and API documentation.
|
||||
%setup -q -n kea-%{VERSION}
|
||||
|
||||
%patch0 -p1 -b .systemd
|
||||
%patch1 -p1 -b .unsigned-long-length
|
||||
|
||||
# install leases db in /var/lib/kea/ not /var/kea/
|
||||
# http://kea.isc.org/ticket/3523
|
||||
@ -231,6 +229,9 @@ EOF
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Tue Dec 29 2015 Jiri Popelka <jpopelka@redhat.com> - 1.0.0-1
|
||||
- 1.0.0
|
||||
|
||||
* Wed Dec 23 2015 Jiri Popelka <jpopelka@redhat.com> - 1.0.0-0.3.beta2
|
||||
- fix compile error
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user