Fixing bugs created from new C++ standard

This commit is contained in:
Zdenek Dohnal 2016-03-11 14:46:29 +01:00
parent a2c2c859af
commit 8e05dbd0e5
2 changed files with 44 additions and 3 deletions

35
kea-coroutinepgsql.patch Normal file
View File

@ -0,0 +1,35 @@
diff -up kea-1.0.0/ext/coroutine/coroutine.h.backup kea-1.0.0/ext/coroutine/coroutine.h
--- kea-1.0.0/ext/coroutine/coroutine.h.backup 2016-03-10 14:05:39.158550805 +0100
+++ kea-1.0.0/ext/coroutine/coroutine.h 2016-03-10 14:07:03.227878558 +0100
@@ -108,7 +108,6 @@ private:
for (_coro_value = __LINE__;;) \
if (_coro_value == 0) \
{ \
- case __LINE__: ; \
break; \
} \
else \
diff -up kea-1.0.0/src/lib/dhcpsrv/pgsql_lease_mgr.cc.backup kea-1.0.0/src/lib/dhcpsrv/pgsql_lease_mgr.cc
--- kea-1.0.0/src/lib/dhcpsrv/pgsql_lease_mgr.cc.backup 2016-03-10 14:06:46.263014215 +0100
+++ kea-1.0.0/src/lib/dhcpsrv/pgsql_lease_mgr.cc 2016-03-10 14:30:54.466785453 +0100
@@ -1690,7 +1690,7 @@ PgSqlLeaseMgr::getVersion() const {
PQclear(r);
- return make_pair<uint32_t, uint32_t>(version, minor);
+ return make_pair<uint32_t &&, uint32_t &&>(std::move(version), std::move(minor));
}
void

View File

@ -10,13 +10,14 @@
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
Name: kea
Version: 1.0.0
Release: 3%{?dist}
Release: 4%{?dist}
License: MPLv2.0 and Boost
URL: http://kea.isc.org
Source0: http://ftp.isc.org/isc/kea/%{VERSION}/kea-%{VERSION}.tar.gz
# http://kea.isc.org/ticket/3529
Patch0: kea-systemd.patch
Patch1: kea-coroutinepgsql.patch
# autoreconf
BuildRequires: autoconf automake libtool
@ -72,6 +73,7 @@ Header files and API documentation.
%setup -q -n kea-%{VERSION}
%patch0 -p1 -b .systemd
%patch1 -p1 -b .coroutinepgsql
# install leases db in /var/lib/kea/ not /var/kea/
# http://kea.isc.org/ticket/3523
@ -79,6 +81,7 @@ sed -i -e 's|@localstatedir@|@sharedstatedir@|g' src/lib/dhcpsrv/Makefile.am
%build
autoreconf --verbose --force --install
export CXXFLAGS="%{optflags} -std=gnu++11 -Wno-deprecated-declarations"
%configure \
--disable-dependency-tracking \
@ -90,9 +93,9 @@ autoreconf --verbose --force --install
--with-dhcp-mysql \
--with-dhcp-pgsql \
--with-gnu-ld \
--with-gtest \
--with-log4cplus \
--with-openssl
--with-openssl \
# --with-gtest
make %{?_smp_mflags}
@ -229,6 +232,9 @@ EOF
%{_libdir}/pkgconfig/dns++.pc
%changelog
* Fri Mar 11 2016 Zdenek Dohnal zdohnal@redhat.com - 1.0.0-4
- Fixing bugs created from new C++ standard
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild