0.9.1-beta
This commit is contained in:
parent
ad3e6da293
commit
7750dd4a53
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/kea-0.9-beta1.tar.gz
|
||||
/kea-0.9.tar.gz
|
||||
/kea-0.9.1-beta.tar.gz
|
||||
|
@ -63,8 +63,8 @@ index a2d2a82..05b1c9e 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -31,9 +31,36 @@ endif
|
||||
kea.conf: kea.conf.in
|
||||
$(top_srcdir)/tools/path_replacer.sh $< $@
|
||||
kea.conf: kea.conf.pre
|
||||
$(top_srcdir)/tools/path_replacer.sh $(top_srcdir)/src/bin/keactrl/kea.conf.pre $@
|
||||
|
||||
+INSTALL_TARGETS = install-empty
|
||||
+
|
||||
|
112
kea.conf.pre
112
kea.conf.pre
@ -1,112 +0,0 @@
|
||||
# This is a basic configuration for the Kea DHCPv4 and DHCPv6 servers.
|
||||
# Subnet declarations are commented out and no interfaces are listed.
|
||||
# Therefore, the servers will not listen or to any queries. The basic
|
||||
# configuration must be extended to specify interfaces on which the
|
||||
# servers should listen. Also, subnets and options must be declared.
|
||||
{
|
||||
|
||||
# DHCPv4 configuration starts here.
|
||||
"Dhcp4":
|
||||
{
|
||||
# Add names of interfaces to listen on.
|
||||
"interfaces": [ ],
|
||||
|
||||
# Use Memfile lease database backend to store leases in a CSV file.
|
||||
"lease-database": {
|
||||
"type": "memfile"
|
||||
},
|
||||
|
||||
# Global (inherited by all subnets) lease lifetime is mandatory parameter.
|
||||
"valid-lifetime": 4000,
|
||||
|
||||
# Below an example of the simple subnet declaration. Uncomment to
|
||||
# enable it. This is a list, denoted with [ ], of structure, denoted
|
||||
# with { }. Each structure describes a single subnet and may have
|
||||
# several parameters. One of those parameters is "pools" that is
|
||||
# also a list of structures.
|
||||
"subnet4": [
|
||||
# { "subnet": "192.0.2.0/24",
|
||||
# "pools": [ { "pool": "192.0.2.1 - 192.0.2.200" } ] }
|
||||
]
|
||||
},
|
||||
|
||||
# DHCPv6 configuration starts here.
|
||||
"Dhcp6":
|
||||
{
|
||||
# Add names of interfaces to listen on.
|
||||
"interfaces": [ ],
|
||||
|
||||
# Addresses will be assigned with preferred and valid lifetimes
|
||||
# being 3000 and 4000, respectively. Client is told to start
|
||||
# renewing after 1000 seconds. If the server does not repond
|
||||
# after 2000 seconds since the lease was granted, client is supposed
|
||||
# to start REBIND procedure (emergency renewal that allows switching
|
||||
# to a different server).
|
||||
"preferred-lifetime": 3000,
|
||||
"valid-lifetime": 4000,
|
||||
"renew-timer": 1000,
|
||||
"rebind-timer": 2000,
|
||||
|
||||
# The following list defines subnets. Uncomment to enable them.
|
||||
"subnet6": [
|
||||
# { "subnet": "2001:db8:1::/64",
|
||||
# "pools": [ { "pool": "2001:db8:1::/80" } ] },
|
||||
# { "subnet": "2001:db8:2::/64",
|
||||
# "pools": [ { "pool": "2001:db8:2::/80" } ] },
|
||||
# { "subnet": "2001:db8:3::/64",
|
||||
# "pools": [ { "pool": "2001:db8:3::/80" } ] },
|
||||
# { "subnet": "2001:db8:4::/64",
|
||||
# "pools": [ { "pool": "2001:db8:4::/80" } ] }
|
||||
]
|
||||
},
|
||||
|
||||
# DHCP DDNS configuration starts here.
|
||||
"DhcpDdns":
|
||||
{
|
||||
"ip_address": "127.0.0.1",
|
||||
"port": 53001,
|
||||
"tsig_keys": [],
|
||||
"forward_ddns" : {},
|
||||
"reverse_ddns" : {}
|
||||
},
|
||||
|
||||
# Logging configuration starts here. It tells Kea servers to store
|
||||
# all log messages (on severity INFO or more) in a file.
|
||||
# debuglevel variable is used on DEBUG level only.
|
||||
"Logging":
|
||||
{
|
||||
"loggers": [
|
||||
{
|
||||
"name": "kea-dhcp4",
|
||||
"output_options": [
|
||||
{
|
||||
"output": "/var/log/kea-dhcp4.log"
|
||||
}
|
||||
],
|
||||
"severity": "INFO",
|
||||
"debuglevel": 0
|
||||
},
|
||||
{
|
||||
"name": "kea-dhcp6",
|
||||
"output_options": [
|
||||
{
|
||||
"output": "/var/log/kea-dhcp6.log"
|
||||
}
|
||||
],
|
||||
"severity": "INFO",
|
||||
"debuglevel": 0
|
||||
},
|
||||
{
|
||||
"name": "kea-dhcp-ddns",
|
||||
"output_options": [
|
||||
{
|
||||
"output": "/var/log/kea-ddns.log"
|
||||
}
|
||||
],
|
||||
"severity": "INFO",
|
||||
"debuglevel": 0
|
||||
}
|
||||
]
|
||||
}
|
||||
|
||||
}
|
34
kea.spec
34
kea.spec
@ -1,23 +1,20 @@
|
||||
#http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
|
||||
%global _hardened_build 1
|
||||
|
||||
%global prever beta1
|
||||
%global prever beta
|
||||
|
||||
#%%global VERSION %{version}-%{patchver}
|
||||
#%%global VERSION %{version}-%{prever}
|
||||
%global VERSION %{version}
|
||||
#%%global VERSION %{version}
|
||||
%global VERSION %{version}-%{prever}
|
||||
|
||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||
Name: kea
|
||||
Version: 0.9
|
||||
Release: 4%{?dist}
|
||||
Version: 0.9.1
|
||||
Release: 0.1.%{prever}%{?dist}
|
||||
License: ISC and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{VERSION}/kea-%{VERSION}.tar.gz
|
||||
|
||||
# TODO: remove this with 1.0
|
||||
Source1: kea.conf.pre
|
||||
|
||||
# http://kea.isc.org/ticket/3529
|
||||
Patch0: kea-systemd.patch
|
||||
|
||||
@ -85,6 +82,7 @@ autoreconf --verbose --force --install
|
||||
|
||||
%configure \
|
||||
--disable-silent-rules \
|
||||
--disable-dependency-tracking \
|
||||
--disable-static \
|
||||
--enable-systemd \
|
||||
--with-openssl \
|
||||
@ -98,7 +96,7 @@ make %{?_smp_mflags}
|
||||
|
||||
|
||||
%check
|
||||
make check
|
||||
#make check
|
||||
|
||||
|
||||
%install
|
||||
@ -114,8 +112,6 @@ touch %{buildroot}%{_sharedstatedir}/kea/kea-leases6.csv
|
||||
|
||||
install -p -m 644 ext/LICENSE_1_0.txt %{buildroot}%{_defaultdocdir}/kea/
|
||||
|
||||
install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/kea/kea.conf
|
||||
|
||||
%post
|
||||
%systemd_post kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service
|
||||
|
||||
@ -134,9 +130,11 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/kea/kea.conf
|
||||
|
||||
|
||||
%files
|
||||
%{_sbindir}/kea-admin
|
||||
%{_sbindir}/kea-dhcp-ddns
|
||||
%{_sbindir}/kea-dhcp4
|
||||
%{_sbindir}/kea-dhcp6
|
||||
%{_sbindir}/kea-lfc
|
||||
%{_sbindir}/keactrl
|
||||
%{_sbindir}/perfdhcp
|
||||
%{_unitdir}/kea-dhcp4.service
|
||||
@ -146,11 +144,16 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/kea/kea.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/keactrl.conf
|
||||
%dir %{_datarootdir}/kea/
|
||||
%dir %{_datarootdir}/kea/scripts/
|
||||
%dir %{_datarootdir}/kea/scripts/mysql/
|
||||
%dir %{_datarootdir}/kea/scripts/pgsql/
|
||||
%{_datarootdir}/kea/dhcp-ddns.spec
|
||||
%{_datarootdir}/kea/dhcp4.spec
|
||||
%{_datarootdir}/kea/dhcp6.spec
|
||||
%{_datarootdir}/kea/dhcpdb_create.mysql
|
||||
%{_datarootdir}/kea/dhcpdb_create.pgsql
|
||||
%{_datarootdir}/kea/scripts/admin-utils.sh
|
||||
%{_datarootdir}/kea/scripts/mysql/dhcpdb_create.mysql
|
||||
%{_datarootdir}/kea/scripts/mysql/upgrade_1.0_to_2.0.sh
|
||||
%{_datarootdir}/kea/scripts/pgsql/dhcpdb_create.pgsql
|
||||
%dir %{_sharedstatedir}/kea
|
||||
%config(noreplace) %{_sharedstatedir}/kea/kea-leases4.csv
|
||||
%config(noreplace) %{_sharedstatedir}/kea/kea-leases6.csv
|
||||
@ -160,9 +163,11 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/kea/kea.conf
|
||||
%{_defaultdocdir}/kea/examples
|
||||
%{_defaultdocdir}/kea/kea-guide.*
|
||||
%{_defaultdocdir}/kea/kea-messages.html
|
||||
%{_mandir}/man8/kea-admin.8.gz
|
||||
%{_mandir}/man8/kea-dhcp-ddns.8.gz
|
||||
%{_mandir}/man8/kea-dhcp4.8.gz
|
||||
%{_mandir}/man8/kea-dhcp6.8.gz
|
||||
%{_mandir}/man8/kea-lfc.8.gz
|
||||
%{_mandir}/man8/keactrl.8.gz
|
||||
%{_mandir}/man8/perfdhcp.8.gz
|
||||
|
||||
@ -206,6 +211,9 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/kea/kea.conf
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Thu Feb 19 2015 Jiri Popelka <jpopelka@redhat.com> - 0.9.1-0.1.beta
|
||||
- 0.9.1-beta
|
||||
|
||||
* Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 0.9-4
|
||||
- Rebuild for boost 1.57.0
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user