Update to 1.5.0-beta1
This commit is contained in:
parent
d0ffb95be5
commit
5388176ecf
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
|||||||
/kea-1.2.0.tar.gz
|
/kea-1.2.0.tar.gz
|
||||||
/kea-1.3.0-beta.tar.gz
|
/kea-1.3.0-beta.tar.gz
|
||||||
/kea-1.3.0.tar.gz
|
/kea-1.3.0.tar.gz
|
||||||
|
/kea-1.5.0-beta1.tar.gz
|
||||||
|
@ -11,3 +11,29 @@ index 2c36689..fb6365e 100644
|
|||||||
lib_hooks_LTLIBRARIES = libdhcp_lease_cmds.la
|
lib_hooks_LTLIBRARIES = libdhcp_lease_cmds.la
|
||||||
|
|
||||||
libdhcp_lease_cmds_la_SOURCES =
|
libdhcp_lease_cmds_la_SOURCES =
|
||||||
|
diff --git a/src/hooks/dhcp/high_availability/Makefile.am b/src/hooks/dhcp/high_availability/Makefile.am
|
||||||
|
index 8550cca..a4f1124 100644
|
||||||
|
--- a/src/hooks/dhcp/high_availability/Makefile.am
|
||||||
|
+++ b/src/hooks/dhcp/high_availability/Makefile.am
|
||||||
|
@@ -44,7 +44,7 @@ libha_la_CXXFLAGS = $(AM_CXXFLAGS)
|
||||||
|
libha_la_CPPFLAGS = $(AM_CPPFLAGS)
|
||||||
|
|
||||||
|
# install the shared object into $(libdir)/hooks
|
||||||
|
-lib_hooksdir = $(libdir)/hooks
|
||||||
|
+lib_hooksdir = $(libdir)/kea/hooks
|
||||||
|
lib_hooks_LTLIBRARIES = libdhcp_ha.la
|
||||||
|
|
||||||
|
libdhcp_ha_la_SOURCES =
|
||||||
|
diff --git a/src/hooks/dhcp/stat_cmds/Makefile.am b/src/hooks/dhcp/stat_cmds/Makefile.am
|
||||||
|
index e6ff587..0fcc578 100644
|
||||||
|
--- a/src/hooks/dhcp/stat_cmds/Makefile.am
|
||||||
|
+++ b/src/hooks/dhcp/stat_cmds/Makefile.am
|
||||||
|
@@ -36,7 +36,7 @@ libstat_cmds_la_CXXFLAGS = $(AM_CXXFLAGS)
|
||||||
|
libstat_cmds_la_CPPFLAGS = $(AM_CPPFLAGS)
|
||||||
|
|
||||||
|
# install the shared object into $(libdir)/hooks
|
||||||
|
-lib_hooksdir = $(libdir)/hooks
|
||||||
|
+lib_hooksdir = $(libdir)/kea/hooks
|
||||||
|
lib_hooks_LTLIBRARIES = libdhcp_stat_cmds.la
|
||||||
|
|
||||||
|
libdhcp_stat_cmds_la_SOURCES =
|
||||||
|
@ -1,90 +0,0 @@
|
|||||||
commit 4fd11ef050438adeb1e0ae0d9d2d8ec3a2cb659c
|
|
||||||
Author: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
|
||||||
Date: Sat Dec 30 14:40:24 2017 +0100
|
|
||||||
|
|
||||||
asiolink: fix build with boost 1.66
|
|
||||||
|
|
||||||
- use native_handle() for getting native socket type
|
|
||||||
- use io_context instead of io_service
|
|
||||||
|
|
||||||
diff --git a/src/lib/asiolink/io_acceptor.h b/src/lib/asiolink/io_acceptor.h
|
|
||||||
index c493d3427..913a3280b 100644
|
|
||||||
--- a/src/lib/asiolink/io_acceptor.h
|
|
||||||
+++ b/src/lib/asiolink/io_acceptor.h
|
|
||||||
@@ -47,7 +47,11 @@ public:
|
|
||||||
|
|
||||||
/// @brief Returns file descriptor of the underlying socket.
|
|
||||||
virtual int getNative() const {
|
|
||||||
+#if BOOST_VERSION < 106600
|
|
||||||
return (acceptor_->native());
|
|
||||||
+#else
|
|
||||||
+ return (acceptor_->native_handle());
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
/// @brief Opens acceptor socket given the endpoint.
|
|
||||||
diff --git a/src/lib/asiolink/io_service.h b/src/lib/asiolink/io_service.h
|
|
||||||
index e9e402d11..e0832b2c0 100644
|
|
||||||
--- a/src/lib/asiolink/io_service.h
|
|
||||||
+++ b/src/lib/asiolink/io_service.h
|
|
||||||
@@ -11,7 +11,12 @@
|
|
||||||
|
|
||||||
namespace boost {
|
|
||||||
namespace asio {
|
|
||||||
+#if BOOST_VERSION < 106600
|
|
||||||
class io_service;
|
|
||||||
+#else
|
|
||||||
+ class io_context;
|
|
||||||
+ typedef io_context io_service;
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/src/lib/asiolink/tcp_socket.h b/src/lib/asiolink/tcp_socket.h
|
|
||||||
index adf74d1f0..83b8264c8 100644
|
|
||||||
--- a/src/lib/asiolink/tcp_socket.h
|
|
||||||
+++ b/src/lib/asiolink/tcp_socket.h
|
|
||||||
@@ -75,7 +75,11 @@ public:
|
|
||||||
|
|
||||||
/// \brief Return file descriptor of underlying socket
|
|
||||||
virtual int getNative() const {
|
|
||||||
+#if BOOST_VERSION < 106600
|
|
||||||
return (socket_.native());
|
|
||||||
+#else
|
|
||||||
+ return (socket_.native_handle());
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
/// \brief Return protocol of socket
|
|
||||||
diff --git a/src/lib/asiolink/udp_socket.h b/src/lib/asiolink/udp_socket.h
|
|
||||||
index 07ba44743..5b040cfe1 100644
|
|
||||||
--- a/src/lib/asiolink/udp_socket.h
|
|
||||||
+++ b/src/lib/asiolink/udp_socket.h
|
|
||||||
@@ -61,7 +61,11 @@ public:
|
|
||||||
|
|
||||||
/// \brief Return file descriptor of underlying socket
|
|
||||||
virtual int getNative() const {
|
|
||||||
+#if BOOST_VERSION < 106600
|
|
||||||
return (socket_.native());
|
|
||||||
+#else
|
|
||||||
+ return (socket_.native_handle());
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
/// \brief Return protocol of socket
|
|
||||||
diff --git a/src/lib/asiolink/unix_domain_socket.cc b/src/lib/asiolink/unix_domain_socket.cc
|
|
||||||
index f17ec2e8f..d1ad9ec30 100644
|
|
||||||
--- a/src/lib/asiolink/unix_domain_socket.cc
|
|
||||||
+++ b/src/lib/asiolink/unix_domain_socket.cc
|
|
||||||
@@ -287,7 +287,11 @@ UnixDomainSocket::UnixDomainSocket(IOService& io_service)
|
|
||||||
|
|
||||||
int
|
|
||||||
UnixDomainSocket::getNative() const {
|
|
||||||
+#if BOOST_VERSION < 106600
|
|
||||||
return (impl_->socket_.native());
|
|
||||||
+#else
|
|
||||||
+ return (impl_->socket_.native_handle());
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
int
|
|
@ -6,7 +6,7 @@ index dd4a81f..04dd2c8 100644
|
|||||||
else
|
else
|
||||||
CRYPTO_NAME="OpenSSL"
|
CRYPTO_NAME="OpenSSL"
|
||||||
DISABLED_CRYPTO="Botan"
|
DISABLED_CRYPTO="Botan"
|
||||||
- CRYPTO_PACKAGE="openssl-1.0.2"
|
- CRYPTO_PACKAGE="openssl-1.1.0"
|
||||||
+ CRYPTO_PACKAGE="openssl"
|
+ CRYPTO_PACKAGE="openssl"
|
||||||
AC_DEFINE_UNQUOTED([WITH_OPENSSL], [], [Compile with OpenSSL crypto])
|
AC_DEFINE_UNQUOTED([WITH_OPENSSL], [], [Compile with OpenSSL crypto])
|
||||||
AC_MSG_CHECKING(for OpenSSL library)
|
AC_MSG_CHECKING(for OpenSSL library)
|
||||||
|
64
kea.spec
64
kea.spec
@ -1,19 +1,19 @@
|
|||||||
#http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
|
#http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
|
||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
|
%define BETAVER beta1
|
||||||
|
|
||||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||||
Name: kea
|
Name: kea
|
||||||
Version: 1.3.0
|
Version: 1.5.0
|
||||||
Release: 12%{?dist}
|
Release: %{BETAVER}.2%{?dist}
|
||||||
License: MPLv2.0 and Boost
|
License: MPLv2.0 and Boost
|
||||||
URL: http://kea.isc.org
|
URL: http://kea.isc.org
|
||||||
Source0: http://ftp.isc.org/isc/kea/%{version}/kea-%{version}.tar.gz
|
Source0: http://ftp.isc.org/isc/kea/%{version}/kea-%{version}-%{BETAVER}.tar.gz
|
||||||
|
|
||||||
# http://kea.isc.org/ticket/3529
|
# http://kea.isc.org/ticket/3529
|
||||||
Patch0: kea-systemd.patch
|
Patch0: kea-systemd.patch
|
||||||
Patch1: kea-1.3.0-hooksdir.patch
|
Patch1: kea-1.3.0-hooksdir.patch
|
||||||
Patch2: kea-openssl.patch
|
Patch2: kea-openssl.patch
|
||||||
Patch3: kea-boost_1.66.patch
|
|
||||||
|
|
||||||
# autoreconf
|
# autoreconf
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
@ -23,8 +23,6 @@ BuildRequires: gcc-c++
|
|||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
# %%configure --with-dhcp-mysql
|
# %%configure --with-dhcp-mysql
|
||||||
BuildRequires: mariadb-connector-c-devel
|
BuildRequires: mariadb-connector-c-devel
|
||||||
# %%configure --with-dhcp-pgsql
|
|
||||||
BuildRequires: libpq-devel
|
|
||||||
# TODO: propose upstream fix so this is not needed (no server-side related
|
# TODO: propose upstream fix so this is not needed (no server-side related
|
||||||
# headers nor configuration should be needed)
|
# headers nor configuration should be needed)
|
||||||
BuildRequires: postgresql-server-devel
|
BuildRequires: postgresql-server-devel
|
||||||
@ -88,15 +86,10 @@ Requires: pkgconfig
|
|||||||
Header files and API documentation.
|
Header files and API documentation.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n kea-%{version}
|
%setup -q -n kea-%{version}-%{BETAVER}
|
||||||
%patch0 -p1 -b .systemd
|
%patch0 -p1 -b .systemd
|
||||||
%patch1 -p1 -b .hooksdir
|
%patch1 -p1 -b .hooksdir
|
||||||
%patch2 -p1 -b .openssl
|
%patch2 -p1 -b .openssl
|
||||||
%patch3 -p1 -b .boost
|
|
||||||
|
|
||||||
# install leases db in /var/lib/kea/ not /var/kea/
|
|
||||||
# http://kea.isc.org/ticket/3523
|
|
||||||
sed -i -e 's|@localstatedir@|@sharedstatedir@|g' src/lib/dhcpsrv/Makefile.am
|
|
||||||
|
|
||||||
# to be able to build on ppc64(le)
|
# to be able to build on ppc64(le)
|
||||||
# https://sourceforge.net/p/flex/bugs/197
|
# https://sourceforge.net/p/flex/bugs/197
|
||||||
@ -109,6 +102,7 @@ export CXXFLAGS="%{optflags} -std=gnu++11 -Wno-deprecated-declarations"
|
|||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--disable-dependency-tracking \
|
--disable-dependency-tracking \
|
||||||
|
--localstatedir=%{_sharedstatedir} \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
--disable-silent-rules \
|
--disable-silent-rules \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
@ -193,9 +187,6 @@ EOF
|
|||||||
%{_datarootdir}/kea/scripts
|
%{_datarootdir}/kea/scripts
|
||||||
%dir /run/kea/
|
%dir /run/kea/
|
||||||
%{_tmpfilesdir}/kea.conf
|
%{_tmpfilesdir}/kea.conf
|
||||||
%{_datarootdir}/kea/dhcp-ddns.spec
|
|
||||||
%{_datarootdir}/kea/dhcp4.spec
|
|
||||||
%{_datarootdir}/kea/dhcp6.spec
|
|
||||||
%dir %{_sharedstatedir}/kea
|
%dir %{_sharedstatedir}/kea
|
||||||
%config(noreplace) %{_sharedstatedir}/kea/kea-leases4.csv
|
%config(noreplace) %{_sharedstatedir}/kea/kea-leases4.csv
|
||||||
%config(noreplace) %{_sharedstatedir}/kea/kea-leases6.csv
|
%config(noreplace) %{_sharedstatedir}/kea/kea-leases6.csv
|
||||||
@ -222,51 +213,18 @@ EOF
|
|||||||
%files libs
|
%files libs
|
||||||
#%%dir %%{_pkgdocdir}/
|
#%%dir %%{_pkgdocdir}/
|
||||||
#%%{_pkgdocdir}/COPYING
|
#%%{_pkgdocdir}/COPYING
|
||||||
#%%{_pkgdocdir}/LICENSE_1_0.txt
|
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%license ext/coroutine/LICENSE_1_0.txt
|
%{_libdir}/libkea-*.so.*
|
||||||
%{_libdir}/libkea-asiodns.so.*
|
|
||||||
%{_libdir}/libkea-asiolink.so.*
|
|
||||||
%{_libdir}/libkea-cc.so.*
|
|
||||||
%{_libdir}/libkea-cfgclient.so.*
|
|
||||||
%{_libdir}/libkea-cryptolink.so.*
|
|
||||||
%{_libdir}/libkea-dhcp++.so.*
|
|
||||||
%{_libdir}/libkea-dhcp_ddns.so.*
|
|
||||||
%{_libdir}/libkea-dhcpsrv.so.*
|
|
||||||
%{_libdir}/libkea-dns++.so.*
|
|
||||||
%{_libdir}/libkea-eval.so.*
|
|
||||||
%{_libdir}/libkea-exceptions.so.*
|
|
||||||
%{_libdir}/libkea-hooks.so.*
|
|
||||||
%{_libdir}/libkea-log.so.*
|
|
||||||
%{_libdir}/libkea-stats.so.*
|
|
||||||
%{_libdir}/libkea-threads.so.*
|
|
||||||
%{_libdir}/libkea-util-io.so.*
|
|
||||||
%{_libdir}/libkea-util.so.*
|
|
||||||
%{_libdir}/libkea-http.so*
|
|
||||||
%{_libdir}/libkea-process.so*
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/kea
|
%{_includedir}/kea
|
||||||
%{_libdir}/libkea-asiodns.so
|
%{_libdir}/libkea-*.so
|
||||||
%{_libdir}/libkea-asiolink.so
|
|
||||||
%{_libdir}/libkea-cc.so
|
|
||||||
%{_libdir}/libkea-cfgclient.so
|
|
||||||
%{_libdir}/libkea-cryptolink.so
|
|
||||||
%{_libdir}/libkea-dhcp++.so
|
|
||||||
%{_libdir}/libkea-dhcp_ddns.so
|
|
||||||
%{_libdir}/libkea-dhcpsrv.so
|
|
||||||
%{_libdir}/libkea-dns++.so
|
|
||||||
%{_libdir}/libkea-eval.so
|
|
||||||
%{_libdir}/libkea-exceptions.so
|
|
||||||
%{_libdir}/libkea-hooks.so
|
|
||||||
%{_libdir}/libkea-log.so
|
|
||||||
%{_libdir}/libkea-stats.so
|
|
||||||
%{_libdir}/libkea-threads.so
|
|
||||||
%{_libdir}/libkea-util-io.so
|
|
||||||
%{_libdir}/libkea-util.so
|
|
||||||
%{_libdir}/pkgconfig/dns++.pc
|
%{_libdir}/pkgconfig/dns++.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 20 2018 Pavel Zhukov <pzhukov@redhat.com> - 1.5.0-2
|
||||||
|
- Update to 1.5.0 beta
|
||||||
|
|
||||||
* Mon Aug 27 2018 Pavel Zhukov <pzhukov@redhat.com> - 1.3.0-12
|
* Mon Aug 27 2018 Pavel Zhukov <pzhukov@redhat.com> - 1.3.0-12
|
||||||
- Disable tests again.
|
- Disable tests again.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (kea-1.3.0.tar.gz) = 4708485efe537d9af00b50da9a3f33b740edaf37d9bbfe96f5625e30715349c48ef8a32f5abb8320f00821aea642a5b7ecdbc9f0d323a71b7a07f46f1bed978b
|
SHA512 (kea-1.5.0-beta1.tar.gz) = a87806808d8afd7cc4735581fc0d722bb595a28474748f0bd98a07b37fe04bb7958a5c3cb374211e3ff3f73e7a5d642c7f3bf1412fc0e10d8086f3ece0c6e8af
|
||||||
|
Loading…
x
Reference in New Issue
Block a user