1.1.0-beta
This commit is contained in:
parent
9659ad88cb
commit
24209acb84
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/kea-1.0.0-beta.tar.gz
|
||||
/kea-1.0.0-beta2.tar.gz
|
||||
/kea-1.0.0.tar.gz
|
||||
/kea-1.1.0-beta.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up ./ext/coroutine/coroutine.h.coroutinepgsql ./ext/coroutine/coroutine.h
|
||||
--- ./ext/coroutine/coroutine.h.coroutinepgsql 2015-12-28 13:18:05.000000000 +0100
|
||||
+++ ./ext/coroutine/coroutine.h 2016-03-15 14:58:26.344825900 +0100
|
||||
diff -up kea-1.1.0-beta/ext/coroutine/coroutine.h.coroutinepgsql kea-1.1.0-beta/ext/coroutine/coroutine.h
|
||||
--- kea-1.1.0-beta/ext/coroutine/coroutine.h.coroutinepgsql 2016-08-28 20:36:34.000000000 +0200
|
||||
+++ kea-1.1.0-beta/ext/coroutine/coroutine.h 2016-09-01 09:59:16.767902664 +0200
|
||||
@@ -108,7 +108,7 @@ private:
|
||||
for (_coro_value = __LINE__;;) \
|
||||
if (_coro_value == 0) \
|
||||
@ -10,12 +10,24 @@ diff -up ./ext/coroutine/coroutine.h.coroutinepgsql ./ext/coroutine/coroutine.h
|
||||
break; \
|
||||
} \
|
||||
else \
|
||||
diff -up ./src/lib/dhcpsrv/pgsql_lease_mgr.cc.coroutinepgsql ./src/lib/dhcpsrv/pgsql_lease_mgr.cc
|
||||
--- ./src/lib/dhcpsrv/pgsql_lease_mgr.cc.coroutinepgsql 2015-12-28 13:18:45.000000000 +0100
|
||||
+++ ./src/lib/dhcpsrv/pgsql_lease_mgr.cc 2016-03-15 13:59:06.837391677 +0100
|
||||
@@ -1690,7 +1690,7 @@ PgSqlLeaseMgr::getVersion() const {
|
||||
diff -up kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_host_data_source.cc.coroutinepgsql kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_host_data_source.cc
|
||||
--- kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_host_data_source.cc.coroutinepgsql 2016-08-28 20:36:34.000000000 +0200
|
||||
+++ kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_host_data_source.cc 2016-09-02 19:48:37.210354247 +0200
|
||||
@@ -1698,7 +1698,7 @@ std::pair<uint32_t, uint32_t> PgSqlHostD
|
||||
uint32_t minor;
|
||||
PgSqlExchange::getColumnValue(r, 0, 0, minor);
|
||||
|
||||
PQclear(r);
|
||||
- return (std::make_pair<uint32_t, uint32_t>(version, minor));
|
||||
+ return (make_pair(version, minor));
|
||||
}
|
||||
|
||||
void
|
||||
diff -up kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_lease_mgr.cc.coroutinepgsql kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_lease_mgr.cc
|
||||
--- kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_lease_mgr.cc.coroutinepgsql 2016-08-28 20:36:34.000000000 +0200
|
||||
+++ kea-1.1.0-beta/src/lib/dhcpsrv/pgsql_lease_mgr.cc 2016-09-01 09:59:16.767902664 +0200
|
||||
@@ -1391,7 +1391,7 @@ PgSqlLeaseMgr::getVersion() const {
|
||||
tmp.str(PQgetvalue(r, 0, 1));
|
||||
tmp >> minor;
|
||||
|
||||
- return make_pair<uint32_t, uint32_t>(version, minor);
|
||||
+ return (make_pair(version, minor));
|
||||
|
@ -186,7 +186,7 @@ index 43d7bff..82625ca 100644
|
||||
echo "Input file: $1"
|
||||
echo "Output file: $2"
|
||||
|
||||
-sed -e "s@SEP@\@localstatedir\@@SEP@${localstatedir}@SEP@g; s@SEP@\@prefix@@SEP@${prefix}@SEP@g; s@SEP@\@sysconfdir@@SEP@${sysconfdir}@SEP@g" $1 > $2
|
||||
-sed -e "s@SEP@\@localstatedir\@@SEP@${localstatedir}@SEP@g; s@SEP@\@prefix\@@SEP@${prefix}@SEP@g; s@SEP@\@sysconfdir\@@SEP@${sysconfdir}@SEP@g" $1 > $2
|
||||
+sed -e "s@SEP@\@localstatedir\@@SEP@${localstatedir}@SEP@g; s@SEP@\@prefix\@@SEP@${prefix}@SEP@g; s@SEP@\@sysconfdir\@@SEP@${sysconfdir}@SEP@g; s@SEP@\@sbindir\@@SEP@${sbindir}@SEP@g" $1 > $2
|
||||
--
|
||||
2.3.4
|
||||
|
13
kea.spec
13
kea.spec
@ -1,16 +1,16 @@
|
||||
#http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
|
||||
%global _hardened_build 1
|
||||
|
||||
%global prever beta2
|
||||
%global prever beta
|
||||
|
||||
#%%global VERSION %%{version}-%%{patchver}
|
||||
#%%global VERSION %%{version}-%%{prever}
|
||||
%global VERSION %{version}
|
||||
#%%global VERSION %%{version}
|
||||
%global VERSION %{version}-%{prever}
|
||||
|
||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||
Name: kea
|
||||
Version: 1.0.0
|
||||
Release: 11%{?dist}
|
||||
Version: 1.1.0
|
||||
Release: 0.1%{?dist}
|
||||
License: MPLv2.0 and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{VERSION}/kea-%{VERSION}.tar.gz
|
||||
@ -242,6 +242,9 @@ EOF
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Thu Sep 01 2016 Jiri Popelka <jpopelka@redhat.com> - 1.1.0-0.1
|
||||
- 1.1.0-beta
|
||||
|
||||
* Fri Aug 12 2016 Michal Toman <mtoman@fedoraproject.org> - 1.0.0-11
|
||||
- No valgrind on MIPS
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user