Package released version (#1545096)
This commit is contained in:
parent
f70621a38e
commit
1f521f8879
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/kea-1.1.0.tar.gz
|
||||
/kea-1.2.0.tar.gz
|
||||
/kea-1.3.0-beta.tar.gz
|
||||
/kea-1.3.0.tar.gz
|
||||
|
@ -21,62 +21,6 @@ index 46780d5..43c57b1 100644
|
||||
# Check for optreset in unistd.h. On BSD systems the optreset is
|
||||
# used to reset the state of getopt() function. Resetting its state
|
||||
# is required if command line arguments are parsed multiple times
|
||||
diff --git a/src/bin/keactrl/Makefile.am b/src/bin/keactrl/Makefile.am
|
||||
index c83a597..827f916 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -32,9 +32,37 @@ endif
|
||||
kea.conf: kea.conf.pre
|
||||
$(top_builddir)/tools/path_replacer.sh $(top_srcdir)/src/bin/keactrl/kea.conf.pre $@
|
||||
|
||||
+INSTALL_TARGETS = install-empty
|
||||
+
|
||||
if INSTALL_CONFIGURATIONS
|
||||
|
||||
install-data-local:
|
||||
+INSTALL_TARGETS += install-config-files
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+if USE_SYSTEMD
|
||||
+
|
||||
+EXTRA_DIST += kea-dhcp4.service.in kea-dhcp6.service.in kea-dhcp-ddns.service.in
|
||||
+DISTCLEANFILES += kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service
|
||||
+BUILT_SOURCES += kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service
|
||||
+INSTALL_TARGETS += install-systemd-files
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+kea-dhcp4.service: kea-dhcp4.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp6.service: kea-dhcp6.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp-ddns.service: kea-dhcp-ddns.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+install-empty:
|
||||
+ :
|
||||
+
|
||||
+install-config-files:
|
||||
$(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@
|
||||
for f in $(CONFIGFILES) ; do \
|
||||
if test ! -f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f; then \
|
||||
@@ -42,4 +70,12 @@ install-data-local:
|
||||
fi ; \
|
||||
done
|
||||
|
||||
-endif
|
||||
+install-systemd-files:
|
||||
+ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNITDIR)
|
||||
+ $(INSTALL_DATA) kea-dhcp4.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp4.service
|
||||
+ $(INSTALL_DATA) kea-dhcp6.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp6.service
|
||||
+ $(INSTALL_DATA) kea-dhcp-ddns.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp-ddns.service
|
||||
+
|
||||
+install-data-local: $(INSTALL_TARGETS)
|
||||
+
|
||||
+uninstall-local: $(UNINSTALL_TARGETS)
|
||||
diff --git a/tools/path_replacer.sh.in b/tools/path_replacer.sh.in
|
||||
index f444afc..2ce8b3b 100644
|
||||
--- a/tools/path_replacer.sh.in
|
||||
@ -97,36 +41,6 @@ index f444afc..2ce8b3b 100644
|
||||
|
||||
-sed -e "s@SEP@\@localstatedir\@@SEP@${localstatedir}@SEP@g; s@SEP@\@prefix\@@SEP@${prefix}@SEP@g; s@SEP@\@sysconfdir\@@SEP@${sysconfdir}@SEP@g" $1 > $2
|
||||
+sed -e "s@SEP@\@localstatedir\@@SEP@${localstatedir}@SEP@g; s@SEP@\@prefix\@@SEP@${prefix}@SEP@g; s@SEP@\@sysconfdir\@@SEP@${sysconfdir}@SEP@g; s@SEP@\@sbindir\@@SEP@${sbindir}@SEP@g" $1 > $2
|
||||
diff --git a/src/bin/keactrl/Makefile.am b/src/bin/keactrl/Makefile.am
|
||||
index 827f916..547df73 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -76,6 +76,4 @@ install-systemd-files:
|
||||
$(INSTALL_DATA) kea-dhcp6.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp6.service
|
||||
$(INSTALL_DATA) kea-dhcp-ddns.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp-ddns.service
|
||||
|
||||
-install-data-local: $(INSTALL_TARGETS)
|
||||
-
|
||||
uninstall-local: $(UNINSTALL_TARGETS)
|
||||
diff --git a/src/bin/keactrl/Makefile.am b/src/bin/keactrl/Makefile.am
|
||||
index 547df73..10f2233 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -36,7 +36,6 @@ INSTALL_TARGETS = install-empty
|
||||
|
||||
if INSTALL_CONFIGURATIONS
|
||||
|
||||
-install-data-local:
|
||||
INSTALL_TARGETS += install-config-files
|
||||
|
||||
endif
|
||||
@@ -76,4 +75,6 @@ install-systemd-files:
|
||||
$(INSTALL_DATA) kea-dhcp6.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp6.service
|
||||
$(INSTALL_DATA) kea-dhcp-ddns.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp-ddns.service
|
||||
|
||||
+install-data-local: $(INSTALL_TARGETS)
|
||||
+
|
||||
uninstall-local: $(UNINSTALL_TARGETS)
|
||||
diff --git a/src/bin/keactrl/kea-dhcp-ddns.service.in b/src/bin/keactrl/kea-dhcp-ddns.service.in
|
||||
new file mode 100644
|
||||
index 0000000..d1e0526
|
||||
@ -181,3 +95,62 @@ index 0000000..c24f584
|
||||
+
|
||||
+[Install]
|
||||
+WantedBy=multi-user.target
|
||||
diff --git a/src/bin/keactrl/Makefile.am b/src/bin/keactrl/Makefile.am
|
||||
index 9eb3da9..b556fcc 100644
|
||||
--- a/src/bin/keactrl/Makefile.am
|
||||
+++ b/src/bin/keactrl/Makefile.am
|
||||
@@ -50,6 +50,8 @@ kea-ctrl-agent.conf: kea-ctrl-agent.conf.pre
|
||||
$(top_builddir)/tools/path_replacer.sh \
|
||||
$(top_srcdir)/src/bin/keactrl/kea-ctrl-agent.conf.pre $@
|
||||
|
||||
+INSTALL_TARGETS = install-empty
|
||||
+
|
||||
if INSTALL_CONFIGURATIONS
|
||||
|
||||
# Since Kea 1.3.0 release we have 4 different Kea configuration files
|
||||
@@ -60,6 +62,31 @@ if INSTALL_CONFIGURATIONS
|
||||
# To preserve any user modifications to the old version of the file,
|
||||
# this old file is backed up as keactrl.conf.bak.
|
||||
install-data-local:
|
||||
+INSTALL_TARGETS += install-config-files
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+if USE_SYSTEMD
|
||||
+
|
||||
+EXTRA_DIST += kea-dhcp4.service.in kea-dhcp6.service.in kea-dhcp-ddns.service.in
|
||||
+DISTCLEANFILES += kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service
|
||||
+BUILT_SOURCES += kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service
|
||||
+INSTALL_TARGETS += install-systemd-files
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+kea-dhcp4.service: kea-dhcp4.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp6.service: kea-dhcp6.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+kea-dhcp-ddns.service: kea-dhcp-ddns.service.in
|
||||
+ $(top_builddir)/tools/path_replacer.sh $< $@
|
||||
+
|
||||
+install-empty:
|
||||
+
|
||||
+install-config-files:
|
||||
$(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@
|
||||
for f in $(CONFIGFILES) ; do \
|
||||
if test -f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f && \
|
||||
@@ -72,4 +99,12 @@ install-data-local:
|
||||
fi; \
|
||||
done
|
||||
|
||||
-endif
|
||||
+install-systemd-files:
|
||||
+ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNITDIR)
|
||||
+ $(INSTALL_DATA) kea-dhcp4.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp4.service
|
||||
+ $(INSTALL_DATA) kea-dhcp6.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp6.service
|
||||
+ $(INSTALL_DATA) kea-dhcp-ddns.service $(DESTDIR)$(SYSTEMD_UNITDIR)/kea-dhcp-ddns.service
|
||||
+
|
||||
+install-data-local: $(INSTALL_TARGETS)
|
||||
+
|
||||
+uninstall-local: $(UNINSTALL_TARGETS)
|
||||
|
29
kea.spec
29
kea.spec
@ -1,19 +1,13 @@
|
||||
#http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
|
||||
%global _hardened_build 1
|
||||
|
||||
%global prever beta
|
||||
|
||||
|
||||
Summary: DHCPv4, DHCPv6 and DDNS server from ISC
|
||||
Name: kea
|
||||
#%%global VERSION %%{LVERSION}-%%{patchver}
|
||||
%global LVERSION %{version}-%{prever}
|
||||
#%%global VERSION %%{LVERSION}
|
||||
Version: 1.3.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: MPLv2.0 and Boost
|
||||
URL: http://kea.isc.org
|
||||
Source0: http://ftp.isc.org/isc/kea/%{LVERSION}/kea-%{LVERSION}.tar.gz
|
||||
Source0: http://ftp.isc.org/isc/kea/%{version}/kea-%{version}.tar.gz
|
||||
|
||||
# http://kea.isc.org/ticket/3529
|
||||
Patch0: kea-systemd.patch
|
||||
@ -90,7 +84,7 @@ Requires: pkgconfig
|
||||
Header files and API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q -n kea-%{LVERSION}
|
||||
%setup -q -n kea-%{version}
|
||||
%patch0 -p1 -b .systemd
|
||||
%patch1 -p1 -b .hooksdir
|
||||
%patch2 -p1 -b .openssl
|
||||
@ -186,8 +180,11 @@ EOF
|
||||
%{_unitdir}/kea-dhcp6.service
|
||||
%{_unitdir}/kea-dhcp-ddns.service
|
||||
%dir %{_sysconfdir}/kea/
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea-ctrl-agent.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/keactrl.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea-dhcp4.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea-dhcp6.conf
|
||||
%config(noreplace) %{_sysconfdir}/kea/kea-dhcp-ddns.conf
|
||||
%dir %{_datarootdir}/kea/
|
||||
%{_datarootdir}/kea/scripts
|
||||
%dir /run/kea/
|
||||
@ -213,7 +210,6 @@ EOF
|
||||
%{_mandir}/man8/keactrl.8.gz
|
||||
%{_mandir}/man8/perfdhcp.8.gz
|
||||
%{_mandir}/man8/kea-ctrl-agent.8.gz
|
||||
%{_mandir}/man8/kea-shell.8.gz
|
||||
|
||||
%files hooks
|
||||
%dir %{_libdir}/%{name}
|
||||
@ -242,12 +238,8 @@ EOF
|
||||
%{_libdir}/libkea-threads.so.*
|
||||
%{_libdir}/libkea-util-io.so.*
|
||||
%{_libdir}/libkea-util.so.*
|
||||
%{_libdir}/libkea-http.so
|
||||
%{_libdir}/libkea-http.so.0
|
||||
%{_libdir}/libkea-http.so.0.0.0
|
||||
%{_libdir}/libkea-process.so
|
||||
%{_libdir}/libkea-process.so.0
|
||||
%{_libdir}/libkea-process.so.0.0.0
|
||||
%{_libdir}/libkea-http.so*
|
||||
%{_libdir}/libkea-process.so*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/kea
|
||||
@ -271,6 +263,9 @@ EOF
|
||||
%{_libdir}/pkgconfig/dns++.pc
|
||||
|
||||
%changelog
|
||||
* Wed Feb 14 2018 Pavel Zhukov <landgraf@fedoraproject.org> - 1.3.0-7
|
||||
- Package released version (#1545096)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (kea-1.3.0-beta.tar.gz) = 24d69bda059aff0187c1e99bd4825591aef1bb876502a0ad5a67457fe02e08b3738de4e0a0c55c6ac482e3c2b8de02c4528c354c6cea598e64d3c553e1fcc051
|
||||
SHA512 (kea-1.3.0.tar.gz) = 4708485efe537d9af00b50da9a3f33b740edaf37d9bbfe96f5625e30715349c48ef8a32f5abb8320f00821aea642a5b7ecdbc9f0d323a71b7a07f46f1bed978b
|
||||
|
Loading…
Reference in New Issue
Block a user