fix bz#1376181, fix endless loop in svgicons

This commit is contained in:
Than Ngo 2016-09-28 17:16:59 +02:00
parent 96d7b4c7a4
commit e35aea8f00
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up kdelibs-3.5.10/kdecore/svgicons/ksvgiconpainter.cpp.than kdelibs-3.5.10/kdecore/svgicons/ksvgiconpainter.cpp
--- kdelibs-3.5.10/kdecore/svgicons/ksvgiconpainter.cpp.than 2016-09-28 16:58:47.881217306 +0200
+++ kdelibs-3.5.10/kdecore/svgicons/ksvgiconpainter.cpp 2016-09-28 16:59:20.518989958 +0200
@@ -2208,7 +2208,7 @@ void KSVGIconPainter::drawPath(const QSt
break;
}
- if(*ptr == '+' || *ptr == '-' || (*ptr >= '0' && *ptr <= '9'))
+ if(*ptr == '+' || *ptr == '-' || (*ptr >= '0' && *ptr <= '9')) || *ptr == '.'
{
// there are still coords in this command
if(command == 'M')

View File

@ -18,7 +18,7 @@
Summary: KDE 3 Libraries
Name: kdelibs3
Version: 3.5.10
Release: 75%{?dist}
Release: 76%{?dist}
License: LGPLv2
Url: http://www.kde.org/
@ -124,6 +124,9 @@ Patch301: kde3-automake-version.patch
# also add --force-missing to get aarch64 support (#925029/#925627)
Patch302: kde3-automake-add-missing.patch
# fix enless loop in svgicon
Patch303: kdelibs3-svgicon-endlessloop.patch
Requires: hicolor-icon-theme
Requires: kde-settings >= 3.5
Requires: kde-filesystem
@ -289,6 +292,8 @@ This package includes tools kgrantpty and kpac_dhcp_helper.
%patch300 -p1 -b .acinclude
%patch301 -p1 -b .automake-version
%patch302 -p1 -b .automake-add-missing
%patch303 -p1 -b .endless-loop
make -f admin/Makefile.common cvs
@ -609,6 +614,9 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%attr(4755,root,root) %{_bindir}/kpac_dhcp_helper
%changelog
* Wed Sep 28 2016 Than Ngo <than@redhat.com> - 3.5.10-76
- fix bz#1376181, fix endless loop in svgicons
* Mon Jun 27 2016 Than Ngo <than@redhat.com> - 3.5.10-75
- move kpac_dhcp_helper, kpac_dhcp_helper into separate subpackage