- kde-3.5.9

This commit is contained in:
Rex Dieter 2008-02-14 14:57:22 +00:00
parent 1c63d2b766
commit d550c71819
7 changed files with 8 additions and 654 deletions

View File

@ -1,4 +1 @@
clog
kdelibs-3.5.6.tar.bz2
kdelibs-3.5.7.tar.bz2
kdelibs-3.5.8.tar.bz2
kdelibs-3.5.9.tar.bz2

View File

@ -1,41 +0,0 @@
Index: kioslave/http/http.cc
===================================================================
--- kioslave/http/http.cc (Revision 717341)
+++ kioslave/http/http.cc (Revision 726097)
@@ -3409,10 +3409,6 @@
} while (!m_bEOF && (len || noHeader) && (headerSize < maxHeaderSize) && (gets(buffer, sizeof(buffer)-1)));
- // Send the current response before processing starts or it
- // might never get sent...
- forwardHttpResponseHeader();
-
// Now process the HTTP/1.1 upgrade
QStringList::Iterator opt = upgradeOffers.begin();
for( ; opt != upgradeOffers.end(); ++opt) {
@@ -3818,6 +3814,10 @@
mimeType( m_strMimeType );
}
+ // Do not move send response header before any redirection as it seems
+ // to screw up some sites. See BR# 150904.
+ forwardHttpResponseHeader();
+
if (m_request.method == HTTP_HEAD)
return true;
@@ -3830,10 +3830,10 @@
// Check...
createCacheEntry(m_strMimeType, expireDate); // Create a cache entry
if (!m_request.fcache)
- {
- m_request.bCachedWrite = false; // Error creating cache entry.
- kdDebug(7113) << "(" << m_pid << ") Error creating cache entry for " << m_request.url.url()<<"!\n";
- }
+ {
+ m_request.bCachedWrite = false; // Error creating cache entry.
+ kdDebug(7113) << "(" << m_pid << ") Error creating cache entry for " << m_request.url.url()<<"!\n";
+ }
m_request.expireDate = expireDate;
m_maxCacheSize = config()->readNumEntry("MaxCacheSize", DEFAULT_MAX_CACHE_SIZE) / 2;
}

View File

@ -1,13 +0,0 @@
--- branches/KDE/3.5/kdelibs/kdeui/kactionclasses.cpp 2007/08/30 19:30:39 706570
+++ branches/KDE/3.5/kdelibs/kdeui/kactionclasses.cpp 2007/10/20 20:49:01 727528
@@ -667,8 +667,8 @@
KToolBar* bar = static_cast<KToolBar*>( widget );
int id_ = KAction::getToolButtonID();
bar->insertCombo( comboItems(), id_, isEditable(),
- SIGNAL( activated( int ) ), this,
- SLOT( slotActivated( int ) ), isEnabled(),
+ SIGNAL( activated( const QString & ) ), this,
+ SLOT( slotActivated( const QString & ) ), isEnabled(),
toolTip(), -1, index );
QComboBox *cb = bar->getCombo( id_ );

View File

@ -1,474 +1,3 @@
diff -Nur kdelibs-3.5.8/configure kdelibs-3.5.8-kspell2-enchant/configure
--- kdelibs-3.5.8/configure 2007-10-08 16:42:25.000000000 +0200
+++ kdelibs-3.5.8-kspell2-enchant/configure 2007-12-21 23:51:34.000000000 +0100
@@ -1095,6 +1095,8 @@
GSSAPI_RPATH
LIBPCRE
PCRECFLAGS
+ENCHANT_CFLAGS
+ENCHANT_LIBS
include_aspell_plugin_TRUE
include_aspell_plugin_FALSE
include_hspell_plugin_TRUE
@@ -8507,7 +8509,7 @@
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 8510 "configure"' > conftest.$ac_ext
+ echo '#line 8512 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -10248,11 +10250,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:10251: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:10253: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:10255: \$? = $ac_status" >&5
+ echo "$as_me:10257: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -10481,11 +10483,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:10484: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:10486: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:10488: \$? = $ac_status" >&5
+ echo "$as_me:10490: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -10548,11 +10550,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:10551: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:10553: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:10555: \$? = $ac_status" >&5
+ echo "$as_me:10557: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -12634,7 +12636,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 12637 "configure"
+#line 12639 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -12732,7 +12734,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 12735 "configure"
+#line 12737 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -14893,11 +14895,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14896: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14898: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:14900: \$? = $ac_status" >&5
+ echo "$as_me:14902: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -14960,11 +14962,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14963: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14965: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:14967: \$? = $ac_status" >&5
+ echo "$as_me:14969: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -16263,7 +16265,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 16266 "configure"
+#line 16268 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -16361,7 +16363,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 16364 "configure"
+#line 16366 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -17184,11 +17186,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17187: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:17189: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:17191: \$? = $ac_status" >&5
+ echo "$as_me:17193: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -17251,11 +17253,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17254: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:17256: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:17258: \$? = $ac_status" >&5
+ echo "$as_me:17260: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -19219,11 +19221,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:19222: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:19224: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:19226: \$? = $ac_status" >&5
+ echo "$as_me:19228: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -19452,11 +19454,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:19455: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:19457: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:19459: \$? = $ac_status" >&5
+ echo "$as_me:19461: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings
@@ -19519,11 +19521,11 @@
-e 's:.*FLAGS}? :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:19522: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:19524: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:19526: \$? = $ac_status" >&5
+ echo "$as_me:19528: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -21605,7 +21607,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 21608 "configure"
+#line 21610 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -21703,7 +21705,7 @@
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 21706 "configure"
+#line 21708 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -34800,7 +34802,7 @@
do
for j in jpeglib.h;
do
- echo "configure: 34803: $i/$j" >&5
+ echo "configure: 34805: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
jpeg_incdir=$i
@@ -35098,7 +35100,7 @@
do
for j in $kde_qt_header;
do
- echo "configure: 35101: $i/$j" >&5
+ echo "configure: 35103: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
qt_incdir=$i
@@ -35928,7 +35930,7 @@
do
for j in $kde_check_header;
do
- echo "configure: 35931: $i/$j" >&5
+ echo "configure: 35933: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
kde_incdir=$i
@@ -35958,7 +35960,7 @@
do
for j in $kde_check_lib;
do
- echo "configure: 35961: $i/$j" >&5
+ echo "configure: 35963: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
kde_libdir=$i
@@ -35976,7 +35978,7 @@
do
for j in "kde3/plugins/designer/kdewidgets.la";
do
- echo "configure: 35979: $i/$j" >&5
+ echo "configure: 35981: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
kde_widgetdir=$i
@@ -37812,7 +37814,7 @@
do
for j in apps/ksgmltools2/customization/kde-chunk.xsl;
do
- echo "configure: 37815: $i/$j" >&5
+ echo "configure: 37817: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
KDE_XSL_STYLESHEET=$i
@@ -42136,7 +42138,7 @@
do
for j in qsql.html;
do
- echo "configure: 42139: $i/$j" >&5
+ echo "configure: 42141: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
QTDOCDIR=$i
@@ -48585,7 +48587,7 @@
do
for j in jpeglib.h;
do
- echo "configure: 48588: $i/$j" >&5
+ echo "configure: 48590: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
jpeg_incdir=$i
@@ -50357,7 +50359,7 @@
do
for j in openssl/ssl.h;
do
- echo "configure: 50360: $i/$j" >&5
+ echo "configure: 50362: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
ssl_incdir=$i
@@ -51076,7 +51078,7 @@
do
for j in gssapi.h;
do
- echo "configure: 51079: $i/$j" >&5
+ echo "configure: 51081: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
gssapi_incdir=$i
@@ -51098,7 +51100,7 @@
do
for j in libgssapi.$ext;
do
- echo "configure: 51101: $i/$j" >&5
+ echo "configure: 51103: $i/$j" >&5
if test -r "$i/$j"; then
echo "taking that" >&5
gssapi_libdir=$i
@@ -51755,6 +51757,108 @@
+ succeeded=no
+
+ if test -z "$PKG_CONFIG"; then
+ # Extract the first word of "pkg-config", so it can be a program name with args.
+set dummy pkg-config; ac_word=$2
+{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+if test "${ac_cv_path_PKG_CONFIG+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ case $PKG_CONFIG in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+done
+IFS=$as_save_IFS
+
+ test -z "$ac_cv_path_PKG_CONFIG" && ac_cv_path_PKG_CONFIG="no"
+ ;;
+esac
+fi
+PKG_CONFIG=$ac_cv_path_PKG_CONFIG
+if test -n "$PKG_CONFIG"; then
+ { echo "$as_me:$LINENO: result: $PKG_CONFIG" >&5
+echo "${ECHO_T}$PKG_CONFIG" >&6; }
+else
+ { echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6; }
+fi
+
+
+ fi
+
+ if test "$PKG_CONFIG" = "no" ; then
+ echo "*** The pkg-config script could not be found. Make sure it is"
+ echo "*** in your path, or set the PKG_CONFIG environment variable"
+ echo "*** to the full path to pkg-config."
+ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
+ else
+ PKG_CONFIG_MIN_VERSION=0.9.0
+ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
+ { echo "$as_me:$LINENO: checking for enchant >= 1.2.5" >&5
+echo $ECHO_N "checking for enchant >= 1.2.5... $ECHO_C" >&6; }
+
+ if $PKG_CONFIG --exists "enchant >= 1.2.5" ; then
+ { echo "$as_me:$LINENO: result: yes" >&5
+echo "${ECHO_T}yes" >&6; }
+ succeeded=yes
+
+ { echo "$as_me:$LINENO: checking ENCHANT_CFLAGS" >&5
+echo $ECHO_N "checking ENCHANT_CFLAGS... $ECHO_C" >&6; }
+ ENCHANT_CFLAGS=`$PKG_CONFIG --cflags "enchant >= 1.2.5"`
+ { echo "$as_me:$LINENO: result: $ENCHANT_CFLAGS" >&5
+echo "${ECHO_T}$ENCHANT_CFLAGS" >&6; }
+
+ { echo "$as_me:$LINENO: checking ENCHANT_LIBS" >&5
+echo $ECHO_N "checking ENCHANT_LIBS... $ECHO_C" >&6; }
+ ENCHANT_LIBS=`$PKG_CONFIG --libs "enchant >= 1.2.5"`
+ { echo "$as_me:$LINENO: result: $ENCHANT_LIBS" >&5
+echo "${ECHO_T}$ENCHANT_LIBS" >&6; }
+ else
+ ENCHANT_CFLAGS=""
+ ENCHANT_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+ ENCHANT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "enchant >= 1.2.5"`
+ echo $ENCHANT_PKG_ERRORS
+ fi
+
+
+
+ else
+ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
+ echo "*** See http://www.freedesktop.org/software/pkgconfig"
+ fi
+ fi
+
+ if test $succeeded = yes; then
+ :
+ else
+ { { echo "$as_me:$LINENO: error: Library requirements (enchant >= 1.2.5) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
+echo "$as_me: error: Library requirements (enchant >= 1.2.5) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+
+
+
+
+
# Check whether --with-aspell was given.
if test "${with_aspell+set}" = set; then
withval=$with_aspell; aspell_test="$withval"
@@ -55436,6 +55540,8 @@
GSSAPI_RPATH!$GSSAPI_RPATH$ac_delim
LIBPCRE!$LIBPCRE$ac_delim
PCRECFLAGS!$PCRECFLAGS$ac_delim
+ENCHANT_CFLAGS!$ENCHANT_CFLAGS$ac_delim
+ENCHANT_LIBS!$ENCHANT_LIBS$ac_delim
include_aspell_plugin_TRUE!$include_aspell_plugin_TRUE$ac_delim
include_aspell_plugin_FALSE!$include_aspell_plugin_FALSE$ac_delim
include_hspell_plugin_TRUE!$include_hspell_plugin_TRUE$ac_delim
@@ -55495,8 +55601,6 @@
libkscreensaver_SUBDIR_included_TRUE!$libkscreensaver_SUBDIR_included_TRUE$ac_delim
libkscreensaver_SUBDIR_included_FALSE!$libkscreensaver_SUBDIR_included_FALSE$ac_delim
licenses_SUBDIR_included_TRUE!$licenses_SUBDIR_included_TRUE$ac_delim
-licenses_SUBDIR_included_FALSE!$licenses_SUBDIR_included_FALSE$ac_delim
-mimetypes_SUBDIR_included_TRUE!$mimetypes_SUBDIR_included_TRUE$ac_delim
_ACEOF
if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 97; then
@@ -55538,6 +55642,8 @@
ac_delim='%!_!# '
for ac_last_try in false false false false false :; do
cat >conf$$subs.sed <<_ACEOF
+licenses_SUBDIR_included_FALSE!$licenses_SUBDIR_included_FALSE$ac_delim
+mimetypes_SUBDIR_included_TRUE!$mimetypes_SUBDIR_included_TRUE$ac_delim
mimetypes_SUBDIR_included_FALSE!$mimetypes_SUBDIR_included_FALSE$ac_delim
pics_SUBDIR_included_TRUE!$pics_SUBDIR_included_TRUE$ac_delim
pics_SUBDIR_included_FALSE!$pics_SUBDIR_included_FALSE$ac_delim
@@ -55569,7 +55675,7 @@
LTLIBOBJS!$LTLIBOBJS$ac_delim
_ACEOF
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 29; then
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 31; then
break
elif $ac_last_try; then
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
@@ -56142,11 +56248,6 @@
{ (exit 0); exit 0; }
_ACEOF
-if test "x$with_fast_perl" = "xyes"; then
- perl -i.bak $ac_aux_dir/conf.change.pl $CONFIG_STATUS \
- || mv $CONFIG_STATUS.bak $CONFIG_STATUS
- rm -f $CONFIG_STATUS.bak
-fi
chmod +x $CONFIG_STATUS
ac_clean_files=$ac_clean_files_save
diff -Nur kdelibs-3.5.8/configure.in kdelibs-3.5.8-kspell2-enchant/configure.in
--- kdelibs-3.5.8/configure.in 2007-10-08 16:41:26.000000000 +0200
+++ kdelibs-3.5.8-kspell2-enchant/configure.in 2007-12-21 23:50:43.000000000 +0100

View File

@ -1,115 +0,0 @@
--- kdeui/qxembed.cpp.sav 2007-12-19 18:46:54.000000000 +0100
+++ kdeui/qxembed.cpp 2007-12-19 18:48:07.000000000 +0100
@@ -1013,6 +1013,44 @@ void QXEmbed::embed(WId w)
}
}
+// When a window is reparented into QXEmbed (or created inside of it), this function
+// sets up the actual embedding.
+void QXEmbed::handleEmbed()
+{
+ // only XEMBED apps can survive crash,
+ // see http://lists.kde.org/?l=kfm-devel&m=106752026501968&w=2
+ if( !d->xplain )
+ XAddToSaveSet( qt_xdisplay(), window );
+ XResizeWindow(qt_xdisplay(), window, width(), height());
+ XMapRaised(qt_xdisplay(), window);
+ // L2024: see L2900.
+ sendSyntheticConfigureNotifyEvent();
+ // L2025: ??? [any idea about drag&drop?]
+ extraData()->xDndProxy = window;
+ if ( parent() ) {
+ // L2030: embedded window might have new size requirements.
+ // see L2500, L2520, L2550.
+ QEvent * layoutHint = new QEvent( QEvent::LayoutHint );
+ QApplication::postEvent( parent(), layoutHint );
+ }
+ windowChanged( window );
+ if (d->xplain) {
+ // L2040: Activation has changed. Grab state might change. See L2800.
+ checkGrab();
+ if ( hasFocus() )
+ // L2041: Send fake focus message to inform the client. See L1521.
+ sendFocusMessage(window, XFocusIn, NotifyNormal, NotifyPointer );
+ } else {
+ // L2050: Send XEMBED messages (see L0670, L1312, L1322, L1530)
+ sendXEmbedMessage( window, XEMBED_EMBEDDED_NOTIFY, 0, (long) winId() );
+ if (isActiveWindow())
+ sendXEmbedMessage( window, XEMBED_WINDOW_ACTIVATE);
+ else
+ sendXEmbedMessage( window, XEMBED_WINDOW_DEACTIVATE);
+ if ( hasFocus() )
+ sendXEmbedMessage( window, XEMBED_FOCUS_IN, XEMBED_FOCUS_CURRENT );
+ }
+}
// L1800: Returns the window identifier of the embedded window
WId QXEmbed::embeddedWinId() const
@@ -1051,6 +1089,14 @@ bool QXEmbed::x11Event( XEvent* e)
emit embeddedWindowDestroyed();
}
break;
+ case CreateNotify:
+ // A window was created inside of QXEmbed, handle it as embedded
+ if( true || // flashplayer v9,0,115,0 bug
+ window == 0 ) { // only one window
+ window = e->xcreatewindow.window;
+ handleEmbed();
+ }
+ break;
case ReparentNotify:
if ( e->xreparent.window == d->focusProxy->winId() )
break; // ignore proxy
@@ -1067,40 +1113,8 @@ bool QXEmbed::x11Event( XEvent* e)
XRemoveFromSaveSet( qt_xdisplay(), window );
} else if ( e->xreparent.parent == winId()){
// L2020: We got a window. Complete the embedding process.
- window = e->xreparent.window;
- // only XEMBED apps can survive crash,
- // see http://lists.kde.org/?l=kfm-devel&m=106752026501968&w=2
- if( !d->xplain )
- XAddToSaveSet( qt_xdisplay(), window );
- XResizeWindow(qt_xdisplay(), window, width(), height());
- XMapRaised(qt_xdisplay(), window);
- // L2024: see L2900.
- sendSyntheticConfigureNotifyEvent();
- // L2025: ??? [any idea about drag&drop?]
- extraData()->xDndProxy = window;
- if ( parent() ) {
- // L2030: embedded window might have new size requirements.
- // see L2500, L2520, L2550.
- QEvent * layoutHint = new QEvent( QEvent::LayoutHint );
- QApplication::postEvent( parent(), layoutHint );
- }
- windowChanged( window );
- if (d->xplain) {
- // L2040: Activation has changed. Grab state might change. See L2800.
- checkGrab();
- if ( hasFocus() )
- // L2041: Send fake focus message to inform the client. See L1521.
- sendFocusMessage(window, XFocusIn, NotifyNormal, NotifyPointer );
- } else {
- // L2050: Send XEMBED messages (see L0670, L1312, L1322, L1530)
- sendXEmbedMessage( window, XEMBED_EMBEDDED_NOTIFY, 0, (long) winId() );
- if (isActiveWindow())
- sendXEmbedMessage( window, XEMBED_WINDOW_ACTIVATE);
- else
- sendXEmbedMessage( window, XEMBED_WINDOW_DEACTIVATE);
- if ( hasFocus() )
- sendXEmbedMessage( window, XEMBED_FOCUS_IN, XEMBED_FOCUS_CURRENT );
- }
+ if( e->xreparent.window == window )
+ handleEmbed();
}
break;
case ButtonPress:
--- kdeui/qxembed.h.sav 2007-12-19 18:46:54.000000000 +0100
+++ kdeui/qxembed.h 2007-12-19 18:47:00.000000000 +0100
@@ -226,6 +226,7 @@ private:
QXEmbedData* d;
void checkGrab();
void sendSyntheticConfigureNotifyEvent();
+ void handleEmbed();
};

View File

@ -6,7 +6,7 @@
%define arts 1
%define arts_epoch 8
%define arts_version 1.5.8
%define arts_version 1.5.9
%define qt_epoch 1
%define qt_version 3.3.8
@ -20,8 +20,8 @@
%define apidocs 1
Summary: K Desktop Environment 3 - Libraries
Version: 3.5.8
Release: 24%{?dist}
Version: 3.5.9
Release: 1%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs3
@ -62,7 +62,6 @@ Patch41: kdelibs-3.5.6-utempter.patch
Patch43: kdelibs-3.5.6-lang.patch
Patch45: kdelibs-3.5.7-autostart.patch
Patch46: kdelibs-3.5.8-kate-vhdl.patch
Patch47: kdelibs-3.5.8-new-flash.patch
Patch48: kdelibs-3.5.8-kspell-hunspell.patch
Patch49: kdelibs-3.5.8-kspell2-enchant.patch
Patch50: kdelibs-3.5.8-kspell2-no-ispell.patch
@ -77,8 +76,6 @@ Patch102: kdelibs-3.5.6-137675.patch
Patch103: kdelibs-3.5.0-101956.patch
## upstream patches
Patch200: kdelibs-3.5.8-http-regression.patch
Patch201: kdelibs-3.5.8-kde#150944.patch
%{?arts:Requires: arts >= %{arts_epoch}:%{arts_version}}
Requires: qt >= %{qt_epoch}:%{qt_ver}
@ -232,7 +229,6 @@ format for easy browsing
%patch43 -p1 -b .lang
%patch45 -p1 -b .xdg-autostart
%patch46 -p1 -b .kate-vhdl
%patch47 -p0 -b .new-flash
%if 0%{?fedora} >= 9
%patch48 -p1 -b .kspell
%patch49 -p1 -b .kspell2
@ -244,8 +240,6 @@ format for easy browsing
%patch102 -p0 -b .kde#137675
# upstream patches
%patch200 -p0 -b .http-regression
%patch201 -p4 -b .kde#150944
sed -i -e "s,^#define KDE_VERSION_STRING .*,#define KDE_VERSION_STRING \"%{version}-%{release} %{distname}\"," kdecore/kdeversion.h
@ -535,6 +529,9 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%changelog
* Thu Feb 14 2008 Rex Dieter <rdieter@fedoraproject.org> 3.5.9-1
- kde-3.5.9
* Mon Feb 11 2008 Than Ngo <than@redhat.com> 3.5.8-24
- make kresources hidden on f9+

View File

@ -1 +1 @@
acaa37e79e840d10dca326277a20863c kdelibs-3.5.8.tar.bz2
55e5f00874933d1a7ba7c95e369a205e kdelibs-3.5.9.tar.bz2