remove flawed and obsolete automake version check in admin/cvs.sh

It turns out that the problem was that Rawhide has automake 1.11.5, which
happens to match "automake*1.5*", which is checked before the valid versions.

So we just remove the flawed version checks entirely. Nobody is using an
automake older than 1.6.1 anymore anyway.
This commit is contained in:
Kevin Kofler 2012-06-12 01:32:07 +02:00
parent 496bfe539d
commit b8199a3fbd
2 changed files with 21 additions and 4 deletions

View File

@ -0,0 +1,17 @@
diff -ur kdelibs-3.5.10/admin/cvs.sh kdelibs-3.5.10-automake-version/admin/cvs.sh
--- kdelibs-3.5.10/admin/cvs.sh 2008-08-19 22:28:39.000000000 +0200
+++ kdelibs-3.5.10-automake-version/admin/cvs.sh 2012-06-12 01:24:13.000000000 +0200
@@ -63,12 +63,7 @@
AUTOMAKE_STRING=`$AUTOMAKE --version | head -n 1`
required_automake_version="1.6.1 or newer"
case $AUTOMAKE_STRING in
- automake*1.5d* | automake*1.5* | automake*1.5-* )
- echo "*** YOU'RE USING $AUTOMAKE_STRING."
- echo "*** KDE requires automake $required_automake_version"
- exit 1
- ;;
- automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10*)
+ automake*)
echo "*** $AUTOMAKE_STRING found."
UNSERMAKE=no
;;

View File

@ -73,6 +73,8 @@ Patch55: kdelibs-3.5.10-latex-syntax-kile-2.0.3.patch
Patch56: kdelibs-3.5.10-qcolor_gcc_ftbfs.patch
# fix FTBFS (cups-util.c must include stdio.h, #714133)
Patch57: kdelibs-3.5.10-cups-util-missing-header.patch
# remove flawed and obsolete automake version check in admin/cvs.sh
Patch58: kdelibs-3.5.10-automake-version.patch
# use /etc/kde in addition to /usr/share/config, borrowed from debian
Patch100: kdelibs-3.5.5-kstandarddirs.patch
@ -244,6 +246,7 @@ format for easy browsing
%patch55 -p1 -b .latex-syntax
%patch56 -p1 -b .qcolor_gcc_ftbfs
%patch57 -p1 -b .cups-util
%patch58 -p1 -b .automake-version
%patch100 -p1 -b .kstandarddirs
%patch101 -p1 -b .libtool-shlibext
@ -269,9 +272,6 @@ format for easy browsing
sed -i -e "s,^#define KDE_VERSION_STRING .*,#define KDE_VERSION_STRING \"%{version}-%{release} %{distname}\"," kdecore/kdeversion.h
# hack/fix for newer automake
sed -i.automake -e 's|automake\*1\.10\*|automake*1.1[0-5]*|' admin/cvs.sh
diff -u admin/cvs.sh.automake admin/cvs.sh
make -f admin/Makefile.common cvs
@ -592,7 +592,7 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%changelog
* Mon Jun 11 2012 Kevin Kofler <Kevin@tigcc.ticalc.org> - 3.5.10-37
- rebuild for fixed GCC (#830618)
- fix sed syntax in the automake version hack
- remove flawed and obsolete automake version check in admin/cvs.sh
* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 3.5.10-36
- rebuild (libtiff)