*** empty log message ***

This commit is contained in:
Rex Dieter 2007-12-01 19:11:02 +00:00
parent 05f68626ba
commit ab006f2ecc
6 changed files with 205 additions and 119 deletions

View File

@ -1 +1,4 @@
clog
kdelibs-3.5.6.tar.bz2
kdelibs-3.5.7.tar.bz2
kdelibs-3.5.8.tar.bz2

12
kde.csh
View File

@ -1,17 +1,17 @@
## http://kde.ground.cz/tiki-index.php?page=Environment+Variables
## for possible entries here
# When/if using prelinking, avoids (some) use of kdeinit
## Make sure KDEDIRS is set
if ( ! $?KDEDIRS ) setenv KDEDIRS /usr
## When/if using prelinking, avoids (some) use of kdeinit
if ( -f /etc/sysconfig/prelink ) then
set PRELINKING = `grep "^PRELINKING=" /etc/sysconfig/prelink | cut -d"=" -f2`
if ( "$PRELINKING" == "yes" ) then
if ( ! $?KDE_IS_PRELINKED ) setenv KDE_IS_PRELINKED 1
if ( ! $?KDE_IS_PRELINKED ) setenv KDE_IS_PRELINKED 1
endif
endif
# if not using IP6, speeds DNS operations
## if not using IPv6, speeds DNS operations
# if ( ! $?KDE_NO_IPV6 ) setenv KDE_NO_IPV6 1
# Make sure KDEDIRS is set
if ( ! $?KDEDIRS ) setenv KDEDIRS /usr

9
kde.sh
View File

@ -1,15 +1,12 @@
## http://kde.ground.cz/tiki-index.php?page=Environment+Variables
## for possible entries here
## Make sure KDEDIRS is set
[ -z "$KDEDIRS" ] && KDEDIRS="/usr" && export KDEDIRS
## When/if using prelinking, avoids (some) use of kdeinit
if [ -f /etc/sysconfig/prelink ]; then
if [ `grep '^PRELINKING=yes' /etc/sysconfig/prelink` ] ; then
[ -z "$KDE_IS_PRELINKED" ] && KDE_IS_PRELINKED=1 && export KDE_IS_PRELINKED
fi
fi
## IPV6 support
#[ -z "$KDE_NO_IPV6" ] && KDE_NO_IPV6=1 && export KDE_NO_IPV6
## Make sure KDEDIRS is set
[ -z "$KDEDIRS" ] && KDEDIRS="/usr" && export KDEDIRS

View File

@ -1,15 +1,3 @@
diff -Nur kdelibs-3.5.6.orig/configure.in kdelibs-3.5.6/configure.in
--- kdelibs-3.5.6.orig/configure.in 2007-01-24 09:52:48.000000000 +0100
+++ kdelibs-3.5.6/configure.in 2007-02-05 23:01:44.000000000 +0100
@@ -399,7 +399,7 @@
[], with_utempter=check)
if test "x$with_utempter" != xno; then
kde_have_utempter=yes
- AC_CHECK_LIB(utempter, addToUtmp, [LIBUTEMPTER=-lutempter], kde_have_utempter=no)
+ AC_CHECK_LIB(utempter, utempter_add_record, [LIBUTEMPTER=-lutempter], kde_have_utempter=no)
AC_SUBST(LIBUTEMPTER)
if test "$kde_have_utempter" = "yes"; then
AC_DEFINE_UNQUOTED(HAVE_UTEMPTER, 1, [Define if you have the utempter helper for utmp managment])
diff -Nur kdelibs-3.5.6.orig/configure.in.in kdelibs-3.5.6/configure.in.in
--- kdelibs-3.5.6.orig/configure.in.in 2006-05-22 20:14:23.000000000 +0200
+++ kdelibs-3.5.6/configure.in.in 2007-02-05 23:01:44.000000000 +0100
@ -96,18 +84,3 @@ diff -Nur kdelibs-3.5.6.orig/kdecore/Makefile.am kdelibs-3.5.6/kdecore/Makefile.
libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
libkdecore_la_NMCHECK = $(srcdir)/libkdecore.nmcheck
libkdecore_la_NMCHECKWEAK = $(srcdir)/libkdecore_weak.nmcheck $(srcdir)/libqt-mt_weak.nmcheck \
diff -Nur kdelibs-3.5.6.orig/kdecore/Makefile.in kdelibs-3.5.6/kdecore/Makefile.in
--- kdelibs-3.5.6.orig/kdecore/Makefile.in 2007-01-24 09:54:07.000000000 +0100
+++ kdelibs-3.5.6/kdecore/Makefile.in 2007-02-05 23:04:12.000000000 +0100
@@ -787,9 +787,9 @@
kuser.cpp kconfigskeleton.cpp kconfigdialogmanager.cpp klockfile.cpp \
kqiodevicegzip_p.cpp ktimezones.cpp ksycoca_skel.cpp kappdcopiface_skel.cpp kdebugdcopiface_skel.cpp
-#>- libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined
+#>- libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(LIBUTEMPTER) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined
#>+ 1
-libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined $(KDE_NO_UNDEFINED)
+libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(LIBUTEMPTER) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined $(KDE_NO_UNDEFINED)
libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
libkdecore_la_NMCHECK = $(srcdir)/libkdecore.nmcheck
libkdecore_la_NMCHECKWEAK = $(srcdir)/libkdecore_weak.nmcheck $(srcdir)/libqt-mt_weak.nmcheck \

View File

@ -1,15 +1,12 @@
# kdelibs3 review: http://bugzilla.redhat.com/248899
%define distname "Fedora"
#define debug 1
%define final 1
%define kde_settings 1
%define arts 1
%define arts_epoch 8
%define arts_version 1.5.7
%define arts_version 1.5.8
%define qt_epoch 1
%define qt_version 3.3.8
@ -22,25 +19,24 @@
%define apidocs 1
Version: 3.5.7
Release: 15%{?dist}
Summary: K Desktop Environment - Libraries
Version: 3.5.8
Release: 8%{?dist}
#if 0%{?fedora} > 7
%if 1
Name: kdelibs3
%if 0%{?fedora} > 8
Name: kdelibs3
Obsoletes: kdelibs < 6:%{version}-%{release}
Provides: kdelibs = 6:%{version}-%{release}
%else
Name: kdelibs
Epoch: 6
# To help transition to kde4
Name: kdelibs
Epoch: 6
Obsoletes: kdelibs3 = %{version}-%{release}
Provides: kdelibs3 = %{version}-%{release}
%endif
Summary: K Desktop Environment - Libraries
License: LGPL
Url: http://www.kde.org/
Group: System Environment/Libraries
License: LGPLv2
Url: http://www.kde.org/
Group: System Environment/Libraries
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdelibs-%{version}.tar.bz2
@ -63,22 +59,21 @@ Patch39: kdelibs-3.5.4-kabc-make.patch
Patch40: kdelibs-3.5.4-kdeprint-utf8.patch
Patch41: kdelibs-3.5.6-utempter.patch
Patch43: kdelibs-3.5.6-lang.patch
Patch44: kdelibs-3.5.7-cups13.patch
Patch45: kdelibs-3.5.7-autostart.patch
Patch46: kdelibs-3.5.8-kate-vhdl.patch
# use /etc/kde in addition to /usr/share/config, borrowed from debian
Patch104: kdelibs-3.5.5-kstandarddirs.patch
# upstream patches
# kget ignores simultaneous download limit (kde #101956)
Patch502: kdelibs-3.5.0-101956.patch
# automake-1.10, $(all_libraries) is missing from a few LDFLAGS (kde #137675)
Patch503: kdelibs-3.5.6-137675.patch
Patch505: kdelibs-3.5.7-kde#146105.patch
Patch100: kdelibs-3.5.5-kstandarddirs.patch
# http://bugs.kde.org/93359, alternative to export libltdl_cv_shlibext=".so" hack.
Patch93359: kde-3.5-libtool-shlibext.patch
## See http://bugs.kde.org/139445, patch needs boost-devel, FIXME, doesn't apply to kde-3.5.7
Patch139445: kdelibs-3.5.5-lib_loader-1.2.patch
#BuildRequires: boost-devel
Patch101: kde-3.5-libtool-shlibext.patch
# automake-1.10, $(all_libraries) is missing from a few LDFLAGS (kde #137675)
Patch102: kdelibs-3.5.6-137675.patch
# kget ignores simultaneous download limit (kde #101956)
Patch103: kdelibs-3.5.0-101956.patch
## upstream patches
Patch200: kdelibs-3.5.8-http-regression.patch
Patch201: kdelibs-3.5.8-kde#150944.patch
%{?arts:Requires: arts >= %{arts_epoch}:%{arts_version}}
Requires: qt >= %{qt_epoch}:%{qt_ver}
@ -89,7 +84,6 @@ Requires: kde-settings >= 3.5
Requires: kde-filesystem
Requires: redhat-menus
Requires: shadow-utils
# kdesu/sudo support, http://bugs.kde.org/20914
BuildRequires: sudo
Requires(hint): sudo
@ -139,7 +133,6 @@ BuildRequires: alsa-lib-devel
BuildRequires: pkgconfig
BuildRequires: glibc-kernheaders
%if 0%{?fedora} > 5 || 0%{?rhel} > 4
# See also http://bugzilla.redhat.com/205767
%define _with_libutempter 1
BuildRequires: libutempter-devel
%else
@ -156,6 +149,8 @@ BuildRequires: automake libtool
Obsoletes: kdelibs-apidocs < 6:%{version}-%{release}
%endif
Provides: crystalsvg-icon-theme = %{version}-%{release}
%description
Libraries for the K Desktop Environment:
KDE Libraries included: kdecore (KDE core library), kdeui (user interface),
@ -166,7 +161,6 @@ kimgio (image manipulation).
%package devel
Group: Development/Libraries
Summary: Header files and documentation for compiling KDE applications.
Conflicts: kdelibs4-devel
%if "%{name}" == "kdelibs"
Obsoletes: kdelibs3-devel < %{version}-%{release}
Provides: kdelibs3-devel = %{version}-%{release}
@ -176,20 +170,22 @@ Provides: kdelibs-devel = 6:%{version}-%{release}
%endif
Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: qt-devel
Requires: openssl-devel
%{?arts:Requires: arts-devel}
%{?libkdnssd:Requires: libkdnssd-devel}
Requires: openssl-devel
## those below can/should be omitted from future builds -- Rex
#Requires: libart_lgpl-devel
#Requires: libxslt-devel
#Requires: libjpeg-devel
#Requires: zlib-devel
#Requires: bzip2-devel
#Requires: libtiff-devel
#Requires: libidn-devel
#Requires: libacl-devel
#Requires: pcre-devel
#{?_with_libutempter:Requires: libutempter-devel}
## those below can/should be omitted from future(f8?) builds -- Rex
%if 0
Requires: bzip2-devel
Requires: libacl-devel
Requires: libart_lgpl-devel
Requires: libidn-devel
Requires: libxslt-devel
Requires: libjpeg-devel
Requires: libtiff-devel
%{?_with_libutempter:Requires: libutempter-devel}
Requires: pcre-devel
Requires: zlib-devel
%endif
%description devel
This package includes the header files you will need to compile
applications for KDE.
@ -197,15 +193,14 @@ applications for KDE.
%package apidocs
Group: Development/Documentation
Summary: KDE API documentation.
Requires: %{name} = %{?epoch:%{epoch}:}:%{version}
Requires: %{name} = %{?epoch:%{epoch}:}%{version}
%if "%{name}" == "kdelibs"
Provides: kdelibs3-apidocs = %{version}-%{release}
%else
Obsoletes: kdelibs-apidocs < 6:%{version}-%{release}
Provides: kdelibs-apidocs = 6:%{version}-%{release}
%endif
## old, never published outside of rawhide, afaik -- Rex
#Obsoletes: kdelibs-docs < 6:%{version}-%{release}
%description apidocs
This package includes the KDE API documentation in HTML
format for easy browsing
@ -215,9 +210,7 @@ format for easy browsing
%setup -q -n kdelibs-%{version}
%patch1 -p1 -b .xdg-menu
%if "%{?debug}" != "1"
%patch2 -p1 -b .debug
%endif
%patch4 -p1 -b .ksyscoca
%patch5 -p1 -b .openssl
%patch15 -p1 -b .buildroot
@ -230,17 +223,17 @@ format for easy browsing
%patch39 -p1 -b .kabc-make
%patch40 -p1 -b .kdeprint-utf8
%{?_with_libutempter:%patch41 -p1 -b .utempter}
# omission recommended by upstream: http://bugs.kde.org/147454#c37
%patch43 -p1 -b .lang
%patch44 -p1 -b .cups13
%patch45 -p1 -b .xdg-autostart
%patch46 -p1 -b .kate-vhdl
%patch104 -p1 -b .kstandarddirs
%patch100 -p1 -b .kstandarddirs
%patch101 -p1 -b .libtool-shlibext
%patch102 -p0 -b .kde#137675
# upstream patches
%patch503 -p0 -b .kde#137675
%patch505 -p0 -b .kde#146105
%patch93359 -p1 -b .libtool-shlibext
#patch139445 -p1 -b .kde#139445
%patch200 -p0 -b .http-regression
%patch201 -p4 -b .kde#150944
sed -i -e "s,^#define KDE_VERSION_STRING .*,#define KDE_VERSION_STRING \"%{version}-%{release} %{distname}\"," kdecore/kdeversion.h
@ -253,8 +246,6 @@ sed -i -e "s,^#define KDE_VERSION_STRING .*,#define KDE_VERSION_STRING \"%{versi
unset QTDIR && . /etc/profile.d/qt.sh
export QTDOC=%{qtdocdir}
# use patch93359 instead
#export libltdl_cv_shlibext=".so"
if [ -x /etc/profile.d/krb5.sh ]; then
. /etc/profile.d/krb5.sh
@ -292,9 +283,8 @@ fi
make %{?_smp_mflags}
# FIXME/TODO: build as noarch? -- Rex
%if "%{?apidocs}" == "1"
make %{?_smp_mflags} apidox
make %{?_smp_mflags} apidox
%endif
@ -328,16 +318,11 @@ install -p -m 755 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d/kde3.csh
%else
install -p -m 755 -D %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/kde.sh
install -p -m 755 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d/kde.csh
# menus
## menus
mkdir -p %{buildroot}%{_sysconfdir}/kde/xdg/menus
mv %{buildroot}%{_sysconfdir}/xdg/menus/applications.menu \
%{buildroot}%{_sysconfdir}/xdg/menus/kde-applications.menu
# compat-symlinks, can go away eventually -- Rex
ln -s %{_sysconfdir}/xdg/menus/kde-applications.menu \
%{buildroot}%{_sysconfdir}/kde/xdg/menus/kde-applications.menu
ln -s kde-applications.menu \
%{buildroot}%{_sysconfdir}/kde/xdg/menus/applications.menu
%endif
echo "OnlyShowIn=KDE;" >> %{buildroot}%{_datadir}/applications/kde/kresources.desktop
@ -348,7 +333,7 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/
# ghost'd files
touch $RPM_BUILD_ROOT%{_datadir}/services/ksycoca
## remove references to extraneous/optional libraries in .la files (#170602)
# remove references to extraneous/optional libraries in .la files (#170602)
# fam, libart_lgpl, pcre, libidn, libpng, libjpeg, libdns_sd, libacl/libattr, alsa-lib/asound
find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
sed -i \
@ -373,23 +358,33 @@ find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
-e "s@-lasound@@g" \
-e "s@-lutempter@@g"
## unpackaged files
# libkdnssd bits
rm -f %{buildroot}%{_libdir}/libkdnssd.la
%{?libkdnssd:rm -rf %{buildroot}{%{_libdir}/libkdnssd.*,%{_includedir}/kde/dnssd}}
%if "%{name}" != "kdelibs"
# remove conflicts with kdelibs-4
pushd %{buildroot}%{_bindir}
rm -f checkXML cupsdconf cupsdoprint imagetops kaddprinterwizard kconfig_compiler kconf_update kcookiejar \
rm -f cupsdconf cupsdoprint imagetops kaddprinterwizard kconf_update kcookiejar \
kde-menu kdesu_stub kdontchangethehostname kdostartupconfig kio_http_cache_cleaner kioslave \
klauncher kpac_dhcp_helper ksendbugmail kstartupconfig ksvgtopng ktradertest kunittestmodrunner \
make_driver_db_cups make_driver_db_lpr makekdewidgets meinproc preparetips \
klauncher kpac_dhcp_helper ksendbugmail kstartupconfig ktradertest \
make_driver_db_cups make_driver_db_lpr meinproc preparetips \
khotnewstuff kinstalltheme kcmshell kfile kioexec
# devel stuff (skip for now)
#rm -f checkXML kconfig_compiler ksvgtopng kunittestmodrunner makekdewidgets
popd
rm -f %{buildroot}%{_datadir}/config/* %{buildroot}%{_datadir}/config/ui/kprintpreviewui.rc || :
rm -rf %{buildroot}%{_datadir}/config/colors %{buildroot}%{_datadir}/apps/k* %{buildroot}%{_datadir}/apps/LICENSES \
%{buildroot}%{_datadir}/apps/proxyscout %{buildroot}%{_datadir}/locale \
%{buildroot}%{_datadir}/autostart %{buildroot}/etc/xdg %{buildroot}%{_docdir}/HTML %{buildroot}%{_datadir}/emoticons
rm -f %{buildroot}%{_datadir}/config/* \
%{buildroot}%{_datadir}/config/ui/kprintpreviewui.rc || :
rm -rf %{buildroot}%{_datadir}/config/colors \
%{buildroot}%{_datadir}/apps/k* \
%{buildroot}%{_datadir}/apps/LICENSES \
%{buildroot}%{_datadir}/apps/proxyscout \
%{buildroot}%{_datadir}/locale \
%{buildroot}%{_datadir}/autostart \
%{buildroot}/etc/xdg \
%{buildroot}%{_docdir}/HTML \
%{buildroot}%{_datadir}/emoticons
%endif
@ -412,8 +407,62 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%files
%defattr(-,root,root,-)
%doc README
%doc COPYING.LIB
%config(noreplace) %{_sysconfdir}/profile.d/*
%{_bindir}/*
%{_bindir}/artsmessage
%{_bindir}/cupsdconf
%{_bindir}/cupsdoprint
%{_bindir}/dcop
%{_bindir}/dcopclient
%{_bindir}/dcopfind
%{_bindir}/dcopobject
%{_bindir}/dcopquit
%{_bindir}/dcopref
%{_bindir}/dcopserver
%{_bindir}/dcopserver_shutdown
%{_bindir}/dcopstart
%{_bindir}/filesharelist
%{_bindir}/fileshareset
%{_bindir}/imagetops
%{_bindir}/kab2kabc
%{_bindir}/kaddprinterwizard
%{_bindir}/kbuildsycoca
%{_bindir}/kcmshell
%{_bindir}/kconf_update
%{_bindir}/kcookiejar
%{_bindir}/kde-config
%{_bindir}/kde-menu
%{_bindir}/kded
%{_bindir}/kdeinit
%{_bindir}/kdeinit_shutdown
%{_bindir}/kdeinit_wrapper
%{_bindir}/kdesu_stub
%{_bindir}/kdontchangethehostname
%{_bindir}/kdostartupconfig
%{_bindir}/kfile
%{_bindir}/kfmexec
%{_bindir}/khotnewstuff
%{_bindir}/kinstalltheme
%{_bindir}/kio_http_cache_cleaner
%{_bindir}/kio_uiserver
%{_bindir}/kioexec
%{_bindir}/kioslave
%{_bindir}/klauncher
%{_bindir}/kmailservice
%{_bindir}/ksendbugmail
%{_bindir}/kshell
%{_bindir}/kstartupconfig
%{_bindir}/ktelnetservice
%{_bindir}/ktradertest
%{_bindir}/kwrapper
%{_bindir}/lnusertemp
%{_bindir}/make_driver_db_cups
%{_bindir}/make_driver_db_lpr
%{_bindir}/meinproc
%{_bindir}/preparetips
%{_bindir}/start_kdeinit
%{_bindir}/start_kdeinit_wrapper
%attr(4755,root,root) %{_bindir}/kgrantpty
%{_libdir}/lib*.so.*
%{_libdir}/libkdeinit_*.so
@ -421,6 +470,9 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%{_libdir}/kde3/
%{_datadir}/applications/kde/*.desktop
%{_datadir}/apps/*
%exclude %{_datadir}/apps/ksgmltools2/
%exclude %{_datadir}/apps/kdewidgets/
%exclude %{_libdir}/kde3/plugins/designer/kdewidgets.*
%config(noreplace) %{_datadir}/config/*
%{_datadir}/icons/crystalsvg/
%{_datadir}/icons/default.kde
@ -430,7 +482,6 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%{_datadir}/servicetypes/*
%ghost %{_datadir}/services/ksycoca
%if "%{name}" == "kdelibs"
%{_sysconfdir}/kde/xdg/menus/*.menu
%{_sysconfdir}/xdg/menus/*.menu
%attr(4755,root,root) %{_bindir}/kpac_dhcp_helper
%{_datadir}/autostart/*
@ -442,7 +493,16 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%files devel
%defattr(-,root,root,-)
%{_bindir}/checkXML
%{_bindir}/dcopidl*
%{_bindir}/kconfig_compiler
%{_bindir}/ksvgtopng
%{_bindir}/kunittestmodrunner
%{_bindir}/makekdewidgets
%{_datadir}/apps/kdewidgets/
%dir %{_libdir}/kde3/plugins/designer
%{_libdir}/kde3/plugins/designer/kdewidgets.*
%{_datadir}/apps/ksgmltools2/
%{_includedir}/kde/
%{_libdir}/lib*.so
%{_libdir}/lib*.a
@ -457,8 +517,61 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%changelog
* Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 3.5.8-8
- Provides: crystalsvg-icon-theme
* Thu Oct 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 3.5.8-7
- fix application of custom zoom patch (rh#335461)
* Tue Oct 23 2007 Than Ngo <than@redhat.com> - 3.5.8-6
- Resolves: rh#335461, kpdf and kview lost custom zoom
* Thu Oct 18 2007 Than Ngo <than@redhat.com> - 3.5.8-5
- bz273681, add vhdl syntax for kate, thanks to Chitlesh GOORAH
* Wed Oct 17 2007 Than Ngo <than@redhat.com> 3.5.8-4
- apply upstream patch to fix http-regression
* Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.8-3
- respin (for openexr-1.6.0)
* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.8-2
- kde-3.5.8
* Tue Sep 25 2007 Than Ngo <than@redhat.com> - 6:3.5.7-23
- fix rh#243611, autostart from XDG_CONFIG_DIRS
* Sat Sep 09 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 6:3.5.7-22
- Remove Conflicts: kdelibs4-devel, let kdelibs4 decide whether we conflict
(allows using the old /opt/kde4 versions for now)
* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.7-21
- vcard30 patch (kde#115219,rh#253496)
- -devel: restore awol Requires (< f8 only) (#253801)
- License: LGPLv2
* Wed Aug 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.7-20
- CVE-2007-3820, CVE-2007-4224, CVE-2007-4225
- clarify licensing
* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.7-19
- ConsoleKit-related patch (#244065)
* Sun Aug 12 2007 Florian La Roche <laroche@redhat.com> 6:3.5.7-18
- fix apidocs subpackage requires
* Mon Aug 06 2007 Than Ngo <than@redhat.com> - 6:3.5.7-17
- cleanup
* Fri Aug 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.7-16
- undo kdelibs3 rename (for now, anyway)
- move to -devel: checkXML, kconfig_compiler, (make)kdewidgets, ksgmltools2,
ksvgtopng, kunittestmodrunner
- set KDE_IS_PRELINKED unconditionally (#244065)
- License: LGPLv2+
* Fri Jul 20 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.7-15
- Obsoletes/Provides: kdelibs-apidocs (f8+)
- Obsoletes/Provides: kdelibs-apidocs (kdelibs3)
* Fri Jul 20 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.7-14
- toggle kdelibs3 (f8+)

View File

@ -1 +1 @@
50ed644f2ec91963570fe2b155652957 kdelibs-3.5.7.tar.bz2
acaa37e79e840d10dca326277a20863c kdelibs-3.5.8.tar.bz2