kdelibs/kdelibs-4.2.2-popupapplet-k...

30 lines
1.7 KiB
Diff

diff -Nur kdelibs-4.2.2/plasma/CMakeLists.txt kdelibs-4.2.2-popupapplet-kconf_update/plasma/CMakeLists.txt
--- kdelibs-4.2.2/plasma/CMakeLists.txt 2009-01-06 18:27:56.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/CMakeLists.txt 2009-04-19 05:33:42.000000000 +0200
@@ -268,3 +268,5 @@
install(FILES scripting/plasmoids.knsrc DESTINATION ${CONFIG_INSTALL_DIR})
+install(FILES plasma_popupapplet_fix_groups.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
+install(PROGRAMS plasma_popupapplet_fix_groups.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
diff -Nur kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl
--- kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl 1970-01-01 01:00:00.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl 2009-04-19 05:24:00.000000000 +0200
@@ -0,0 +1,8 @@
+#!/usr/bin/perl
+
+while(<>) {
+ if ($_ =~ m/^\[.*\[Configuration\]\[PopupApplet\]$/) {
+ $_ =~ s/\[Configuration\]\[PopupApplet\]$/[PopupApplet]/;
+ }
+ print $_;
+}
diff -Nur kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.upd kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.upd
--- kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.upd 1970-01-01 01:00:00.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.upd 2009-04-19 05:31:20.000000000 +0200
@@ -0,0 +1,4 @@
+# Fix groups of the form ...[Configuration][PopupApplet] into ...[PopupApplet]
+Id=PlasmaPopupAppletFixGroups
+File=plasma-appletsrc,plasmarc,plasmoidviewer-appletsrc
+Script=plasma_popupapplet_fix_groups.pl,perl