Update to 4.3.75

This commit is contained in:
Ben Boeckel 2009-11-24 15:24:36 +00:00
parent 39e567d3c3
commit f8ff5b60d8
9 changed files with 175 additions and 354 deletions

View File

@ -1 +1 @@
kdelibs-4.3.3.tar.bz2
kdelibs-4.3.75svn1048496.tar.bz2

View File

@ -1,16 +0,0 @@
diff -rU5 kdelibs-4.3.0/kio/bookmarks/kbookmark.cc kdelibs-4.3.0.bookmarks/kio/bookmarks/kbookmark.cc
--- kdelibs-4.3.0/kio/bookmarks/kbookmark.cc 2008-07-08 05:54:18.000000000 -0400
+++ kdelibs-4.3.0.bookmarks/kio/bookmarks/kbookmark.cc 2009-08-28 15:09:07.000000000 -0400
@@ -681,11 +681,11 @@
doc.setContent( payload );
QDomElement elem = doc.documentElement();
QDomNodeList children = elem.childNodes();
for ( int childno = 0; childno < children.count(); childno++)
{
- bookmarks.append( KBookmark( children.item(childno).cloneNode(true).toElement() ));
+ bookmarks.append( KBookmark( children.item(childno).toElement() ));
}
return bookmarks;
}
const KUrl::List urls = KUrl::List::fromMimeData( mimeData );
if ( !urls.isEmpty() )

View File

@ -1,61 +0,0 @@
diff -up kdelibs-4.3.1/kio/kssl/kopenssl.cpp.orig kdelibs-4.3.1/kio/kssl/kopenssl.cpp
--- kdelibs-4.3.1/kio/kssl/kopenssl.cpp.orig 2009-09-01 21:58:06.000000000 +0200
+++ kdelibs-4.3.1/kio/kssl/kopenssl.cpp 2009-09-01 22:08:16.000000000 +0200
@@ -622,7 +622,7 @@ KOpenSSLProxy::KOpenSSLProxy()
K_SSL_set_session = (int (*)(SSL*,SSL_SESSION*)) d->sslLib->resolveFunction("SSL_set_session");
K_d2i_SSL_SESSION = (SSL_SESSION* (*)(SSL_SESSION**,unsigned char**, long)) d->sslLib->resolveFunction("d2i_SSL_SESSION");
K_i2d_SSL_SESSION = (int (*)(SSL_SESSION*,unsigned char**)) d->sslLib->resolveFunction("i2d_SSL_SESSION");
- K_SSL_get_ciphers = (STACK *(*)(const SSL*)) d->sslLib->resolveFunction("SSL_get_ciphers");
+ K_SSL_get_ciphers = (STACK_OF(SSL_CIPHER) *(*)(const SSL*)) d->sslLib->resolveFunction("SSL_get_ciphers");
#endif
diff -up kdelibs-4.3.1/kio/kssl/kopenssl.h.orig kdelibs-4.3.1/kio/kssl/kopenssl.h
--- kdelibs-4.3.1/kio/kssl/kopenssl.h.orig 2009-09-01 21:58:31.000000000 +0200
+++ kdelibs-4.3.1/kio/kssl/kopenssl.h 2009-09-01 22:48:44.000000000 +0200
@@ -44,6 +44,14 @@ class KOpenSSLProxyPrivate;
#include <openssl/stack.h>
#include <openssl/bn.h>
#undef crypt
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+#define STACK _STACK
+#define OSSL_SKVALUE_RTYPE void
+#define OSSL_MORECONST const
+#else
+#define OSSL_SKVALUE_RTYPE char
+#define OSSL_MORECONST
+#endif
#endif
/**
@@ -505,6 +513,9 @@ public:
*/
void sk_free(STACK *s);
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+ void sk_free(void *s) { return sk_free(reinterpret_cast<STACK*>(s)); }
+#endif
/*
* Number of elements in the stack
@@ -517,6 +528,9 @@ public:
*/
char *sk_value(STACK *s, int n);
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+ char *sk_value(void *s, int n) { return sk_value(reinterpret_cast<STACK*>(s), n); }
+#endif
/*
* Create a new stack
@@ -529,6 +543,10 @@ public:
*/
int sk_push(STACK *s, char *d);
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+ int sk_push(void *s, void *d) { return sk_push(reinterpret_cast<STACK*>(s), reinterpret_cast<char*>(d)); }
+#endif
+
/*
* Duplicate the stack

View File

@ -1,156 +0,0 @@
Index: khtml/khtml_settings.h
===================================================================
--- khtml/khtml_settings.h (revision 1027233)
+++ khtml/khtml_settings.h (revision 1027234)
@@ -186,7 +186,23 @@
bool isPluginsEnabled( const QString& hostname = QString() ) const;
// AdBlocK Filtering
+
+ /** tests whether @p url is filtered.
+ * @param url the URL to test.
+ * @return @c true if the URL is blacklisted and is not whitelisted.
+ */
bool isAdFiltered( const QString &url ) const;
+
+ /** identify the filter which matches @p url.
+ * @param url the URL to test.
+ * @param isWhiteListed if not @c NULL, set to @c true if the URL matched
+ * a whitelist filter; set to @c false if it matched a blacklist filter.
+ * @return the filter string that matched,
+ * or @c QString() if no filter matched.
+ * @since 4.4
+ */
+ QString adFilteredBy( const QString &url, bool *isWhiteListed = 0 ) const;
+
bool isAdFilterEnabled() const;
bool isHideAdsEnabled() const;
void addAdFilter( const QString &url );
Index: khtml/khtml_filter_p.h
===================================================================
--- khtml/khtml_filter_p.h (revision 1027233)
+++ khtml/khtml_filter_p.h (revision 1027234)
@@ -35,8 +35,9 @@
// add filter to matching set
void addString(const QString& pattern);
- // check if string match at least one string from matching set
- bool isMatched(const QString& str) const;
+ // check if string matches at least one string from matching set,
+ // optionally return the matching string or filter
+ bool isMatched(const QString& str, QString *by = 0) const;
// add filter to matching set with wildcards (*,?) in it
void addWildedString(const QString& prefix, const QRegExp& rx);
@@ -60,9 +61,10 @@
// Parses and registers a filter. This will also strip @@ for exclusion rules, skip comments, etc.
// The user does have to split black and white lists into separate sets, however
void addFilter(const QString& filter);
-
+
bool isUrlMatched(const QString& url);
-
+ QString urlMatchedBy(const QString& url);
+
void clear();
private:
Index: khtml/khtml_settings.cpp
===================================================================
--- khtml/khtml_settings.cpp (revision 1027233)
+++ khtml/khtml_settings.cpp (revision 1027234)
@@ -743,6 +743,27 @@
return false;
}
+QString KHTMLSettings::adFilteredBy( const QString &url, bool *isWhiteListed ) const
+{
+ QString m = d->adWhiteList.urlMatchedBy(url);
+ if (!m.isEmpty())
+ {
+ if (isWhiteListed != 0)
+ *isWhiteListed = true;
+ return (m);
+ }
+
+ m = d->adBlackList.urlMatchedBy(url);
+ if (!m.isEmpty())
+ {
+ if (isWhiteListed != 0)
+ *isWhiteListed = false;
+ return (m);
+ }
+
+ return (QString());
+}
+
void KHTMLSettings::addAdFilter( const QString &url )
{
KConfigGroup config = KSharedConfig::openConfig( "khtmlrc", KConfig::NoGlobals )->group( "Filter Settings" );
Index: khtml/khtml_filter.cpp
===================================================================
--- khtml/khtml_filter.cpp (revision 1027233)
+++ khtml/khtml_filter.cpp (revision 1027234)
@@ -133,6 +133,25 @@
return false;
}
+QString FilterSet::urlMatchedBy(const QString& url)
+{
+ QString by;
+
+ if (stringFiltersMatcher.isMatched(url, &by))
+ return by;
+
+ for (int c = 0; c < reFilters.size(); ++c)
+ {
+ if (url.contains(reFilters[c]))
+ {
+ by = reFilters[c].pattern();
+ break;
+ }
+ }
+
+ return by;
+}
+
void FilterSet::clear()
{
reFilters.clear();
@@ -196,12 +215,15 @@
}
}
-bool StringsMatcher::isMatched(const QString& str) const
+bool StringsMatcher::isMatched(const QString& str, QString *by) const
{
// check short strings first
for (int i = 0; i < shortStringFilters.size(); ++i) {
if (str.contains(shortStringFilters[i]))
+ {
+ if (by != 0) *by = shortStringFilters[i];
return true;
+ }
}
int len = str.length();
@@ -235,13 +257,19 @@
if (index >= 0) {
int flen = stringFilters[index].length();
if (k - flen + 1 >= 0 && stringFilters[index] == str.midRef(k - flen + 1 , flen))
+ {
+ if (by != 0) *by = stringFilters[index];
return true;
+ }
} else {
index = -index - 1;
int flen = rePrefixes[index].length();
if (k - 8 + flen < len && rePrefixes[index] == str.midRef(k - 7, flen) &&
str.indexOf(reFilters[index], k - 7 + flen) == k - 7 + flen)
+ {
+ if (by != 0) *by = rePrefixes[index]+reFilters[index].pattern();
return true;
+ }
}
}
}

View File

@ -1,21 +0,0 @@
diff -ur kdelibs-4.3.3/kdecore/fakes.c kdelibs-4.3.3-fix-kdefakes-build/kdecore/fakes.c
--- kdelibs-4.3.3/kdecore/fakes.c 2008-05-21 13:09:15.000000000 +0200
+++ kdelibs-4.3.3-fix-kdefakes-build/kdecore/fakes.c 2009-11-06 01:47:27.000000000 +0100
@@ -313,6 +313,8 @@
#endif /* !HAVE_MKDTEMP */
#ifndef HAVE_STRLCPY
+#include <string.h>
+
KDECORE_EXPORT unsigned long strlcpy(char* d, const char* s, unsigned long bufsize)
{
unsigned long len, ret = strlen(s);
@@ -331,6 +333,8 @@
#endif
#ifndef HAVE_STRLCAT
+#include <string.h>
+
KDECORE_EXPORT unsigned long strlcat(char* d, const char* s, unsigned long bufsize)
{
char *cp;

View File

@ -1,7 +1,9 @@
diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel 2009-07-08 16:41:09.000000000 +0200
+++ kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake 2009-07-13 16:32:48.000000000 +0200
@@ -15,10 +15,10 @@
diff -r -U5 kdelibs-4.3.75svn1048496/cmake/modules/FindKDE4Internal.cmake kdelibs-4.3.75svn1048496.parallel_devel/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.3.75svn1048496/cmake/modules/FindKDE4Internal.cmake 2009-11-13 05:58:59.000000000 -0500
+++ kdelibs-4.3.75svn1048496.parallel_devel/cmake/modules/FindKDE4Internal.cmake 2009-11-23 10:34:21.000000000 -0500
@@ -13,14 +13,14 @@
# intended to be used with LINK_DIRECTORIES()
#
# The following variables are defined for the various tools required to
# compile KDE software:
#
@ -14,8 +16,12 @@ diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
#
# The following variables point to the location of the KDE libraries,
# but shouldn't be used directly:
@@ -129,7 +129,7 @@
#
# KDE4_KDECORE_LIBRARY - the kdecore library
@@ -134,11 +134,11 @@
# Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files.
# Use optional USE_RELATIVE_PATH to generate the classes in the build following the given
# relative path to the file.
#
# KDE4_ADD_WIDGET_FILES (SRCS_VAR file1.widgets ... fileN.widgets)
-# Use this to add widget description files for the makekdewidgets code generator
@ -23,37 +29,47 @@ diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# for Qt Designer plugins.
#
# KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN)
@@ -383,23 +383,23 @@ if (_kdeBootStrapping)
# This macro is intended mainly for internal uses.
# It is used for enable-final. It will generate two source files,
@@ -421,29 +421,29 @@
set(EXECUTABLE_OUTPUT_PATH ${kdelibs_BINARY_DIR}/bin )
if (WIN32)
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
# CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC
- set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler )
+ set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler4 )
- set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler )
+ set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler4 )
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4 )
- set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets )
+ set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets4 )
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4 )
set(KDE4_KAUTH_POLICY_GEN_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kauth-policy-gen )
- set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets )
+ set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets4 )
else (WIN32)
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib )
- set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler.shell )
+ set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler4.shell )
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4.shell )
- set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets.shell )
+ set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets4.shell )
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib )
- set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler${CMAKE_EXECUTABLE_SUFFIX}.shell )
+ set(KDE4_KCFGC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kconfig_compiler4${CMAKE_EXECUTABLE_SUFFIX}.shell )
set(KDE4_KAUTH_POLICY_GEN_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/kauth-policy-gen${CMAKE_EXECUTABLE_SUFFIX}.shell )
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4${CMAKE_EXECUTABLE_SUFFIX}.shell )
- set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets${CMAKE_EXECUTABLE_SUFFIX}.shell )
+ set(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/makekdewidgets4${CMAKE_EXECUTABLE_SUFFIX}.shell )
endif (WIN32)
set(KDE4_LIB_DIR ${LIBRARY_OUTPUT_PATH}/${CMAKE_CFG_INTDIR})
# when building kdelibs, make the kcfg rules depend on the binaries...
- set( _KDE4_KCONFIG_COMPILER_DEP kconfig_compiler)
- set( _KDE4_MAKEKDEWIDGETS_DEP makekdewidgets)
+ set( _KDE4_KCONFIG_COMPILER_DEP kconfig_compiler4)
set( _KDE4_KAUTH_POLICY_GEN_EXECUTABLE_DEP kauth-policy-gen)
- set( _KDE4_MAKEKDEWIDGETS_DEP makekdewidgets)
+ set( _KDE4_MAKEKDEWIDGETS_DEP makekdewidgets4)
set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4)
set(KDE4_INSTALLED_VERSION_OK TRUE)
@@ -497,7 +497,8 @@ else (_kdeBootStrapping)
else (_kdeBootStrapping)
@@ -540,11 +540,12 @@
# and this one for compatibility:
set(KDE4_THREADWEAVER_LIBRARIES ${KDE4_TARGET_PREFIX}threadweaver )
# KDE4_LIB_INSTALL_DIR and KDE4_INCLUDE_INSTALL_DIR are set in KDELibsDependencies.cmake,
# use them to set the KDE4_LIB_DIR and KDE4_INCLUDE_DIR "public interface" variables
@ -63,33 +79,42 @@ diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
set(KDE4_INCLUDE_DIR ${KDE4_INCLUDE_INSTALL_DIR} )
@@ -510,12 +511,12 @@ else (_kdeBootStrapping)
# This setting is currently not recorded in KDELibsDependencies.cmake:
find_file(KDE4_PLASMA_OPENGL_FOUND plasma/glapplet.h PATHS ${KDE4_INCLUDE_DIR} NO_DEFAULT_PATH)
@@ -556,14 +557,14 @@
# get the build CONFIGURATIONS which were exported in this file, and use just the first
# of them to get the location of the installed executables
- get_target_property(_importedConfigurations ${KDE4_TARGET_PREFIX}kconfig_compiler IMPORTED_CONFIGURATIONS )
+ get_target_property(_importedConfigurations ${KDE4_TARGET_PREFIX}kconfig_compiler4 IMPORTED_CONFIGURATIONS )
get_target_property(_importedConfigurations ${KDE4_TARGET_PREFIX}kconfig_compiler IMPORTED_CONFIGURATIONS )
list(GET _importedConfigurations 0 _firstConfig)
- get_target_property(KDE4_KCFGC_EXECUTABLE ${KDE4_TARGET_PREFIX}kconfig_compiler LOCATION_${_firstConfig})
+ get_target_property(KDE4_KCFGC_EXECUTABLE ${KDE4_TARGET_PREFIX}kconfig_compiler4 LOCATION_${_firstConfig})
get_target_property(KDE4_MEINPROC_EXECUTABLE ${KDE4_TARGET_PREFIX}meinproc4 LOCATION_${_firstConfig})
- get_target_property(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${KDE4_TARGET_PREFIX}makekdewidgets LOCATION_${_firstConfig})
+ get_target_property(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${KDE4_TARGET_PREFIX}makekdewidgets4 LOCATION_${_firstConfig})
- get_target_property(KDE4_KCFGC_EXECUTABLE ${KDE4_TARGET_PREFIX}kconfig_compiler LOCATION_${_firstConfig})
+ get_target_property(KDE4_KCFGC_EXECUTABLE ${KDE4_TARGET_PREFIX}kconfig_compiler4 LOCATION_${_firstConfig})
get_target_property(KDE4_MEINPROC_EXECUTABLE ${KDE4_TARGET_PREFIX}meinproc4 LOCATION_${_firstConfig})
get_target_property(KDE4_KAUTH_POLICY_GEN_EXECUTABLE ${KDE4_TARGET_PREFIX}kauth-policy-gen LOCATION_${_firstConfig})
- get_target_property(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${KDE4_TARGET_PREFIX}makekdewidgets LOCATION_${_firstConfig})
+ get_target_property(KDE4_MAKEKDEWIDGETS_EXECUTABLE ${KDE4_TARGET_PREFIX}makekdewidgets4 LOCATION_${_firstConfig})
# allow searching cmake modules in all given kde install locations (KDEDIRS based)
execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -782,7 +783,8 @@ set(CMAKE_SYSTEM_INCLUDE_PATH ${CMAKE_SY
file(TO_CMAKE_PATH "${_data_DIR}" _data_DIR)
foreach(dir ${_data_DIR})
@@ -828,11 +829,12 @@
"${KDE4_INCLUDE_INSTALL_DIR}")
set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SYSTEM_PROGRAM_PATH}
"${KDE4_BIN_INSTALL_DIR}" )
-set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
-set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
+set(CMAKE_SYSTEM_LIBRARY_PATH "${KDE4_LIB_INSTALL_DIR}/kde4/devel"
+ ${CMAKE_SYSTEM_LIBRARY_PATH}
"${KDE4_LIB_INSTALL_DIR}" )
# under Windows dlls may be also installed in bin/
@@ -1166,9 +1168,9 @@ macro (KDE4_PRINT_RESULTS)
if(WIN32)
set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
@@ -1217,13 +1219,13 @@
message(STATUS "ERROR: unable to find the KDE 4 core library")
endif(KDE4_LIB_DIR)
endif (NOT _kdeBootStrapping)
if(KDE4_KCFGC_EXECUTABLE)
@ -101,7 +126,11 @@ diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
endif(KDE4_KCFGC_EXECUTABLE)
if(AUTOMOC4_EXECUTABLE)
@@ -1187,7 +1189,7 @@ if (KDE4Internal_FIND_REQUIRED AND NOT K
message(STATUS "Found automoc4: ${AUTOMOC4_EXECUTABLE}")
else(AUTOMOC4_EXECUTABLE)
@@ -1238,11 +1240,11 @@
if (NOT KDE4_INSTALLED_VERSION_OK)
message(FATAL_ERROR "ERROR: the installed kdelibs version ${KDE_VERSION} is too old, at least version ${KDE_MIN_VERSION} is required")
endif (NOT KDE4_INSTALLED_VERSION_OK)
if (NOT KDE4_KCFGC_EXECUTABLE)
@ -110,10 +139,13 @@ diff -up kdelibs-4.2.96/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
endif (NOT KDE4_KCFGC_EXECUTABLE)
message(FATAL_ERROR "ERROR: could NOT find everything required for compiling KDE 4 programs")
diff -up kdelibs-4.2.96/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelibs-4.2.96/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.2.96/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel 2008-05-21 13:07:26.000000000 +0200
+++ kdelibs-4.2.96/doc/api/doxygen-preprocess-kcfg.sh 2009-07-13 16:26:04.000000000 +0200
@@ -2,9 +2,9 @@
endif (KDE4Internal_FIND_REQUIRED AND NOT KDE4_FOUND)
diff -r -U5 kdelibs-4.3.75svn1048496/doc/api/doxygen-preprocess-kcfg.sh kdelibs-4.3.75svn1048496.parallel_devel/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.3.75svn1048496/doc/api/doxygen-preprocess-kcfg.sh 2008-05-21 07:07:26.000000000 -0400
+++ kdelibs-4.3.75svn1048496.parallel_devel/doc/api/doxygen-preprocess-kcfg.sh 2009-11-23 10:33:58.000000000 -0500
@@ -1,12 +1,12 @@
#
# Generates and cleans KConfigXT source code during a API dox build
#
@ -125,10 +157,14 @@ diff -up kdelibs-4.2.96/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelib
exit 1;
fi
diff -up kdelibs-4.2.96/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kdelibs-4.2.96/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.2.96/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.2.96/kdecore/kconfig_compiler/checkkcfg.pl 2009-07-13 16:26:04.000000000 +0200
@@ -15,12 +15,12 @@ $file_cpp = "$filebase.cpp";
for i in `find . -maxdepth 1 -name "*.kcfgc"`; do
kcfg_file=`grep "^File=" $i | sed -e "s/File=//"`
diff -r -U5 kdelibs-4.3.75svn1048496/kdecore/kconfig_compiler/checkkcfg.pl kdelibs-4.3.75svn1048496.parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.3.75svn1048496/kdecore/kconfig_compiler/checkkcfg.pl 2008-05-21 07:09:13.000000000 -0400
+++ kdelibs-4.3.75svn1048496.parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl 2009-11-23 10:33:58.000000000 -0500
@@ -13,16 +13,16 @@
$file_h = "$filebase.h";
$file_cpp = "$filebase.cpp";
$kcfgc = $file . "c";
@ -143,15 +179,19 @@ diff -up kdelibs-4.2.96/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kde
exit 1;
}
diff -up kdelibs-4.2.96/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.2.96/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.2.96/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel 2009-01-06 18:27:49.000000000 +0100
+++ kdelibs-4.2.96/kdecore/kconfig_compiler/CMakeLists.txt 2009-07-13 16:26:04.000000000 +0200
@@ -8,13 +8,13 @@ add_subdirectory( example )
checkfile( $file_h );
checkfile( $file_cpp );
diff -r -U5 kdelibs-4.3.75svn1048496/kdecore/kconfig_compiler/CMakeLists.txt kdelibs-4.3.75svn1048496.parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.3.75svn1048496/kdecore/kconfig_compiler/CMakeLists.txt 2009-10-26 05:15:46.000000000 -0400
+++ kdelibs-4.3.75svn1048496.parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt 2009-11-23 10:33:58.000000000 -0500
@@ -2,17 +2,17 @@
########### next target ###############
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
-kde4_add_executable(kconfig_compiler NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
-kde4_add_executable(kconfig_compiler NOGUI ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI ${kconfig_compiler_SRCS})
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
@ -163,10 +203,14 @@ diff -up kdelibs-4.2.96/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel k
########### install files ###############
diff -up kdelibs-4.2.96/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.2.96/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.2.96/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-05-21 13:08:30.000000000 +0200
+++ kdelibs-4.2.96/kdeui/tests/kconfig_compiler/CMakeLists.txt 2009-07-13 16:26:04.000000000 +0200
@@ -9,7 +9,7 @@ macro(GEN_KCFG_TEST_SOURCE _testName _sr
diff -r -U5 kdelibs-4.3.75svn1048496/kdeui/tests/kconfig_compiler/CMakeLists.txt kdelibs-4.3.75svn1048496.parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.3.75svn1048496/kdeui/tests/kconfig_compiler/CMakeLists.txt 2009-08-12 06:00:20.000000000 -0400
+++ kdelibs-4.3.75svn1048496.parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt 2009-11-23 10:33:58.000000000 -0500
@@ -7,11 +7,11 @@
macro(GEN_KCFG_TEST_SOURCE _testName _srcs)
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h
COMMAND ${KDE4_KCFGC_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc
@ -175,15 +219,19 @@ diff -up kdelibs-4.2.96/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_dev
# set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE)
qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc )
diff -up kdelibs-4.2.96/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.2.96/kdewidgets/CMakeLists.txt
--- kdelibs-4.2.96/kdewidgets/CMakeLists.txt.parallel_devel 2009-01-06 18:27:44.000000000 +0100
+++ kdelibs-4.2.96/kdewidgets/CMakeLists.txt 2009-07-13 16:26:04.000000000 +0200
@@ -14,24 +14,24 @@ include_directories(
# do not run automoc on the generated file
set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp PROPERTIES SKIP_AUTOMOC TRUE)
diff -r -U5 kdelibs-4.3.75svn1048496/kdewidgets/CMakeLists.txt kdelibs-4.3.75svn1048496.parallel_devel/kdewidgets/CMakeLists.txt
--- kdelibs-4.3.75svn1048496/kdewidgets/CMakeLists.txt 2009-09-23 15:23:44.000000000 -0400
+++ kdelibs-4.3.75svn1048496.parallel_devel/kdewidgets/CMakeLists.txt 2009-11-23 10:33:58.000000000 -0500
@@ -12,28 +12,28 @@
########### next target ###############
set(makekdewidgets_SRCS makekdewidgets.cpp )
-kde4_add_executable(makekdewidgets NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
-kde4_add_executable(makekdewidgets NOGUI ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI ${makekdewidgets_SRCS})
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
@ -208,7 +256,11 @@ diff -up kdelibs-4.2.96/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.2.96/
set(kdewidgets_PART_SRCS
classpreviews.cpp
@@ -66,7 +66,7 @@ if (QT_QT3SUPPORT_FOUND)
${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp
)
@@ -64,11 +64,11 @@
${CMAKE_SOURCE_DIR}/kde3support/kdeui
)
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kde3supportwidgets.cpp
COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kde3supportwidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kde3support.widgets
@ -217,3 +269,5 @@ diff -up kdelibs-4.2.96/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.2.96/
set(kde3supportwidgets_PART_SRCS
classpreviews.cpp
${CMAKE_CURRENT_BINARY_DIR}/kde3supportwidgets.cpp
)

View File

@ -1,7 +1,9 @@
diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cpp 2008-11-04 18:13:11.000000000 +0100
+++ kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.cpp 2008-11-10 18:45:41.000000000 +0100
@@ -17,6 +17,8 @@
diff -r -U5 kdelibs-4.3.75svn1048496/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.3.75svn1048496.polkit/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.3.75svn1048496/solid/solid/backends/hal/halstorageaccess.cpp 2009-08-12 06:00:18.000000000 -0400
+++ kdelibs-4.3.75svn1048496.polkit/solid/solid/backends/hal/halstorageaccess.cpp 2009-11-20 14:39:44.000000000 -0500
@@ -15,10 +15,12 @@
the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
Boston, MA 02110-1301, USA.
*/
@ -10,29 +12,37 @@ diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cp
#include "halstorageaccess.h"
#include "halfstabhandling.h"
@@ -172,11 +174,21 @@
#include <QtCore/QLocale>
@@ -170,15 +172,25 @@
void StorageAccess::slotDBusError(const QDBusError &error)
{
// TODO: Better error reporting here
if (m_setupInProgress) {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (callPrivilegedMount())
+ return;
+ // if we fail to run kdesu, fall through and emit the original PermissionDeniedByPolicy error
+ }
m_setupInProgress = false;
emit setupDone(Solid::UnauthorizedOperation,
error.name()+": "+error.message(),
QString(error.name()+": "+error.message()),
m_device->udi());
} else if (m_teardownInProgress) {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (callPrivilegedUnmount())
+ return;
+ // if we fail to run kdesu, fall through and emit the original PermissionDeniedByPolicy error
+ }
m_teardownInProgress = false;
emit teardownDone(Solid::UnauthorizedOperation,
error.name()+": "+error.message(),
@@ -294,8 +306,9 @@
QString(error.name()+": "+error.message()),
m_device->udi());
}
@@ -292,12 +304,13 @@
#ifdef Q_OS_FREEBSD
QString uid="-u=";
#else
QString uid="uid=";
#endif
@ -44,7 +54,11 @@ diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cp
}
#ifdef Q_OS_FREEBSD
@@ -333,6 +346,59 @@
char *cType;
if ( fstype=="vfat" && halOptions.contains("-L=")) {
@@ -335,10 +348,63 @@
return c.callWithCallback(msg, this,
SLOT(slotDBusReply(const QDBusMessage &)),
SLOT(slotDBusError(const QDBusError &)));
}
@ -104,10 +118,15 @@ diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cp
bool StorageAccess::callHalVolumeUnmount()
{
QDBusConnection c = QDBusConnection::systemBus();
diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.h 2008-05-21 13:07:38.000000000 +0200
+++ kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.h 2008-11-10 18:45:01.000000000 +0100
@@ -69,6 +69,9 @@
QString udi = m_device->udi();
QDBusMessage msg = QDBusMessage::createMethodCall("org.freedesktop.Hal", udi,
Only in kdelibs-4.3.75svn1048496.polkit/solid/solid/backends/hal: halstorageaccess.cpp.orig
diff -r -U5 kdelibs-4.3.75svn1048496/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.3.75svn1048496.polkit/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.3.75svn1048496/solid/solid/backends/hal/halstorageaccess.h 2008-05-21 07:07:38.000000000 -0400
+++ kdelibs-4.3.75svn1048496.polkit/solid/solid/backends/hal/halstorageaccess.h 2009-11-20 14:38:17.000000000 -0500
@@ -67,10 +67,13 @@
bool callHalVolumeUnmount();
bool callSystemMount();
bool callSystemUnmount();
@ -117,3 +136,5 @@ diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.h
bool requestPassphrase();
void callCryptoSetup(const QString &passphrase);
bool callCryptoTeardown();
private:

View File

@ -1,14 +1,15 @@
%define phonon_ver 4.3.1
%define soprano_ver 2.3.0
%define strigi_ver 0.7
%define alphatag svn1048496
%if 0%{?fedora} > 11
%define soprano_ver 2.3.1
%endif
Summary: K Desktop Environment 4 - Libraries
Version: 4.3.3
Release: 6%{?dist}
Version: 4.3.75
Release: 0.1.%{alphatag}%{?dist}
Name: kdelibs
Epoch: 6
@ -20,7 +21,7 @@ Provides: kdelibs4 = %{version}-%{release}
License: LGPLv2+
URL: http://www.kde.org/
Group: System Environment/Libraries
Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdelibs-%{version}.tar.bz2
Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/kdelibs-%{version}%{?alphatag}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%ifarch noarch
@ -51,7 +52,7 @@ Source1: kde4.sh
Source2: kde4.csh
# make -devel packages parallel-installable
Patch0: kdelibs-4.2.96-parallel_devel.patch
Patch0: kdelibs-4.3.75-parallel_devel.patch
# fix kde#149705
Patch2: kdelibs-4.2.85-kde149705.patch
# Hunspell support for K3Spell
@ -69,19 +70,14 @@ Patch9: kdelibs-4.0.2-branding.patch
# are loaded from kde4rc
Patch10: kdelibs-4.1.72-no-cache-kdeglobals-paths.patch
# workaround for policykit
Patch11: kdelibs-4.1.72-policykit-workaround.patch
Patch11: kdelibs-4.3.75-policykit-workaround.patch
Patch12: kdelibs-4.1.0-xdg-menu.patch
# patch KStandardDirs to use %{_libexecdir}/kde4 instead of %{_libdir}/kde4/libexec
Patch14: kdelibs-4.2.85-libexecdir.patch
# kstandarddirs changes: search /etc/kde, find /usr/libexec/kde4
Patch18: kdelibs-4.1.72-kstandarddirs.patch
Patch20: kdelibs-4.1.70-cmake.patch
Patch21: kdelibs-4.3.1-ossl-1.x.patch
# patch to fix keditbookmarks crash (kde#160679)
Patch22: kdelibs-4.3.0-bookmarks.patch
Patch24: kdelibs-4.3.1-drkonq.patch
# fix build of fakes.c due to missing #include <string.h>
Patch25: kdelibs-4.3.3-fix-kdefakes-build.patch
# use -fno-var-tracking-assignments on khtml/svg bits, use in a pinch on f12+
# workaound for low-mem systems (ppc64), tracking here (for now),
# https://bugzilla.redhat.com/show_bug.cgi?id=539697
@ -90,10 +86,6 @@ Patch26: kdelibs-4.3.3-khtml_svg_no_var_tracking_assignments.patch
# upstream
# kubuntu working to upstream this
Patch50: http://bazaar.launchpad.net/~kubuntu-members/kdelibs/ubuntu/download/head:/kubuntu_80_kaction_q-20091014221915-y11xctvidhr0ewmz-1/kubuntu_80_kaction_qt_keys.diff
# 4.4 trunk
# http://websvn.kde.org/?view=revision&revision=1027234
# add adFilteredBy API required for konq-plugins-4.3.3 to build
Patch100: kdelibs-4.3.3-adFilteredBy.patch
# security fix
Patch200: kdelibs-4.3.1-CVE-2009-2702.patch
@ -115,8 +107,6 @@ BuildRequires: enchant-devel
BuildRequires: gamin-devel
BuildRequires: gettext-devel
BuildRequires: giflib-devel
# busted at least on x86_64
#BuildRequires: hspell-devel
BuildRequires: jasper-devel
BuildRequires: krb5-devel
BuildRequires: libacl-devel libattr-devel
@ -129,6 +119,9 @@ BuildRequires: OpenEXR-devel
BuildRequires: openssl-devel
BuildRequires: pcre-devel
BuildRequires: phonon-devel >= %{phonon_ver}
# TODO: polkit-qt dependency
#BuildRequires: polkit-qt-devel >= %{polkit_qt_ver}
BuildRequires: qca2-devel
BuildRequires: shared-mime-info
BuildRequires: soprano-devel >= %{soprano_ver}
BuildRequires: strigi-devel >= %{strigi_ver}
@ -149,6 +142,9 @@ BuildRequires: qt4-doc
Provides: kross(javascript) = %{version}-%{release}
Provides: kross(qtscript) = %{version}-%{release}
Provides: kdelibs-experimental = %{version}-%{release}
Obsoletes: kdelibs-experimental < %{version}-%{release}
%description
Libraries for the K Desktop Environment 4.
@ -168,6 +164,8 @@ Provides: plasma-devel = %{version}-%{release}
Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: kdelibs4-devel < %{version}-%{release}
Provides: kdelibs4-devel = %{version}-%{release}
Obsoletes: kdelibs-experimental-devel < %{version}-%{release}
Provides: kdelibs-experimental-devel = %{version}-%{release}
Requires: cmake >= 2.6.2-3
Requires: automoc4 >= 0.9.88
Requires: qt4-devel
@ -177,6 +175,10 @@ Requires: phonon-devel
Requires: strigi-devel
Requires: bzip2-devel gamin-devel libacl-devel
%{?x_deps:Requires: %{x_deps}}
Provides: kdelibs-experimental-devel = %{version}-%{release}
Obsoletes: kdelibs-experimental-devel < %{version}-%{release}
%description devel
This package includes the header files you will need to compile
applications for KDE 4.
@ -195,7 +197,7 @@ format for easy browsing.
%prep
%setup -q -n kdelibs-%{version}
%setup -q -n kdelibs-%{version}%{?alphatag}
%patch0 -p1 -b .parallel_devel
%patch2 -p1 -b .kde149705
@ -207,20 +209,13 @@ format for easy browsing.
%patch14 -p1 -b .libexecdir
%patch18 -p1 -b .kstandarddirs
%patch20 -p1 -b .xxcmake
%patch21 -p1 -b .ossl-1.x
%patch22 -p1 -b .bookmarks
%if 0%{?rhel} > 5
%patch24 -p1 -b .drkonq
%endif
%patch25 -p1 -b .fix-kdefakes-build
%ifarch ppc64
%patch26 -p1 -b .khtml_svg_no_var_tracking_assignments
%endif
# upstream patches
%patch50 -p1 -b .kaction_qt_keys
# 4.4
%patch100 -p0 -b .adFilteredBy
# security fix
%patch200 -p1 -b .CVE-2009-2702
@ -348,6 +343,8 @@ rm -rf %{buildroot}
%exclude %{_kde4_appsdir}/cmake/
%{_kde4_configdir}/*
%{_datadir}/dbus-1/interfaces/*
%{_datadir}/dbus-1/system-services/*
%{_sysconfdir}/dbus-1/system.d/*
%{_kde4_datadir}/mime/packages/kde.xml
%{_kde4_sharedir}/kde4/services/*
%{_kde4_sharedir}/kde4/servicetypes/*
@ -413,6 +410,9 @@ rm -rf %{buildroot}
%changelog
* Fri Nov 20 2009 Ben Boeckel <MathStuf@gmail.com> - 4.3.75-0.1.svn1048496
- Update to 4.3.75 snapshot
* Wed Nov 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-6
- rebuild (for qt-4.6.0-rc1, f13+)
- fix/revert soprano_ver change in -5

View File

@ -1 +1 @@
20fd3793d9d23088ecb1d5aed0254216 kdelibs-4.3.3.tar.bz2
d8b84a20332c30256c431203b962bad9 kdelibs-4.3.75svn1048496.tar.bz2