adapt patches

This commit is contained in:
Than Ngo 2011-06-28 10:02:02 +02:00
parent 8dd23ad977
commit ee74271256
5 changed files with 45 additions and 45 deletions

View File

@ -1,25 +0,0 @@
diff -up kdelibs-4.6.80/CMakeLists.txt.kate kdelibs-4.6.80/CMakeLists.txt
--- kdelibs-4.6.80/CMakeLists.txt.kate 2011-05-21 09:43:22.000000000 +0200
+++ kdelibs-4.6.80/CMakeLists.txt 2011-05-30 17:16:02.660240856 +0200
@@ -332,6 +332,7 @@ endif(NOT WINCE)
add_subdirectory( kunitconversion )
add_subdirectory( kdewebkit )
add_subdirectory( includes )
+add_subdirectory( kate )
macro_optional_add_subdirectory( experimental )
macro_optional_add_subdirectory( doc )
diff -up kdelibs-4.6.80/kate/script/katescriptconsole.cpp.kate kdelibs-4.6.80/kate/script/katescriptconsole.cpp
--- kdelibs-4.6.80/kate/script/katescriptconsole.cpp.kate 2011-05-21 01:07:31.000000000 +0200
+++ kdelibs-4.6.80/kate/script/katescriptconsole.cpp 2011-05-30 19:33:32.131448941 +0200
@@ -27,8 +27,8 @@
#include <QtGui/QTextEdit>
// KDE
-#include <KStandardDirs>
-#include <KLocale>
+#include <kstandarddirs.h>
+#include <klocale.h>
// Kate
#include "katescriptconsole.h"

25
kdelibs-4.6.90-kate.patch Normal file
View File

@ -0,0 +1,25 @@
diff -up kdelibs-4.6.90/CMakeLists.txt.kate kdelibs-4.6.90/CMakeLists.txt
--- kdelibs-4.6.90/CMakeLists.txt.kate 2011-06-23 16:49:05.000000000 +0200
+++ kdelibs-4.6.90/CMakeLists.txt 2011-06-28 09:37:02.000000000 +0200
@@ -327,6 +327,7 @@ endif(NOT WINCE)
add_subdirectory( kunitconversion )
add_subdirectory( kdewebkit )
add_subdirectory( includes )
+add_subdirectory( kate )
add_subdirectory( experimental )
macro_optional_add_subdirectory( doc )
diff -up kdelibs-4.6.90/kate/script/katescriptconsole.cpp.kate kdelibs-4.6.90/kate/script/katescriptconsole.cpp
--- kdelibs-4.6.90/kate/script/katescriptconsole.cpp.kate 2011-05-21 01:07:31.000000000 +0200
+++ kdelibs-4.6.90/kate/script/katescriptconsole.cpp 2011-06-28 09:35:59.000000000 +0200
@@ -27,8 +27,8 @@
#include <QtGui/QTextEdit>
// KDE
-#include <KStandardDirs>
-#include <KLocale>
+#include <kstandarddirs.h>
+#include <klocale.h>
// Kate
#include "katescriptconsole.h"

View File

@ -19,15 +19,3 @@ index 0209f49..a0f6af2 100644
QComboBox *cb = qobject_cast<QComboBox *>(w);
if (cb) {
if (cb->isEditable()) {
@@ -490,6 +487,11 @@ QVariant KConfigDialogManager::property(QWidget *w) const
return QVariant(cb->currentIndex());
}
}
+ }
+ if (userproperty.isEmpty()) {
+ userproperty = getUserProperty(w);
+ }
+ if (userproperty.isEmpty()) {
kWarning(d->debugArea()) << w->metaObject()->className() << " widget not handled!";
return QVariant();
}

View File

@ -1,6 +1,6 @@
diff -up kdelibs-4.6.80/kdecore/kernel/kstandarddirs.cpp.kstandarddirs kdelibs-4.6.80/kdecore/kernel/kstandarddirs.cpp
--- kdelibs-4.6.80/kdecore/kernel/kstandarddirs.cpp.kstandarddirs 2011-05-20 22:24:54.000000000 +0200
+++ kdelibs-4.6.80/kdecore/kernel/kstandarddirs.cpp 2011-05-27 14:33:01.445487773 +0200
diff -up kdelibs-4.6.90/kdecore/kernel/kstandarddirs.cpp.me kdelibs-4.6.90/kdecore/kernel/kstandarddirs.cpp
--- kdelibs-4.6.90/kdecore/kernel/kstandarddirs.cpp.me 2011-06-28 09:43:49.000000000 +0200
+++ kdelibs-4.6.90/kdecore/kernel/kstandarddirs.cpp 2011-06-28 09:47:44.000000000 +0200
@@ -1152,7 +1152,9 @@ QStringList KStandardDirs::KStandardDirs
pit != prefixList->end();
++pit)
@ -20,7 +20,7 @@ diff -up kdelibs-4.6.80/kdecore/kernel/kstandarddirs.cpp.kstandarddirs kdelibs-4
+ // hack) - we want /etc/kde after the local config paths
+ // and before the ones in /usr (including kde-profile)
+ if (local && !strcmp("config", type))
+ candidates.append(QLatin1String("/etc/kde/"));
+ candidates.append(QLatin1String("/etc/kde/"));
local = false;
}
else

View File

@ -56,27 +56,37 @@ Requires: strigi-libs%{?_isa} >= %{strigi_version}
# make kdelibs-devel parallel-installable with kdelibs3-devel
Patch0: kdelibs-4.5.80-parallel_devel.patch
# fix kde#149705
Patch2: kdelibs-4.2.85-kde149705.patch
# install all .css files and Doxyfile.global in kdelibs-common to build
# kdepimlibs-apidocs against
Patch8: kdelibs-4.3.90-install_all_css.patch
# add Fedora/V-R to KHTML UA string
Patch9: kdelibs-4.6.80-branding.patch
# don't cache kdeglobals paths because they change after profile directories
# are loaded from kde4rc
Patch10: kdelibs-4.1.72-no-cache-kdeglobals-paths.patch
# adds the Administration menu from redhat-menus which equals System + Settings
# This prevents the stuff getting listed twice, under both System and Settings.
Patch12: kdelibs-4.1.0-xdg-menu.patch
# patch KStandardDirs to use %{_libexecdir}/kde4 instead of %{_libdir}/kde4/libexec
Patch14: kdelibs-4.5.80-libexecdir.patch
# kstandarddirs changes: search /etc/kde, find %{_kde4_libexecdir}
Patch18: kdelibs-4.6.80-kstandarddirs.patch
# COMMENT ME PLEASE
Patch18: kdelibs-4.6.90-kstandarddirs.patch
# set build type
Patch20: kdelibs-4.1.70-cmake.patch
# disable drkonqi by default, RHEL prefers/wants abrt
Patch24: kdelibs-4.3.1-drkonq.patch
# die rpath die, since we're using standard paths, we can avoid
# this extra hassle (even though cmake is *supposed* to not add standard
# paths (like /usr/lib64) already! With this, we can drop
@ -88,16 +98,18 @@ Patch27: kdelibs-4.5.80-no_rpath.patch
# reverting to our past gnupg2-only setup.
# TODO: try to use either gpg or gpg2, whichever is available
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
# https://bugs.kde.org/show_bug.cgi?id=269045
# https://git.reviewboard.kde.org/r/101231/
Patch51: kdelibs-4.6.2-uri_mimetypes.patch
#
Patch52: kdelibs-4.6.80-kstatusnotifieritem_dbus_leak.patch
## upstream
# https://projects.kde.org/projects/kde/kdelibs/repository/revisions/d44186bce4670d2985fb6aba8dba59bbd2c4c77a
# fix KConfigXT KComboBox for Qt 4.8 TP1
Patch100: kdelibs-4.6.80-kconfigxt-qt48.patch
Patch100: kdelibs-4.6.90-kconfigxt-qt48.patch
## security fix
# Not Upstreamed? why not ? -- Rex
@ -108,7 +120,7 @@ Patch200: kdelibs-4.3.1-CVE-2009-2702.patch
Patch300: kdelibs-4.6.80-halectomy.patch
# katepart hack!
Patch1000: kdelibs-4.6.80-kate.patch
Patch1000: kdelibs-4.6.90-kate.patch
%if 0%{?fedora} && 0%{?fedora} < 13
Conflicts: kdebase-workspace-libs < 4.3.80