* Sat Feb 27 2010 Rex Dieter <rdieter@fedoraproject.org> - 6:4.4.1-1
- 4.4.1
This commit is contained in:
parent
626d082d3c
commit
ed679813cd
@ -1 +1 @@
|
|||||||
kdelibs-4.4.0.tar.bz2
|
kdelibs-4.4.1.tar.bz2
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
SVN commit 1089160 by ggarand:
|
|
||||||
|
|
||||||
automatically merged revision 1089159:
|
|
||||||
Critical performance fix:
|
|
||||||
|
|
||||||
There is a huge difference of behaviour between DEBUG and RELEASE
|
|
||||||
builds of Qt 4.6, that breaks scrolling in KHTML.
|
|
||||||
|
|
||||||
Using QWidget::scroll() on a widget that doesn't have WA_OpaquePaintEvent
|
|
||||||
attribute set works just fine in Debug, but completely breaks down in
|
|
||||||
Release, causing the whole view to get repainted always.
|
|
||||||
|
|
||||||
|
|
||||||
CCMAIL: kde-packager@kde.org
|
|
||||||
|
|
||||||
M +6 -0 khtmlview.cpp
|
|
||||||
|
|
||||||
|
|
||||||
--- branches/KDE/4.4/kdelibs/khtml/khtmlview.cpp #1089159:1089160
|
|
||||||
@@ -604,6 +604,12 @@
|
|
||||||
setWidget( new QWidget(this) );
|
|
||||||
widget()->setAttribute( Qt::WA_NoSystemBackground );
|
|
||||||
|
|
||||||
+ // Do *not* remove this attribute frivolously.
|
|
||||||
+ // You might not notice a change of behaviour in Debug builds
|
|
||||||
+ // but removing opaque events will make QWidget::scroll fail horribly
|
|
||||||
+ // in Release builds.
|
|
||||||
+ widget()->setAttribute( Qt::WA_OpaquePaintEvent );
|
|
||||||
+
|
|
||||||
verticalScrollBar()->setCursor( Qt::ArrowCursor );
|
|
||||||
horizontalScrollBar()->setCursor( Qt::ArrowCursor );
|
|
||||||
|
|
@ -1,15 +0,0 @@
|
|||||||
Index: plasma/runnercontext.cpp
|
|
||||||
===================================================================
|
|
||||||
--- plasma/runnercontext.cpp (Revision 1090801)
|
|
||||||
+++ plasma/runnercontext.cpp (Revision 1090802)
|
|
||||||
@@ -128,6 +128,10 @@
|
|
||||||
components.pop_back();
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (components.isEmpty()) {
|
|
||||||
+ return true;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
QString correctPath;
|
|
||||||
const unsigned initialComponents = components.size();
|
|
||||||
for (unsigned i = 0; i < initialComponents - 1; i ++) {
|
|
@ -1,23 +0,0 @@
|
|||||||
SVN commit 1087530 by trueg:
|
|
||||||
|
|
||||||
Backport of mem/dbus connection leak.
|
|
||||||
|
|
||||||
CCMAIL: faure@kde.org, release-team@kde.org, thiago@kde.org
|
|
||||||
|
|
||||||
|
|
||||||
M +1 -0 queryserviceclient.cpp
|
|
||||||
|
|
||||||
|
|
||||||
--- branches/KDE/4.4/kdelibs/nepomuk/query/queryserviceclient.cpp #1087529:1087530
|
|
||||||
@@ -177,6 +177,7 @@
|
|
||||||
Nepomuk::Query::QueryServiceClient::~QueryServiceClient()
|
|
||||||
{
|
|
||||||
close();
|
|
||||||
+ delete d->queryServiceInterface;
|
|
||||||
delete d;
|
|
||||||
}
|
|
||||||
|
|
||||||
_______________________________________________
|
|
||||||
release-team mailing list
|
|
||||||
release-team@kde.org
|
|
||||||
https://mail.kde.org/mailman/listinfo/release-team
|
|
@ -1,63 +0,0 @@
|
|||||||
Index: plasma/applet.cpp
|
|
||||||
===================================================================
|
|
||||||
--- plasma/applet.cpp (Revision 1090827)
|
|
||||||
+++ plasma/applet.cpp (Revision 1090828)
|
|
||||||
@@ -1712,6 +1712,7 @@
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ d->publishUI.publishCheckbox = 0;
|
|
||||||
if (d->package && d->configLoader) {
|
|
||||||
KConfigDialog *dialog = 0;
|
|
||||||
|
|
||||||
@@ -1878,29 +1879,31 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef ENABLE_REMOTE_WIDGETS
|
|
||||||
- q->config().writeEntry("Share", publishUI.publishCheckbox->isChecked());
|
|
||||||
+ if (publishUI.publishCheckbox) {
|
|
||||||
+ q->config().writeEntry("Share", publishUI.publishCheckbox->isChecked());
|
|
||||||
|
|
||||||
- if (publishUI.publishCheckbox->isChecked()) {
|
|
||||||
- QString resourceName =
|
|
||||||
- i18nc("%1 is the name of a plasmoid, %2 the name of the machine that plasmoid is published on",
|
|
||||||
- "%1 on %2", q->name(), QHostInfo::localHostName());
|
|
||||||
- q->publish(Plasma::ZeroconfAnnouncement, resourceName);
|
|
||||||
- if (publishUI.allUsersCheckbox->isChecked()) {
|
|
||||||
- if (!AuthorizationManager::self()->d->matchingRule(resourceName, Credentials())) {
|
|
||||||
- AuthorizationRule *rule = new AuthorizationRule(resourceName, "");
|
|
||||||
- rule->setPolicy(AuthorizationRule::Allow);
|
|
||||||
- rule->setTargets(AuthorizationRule::AllUsers);
|
|
||||||
- AuthorizationManager::self()->d->rules.append(rule);
|
|
||||||
+ if (publishUI.publishCheckbox->isChecked()) {
|
|
||||||
+ QString resourceName =
|
|
||||||
+ i18nc("%1 is the name of a plasmoid, %2 the name of the machine that plasmoid is published on",
|
|
||||||
+ "%1 on %2", q->name(), QHostInfo::localHostName());
|
|
||||||
+ q->publish(Plasma::ZeroconfAnnouncement, resourceName);
|
|
||||||
+ if (publishUI.allUsersCheckbox->isChecked()) {
|
|
||||||
+ if (!AuthorizationManager::self()->d->matchingRule(resourceName, Credentials())) {
|
|
||||||
+ AuthorizationRule *rule = new AuthorizationRule(resourceName, "");
|
|
||||||
+ rule->setPolicy(AuthorizationRule::Allow);
|
|
||||||
+ rule->setTargets(AuthorizationRule::AllUsers);
|
|
||||||
+ AuthorizationManager::self()->d->rules.append(rule);
|
|
||||||
+ }
|
|
||||||
+ } else {
|
|
||||||
+ AuthorizationRule *matchingRule =
|
|
||||||
+ AuthorizationManager::self()->d->matchingRule(resourceName, Credentials());
|
|
||||||
+ if (matchingRule) {
|
|
||||||
+ AuthorizationManager::self()->d->rules.removeAll(matchingRule);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
} else {
|
|
||||||
- AuthorizationRule *matchingRule =
|
|
||||||
- AuthorizationManager::self()->d->matchingRule(resourceName, Credentials());
|
|
||||||
- if (matchingRule) {
|
|
||||||
- AuthorizationManager::self()->d->rules.removeAll(matchingRule);
|
|
||||||
- }
|
|
||||||
+ q->unpublish();
|
|
||||||
}
|
|
||||||
- } else {
|
|
||||||
- q->unpublish();
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
15
kdelibs.spec
15
kdelibs.spec
@ -7,8 +7,8 @@
|
|||||||
%define apidocs 1
|
%define apidocs 1
|
||||||
|
|
||||||
Summary: KDE Libraries
|
Summary: KDE Libraries
|
||||||
Version: 4.4.0
|
Version: 4.4.1
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Name: kdelibs
|
Name: kdelibs
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
@ -90,10 +90,6 @@ Patch27: kdelibs-4.3.98-no_rpath.patch
|
|||||||
# upstreamable
|
# upstreamable
|
||||||
|
|
||||||
# 4.4 upstream
|
# 4.4 upstream
|
||||||
Patch100: kdelibs-4.4.0-khtml_scrolling.patch
|
|
||||||
Patch101: kdelibs-4.4.0-nepomuk_memleak.patch
|
|
||||||
patch102: kdelibs-4.4.0-krunner-crash-kde#227118.patch
|
|
||||||
Patch103: kdelibs-4.4.0-plasma-crash-kde#226823.patch
|
|
||||||
|
|
||||||
# security fix
|
# security fix
|
||||||
## Not Upstreamed? why not ? -- Rex
|
## Not Upstreamed? why not ? -- Rex
|
||||||
@ -245,10 +241,6 @@ format for easy browsing.
|
|||||||
# upstreamable patches
|
# upstreamable patches
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p4 -b .khtml_scrolling
|
|
||||||
%patch101 -p4 -b .nepomuk_memleak
|
|
||||||
%patch102 -p0 -b .krunner-crash-kde#227118
|
|
||||||
%patch103 -p0 -b .plasma-crash-kde#226823
|
|
||||||
|
|
||||||
# security fix
|
# security fix
|
||||||
%patch200 -p1 -b .CVE-2009-2702
|
%patch200 -p1 -b .CVE-2009-2702
|
||||||
@ -440,6 +432,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 27 2010 Rex Dieter <rdieter@fedoraproject.org> - 6:4.4.1-1
|
||||||
|
- 4.4.1
|
||||||
|
|
||||||
* Fri Feb 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 6:4.4.0-9
|
* Fri Feb 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 6:4.4.0-9
|
||||||
- -devel: Provides: nepomuk-devel, Requires: soprano-devel
|
- -devel: Provides: nepomuk-devel, Requires: soprano-devel
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user