* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.8-1

- kde-3.5.8
This commit is contained in:
Rex Dieter 2007-10-12 19:37:53 +00:00
parent cb266bcee0
commit eb67935aa4
9 changed files with 7 additions and 312 deletions

View File

@ -1,3 +1,4 @@
clog
kdelibs-3.5.6.tar.bz2
kdelibs-3.5.7.tar.bz2
kdelibs-3.5.8.tar.bz2

View File

@ -1,15 +1,3 @@
diff -Nur kdelibs-3.5.6.orig/configure.in kdelibs-3.5.6/configure.in
--- kdelibs-3.5.6.orig/configure.in 2007-01-24 09:52:48.000000000 +0100
+++ kdelibs-3.5.6/configure.in 2007-02-05 23:01:44.000000000 +0100
@@ -399,7 +399,7 @@
[], with_utempter=check)
if test "x$with_utempter" != xno; then
kde_have_utempter=yes
- AC_CHECK_LIB(utempter, addToUtmp, [LIBUTEMPTER=-lutempter], kde_have_utempter=no)
+ AC_CHECK_LIB(utempter, utempter_add_record, [LIBUTEMPTER=-lutempter], kde_have_utempter=no)
AC_SUBST(LIBUTEMPTER)
if test "$kde_have_utempter" = "yes"; then
AC_DEFINE_UNQUOTED(HAVE_UTEMPTER, 1, [Define if you have the utempter helper for utmp managment])
diff -Nur kdelibs-3.5.6.orig/configure.in.in kdelibs-3.5.6/configure.in.in
--- kdelibs-3.5.6.orig/configure.in.in 2006-05-22 20:14:23.000000000 +0200
+++ kdelibs-3.5.6/configure.in.in 2007-02-05 23:01:44.000000000 +0100
@ -96,18 +84,3 @@ diff -Nur kdelibs-3.5.6.orig/kdecore/Makefile.am kdelibs-3.5.6/kdecore/Makefile.
libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
libkdecore_la_NMCHECK = $(srcdir)/libkdecore.nmcheck
libkdecore_la_NMCHECKWEAK = $(srcdir)/libkdecore_weak.nmcheck $(srcdir)/libqt-mt_weak.nmcheck \
diff -Nur kdelibs-3.5.6.orig/kdecore/Makefile.in kdelibs-3.5.6/kdecore/Makefile.in
--- kdelibs-3.5.6.orig/kdecore/Makefile.in 2007-01-24 09:54:07.000000000 +0100
+++ kdelibs-3.5.6/kdecore/Makefile.in 2007-02-05 23:04:12.000000000 +0100
@@ -787,9 +787,9 @@
kuser.cpp kconfigskeleton.cpp kconfigdialogmanager.cpp klockfile.cpp \
kqiodevicegzip_p.cpp ktimezones.cpp ksycoca_skel.cpp kappdcopiface_skel.cpp kdebugdcopiface_skel.cpp
-#>- libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined
+#>- libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(LIBUTEMPTER) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined
#>+ 1
-libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined $(KDE_NO_UNDEFINED)
+libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(LIBUTEMPTER) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined $(KDE_NO_UNDEFINED)
libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
libkdecore_la_NMCHECK = $(srcdir)/libkdecore.nmcheck
libkdecore_la_NMCHECKWEAK = $(srcdir)/libkdecore_weak.nmcheck $(srcdir)/libqt-mt_weak.nmcheck \

View File

@ -1,82 +0,0 @@
--- kdelibs-3.5.7/kdeprint/cups/cupsdconf2/cups-util.c.cups13 2006-10-01 12:33:43.000000000 -0500
+++ kdelibs-3.5.7/kdeprint/cups/cupsdconf2/cups-util.c 2007-07-19 15:12:48.000000000 -0500
@@ -108,7 +108,8 @@ cupsGetConf(void)
* See if we should retry the current digest password...
*/
- if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0 ||
+ if (strncmp(httpGetField (cups_server, HTTP_FIELD_WWW_AUTHENTICATE),
+ "Basic", 5) == 0 ||
digest_tries > 1 || !pwdstring[0])
{
/*
@@ -116,7 +117,7 @@ cupsGetConf(void)
*/
snprintf(prompt, sizeof(prompt), "Password for %s on %s? ", cupsUser(),
- cups_server->hostname);
+ cupsServer());
if ((password = cupsGetPassword(prompt)) == NULL)
break;
@@ -135,7 +136,8 @@ cupsGetConf(void)
* Got a password; encode it for the server...
*/
- if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0)
+ if (strncmp(httpGetField (cups_server, HTTP_FIELD_WWW_AUTHENTICATE),
+ "Basic", 5) == 0)
{
/*
* Basic authentication...
@@ -334,7 +336,8 @@ cupsPutConf(const char *name) /* I - Na
* See if we should retry the current digest password...
*/
- if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0 ||
+ if (strncmp(httpGetField (cups_server, HTTP_FIELD_WWW_AUTHENTICATE),
+ "Basic", 5) == 0 ||
digest_tries > 1 || !pwdstring[0])
{
/*
@@ -342,7 +345,7 @@ cupsPutConf(const char *name) /* I - Na
*/
snprintf(prompt, sizeof(prompt), "Password for %s on %s? ", cupsUser(),
- cups_server->hostname);
+ cupsServer());
if ((password = cupsGetPassword(prompt)) == NULL)
break;
@@ -361,7 +364,8 @@ cupsPutConf(const char *name) /* I - Na
* Got a password; encode it for the server...
*/
- if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0)
+ if (strncmp(httpGetField (cups_server, HTTP_FIELD_WWW_AUTHENTICATE),
+ "Basic", 5) == 0)
{
/*
* Basic authentication...
--- kdelibs-3.5.7/kdeprint/cups/ipprequest.cpp.cups13 2007-01-15 05:34:19.000000000 -0600
+++ kdelibs-3.5.7/kdeprint/cups/ipprequest.cpp 2007-07-19 15:15:09.000000000 -0500
@@ -309,7 +309,8 @@ bool IppRequest::doFileRequest(const QSt
return false;
}
-#ifdef HAVE_CUPS_NO_PWD_CACHE
+#if defined(HAVE_CUPS_NO_PWD_CACHE) && \
+ CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 3
strncpy( HTTP->authstring, cups_authstring.data(), HTTP_MAX_VALUE );
#endif
@@ -319,7 +320,8 @@ bool IppRequest::doFileRequest(const QSt
}
request_ = cupsDoFileRequest(HTTP, request_, (res.isEmpty() ? "/" : res.latin1()), (filename.isEmpty() ? NULL : filename.latin1()));
-#ifdef HAVE_CUPS_NO_PWD_CACHE
+#if defined(HAVE_CUPS_NO_PWD_CACHE) && \
+ CUPS_VERSION_MAJOR == 1 && CUPS_VERSION_MINOR < 3
cups_authstring = HTTP->authstring;
#endif
httpClose(HTTP);

View File

@ -1,63 +0,0 @@
diff -up kdelibs-3.5.7/kabc/vcardtool.cpp.kde#115219 kdelibs-3.5.7/kabc/vcardtool.cpp
--- kdelibs-3.5.7/kabc/vcardtool.cpp.kde#115219 2006-03-17 04:19:10.000000000 -0600
+++ kdelibs-3.5.7/kabc/vcardtool.cpp 2007-08-22 08:27:19.000000000 -0500
@@ -242,8 +242,12 @@ QString VCardTool::createVCards( Address
card.addLine( noteLine );
// ORG
- VCardLine orgLine( "ORG", (*addrIt).organization() );
- if ( version == VCard::v2_1 && needsEncoding( (*addrIt).organization() ) ) {
+ QStringList organization;
+ organization.append( ( *addrIt ).organization().replace( ';', "\\;" ) );
+ if ( !( *addrIt ).department().isEmpty() )
+ organization.append( ( *addrIt ).department().replace( ';', "\\;" ) );
+ VCardLine orgLine( "ORG", organization.join( ";" ) );
+ if ( version == VCard::v2_1 && needsEncoding( organization.join( ";" ) ) ) {
orgLine.addParameter( "charset", "UTF-8" );
orgLine.addParameter( "encoding", "QUOTED-PRINTABLE" );
}
@@ -506,8 +510,13 @@ Addressee::List VCardTool::parseVCards(
addr.setNote( (*lineIt).value().asString() );
// ORGANIZATION
- else if ( identifier == "org" )
- addr.setOrganization( (*lineIt).value().asString() );
+ else if ( identifier == "org" ) {
+ const QStringList orgParts = splitString( semicolonSep, (*lineIt).value().toString() );
+ if ( orgParts.count() > 0 )
+ addr.setOrganization( orgParts[ 0 ] );
+ if ( orgParts.count() > 1 )
+ addr.setDepartment( orgParts[ 1 ] );
+ }
// PHOTO
else if ( identifier == "photo" )
diff -up kdelibs-3.5.7/kabc/ldifconverter.cpp.kde#115219 kdelibs-3.5.7/kabc/ldifconverter.cpp
--- kdelibs-3.5.7/kabc/ldifconverter.cpp.kde#115219 2005-10-10 10:05:53.000000000 -0500
+++ kdelibs-3.5.7/kabc/ldifconverter.cpp 2007-08-22 08:24:25.000000000 -0500
@@ -141,7 +141,13 @@ bool LDIFConverter::addresseeToLDIF( con
ldif_out( t, "o", addr.organization() );
ldif_out( t, "organization", addr.organization() );
ldif_out( t, "organizationname", addr.organization() );
- ldif_out( t, "department", addr.custom("KADDRESSBOOK", "X-Department") );
+
+ // Compatibility with older kabc versions.
+ if ( !addr.department().isEmpty() )
+ ldif_out( t, "department", addr.department() );
+ else
+ ldif_out( t, "department", addr.custom("KADDRESSBOOK", "X-Department") );
+
ldif_out( t, "workurl", addr.url().prettyURL() );
ldif_out( t, "homeurl", addr.url().prettyURL() );
ldif_out( t, "description", addr.note() );
diff -up kdelibs-3.5.7/kabc/scripts/entrylist.kde#115219 kdelibs-3.5.7/kabc/scripts/entrylist
--- kdelibs-3.5.7/kabc/scripts/entrylist.kde#115219 2007-05-14 02:52:37.000000000 -0500
+++ kdelibs-3.5.7/kabc/scripts/entrylist 2007-08-22 08:25:05.000000000 -0500
@@ -63,6 +63,7 @@ ALE,geographic position,,Geo,geo,,.asStr
ALFE,title,person,QString,title,Organization
ALFE,role,person in organization,QString,role,Organization
ALFE,organization,,QString,organization,Organization
+ALFE,department,,QString,department,Organization
ALFE,note,,QString,note

View File

@ -1,36 +0,0 @@
Index: kdecore/kcmdlineargs.cpp
===================================================================
--- kdecore/kcmdlineargs.cpp (Revision 669593)
+++ kdecore/kcmdlineargs.cpp (Revision 669594)
@@ -1248,21 +1248,22 @@
KURL KCmdLineArgs::makeURL(const char *_urlArg)
{
- QString urlArg = QFile::decodeName(_urlArg);
- if (!QDir::isRelativePath(urlArg))
- {
+ const QString urlArg = QFile::decodeName(_urlArg);
+ QFileInfo fileInfo(urlArg);
+ if (!fileInfo.isRelative()) { // i.e. starts with '/', on unix
KURL result;
result.setPath(urlArg);
return result; // Absolute path.
}
- if ( !KURL::isRelativeURL(urlArg) )
- return KURL(urlArg); // Argument is a URL
+ if ( KURL::isRelativeURL(urlArg) || fileInfo.exists() ) {
+ KURL result;
+ result.setPath( cwd()+'/'+urlArg );
+ result.cleanPath();
+ return result; // Relative path
+ }
- KURL result;
- result.setPath( cwd()+"/"+urlArg );
- result.cleanPath();
- return result; // Relative path
+ return KURL(urlArg); // Argument is a URL
}
void

View File

@ -1,26 +0,0 @@
--- branches/KDE/3.5/kdelibs/kinit/setproctitle.cpp 2005/07/26 18:54:59 438982
+++ branches/KDE/3.5/kdelibs/kinit/setproctitle.cpp 2007/08/10 18:22:59 698691
@@ -173,6 +173,15 @@
else
continue;
}
+
+ /*
+ * On linux, we don't want to reuse the memory allocated for
+ * the environment, as there are tools that try to read our environment
+ * variables while we're running (ConsoleKit does that).
+ * There is no way to move or resize it, so just not touchint it
+ * seems to be the only option
+ */
+#ifndef __linux__
for (i=0; envp[i] != NULL; i++)
{
if (LastArgv + 1 == envp[i])
@@ -180,6 +189,7 @@
else
continue;
}
+#endif
}
#if SPT_TYPE != SPT_BUILTIN

View File

@ -20,8 +20,8 @@
%define apidocs 1
Summary: K Desktop Environment - Libraries
Version: 3.5.7
Release: 23%{?dist}
Version: 3.5.8
Release: 1%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs3
@ -59,7 +59,6 @@ Patch39: kdelibs-3.5.4-kabc-make.patch
Patch40: kdelibs-3.5.4-kdeprint-utf8.patch
Patch41: kdelibs-3.5.6-utempter.patch
Patch43: kdelibs-3.5.6-lang.patch
Patch44: kdelibs-3.5.7-cups13.patch
Patch45: kdelibs-3.5.7-autostart.patch
# use /etc/kde in addition to /usr/share/config, borrowed from debian
@ -72,14 +71,6 @@ Patch102: kdelibs-3.5.6-137675.patch
Patch103: kdelibs-3.5.0-101956.patch
## upstream patches
Patch500: kdelibs-3.5.7-kde#146105.patch
# http://bugzilla.redhat.com/244065
# http://websvn.kde.org/branches/KDE/3.5/kdelibs/kinit/setproctitle.cpp?r1=438982&r2=698691
Patch501: kdelibs-3.5.7-rh#244065.patch
# http://www.kde.org/info/security/advisory-20070815-1.txt
Patch502: ftp://ftp.kde.org/pub/kde/security_patches/post-3.5.7-kdelibs-kdecore.diff
# vcard30 patch, http://bugs.kde.org/115219
Patch503: kdelibs-3.5.7-kde#115219.patch
%{?arts:Requires: arts >= %{arts_epoch}:%{arts_version}}
Requires: qt >= %{qt_epoch}:%{qt_ver}
@ -229,7 +220,6 @@ format for easy browsing
%patch40 -p1 -b .kdeprint-utf8
%{?_with_libutempter:%patch41 -p1 -b .utempter}
%patch43 -p1 -b .lang
%patch44 -p1 -b .cups13
%patch45 -p1 -b .xdg-autostart
%patch100 -p1 -b .kstandarddirs
@ -237,10 +227,6 @@ format for easy browsing
%patch102 -p0 -b .kde#137675
# upstream patches
%patch500 -p0 -b .kde#146105
%patch501 -p4 -b .rh#244065
%patch502 -p0 -b .advisory-20070815-1
%patch503 -p1 -b .kde#115219
sed -i -e "s,^#define KDE_VERSION_STRING .*,#define KDE_VERSION_STRING \"%{version}-%{release} %{distname}\"," kdecore/kdeversion.h
@ -523,6 +509,9 @@ touch --no-create %{_datadir}/icons/crystalsvg 2> /dev/null || :
%changelog
* Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 6:3.5.8-1
- kde-3.5.8
* Tue Sep 25 2007 Than Ngo <than@redhat.com> - 6:3.5.7-23
- fix rh#243611, autostart from XDG_CONFIG_DIRS

View File

@ -1,61 +0,0 @@
------------------------------------------------------------------------
r700053 | mueller | 2007-08-14 18:37:30 +0200 (Tue, 14 Aug 2007) | 2 lines
be more robust against addressbar spoofing (CVE-2007-4225)
------------------------------------------------------------------------
--- kdecore/tests/kurltest.cpp
+++ kdecore/tests/kurltest.cpp
@@ -288,6 +288,16 @@ int main(int argc, char *argv[])
check("KURL::prettyURL()", url15582.prettyURL(), "http://alain.knaff.linux.lu/bug-reports/kde/percentage%in%url.html");
check("KURL::url()", url15582.url(), "http://alain.knaff.linux.lu/bug-reports/kde/percentage%25in%25url.html");
+ KURL whitespaceInUser("http://www.google.com%20%20%20%20%20@foobar.com/");
+ check("KURL::prettyURL()", whitespaceInUser.prettyURL(), "http://www.google.com%20%20%20%20%20@foobar.com/");
+
+ KURL whitespaceInPath("http://www.google.com/foo%20bar/");
+ check("KURL::prettyURL()", whitespaceInPath.prettyURL(), "http://www.google.com/foo bar/");
+
+ KURL whitespaceInPath2("http://www.google.com/foo%20%20%20%20%20%20%20bar/");
+ check("KURL::prettyURL()", whitespaceInPath2.prettyURL(),
+ "http://www.google.com/foo%20%20%20%20%20%20 bar/");
+
KURL carsten;
carsten.setPath("/home/gis/src/kde/kdelibs/kfile/.#kfiledetailview.cpp.1.18");
check("KURL::path()", carsten.path(), "/home/gis/src/kde/kdelibs/kfile/.#kfiledetailview.cpp.1.18");
@@ -594,6 +604,15 @@ int main(int argc, char *argv[])
check("http: URL with empty path string path", waba1.path(),
"");
+ waba1 = "http://www.meinestadt.de&url_plain=http";
+ check("http: URL with empty path string", waba1.host(),
+ "www.meinestadt.de&url_plain=http");
+ check("http: URL with empty path string", waba1.htmlURL(),
+ "http://www.meinestadt.de&amp;url_plain=http");
+
+ check("http: URL with empty path string", waba1.path(),
+ "");
+
waba1 = "http://a:389#b=c";
check( "http: URL with port, ref, and empty path; url", waba1.url(), "http://a:389#b=c" );
check( "http: URL with port, ref, and empty path; host", waba1.host(), "a" );
--- kdecore/kurl.cpp
+++ kdecore/kurl.cpp
@@ -183,7 +183,7 @@ static QString lazy_encode( const QStrin
(character == '?') || // Start of query delimiter
((character == '@') && encodeAt) || // Username delimiter
(character == '#') || // Start of reference delimiter
- ((character == 32) && (i+1 == old_length))) // A trailing space
+ ((character == 32) && (i+1 == old_length || segment[i+1] == ' '))) // A trailing space
{
new_segment[ new_length++ ] = '%';
@@ -1540,7 +1540,7 @@ QString KURL::prettyURL( int _trailing )
u += "//";
if ( hasUser() )
{
- u += lazy_encode(m_strUser);
+ u += encode(m_strUser, 0, 0);
// Don't show password!
u += "@";
}

View File

@ -1 +1 @@
50ed644f2ec91963570fe2b155652957 kdelibs-3.5.7.tar.bz2
acaa37e79e840d10dca326277a20863c kdelibs-3.5.8.tar.bz2